Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 20/10/2012, à 13:05

Danquebec

Les touches mortes n’attendent pas [résolu]

J’ai fait la mise à jour vers Ubuntu 12.04 tout récemment… Dans la m^eme journée de cette mise à jour, les touches mortes se sont mises à ne plus marcher. Maintenant, quand je tape sur la touche morte pour mettre un accent circonflexe sur une lettre, par exemple, j’obtiens tout de suite « ^ ». Du coup je ne peux plus mettre mes accents circonflexe sur mes « e ».

J’ai la bonne disposition, et de plus, ça le fait avec toutes les dispositions (qwerty canadien multilingue, bépo…).

À la recommandation de quelqu’un, je suis allé faire un tour sur http://doc.ubuntu-fr.org/ibus. Ça parle bien d’un problème d’accent circonflexe, j’ai donc désinstallé ibus et j’ai redémarré, mais le problème persiste. Dans l’article, ça dit d’entrer

setxkbmap -layout fr -variant oss

afin de pouvoir écrire des lettres avec un accent circonflexe à l’aide d’Alt-Gr… Cependant, ce ne serait pas du tout pratique. J’utilise le français tous les jours, abondamment. Et de plus, ce ne sont pas seulement les accents circonflexes le problème, c’est toutes les touches mortes (donc il y a le m^eme problème pour les trémas : No¨el).

Si c’est important, j’utilise la disposition bépo (mais j’ai testé avec qwerty et il y a le m^eme problème).

Dernière modification par Danquebec (Le 30/10/2012, à 19:29)


Salon jabber bien : discussion@chat.jabberfr.org - Pour parler de tout et n'importe quoi - Venez en grand nombre !
Donnez du calcul inutilisé à des recherches scientifiques et technologiques (cure du cancer, du sida, énergies propres, etc...) http://www.worldcommunitygrid.org/

Hors ligne

#2 Le 21/10/2012, à 17:31

jee-el

Re : Les touches mortes n’attendent pas [résolu]

bonjour Dan!
problème identique,

jee-el dit dans un autre sujet (déplacé) :

je suis avec un clavier qwertz, sans touches morte qui a toujours bien fonctionné, m^eme sous Cubuntu 12.04-64 bits. sauf que par maladresse, j'ai du réinstaller la 12.04. et là, plus moyen d'écrire avec ces signes. et je ne sais pas o`u aller pour corriger ce problème. j'ai bien essayé de mettre une touche de composition  (<), mais le succès est mitigé. cela a fonctionné un moment pour le ^, mais pas pour `. d'o`u ma question:

comment corriger ce bug?

et :
la disposition du clavier est bonne, le ^ à sa place, de m^eme que le ` et le ¨ . ce qui ne passe pas, c'est que justement comme ces mots le mettent en évidence, la superposition de l'accent ne s'effectue pas!  ( m^eme, ch^ateau, no¨el, "o`u vas-tu",...)

constaté sur la 12.04.1 et sur la beta 12.10

Dernière modification par jee-el (Le 21/10/2012, à 17:33)


jee-el, Grand-Père Plex!
C-mère Gigabyte H87-HD3
C Graphique NVIDIA GTX 760
multiboot voyager 13.04 64bits Ubuntu 14.04/ XP sp3

Hors ligne

#3 Le 28/10/2012, à 21:23

mithi

Re : Les touches mortes n’attendent pas [résolu]

Bonjour,

J'ai le m^eme problème.
C'est vraiment très g^enant, d'autant.
En surfant sur le net, j'ai vu comment changer l'agencement du clavier.
Or que le clavier soit en
Français (variante touches mortes sun)
Français tout court
Français (variante)
Français (variante, sans touches mortes)

J'ai toujours le m^eme problème.

Le plus bizarre, c'est que lorsque je me connecte avec une session "invité", le problème ne se pose pas. C'est donc bien un problème de config lié à la mise  jour.

Merci de votre aide.

Mithi.

Hors ligne

#4 Le 28/10/2012, à 22:01

mithi

Re : Les touches mortes n’attendent pas [résolu]

Hello,

J'ai résolu mon problème, mais suis bien incapable d'expliquer le pourquoi du comment.

après lecture de la page http://www.mail-archive.com/carrefourbl … 07226.html

dans un terminal, j'ai lancé
gnome-language-selector

Un message m'a indiqué que certains paquets n'étaient pas installés. J'ai dit OK pour l'installation.

Ensuite, dans la fenêtre "Prise en charge des langues",
dans la rubrique "Système de saisie du clavier" j'ai choisi "Aucun".
Et c'est OK, ça mârche.

mithi

Hors ligne

#5 Le 28/10/2012, à 23:52

Danquebec

Re : Les touches mortes n’attendent pas [résolu]

@mithi

J’ai essayé, ça a aussi dit que j’avais certains paquets qui n’étaient pas installés, mais ça ne marche pas, m^eme après redémarrage.

Dernière modification par Danquebec (Le 28/10/2012, à 23:53)


Salon jabber bien : discussion@chat.jabberfr.org - Pour parler de tout et n'importe quoi - Venez en grand nombre !
Donnez du calcul inutilisé à des recherches scientifiques et technologiques (cure du cancer, du sida, énergies propres, etc...) http://www.worldcommunitygrid.org/

Hors ligne

#6 Le 29/10/2012, à 05:08

jee-el

Re : Les touches mortes n’attendent pas [résolu]

je cite l'essentiel du post évoqué par mithi

....En fait grâce à ma compagne, j'ai pu voir que le périphérique de saisie était positionné sur th-gtk. Dans les choix dispos il y a aucun, ibus, th-gtk, lo-gtk.

J'ai donc positionné sur aucun. Délivrance, ça marche...

Je pense que l'innaccessibilité de cette boîte de dialogue a causé ma perte car j'ai sélectionné un mauvais truc sans le savoir...

c'est bête, hein, mais ça suffit pour pourrir la vie!
problème réglé!

le chemin:
paramètres système -->tous les paramètres --> PERSONNEL --> prise en charge des langues -->langue--> système de saisie (tout en bas, le menu déroulant)

Dernière modification par jee-el (Le 29/10/2012, à 05:17)


jee-el, Grand-Père Plex!
C-mère Gigabyte H87-HD3
C Graphique NVIDIA GTX 760
multiboot voyager 13.04 64bits Ubuntu 14.04/ XP sp3

Hors ligne

#7 Le 29/10/2012, à 05:28

Hizoka

Re : Les touches mortes n’attendent pas [résolu]

Pour KDE : configuration système => périphériques d’entrée => clavier => onglet disposition => cocher "configurer disposition" => choisir fr avec aucune disposition

Hors ligne

#8 Le 30/10/2012, à 00:29

Danquebec

Re : Les touches mortes n’attendent pas [résolu]

Hé, non mais en fait la solution de Mithi ça marche pour moi aussi en fin de compte. Ça a juste pris du temps, aucune idée pourquoi ! J’ai rien fait depuis et ça s’est mis à marcher comme ça !


Salon jabber bien : discussion@chat.jabberfr.org - Pour parler de tout et n'importe quoi - Venez en grand nombre !
Donnez du calcul inutilisé à des recherches scientifiques et technologiques (cure du cancer, du sida, énergies propres, etc...) http://www.worldcommunitygrid.org/

Hors ligne

#9 Le 30/10/2012, à 16:29

jee-el

Re : Les touches mortes n’attendent pas [résolu]

hello Dan! si c'est ok pour toi, peux-tu ajouter au titre du fil  (RESOLU) ?

content pour nous! smile


jee-el, Grand-Père Plex!
C-mère Gigabyte H87-HD3
C Graphique NVIDIA GTX 760
multiboot voyager 13.04 64bits Ubuntu 14.04/ XP sp3

Hors ligne

#10 Le 26/12/2012, à 14:24

marbotte

Re : Les touches mortes n’attendent pas [résolu]

Chez moi (Kubuntu 12.04), aucune de ces solutions n'a marché, mon problème était plus exactement de pouvoir écrire les caractères espagnols du style ñ ò etc.
mais j'ai trouvé une solution de rechange en attendant: utiliser la touche "Compose"
Pour ce faire:
(sous kde) Aller dans "Configuration du système", "périphérique d'entrée", "Avancé", "Position de la touche Compose". Il suffit ensuite de choisir la touche qui vous convient.
Personnellement j'ai choisi la touche windows droite.
Ensuite, sans paramétrage supplémentaire:
"Compose+AltGr+é(2èmetouche)" puis "n" en gardant la touche compose appuyée donne "ñ" les touches '`~ marchent aussi très bien avec les lettres correspondantes.
Il est aussi possible de paramétrer d'autres caractères (chercher "touche compose" dans la documentation de ce site)

Hors ligne

Haut de page ↑