Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 24/10/2012, à 17:07

RemPsy

[Résolu]Problème Proxy Subsonic via Apache2

Bonjour,

Je viens d'installer Subsonic sur mon serveur OVH, il fonctionne parfaitement j'ai suivi les tutos, j'ai créé le vhost et on peux bien joindre mon serveur subsonic à "sousdomaine.domaine.com:4040" mais j'aimerais passer directement par l'url " sousdomaine.domaine.com ".

J'ai essayé les tutos pour utiliser apache2 comme proxy mais, la plupart étaient vieux et périmes en effet aucun n'a fonctionné.

Pouvez m'aider s'il vous plaIt ?

Merci d'avance,
Jeremy

Dernière modification par RemPsy (Le 31/10/2012, à 22:30)

Hors ligne

#2 Le 24/10/2012, à 18:25

Maisondouf

Re : [Résolu]Problème Proxy Subsonic via Apache2

Une solution à laquelle je pense dans l'immédiat parce que je l'utilise pour qwebirc, c'est de créer réellement le sous domaine chez OVH.
Dans le fichier 'index.html' du sous-domaine, tu crées la redirection vers Subsonic.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 24/10/2012, à 19:18

RemPsy

Re : [Résolu]Problème Proxy Subsonic via Apache2

Bonsoir, enfaite je n'utilise pas les dns OVH.
J'utilise actuellement CloudFlare et j'ai bien mis le A record, quand je vais sur sousdomaine.domaine.com j'ai la page d'accueil de apache ( it's work!) qui s'affiche mais je voudrais tomber directement sur le subsonic.

Dernière modification par RemPsy (Le 25/10/2012, à 11:40)

Hors ligne

#4 Le 28/10/2012, à 14:47

RemPsy

Re : [Résolu]Problème Proxy Subsonic via Apache2

Quelqu'un aurait une idée ? ^^

Hors ligne

#5 Le 28/10/2012, à 16:18

Titouan

Re : [Résolu]Problème Proxy Subsonic via Apache2

par reverse_proxy

je te donne un exemple avec tomcat, qui pointe sur leur exemple "bonjour".
pour subsonic, c'est la même chose, qui utilise jetty (je crois). tu adapteras.
il faut au niveau d'apache charger les modules nécessaires proxy (sudo a2enmod)

pour toutes les applis web qui utilisent des mini-serveurs indépendants http sur le port xxxx, c'est la même chose.

<VirtualHost *:80>

	ServerName ...
	UseCanonicalName On
	ProxyRequests Off
	ProxyPreserveHost On
....
<Proxy *>
	Order allow,deny
        Allow from all
</Proxy>
	ProxyPass /bonjour/ http://127.0.0.1:8080/examples/servlets/servlet/HelloWorldExample
	ProxyPassReverse /bonjour/ http://127.0.0.1:8080/examples/servlets/servletHelloWorldExample
....
</VirtualHost>

firefox http://www.domain.tld/bonjour/

Hors ligne

#6 Le 28/10/2012, à 17:46

RemPsy

Re : [Résolu]Problème Proxy Subsonic via Apache2

Bonjour, pour votre exemple vous parler d'un sous dossier mais moi je voudrais tomber directement sur subsonic en allant sur mon sous domaine ?

Hors ligne

#7 Le 29/10/2012, à 17:22

RemPsy

Re : [Résolu]Problème Proxy Subsonic via Apache2

Voii mon fichier vhost :

Mon fichier host porte le nom de mon sous domaine :

NameVirtualHost Mon-IP:4040
<VirtualHost Mon-IP:4040>
        ServerAdmin perso@hotmail.fr
        ServerName subsonic.mondomaine.com
        ServerAlias www.subsonic.mondomaine.com subsonic.mondomaine.com
        ErrorLog /var/log/apache2/subsonic.mondomaine.com-error.log
        CustomLog /var/log/apache2/subsonic.mondomaine.com-access.log combined
        DocumentRoot /var/subsonic
        <Directory /var/subsonic>
                Options Indexes ExecCGI FollowSymLinks
                Order allow,deny
                Allow from all
                AllowOverride all
        </Directory>
        # Permet de masquer la signature renvoyée par Apache
        ServerSignature Off

# Directives concernant le Proxy que nous venons d'activer sur notre serveur
<IfModule mod_proxy_http.c>
    ProxyRequests Off
    ProxyPreserveHost On
    UseCanonicalName On
	<Proxy *>
    Order allow,deny
    Allow from all
    </Proxy>
	
    ProxyPass / http://subsonic.mondomaine.com:4040/
    ProxyPassReverse / http://subsonic.mondomaine.com:4040/
</IfModule>
</VirtualHost>

Hors ligne

#8 Le 31/10/2012, à 16:22

RemPsy

Re : [Résolu]Problème Proxy Subsonic via Apache2

Je suis sur que le problème est simple j'ai du oublié un truc à un endroit j'ai beau vérifier chaque ligne je trouve pas x)

Hors ligne

#9 Le 31/10/2012, à 16:27

peterp@n

Re : [Résolu]Problème Proxy Subsonic via Apache2

Salut,
J'étais tomber sur ce tuto pour Subsonic sur un RaspberryPi et j'ai tenté la partie http_proxy. Sans succès pour moi. Peut être auras tu plus de chance.
En tous cas le tuto date de Février 2012...
Edit : c'est mieu avec un lien wink
http://www.sublimigeek.fr/subsonic-serv … udio-video

Dernière modification par peterp@n (Le 31/10/2012, à 16:28)

Hors ligne

#10 Le 31/10/2012, à 17:13

RemPsy

Re : [Résolu]Problème Proxy Subsonic via Apache2

Merci je aller voir ^^
Edit: c'est le tuto que j'avais suivit x)

Dernière modification par RemPsy (Le 31/10/2012, à 17:13)

Hors ligne

#11 Le 31/10/2012, à 22:30

RemPsy

Re : [Résolu]Problème Proxy Subsonic via Apache2

Problème Résolu !

Enfaîte le fichier de conf est ultra simple !

<VirtualHost *:80>

ServerAlias sousdomaine.domaine.com
ServerName www.domaine.com
ProxyPass / http://localhost:4040/
ProxyPassReverse / http://localhost:4040/

</VirtualHost>

Hors ligne

Haut de page ↑