Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 02/11/2012, à 13:11

Sauzee

Session Gnome-Shell inaccessible si Compiz activé au démarrage.

Bonjour

Petit soucis sur Precise 64 bits, drivers proprio nVidia activés.

J'ai installé Gnome-Shell par les dépots Ubuntu et tout fonctionne. Mais de façon assez selective:
- Si j'active Compiz (dans les applications au démarrage), je n'ai ensuite plus la possibilité d'ouvrir une session avec interface Gnome-Shell. J'ai bien tous les choix au Login mais rien n'y fait. Je selectionne "Gnome" dans le menu LightDm mais retombe invariablement sur une session Unity.
- Si je désactive Compiz, Gnome-Shell redevient normalement accessible.
.... Mais dans ce cas de figure, je ne peux plus utiliser une session Unity, because cette interface est dépendante de Compiz (je me retrouve avec un bureau Unity nu: sans accès au Dash et sans tableau de bord supérieur).
J'ai essayé tout l'essayable (à mon faible niveau) mais rien de concluant.

Vos puissantes lumières sont les bienvenues. Au pire une poignée de photons fera l'affaire.
Merci.

Dernière modification par Sauzee (Le 02/11/2012, à 13:12)

Hors ligne

#2 Le 02/11/2012, à 16:18

Bertrand49

Re : Session Gnome-Shell inaccessible si Compiz activé au démarrage.

Bonjour, cela est bien normal puisque compiz est incompatible avec gnome-shell.....qui possède son propre système d'effets.

Hors ligne

#3 Le 02/11/2012, à 16:39

Sauzee

Re : Session Gnome-Shell inaccessible si Compiz activé au démarrage.

?

Merci de ta réponse mais... tu es sûr de ça?
Donc on ne peut pas faire cohabiter Unity et Gnome-Shell sur la même machine sans que l'un des deux ne refuse de s'afficher? Unity parce qu’il nécessite Compiz alors que Gnome-Shell y est allergique....
Mhmmm... Pourquoi diable LightDm propose un menu qui laisse supposer que toutes ces options graphiques sont  disponibles sans prise de tête ...
Je suis un garçon positif. Je reformule la question:
- Y-a-t-il une possibilité pour inclure dans le chargement de la session Unity (et seulement de la session Unity) une commande qui active Compiz  et qui bien sur le désactive en fermeture de session?

- Question subsidiaire: virer Unity de Précise, est-ce risqué ou dangereux?

Dernière modification par Sauzee (Le 02/11/2012, à 16:57)

Hors ligne

#4 Le 03/11/2012, à 11:07

Bertrand49

Re : Session Gnome-Shell inaccessible si Compiz activé au démarrage.

Oui, je suis sûr de ce que je dis, ce n'est pas le premier forum qui en parle...cependant, le mieux étant donné que tu as l'air plutôt gnome, c'est d'installer la version ubuntu 12.04 GS-remix, qui est fournie uniquement avec gnome. Pour Precise, rien n'interdit de virer unity, mais l'autre solution est meilleure, c'est évidemment celle que j'ai adopté.

Hors ligne

#5 Le 04/11/2012, à 02:36

Sauzee

Re : Session Gnome-Shell inaccessible si Compiz activé au démarrage.

Ok, je doutais de ta réponse parce-qu'il me semblait impossible de ne pas pouvoir passer simplement d'une interface à l'autre. M'enfin bon, ça reste un problème plutôt bénin.
Je viens d'installer Debian Testing en Dual-Boot, demain j'essaierais aussi  Ubuntu 12.04 GS-remix.
Merci pour tes conseils.

Hors ligne

#6 Le 04/11/2012, à 09:04

bluc

Re : Session Gnome-Shell inaccessible si Compiz activé au démarrage.

Même si Unity utilise Compiz , a l'ouverture de ta session Gnome shell il n'est pas activé au démarrage
a moins que tu l'aie toi même activé
on peut tres bien passer d'une interface a l'autre sans probleme
Chez moi Unity , Gnome shell, Xfce et Kde

Dernière modification par bluc (Le 04/11/2012, à 09:06)


Packard Bell : elementary OS  ❖  Ubuntu 14.04 Unity
Toshiba A 100-187 :  elementary OS ❖ Xubuntu 13.04 

Hors ligne

#7 Le 04/11/2012, à 12:30

Sauzee

Re : Session Gnome-Shell inaccessible si Compiz activé au démarrage.

... Ah ...
Ben faudra que je vois mon exorciste.
Je viens d'installer fraîche de chez fraîche Quantal + Gnome-Shell et c'est exactement la même chose:
Compiz est installé mais n'est pas inclus dans les applis au démarrage. (j'ai installé Compiz Settings Manager pour m'assurer que le Plugin Unity était bien activé. Il l'est.)
Bilan:
Gnome-Shell se lance sans problème.
Unity "se lance" sans Dash ni Tableau de bord. Seules les icônes du bureaux sont visibles.
- Si je mets Compiz dans les applis au démarrage, impossible d'ouvrir une session Gnome-Shell, malgré le choix qui va bien à l'écran de Login. Je retombe invariablement sur Unity - qui fonctionne alors farpaitement wink -

Dernière modification par Sauzee (Le 04/11/2012, à 12:32)

Hors ligne

#8 Le 04/11/2012, à 15:06

bluc

Re : Session Gnome-Shell inaccessible si Compiz activé au démarrage.

c'est donc que ta carte graphique ne fonctionne pas bien ,voir pas du tout, avec Compiz


Packard Bell : elementary OS  ❖  Ubuntu 14.04 Unity
Toshiba A 100-187 :  elementary OS ❖ Xubuntu 13.04 

Hors ligne

#9 Le 04/11/2012, à 16:40

Sauzee

Re : Session Gnome-Shell inaccessible si Compiz activé au démarrage.

Et pourtant... sous Unity avec Compiz activé, je peux sans problèmes jouir de tous les effets, type Fenêtres Hollande Gélatine, Zoom, Fade, j'en passe et des meilleures... Même GlxGears se la tire sur ma modeste nVidia 8600 GT:

GlxGears a écrit :

16135 frames in 5.0 seconds = 3226.941 FPS

Mais bon, on va pas non plus y passer les fêtes. Disons que c'est probablement moi qui suis incapable de synthétiser tout ça.
Merci pour vos réponses.

Dernière modification par Sauzee (Le 04/11/2012, à 16:41)

Hors ligne

#10 Le 04/11/2012, à 17:53

bluc

Re : Session Gnome-Shell inaccessible si Compiz activé au démarrage.

Sauzee a écrit :

Et pourtant... sous Unity avec Compiz activé, je peux sans problèmes jouir de tous les effets, type Fenêtres Hollande Gélatine, Zoom, Fade, j'en passe et des meilleures... Même GlxGears se la tire sur ma modeste nVidia 8600 GT:

Et bien tout va bien alors !...
Normalement tu dois pouvoir aller sur Gnome shell sans problème sans aucune modification


Packard Bell : elementary OS  ❖  Ubuntu 14.04 Unity
Toshiba A 100-187 :  elementary OS ❖ Xubuntu 13.04 

Hors ligne

#11 Le 04/11/2012, à 18:15

Sauzee

Re : Session Gnome-Shell inaccessible si Compiz activé au démarrage.

Bluc, faudra changer les piles de ton Sonautone .... le monsieur a dit:

Sauzee a écrit :

.../
- Si je mets Compiz dans les applis au démarrage, impossible d'ouvrir une session Gnome-Shell, malgré le choix qui va bien à l'écran de Login. Je retombe invariablement sur Unity - qui fonctionne alors farpaitement wink -

Allez, pas de soucis.
à +
wink

Dernière modification par Sauzee (Le 04/11/2012, à 18:16)

Hors ligne

#12 Le 04/11/2012, à 18:58

bluc

Re : Session Gnome-Shell inaccessible si Compiz activé au démarrage.

T’inquiètes, ça ne m’empêchera pas de dormir    lol
Chez moi, comme chez tout le monde, ça fonctionne très bien , j'ai fait une recherche sur Google pas vu de cas similaire

Bye

Dernière modification par bluc (Le 04/11/2012, à 19:21)


Packard Bell : elementary OS  ❖  Ubuntu 14.04 Unity
Toshiba A 100-187 :  elementary OS ❖ Xubuntu 13.04 

Hors ligne

  • Accueil
  • » Forum
  • » Gnome3
  • » Session Gnome-Shell inaccessible si Compiz activé au démarrage.

Haut de page ↑