Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 04/11/2012, à 03:46

Skafkef

[RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

Bonjour,
Après avoir laisser tomber depuis longtemps je chercher a régler ce problème avec la sortie de Windows 8 et d'Ubuntu 12.10
J'arrive toujours pas à avoir Windows dans Grub, du coup pour choisir mon OS je rentre à chaque fois dans le BIOS, j'ai presque tout essayer mais rien ne marche .
j'ai aussi tenté ce tuto : http://forum.ubuntu-fr.org/viewtopic.php?id=757311
Voici mon Boot-Info au cas où: paste.ubuntu.com/1330723/
Merci d'avance.

Dernière modification par Skafkef (Le 09/11/2012, à 03:26)

Hors ligne

#2 Le 04/11/2012, à 04:02

f.x0

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

Bonjour Skafkef,

La doc que tu cites n'est pas prévue pour la 12.04 ni la 12.10, suit plutôt le lien indiqué par Malbo vers la doc Ubuntu

http://forum.ubuntu-fr.org/viewtopic.php?id=757311 a écrit :

Ce tuto est obsolète pour Ubuntu 12.04 (il est inadapté aux disques durs de grande taille, du fait qu'il propose de créer une partition EFI éloignée du début du disque dur) : pour 12.04, utiliser la doc : http://doc.ubuntu-fr.org/efi


SOPI

Hors ligne

#3 Le 06/11/2012, à 17:43

Skafkef

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

Bonjour,
Désolé pour le feedback en retard, je tiens à préciser que j'ai toujours le problème même après avoir essayer de me baser sur la doc, en fait lors de l’installation en me propose pas du tout d'installer Ubuntu à coté des autres c'est comme si y a pas de windows dans mon disque.

Hors ligne

#4 Le 06/11/2012, à 19:44

f.x0

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

Tu parles bien de cette doc ???


SOPI

Hors ligne

#5 Le 06/11/2012, à 20:27

Skafkef

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

Oui biensûr.

Hors ligne

#6 Le 06/11/2012, à 20:44

f.x0

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

A la vue du message de ton boot info

=================== Final advice in case of recommended repair
Please do not forget to make your BIOS boot on sda1/efi/.../grub*.efi file!

The boot files of [Ubuntu 12.10] are far from the start of the disk. Your BIOS may not detect them. You may want to retry after creating a /boot partition (EXT4, >200MB, start of the disk). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot partition:] option of [Boot Repair]. (https://help.ubuntu.com/community/BootPartition)


as-tu fait ???
Please do not forget to make your BIOS boot on sda1/efi/.../grub*.efi file!

si c'est le cas, tu devrais mettre un lien de ton message dans ce post,
tu devrais être entre les mains de spécialistes (Yannubuntu ou encore Malbo)


SOPI

Hors ligne

#7 Le 07/11/2012, à 13:26

malbo

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

Skafkef a écrit :

du coup pour choisir mon OS je rentre à chaque fois dans le BIOS, j'ai presque tout essayer mais rien ne marche .

Moi je ne sais pas t'aider pour accéder à Windows en passant par Grub. Je réagis à "je rentre à chaque fois dans le BIOS". A mon avis, tu pourrais déjà intervenir dans ton Bios pour mettre la priorité de démarrage sur l'OS que tu utilises le plus, de sorte qu'à la mise en marche, ton PC démarre direct sur cet OS. Du coup, il n'y a que pour aller sur l'autre OS qu'il faudrait aller dans le Bios.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#8 Le 08/11/2012, à 02:30

Skafkef

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

malbo a écrit :

Moi je ne sais pas t'aider pour accéder à Windows en passant par Grub. Je réagis à "je rentre à chaque fois dans le BIOS". A mon avis, tu pourrais déjà intervenir dans ton Bios pour mettre la priorité de démarrage sur l'OS que tu utilises le plus, de sorte qu'à la mise en marche, ton PC démarre direct sur cet OS. Du coup, il n'y a que pour aller sur l'autre OS qu'il faudrait aller dans le Bios.

Le problème c'est qu'il y a pas de OS que j'utilise plus, chaque jour j’utilise les deux Ubuntu pour les études, et Windows pour le reste pour ça que j'ai besoin d'une solution plus propre et facile.

Ps j'ai refait l’installation voici mon boot info : paste.ubuntu.com/1341382/

Dernière modification par Skafkef (Le 08/11/2012, à 02:31)

Hors ligne

#9 Le 08/11/2012, à 10:08

malbo

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

Il va falloir lancer la réparation recommandée de Boot-Repair. En effet, tu peux lire dans ton Boot-Info :

=================== Default settings
Recommended-Repair
This setting would reinstall the grub-efi of sda7, using the following options:        sda2/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s   fix-windows-boot backup-and-rename-efi-files

La partie utile est "fix-windows-boot backup-and-rename-efi-file" qui veut dire que la réparation recommandée va créer une entrée fonctionnelle pour démarrer Windows.

Je te prie de te référer à cette discussion (à partir du post #31) pour comprendre ce qui va se passer : http://forum.ubuntu-fr.org/viewtopic.ph … #p10623001
En particulier, la partie suivante de ton Boot-Info :

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

devrait s'enrichir de lignes pour la nouvelle entrée permettant de démarrer Windows.

Dernière modification par malbo (Le 08/11/2012, à 10:19)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#10 Le 09/11/2012, à 03:26

Skafkef

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

Problème réglé merci beaucoup.

Hors ligne

#11 Le 09/11/2012, à 08:13

malbo

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

Bonne nouvelle. Peux-tu refaire un Boot-Info pour que je puisse voir comment la réparation s'est effectuée ? Et indiquer également le modèle et le fabricant de ton PC ?


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#12 Le 10/11/2012, à 17:46

Skafkef

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

Voici le boot-info : http://paste.ubuntu.com/1348113/
Et pour le modèle c'est un pc monté avec une carte mère Asus P8H67

Hors ligne

#13 Le 10/11/2012, à 20:21

malbo

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

Merci pour ces infos


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#14 Le 11/11/2012, à 02:27

Skafkef

Re : [RESOLU] DualBoot: Absense de Windows dans Grub [EFI]

C'est la moindre des choses ^^

Hors ligne

Haut de page ↑