Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 14/10/2012, à 12:30

tanpalomino

[RESOLU] Problème avec le raccourci clavier de gestion du volume

Bonjour à tous,

Après quelques tâtonnements sur Linux (ai essayé Ubuntu avec gnome-session-fallback, puis Kubuntu), je suis tombé sur Xubuntu, qui me semble vraiment génial. Le seul petit bug que j'ai est mineur, mais je vous le soumets quand même car je rêve d'un ordi qui m'obéisse au doigt et à l'oeil...

Sur mon laptop Dell Inspiron N5110 (avec Xubuntu 12.04, donc), j'ai un "raccourci clavier" pour monter, baisser et couper le son : Fn + F11 / F12. Ce raccourci fait bien apparaître une barre de son qui monte et qui descend dans la zone de notification, mais celle-ci semble n'avoir aucun lien avec le son réel de mon ordi.

Y a-t-il donc un moyen de faire correspondre l'action du raccourci au son de l'ordinateur ?

Merci d'avance,

Tan

Dernière modification par tanpalomino (Le 15/10/2012, à 20:37)

Hors ligne

#2 Le 14/10/2012, à 12:45

fcn50

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

Salut,

Est-ce que Xfce Volume Deamon est installé et coché dans Paramètres>Session et Démarrage>Démarrage automatique? Si non, il faut le cocher.


12.04.4 LTS, Xfce 4.10, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
    Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#3 Le 14/10/2012, à 13:57

tanpalomino

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

Alors je suis désolé mais le newbie que je suis ne trouve pas l'option de démarrage automatique... Il n'y a pas "Session et démarrage", ni dans Paramètres, ni dans Système, ni dans Accessoires... Pour info je suis sur Xfce 4.8. Ne peut-on pas modifier l'option à partir d'un simple de fichier de config ou qqc du genre ?

Merci d'avance,

Tan

Hors ligne

#4 Le 15/10/2012, à 16:35

tanpalomino

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

D'après ce que j'ai cru comprendre la solution que tu me proposes est valable pour Xfce 4.10, mais je ne trouve pas la commande équivalente pour Xfce 4.8... Et j'avoue que j'aimerais autant ne pas modifier mon install qui marche tellement bien !

Hors ligne

#5 Le 15/10/2012, à 17:28

The Uploader

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

Salut

xfce4-volumed est le démon Xfce qui s'occupe des touches multimédia liées au volume sonore, et affiche les notifications que tu décris.
Pour savoir s'il est actif, faire dans un terminal :

ps aux | grep volumed

Cela devrait retourner quelque chose comme :

max        602  0.0  0.3 349416 13000 ?        Ssl  14:38   0:00 xfce4-volumed
max       4911  0.0  0.0   8468  1060 pts/0    S+   17:11   0:00 grep --color=auto volumed

La première ligne montre que xfce4-volumed est bien présent.

S'il n'a aucun effet, tu peux rajouter des raccourcis clavier dans le gestionnaire de paramètres => Clavier => Raccourcis d'applications :
La commande du raccourci clavier pour baisser le son sera :

pactl -- set-sink-volume 0 -5%

La commande du raccourci clavier pour augmenter le son sera :

pactl -- set-sink-volume 0 +5%

La commande du raccourci clavier pour mettre le son sur muet sera :

pactl -- set-sink-volume 0 0%

La commande du raccourci clavier pour réactiver le son sera :

pactl -- set-sink-volume 0 65%

(ou 100% si on veut qu'il soit activé et "à fond")

Bien sûr, si ces raccourcis claviers sont affectés aux mêmes touches qu'avant, il faut virer xfce4-volumed sinon ces raccourcis seront pris par lui, et n'auront aucun effet :
Dans le gestionnaire de paramètres => Session et Démarrage => Démarrage automatique, décoche "Démon de volume XFCE". Ensuite, tue son processus :

killall xfce4-volumed

Dernière modification par The Uploader (Le 15/10/2012, à 17:29)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#6 Le 15/10/2012, à 20:37

tanpalomino

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

Ca y est j'ai réglé mon problème, merci à vous. The Uploader, j'ai utilisé ta solution, mais avec d'autres commandes (celles-ci ne marchent pas) que j'ai trouvées sur cette page : http://doc.ubuntu-fr.org/tutoriel/regle … ume_sonore (d'ailleurs mea culpa, j'aurais sûrement pu me débrouiller seul !)

Merci à vous pour le temps passé,

Tan

Hors ligne

#7 Le 09/11/2012, à 21:08

pierrecastor

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

Salut

Même problème que tanpalomino, mon raccourcis clavier ne marche pas, que ça sois sur ma tour ou mon portable.

Ce raccourcie fait apparaitre une petite zone de notification qui bouge bien comme il faut, mais cela n'à pas d'effets sur le volume réel.

La commande ps aux | grep volumed me renvoi ça :

pierre    1724  0.0  0.1 1108960 11124 ?       Ssl  18:16   0:00 xfce4-volumed
pierre    6861  0.0  0.0  13648   920 pts/1    S+   20:06   0:00 grep --color=auto volumed

Donc à priori, c'est bien activé, j'ai essayer de rajouté les raccourcies clavier donné par The Uploader ainsi que ceux de la doc, mais ça ne change rien.

Merci d'avance pour l'aide que vous pouvez m'apporter.

Dernière modification par pierrecastor (Le 09/11/2012, à 21:09)


C'est cool, les quotes dans la signature, j'en une super, n'est-ce pas ? :lol:

S.O.D.

En ligne

#8 Le 09/11/2012, à 21:17

The Uploader

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

Si tu as rajouté des raccourcis claviers et qu'ils utilisent les mêmes touches que les touches multimédias gérées par xfce4-volumed (exemple : Fn + F10 pour couper/remettre le son), il faut tuer xfce4-volumed pour qu'ils soient effectifs (sinon ils sont gérés par xfce4-volumed, qui affiche ensuite la notification), et le décocher dans session et démarrage => Démarrage automatique.


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#9 Le 09/11/2012, à 21:26

pierrecastor

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

Ou pinaise, ça marche, je te kiff, The Uploader. smile

Un dernier détail, la commande

amixer set Master toggle

Permet bien de couper le son, mais pas de le remettre, une idée ?


C'est cool, les quotes dans la signature, j'en une super, n'est-ce pas ? :lol:

S.O.D.

En ligne

#10 Le 09/11/2012, à 22:01

The Uploader

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

J'utilise ALSA seul sous Archlinux, ça fait les deux. J'imagine que c'est PulseAudio qui fait son intéressant.

La doc à ceci à ce propos :

amixer set Master toggle ne fonctionne pas avec pulseaudio car la fonction unmute ne s'applique qu'au canal Master et les autres restent muets. Pour contourner cela, utiliser la commande amixer -D pulse set Master toggle afin que l'activation/désactivation du son passe par Pulseaudio


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#11 Le 09/11/2012, à 22:05

pierrecastor

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

Rhaaaa, lovely, ça marche.

Merci beaucoup. smile


C'est cool, les quotes dans la signature, j'en une super, n'est-ce pas ? :lol:

S.O.D.

En ligne

#12 Le 25/08/2013, à 15:12

ergatif

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

Bonjour,
Cette solution a fonctionné pour moi, sur un Acer Aspire One 725, avec juste un détail à modifier :
le numero du sink audio interne est 1 pour moi, le 0 est pour la sortie son HDMI.
D'où les ocmmandes suivantes chez moi :

Commande pour monter le son

pactl -- set-sink-volume 1 +5%

Commande pour baisser le son

pactl -- set-sink-volume 1 -5%

Toggle pour muet (mute)

amixer -D pulse set Master toggle

Note : on peut voir ses numéros de sink avec

 pactl list short sinks

et si on ne met pas l'option short on a beaucoup plus d'infos...

Dernière modification par ergatif (Le 25/08/2013, à 15:14)

Hors ligne

#13 Le 25/08/2013, à 15:49

ergatif

Re : [RESOLU] Problème avec le raccourci clavier de gestion du volume

En fait la bonne solution se trouve là :
http://xubuntugeek.blogspot.ch/2012/05/ … -keys.html
En résumé  il s'agit d'indiquer à xfce4-mixer la bonne sortie son :
Alt+F2 pour accéder aux réglages XFCE par la commande

xfce4-settings-editor

puis sélctionner xfce4-mixer et  dans le champ active-card remplacer

PlaybackAudiointerneStronumriqueHDMIPulseAudioMixer

ATTENTION Votre valeur peut différer, noter bien la valeur avant modification pour pouvoir revenir en arrière en cas de problème !
par

PlaybackAudiointerneStroanalogiquePulseAudioMixer

Et là tout marche y compris les notifications big_smile

Note : bien sûr pour cette solution il faut RÉACTIVER xfce4-volumed au démarrage, si vous l'aviez désactivé auparavant.

Dernière modification par ergatif (Le 25/08/2013, à 17:36)

Hors ligne

  • Accueil
  • » Forum
  • » XFCE
  • » [RESOLU] Problème avec le raccourci clavier de gestion du volume

Haut de page ↑