Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 11/11/2012, à 20:11

MrGlitch

Installation Ubuntu 12.04 (EFI)

Bonsoir les Linuxiens !

J'ai récemment fais l'acquisition d'un Asus X501A

Le voici

Cependant quelque chose me chagrine ... Vous devinez bien que c'est Windows 8 smile

Mais je ne connaissais pas encore l'UEFI !!!

Donc j'essaie une première fois sans succès puis je viens me renseigner ici (bien sûr j'ai épluché le forum avant de poster)

Donc j'ai télécharger la version sécurisée d'Ubuntu 64bits

Je crée une clé "bootable"

Et j'essaie d'installer la bête

J'arrive à cet écran

Le voici

Je lance "Install Ubuntu"

Et puis plus rien à part un écran noir ...

Que faire ?

Merci de vos réponses smile

Hors ligne

#2 Le 11/11/2012, à 20:54

f.x0

Re : Installation Ubuntu 12.04 (EFI)

Bonjour MrGlitch,


Tu as suivi cette doc ???


SOPI

Hors ligne

#3 Le 11/11/2012, à 22:42

MrGlitch

Re : Installation Ubuntu 12.04 (EFI)

Bonsoir f.x0

Oui je l'ai suivie

Hors ligne

#4 Le 12/11/2012, à 03:07

david96

Re : Installation Ubuntu 12.04 (EFI)

Houllà, tu n'es pas le premier que je viens de voir cette semaine avoir un problème avec EFI… N'ayant pas encore vu ce système dans mon entourage, je ne peux peux dire si le problème viens de là, mais ça commence à m'inquiéter sérieusement.

Hors ligne

#5 Le 12/11/2012, à 08:22

MrGlitch

Re : Installation Ubuntu 12.04 (EFI)

C'est rageant de voir que l'on ne peut pas faire ce que l'on veut avec son matériel ...

Hors ligne

#6 Le 12/11/2012, à 09:18

david96

Re : Installation Ubuntu 12.04 (EFI)

Oui, c'est scandaleux… Encore une entourloupe pour piéger le consommateur… Rhaaa ! mad

Édite : ceci dit, y'a de plus en plus de portable pre-installé sous GNU/Linux, à voir au niveau config si c'est aussi performant.

Dernière modification par david96 (Le 12/11/2012, à 09:20)

Hors ligne

#7 Le 12/11/2012, à 11:12

malbo

Re : Installation Ubuntu 12.04 (EFI)

Une info rassurante pour toi : http://ubuntuforums.org/showpost.php?p= … ostcount=7
dans ce post, Cheesemill indique qu'il a pu installer Ubuntu 12.10 (The Quantal Quetzal) dans son X501A. Je n'en sais pas plus que ça (ce n'est pas mon pote Cheesemill) mais je serais étonné que tu galères encore longtemps avant d'installer Ubuntu la-dedans. Il doit y avoir un petit grain de sable qui coince...

Je ne veux absolument pas te conseiller Ubuntu 12.10 plutôt que Ubuntu 12.04 pour l'avenir : je te suggère seulement d'être pragmatique et de faire un essai en session live de Ubuntu 12.10. S'il se trouve que la session live de Ubuntu 12.10 fonctionne les doigts dans le nez dans ta machine, c'est sûr que cette dernière version (12.10) marquera un point et que ça voudrait le coup de songer à l'installer. Si par contre c'est la même galère, reviens sur Ubuntu 12.04 et on tentera de t'aider à trouver une solution pour arriver à installer.

Edit : normalement, si tu démarres ta machine sur une liveUSB de Ubuntu 12.10, tu devrais voir très brièvement une ligne "Secure Boot Not Enabled" comme dans ce post : http://forum.ubuntu-fr.org/viewtopic.ph … #p11306521
Si tu ne la vois pas, vérifies que tu n'as pas une possibilité de désactiver "Secure Boot" dans ton "Bios". On parle ici de ce problème possible : http://fr.wikipedia.org/wiki/Unified_Ex … re_boot.29
Moi, je m'y connais très peu avec "Secure Boot" parce qu'on découvre Win8 préinstallé sur les PC et qu'on démoule toutes les vacheries qui peuvent se produire. Je sais seulement qu'on peut désactiver Secure Boot et c'est pourquoi je te suggère de le faire.

Dernière modification par malbo (Le 12/11/2012, à 11:35)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#8 Le 12/11/2012, à 11:17

phpmyadmin

Re : Installation Ubuntu 12.04 (EFI)

j'ai un problème dans mon phpmyadmin:
j'ai installé apache2 en fastcgi et php5-fpm
quand j'ai installé phpmyadmin je n'arrive pas à y accéder voilà l'erreur qui est affichée "The requested URL /php5-fcgi//phpmyadmin/index.php was not found on this server." je ne sais pas comment configurer mon phpmyadmin de sorte qu'il fonctionne sous php5-fpm.
aidez moi SVP.

Hors ligne

#9 Le 13/11/2012, à 00:10

MrGlitch

Re : Installation Ubuntu 12.04 (EFI)

@malbo

C'est la version 64bits dans ce lien ? ===> Celui ci

Car moi j'ai essayé la version 32bits et ça ne fonctionne pas (boot directement sur le W8 sans rien afficher)

Hors ligne

#10 Le 13/11/2012, à 07:56

malbo

Re : Installation Ubuntu 12.04 (EFI)

Lis bien la doc (§ 2.3 "Versions d'Ubuntu démarrables en mode EFI") : http://doc.ubuntu-fr.org/efi#versions_d … n_mode_efi
La version 32 bits de Ubuntu ne peut pas installer en mode EFI : il faut que tu utilises un support d'installation 64 bits
Tu peux télécharger l'iso 64 bits officiel à cette adresse : http://releases.ubuntu.com/releases/qua … -amd64.iso
ou bien si tu veux utiliser le torrent, c'est là : http://releases.ubuntu.com/releases/qua … so.torrent
Dans le lien, moi j'utilise "Ubuntu sécurisée" qui est une version 64 bits qui peut être téléchargée depuis cette page : http://doc.ubuntu-fr.org/ubuntu_secure_ … chargement
Tu choisis la version officielle ou la version "sécurisée", en tout cas, je te garantis que les deux permettent bien d'installer en EFI.

Dernière modification par malbo (Le 13/11/2012, à 13:08)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#11 Le 14/11/2012, à 19:17

MrGlitch

Re : Installation Ubuntu 12.04 (EFI)

@malbo

Bonsoir malbo, je suis allé dans mon bios et il n'y a pas de "Secure Boot" que faire ?

J'ai essayé d'installer la version que tu m'as donné mais çe ne fonctonne pas (écran noir quand je lance install Ubuntu)

Dernière modification par MrGlitch (Le 14/11/2012, à 22:47)

Hors ligne

#12 Le 15/11/2012, à 22:42

MrGlitch

Re : Installation Ubuntu 12.04 (EFI)

Up

Hors ligne

#13 Le 16/11/2012, à 08:18

malbo

Re : Installation Ubuntu 12.04 (EFI)

MrGlitch a écrit :

J'ai essayé d'installer la version que tu m'as donné mais çe ne fonctonne pas (écran noir quand je lance install Ubuntu)

je t'ai indiqué deux sources dans le post #10 (l'iso 64 bits officiel ou bien "Ubuntu sécurisée") : je te prie de préciser laquelle tu as choisie.

MrGlitch a écrit :

mais çe ne fonctonne pas (écran noir quand je lance install Ubuntu)

Il ne faut pas lancer l'installation : il faut d'abord faire une "session live", c'est à dire choisir "Essayer" (et non pas "installer"). Est-ce que ça fonctionne en session live ?

Dernière modification par malbo (Le 16/11/2012, à 08:20)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#14 Le 16/11/2012, à 08:29

MrGlitch

Re : Installation Ubuntu 12.04 (EFI)

Bonjour malbo j'ai téléchargé l'officielle en 64bits et j'ai bien aussi lancer en session live et toujours cet écran noir !

Hors ligne

#15 Le 16/11/2012, à 10:54

malbo

Re : Installation Ubuntu 12.04 (EFI)

C'est peut-être seulement un souci graphique qui nécessite de prendre l'option de démarrage nomodeset.
Je détaille la procédure pour prendre l'option nomodeset sur un support live qui démarre en mode EFI :

Au démarrage, on voit ce menu Grub avec la ligne "Try Ubuntu without installing" qui est sélectionnée :
mini_533451Capturedu20121116092956.png

Après appui sur la touche E du clavier, on voit ça :
mini_367418Capturedu20121116093137.png

Avec les flèches du clavier, on peut se déplacer après -- et supprimer "quiet splash --" à l'aide de la touche Backspace et taper à la place "nomodeset" pour que ça apparaisse comme ça :
A noter : comme le clavier est considéré comme étant "Qwerty", on doit utiliser la virgule pour faire le "m" de "nomodeset"
mini_403256Capturedu20121116093340.png

Ensuite, il ne reste plus qu'à valider en appuyant sur la touche de fonction F10

Dernière modification par malbo (Le 16/11/2012, à 11:14)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#16 Le 17/11/2012, à 00:08

david96

Re : Installation Ubuntu 12.04 (EFI)

Le nomodest étant souvent préconisé en cas de session de boot déféctueux, il serait bon de mettre ton explication (bien détaillée) dans la doc, par exemple dans le sujet : grub
Je te laisse l'honneur malbo ?

Dernière modification par david96 (Le 17/11/2012, à 00:09)

Hors ligne

#17 Le 17/11/2012, à 12:39

MrGlitch

Re : Installation Ubuntu 12.04 (EFI)

@malbo

Non vraiment désolé mais ça ne fonctionne pas
J'ai pourtant suivi ton post scrupuleusement et j'ai même recommencer deux fois

J'ai l'impression que ça ne sauvegarde pas quand je fais F10, quand j'ai recommencé une deuxième fois j'ai du réécrire "nomodeset"

Hors ligne

#18 Le 17/11/2012, à 12:45

malbo

Re : Installation Ubuntu 12.04 (EFI)

MrGlitch a écrit :

J'ai l'impression que ça ne sauvegarde pas quand je fais F10, quand j'ai recommencé une deuxième fois j'ai du réécrire "nomodeset"

C'est normal parce que justement ça n'a pas la prétention de sauvegarder le réglage et c'est "voulu". La procédure permet de prendre une option "à la volée", juste pour une session. L'intérêt c'est que si ça ne sert à rien pour résoudre le problème, comme tu ne l'as pas gravée "en dur", tu peux en essayer une autre à la place (du genre acpi=off ) jusqu'à ce que tu trouves celle qui sert à quelque chose.
Dans ce paragraphe, tu as toute une liste d'options : http://doc.ubuntu-fr.org/kernel#modifie … ssion-live
L'option acpi=off que j'ai mentionnée s'y trouve.

Dernière modification par malbo (Le 17/11/2012, à 12:47)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#19 Le 17/11/2012, à 12:46

MrGlitch

Re : Installation Ubuntu 12.04 (EFI)

Donc je dois essayer acpi=off ?

Hors ligne

#20 Le 17/11/2012, à 12:47

malbo

Re : Installation Ubuntu 12.04 (EFI)

Oui, ça vaut le coup d'essayer acpi=off (j'ai complété mon post #18 entre temps)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#21 Le 17/11/2012, à 12:50

MrGlitch

Re : Installation Ubuntu 12.04 (EFI)

Je te  remercie je vais essayer de ce pas

Hors ligne

#22 Le 17/11/2012, à 13:32

malbo

Re : Installation Ubuntu 12.04 (EFI)

D'autre part, je te prie de réessayer de désactiver Secure Boot (dans le post #11 tu as dit que tu n'avais pas trouvé mais j'ai de gros doutes). Regarde dans la partie ** Configuration du Setup pour le boot ** de ce doc : http://www.forum-des-portables-asus.fr/ … 916#p68916
L'auteur du tuto (phiphilou) explique bien comment désactiver Secure Boot (il faut passer "Secure Boot control" sur "disabled" (au lieu de Enabled") et tu peux aussi vérifier ce qu'il propose pour "si vous voulez booter en mode UEFI" parce que c'est ton cas : tu veux démarrer en mode EFI.

Dernière modification par malbo (Le 17/11/2012, à 13:34)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#23 Le 22/11/2012, à 18:41

MrGlitch

Re : Installation Ubuntu 12.04 (EFI)

Bonsoir malbo,

J'ai fais tous ce que tu m'as dis et rien ne marche sad

Y a t-il un rapport avec le fait que dans mon BIOS le "Lauch CSM" est sur "Disabled" ?

Dois-je suivre ce tuto ? ICI

Dernière modification par MrGlitch (Le 22/11/2012, à 18:46)

Hors ligne

#24 Le 22/11/2012, à 19:14

malbo

Re : Installation Ubuntu 12.04 (EFI)

MrGlitch a écrit :

Dois-je suivre ce tuto ? ICI

Si tu as ce qu'il faut pour installer Windows 8 en mode classique, tu peux suivre ce tuto mais il faudra supprimer la totalité des partitions du disque dur et créer une nouvelle table de partitions en MSDOS (au lieu de GPT).


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#25 Le 22/11/2012, à 19:25

MrGlitch

Re : Installation Ubuntu 12.04 (EFI)

Je veux installer uniquement Ubuntu Pour W8 si il doit être supprimé il sera supprimé c'est pas un problème smile

Hors ligne

Haut de page ↑