Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 30/10/2005, à 00:18

Mojuba

public_html, apache2 et Breezy Badger

Salut,

Je viens d'adopter Ubuntu et seul un problème subsiste : je n'arrive pas à configurer apache2 pour utiliser public_html via une url du type http://localhost/~<user>/

J'ai créé des symlinks pour /etc/apache2/mods-available/userdir.load + userdir.conf dans ../mods-enabled. Le phpinfo() me confirme bien le chargement de ce module. Et j'ai ouvert les droits maximum pour public_html (chmod -R 777 public_html).

Je suis toujours confronté à une erreur 403... et ça commence à me titiller sévère !

Qu'ai-je oublié de faire ?

Merci de votre aide !
-- Moj'

Dernière modification par Mojuba (Le 30/10/2005, à 13:33)

Hors ligne

#2 Le 30/10/2005, à 13:36

Mojuba

Re : public_html, apache2 et Breezy Badger

J'ai le souvenir que SELinux posait des problème avec Fedora (il fallait désactiver le module apache de SELinux). Les alias ne fonctionnaient pas. Est-ce également le cas avec Ubuntu ?

Merci pour vos réponses (et dites-moi si ça marche chez vous !).

-- Moj'

Hors ligne

#3 Le 30/10/2005, à 19:07

Nubster

Re : public_html, apache2 et Breezy Badger

Bonsoir,
'public_html' marche très bien, pour le mettre en place il suffit de faire ceci (extrait du wiki):

Dans le fichier “/etc/apache2/apache2.conf” recherchez les lignes (environ ligne 205) :

# UserDir is now a module
#UserDir public_html
#UserDir disabled root

#<Directory /home/*/public_html>
# AllowOverride FileInfo AuthConfig Limit
# Options Indexes SymLinksIfOwnerMatch IncludesNoExec
#</Directory>

Puis modifiez les (décommentez les lignes nécessaires) pour obtenir :

# UserDir is now a module
UserDir public_html
#UserDir disabled root

<Directory /home/*/public_html>
 AllowOverride FileInfo AuthConfig Limit
 Options Indexes SymLinksIfOwnerMatch IncludesNoExec
</Directory>

Puis redémarrez apache :

sudo /etc/init.d/apache2 restart

Voila smile

Hors ligne

#4 Le 30/10/2005, à 23:16

Mojuba

Re : public_html, apache2 et Breezy Badger

Merci pour cette réponse.

C'est ce que je pense avoir fait, en tout cas dans un premier temps.

Cela n'a pas fonctionné dans mon cas. Je me suis alors rendu compte que le module userdir n'était pas chargé par défaut. Logiquement, la simple modification de apache2.conf ne pouvait pas suffire. Cette modification peut-être apportée directement dans userdir.conf désormais. L'organisation d'apache2 sous Debian/Ubuntu est d'ailleurs très astucieuse par rapport à Fedora.

Mais le résultat est le même : erreur 403 ! J'ai dû louper un truc...

-- Moj'

Dernière modification par Mojuba (Le 30/10/2005, à 23:17)

Hors ligne

Haut de page ↑