Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 15/11/2012, à 11:19

PengouinPdt

cryptswap1 is not ready yet or not present

Bonjour,

Depuis l'install de Xubuntu 12.10, sur mon laptop, j'ai apparement un problème de montage avec ma swap.
Depuis des années, j'utilise le partitionnement crypté - dès l'install - de mon home -jusqu'à présent je n'avais jamais eu de soucis.
Avec la 12.10, j'ai au démarrage le message d'erreur suivant :
cryptswap1 is not ready yet or not present

Après quelques recherches, y'a pour l'instant pas de réponse trouvé dans notre propre idiome ; les réponses, trouvées dans la langue de shakespeare, ne me semblent pas résoudre le problème.

Ce que j'ai compris, lors de l'install de la 12.10, vu que j'ai demandé le chiffrement de ma partition, le système chiffre ma partition swap (/dev/sda14) et fait le montage (/dev/mapper/cryptswap1). À chaque démarrage de l'ordi, l'UUID change...  et devrait modifier automatiquement /etc/fstab.

L'UUID change bien ... mais /etc/fstab n'est pas modifié. Résultat, lors du montage, il n'arrive pas à trouver 'cryptswap1'.

Voilà, j'en suis là, dans ma compréhension du problème ...

Le seul moyen que j'ai trouvé - qui apparement n'est pas la réponse - est de modifier /etc/fstab pour faire pointer directement /dev/mapper/cryptswap1 sans passer par son UUID. De toute façon, j'ai toujours le même message d'erreur au démarrage.

Mon fichier  /etc/fstab :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

#Entry for /dev/sda7 :
UUID=1e88affb-0ca0-4c34-9940-80317abddec7	/	ext4	errors=remount-ro	0	1
#Entry for /dev/sda12 :
UUID=2567b87a-b449-4c8a-abf1-a35d7c630fd9	/boot	ext4	defaults	0	2
#Entry for /dev/sda13 :
UUID=a2667441-e05e-4473-8fd1-a235202e9df1	/home	ext4	defaults	0	2
#Entry for /dev/sda5 :
UUID=73E7FC373F1DECF8	/media/datas	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0
#Entry for /dev/sda11 :
UUID=f3ee5362-7d94-4655-9522-28cbf0ea202e	/opt	ext4	defaults	0	2
#Entry for /dev/sda9 :
UUID=74f63fdc-2228-47e1-8ecb-8691cecb8363	/tmp	ext4	defaults	0	2
#Entry for /dev/sda8 :
UUID=b0abf2e9-9c84-45df-9458-7bac6b53f767	/usr	ext4	defaults	0	2
#Entry for /dev/sda10 :
UUID=ae224a1a-cf58-4ba0-a168-ad20a3137b3a	/var	ext4	defaults	0	2
#Entry for /dev/mapper/cryptswap1 :
#UUID=c2270eae-957c-48ff-9f8c-d61072d678a2	none	swap	sw	0	0
/dev/mapper/cryptswap1	none	swap	sw	0	0

La commande 'blkid' restitue cela (sachant que l'UUID de cryptswap1) change à chaque boot :

:~$ sudo blkid 
/dev/sda1: SEC_TYPE="msdos" LABEL="DELLUTILITY" UUID="3030-3030" TYPE="vfat" 
/dev/sda2: LABEL="Recovery" UUID="CC70378A703779F2" TYPE="ntfs" 
/dev/sda3: LABEL="OS" UUID="905E0C695E0C4B04" TYPE="ntfs" 
/dev/sda5: LABEL="datas" UUID="73E7FC373F1DECF8" TYPE="ntfs" 
/dev/sda6: LABEL="swap" UUID="63A037674176271D" TYPE="ntfs" 
/dev/sda7: UUID="1e88affb-0ca0-4c34-9940-80317abddec7" TYPE="ext4" 
/dev/sda8: UUID="b0abf2e9-9c84-45df-9458-7bac6b53f767" TYPE="ext4" 
/dev/sda9: UUID="74f63fdc-2228-47e1-8ecb-8691cecb8363" TYPE="ext4" 
/dev/sda10: UUID="ae224a1a-cf58-4ba0-a168-ad20a3137b3a" TYPE="ext4" 
/dev/sda11: UUID="f3ee5362-7d94-4655-9522-28cbf0ea202e" TYPE="ext4" 
/dev/sda12: UUID="2567b87a-b449-4c8a-abf1-a35d7c630fd9" TYPE="ext4" 
/dev/sda13: UUID="a2667441-e05e-4473-8fd1-a235202e9df1" TYPE="ext4" 
/dev/mapper/cryptswap1: UUID="b8a61f09-23fe-4a50-b844-13e10b209dc5" TYPE="swap"

le fichier 'crypttab' renferme ces infos :

:~$ cat /etc/crypttab 
cryptswap1 /dev/sda14 /dev/urandom swap,cipher=aes-cbc-essiv:sha256

quant à 'free -m' :

:~$ free -m
             total       used       free     shared    buffers     cached
Mem:          7892       1536       6356          0         69        752
-/+ buffers/cache:        715       7177
Swap:         4095          0       4095

'free -m' me restitue 4095 parce que j'ai modifié le fichier /etc/fstab pour  pointer directement sur /dev/mapper/cryptswap1 ... sinon il restitue 0 !

Voili, voilou ... je sais, ça fait long ... mais si on pouvait m'aider à résoudre ce problème.
Merci d'avance.

Hors ligne

#2 Le 17/11/2012, à 13:22

PengouinPdt

Re : cryptswap1 is not ready yet or not present

Personne n'a d'idée ?

Hors ligne

Haut de page ↑