Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 15/11/2012, à 12:39

Kazkreol

(Résolu) - Droits d'administration

Bonjour,

Après avoir quitté le lit douillet de la version 9 pour la 12.10, je rencontre quelques problèmes. Mon disque est partagé en 3 : Une partition pour installer Ubuntu, une pour Windows et une pour stocker mes documents.

Le problème se pose avec la partition de stockage sur laquelle je ne peux modifier les droits administrateurs (méthode graphique, je lance Dolphin avec la console en sudo, ça marche avec la partition Ubuntu). D'autre part, tous les dossiers ou fichiers contenant des caractères type "é" ou "à" sont illisibles sur cette partition.

Je n'ai pas trouvé de solution dans la doc ou le forum.

Cela peut-il venir de la façon dont j'ai monté la partition?


Un grand merci.

Dernière modification par Kazkreol (Le 23/11/2012, à 14:37)

Hors ligne

#2 Le 15/11/2012, à 13:02

sechanbask

Re : (Résolu) - Droits d'administration

Bonjour,

Clairement cela peut venir de la méthode de montage, peux-tu renvoyer le résultat de la commande :

sudo fdisk -l

et faire de même avec

sudo mount

Hors ligne

#3 Le 15/11/2012, à 15:38

Kazkreol

Re : (Résolu) - Droits d'administration

Salut et merci. Je t’envoie ça ce soir.

Hors ligne

#4 Le 15/11/2012, à 20:44

Kazkreol

Re : (Résolu) - Droits d'administration

Voila, la partition concernée est "Stockage"

kazkreole@kazkreole-HP:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 têtes, 63 secteurs/piste, 19457 cylindres, total 312581808 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x8fc167e5

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1   *          63    51199154    25599546    7  HPFS/NTFS/exFAT
/dev/sda2        51199998   153595903    51197953    5  Étendue
/dev/sda3       153597465   157694039     2048287+  82  partition d'échange Linux / Solaris
/dev/sda4       157694040   312576704    77441332+   b  W95 FAT32
/dev/sda5        51200000   153595903    51197952   83  Linux


kazkreole@kazkreole-HP:~$ sudo mount


/dev/sda5 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
/dev/sda4 on /home/Stockage type vfat (rw)
/dev/sda1 on /home/Windows type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/kazkreole/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=kazkreole)

Hors ligne

#5 Le 19/11/2012, à 12:32

Kazkreol

Re : (Résolu) - Droits d'administration

Damned!! Suis-je donc seul à me galérer avec les droits d'écritures sur mes propres disques??

hmm hmm

Hors ligne

#6 Le 20/11/2012, à 08:20

AlexandreP

Re : (Résolu) - Droits d'administration

Salut,

Kazkreol a écrit :

Le problème se pose avec la partition de stockage sur laquelle je ne peux modifier les droits administrateurs (méthode graphique, je lance Dolphin avec la console en sudo, ça marche avec la partition Ubuntu).

From the doc à propos des systèmes de fichiers:

Les systèmes de fichiers créés par Microsoft (FAT, FAT32 et NTFS) ne gèrent pas les droits d'accès aux fichiers comme les systèmes de fichiers de type Unix (ext2, ext3, ReiserFS…). Toutefois, pour être accessible sous Linux, un système de fichiers doit disposer du système de droits d'accès; pour contourner cette limitation, les droits d'accès de type Unix sont émulés sur ces systèmes de fichiers. Cette émulation est effectuée au montage d'une partition de disque dur formatée selon l'un de ces systèmes de fichiers, et ces droits sont immuables tout le temps que ce système de fichiers est en cours d'utilisation.

Il n'est pas possible de modifier les permissions ou les propriétés d'un fichier ou d'un dossier situé dans un système de fichiers NTFS ou FAT32. Le seul moyen de changer ce comportement est de démonter le système de fichiers puis le remonter avec des options de montage différentes.

La raison pour laquelle tu ne peux pas modifier les droits d'accès par Dolphin, que ce soit sur l'ensemble du volume ou sur un fichier en particulier situé dans ce volume, est parce qu'il se trouve dans un système de fichiers qui ne gère pas les droits d'accès. Le seul moyen de changer les droits d'accès à un fichier, un dossier ou l'ensemble du volume, c'est de le démonter puis le remonter avec des options de montage adéquates.



C'est aussi le même problème pour les fichiers et dossiers qui contiennent des caractères accentués et qui s'affichent mal dans l'explorateur de fichiers:

Kazkreol a écrit :

D'autre part, tous les dossiers ou fichiers contenant des caractères type "é" ou "à" sont illisibles sur cette partition.

Le jeu de caractères utilisé par le système de fichiers de ta partition Stockage doit être Windows-1252, mais Ubuntu doit le monter avec un jeu de caractère UTF-8 ou autre, faisant en sorte que certains caractères soient mal reconnus. Encore une fois, en modifiant les options de montage du système de fichiers, ceci devrait pouvoir être corrigé.



Pour modifier les options de montage de ton volume Stockage:

  1. Ouvre un éditeur de texte simple en mode administrateur. Dans un terminal, exécute la commande suivante:

    kdesudo kate
  2. Dans cet éditeur de texte simple, ouvre le fichier /etc/fstab ;

  3. Recherche la ligne traitant du montage du volume /dev/sda4. Cette ligne devrait ressembler à ceci -- elle n'est sans doute pas identique, mais le début sera le même:

    /dev/sda4     /home/Stockage     vfat     auto,rw     0     0
  4. La 4e colonne est celle contenant les options de montage. À cette ligne d'options, on ajoutera les options suivantes:

    /dev/sda4     /home/Stockage     vfat     auto,rw,umask=000,iocharset=utf8,codepage=850     0     0
  5. Enregistre les modifications et ferme l'éditeur de texte ;

  6. Dans un terminal, exécute la commande suivante pour remonter le volume Stockage :

    sudo mount -o remount /home/Stockage

«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#7 Le 20/11/2012, à 21:57

Kazkreol

Re : (Résolu) - Droits d'administration

J'ai ouvert le fichier etc/fstab avec gedit en mode sudo.

A la place de "auto,rw", j'avais "defaults".

Comme indiqué, j'ai remplacé par "auto,rw,umask=000,iocharset=utf8,codepage=850"

J'ai démonté puis remonté le disque avec Storage device manager (cela n'a pas marché en mode console).

Et ça marche. Dément! Merci. J'étais sur le point de repasser à la 9.10 mais je vais donc insister encore un peu avec les nouvelles technologies.

Hors ligne

#8 Le 21/11/2012, à 07:19

AlexandreP

Re : (Résolu) - Droits d'administration

Ah, tu utilises Ubuntu? Je pensais que tu étais sous Kubuntu, car tu utilises Dolphin...

Je me permets alors une petite mention que le nouvel utilitaire de disque (qui s'appelle simplement Disques) permet de modifier les options de montage. Il n'est donc pas nécessaire de modifier à la main le fichier fstab, les options peuvent être inscrites dans l'utilitaire Disques.

f6f17f7abbf05c1efe3e6901396f2t.jpg   97fa77673c0728d3ef3fe3754754dt.jpg


Si ton problème est réglé, n'oublie pas de modifier le sujet du fil de discussion pour ajouter [Résolu] en préfixe.

Dernière modification par AlexandreP (Le 21/11/2012, à 07:19)


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#9 Le 23/11/2012, à 14:40

Kazkreol

Re : (Résolu) - Droits d'administration

Oué j'étais aussi fâché avec Nautilus rapport à la difficile configuration de la liste de raccourcis sur la gauche. J'y suis revenu depuis.

Pour l'utilitaire de disque, j'avais essayé sans succès en mode console..

La route est longue...

Hors ligne

Haut de page ↑