Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 20/11/2012, à 10:38

Spyware93

[Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Bonjour à tous,

Je viens d'acquérir un nouveau PC : Sony VAIO. J'essaye d'installer Ubuntu en dual boot avec windows 7 depuis maintenant 5 jours mais les problèmes ne font que se répéter.
Lors de l'installation j'ai un message qui me dit : Aucun système d'exploitation détecté, alors que Windows 7 est installé et fonctionne. J'ai donc le choix d'effacer l'entièreté du disque dur ou d'opter pour une installation manuelle.
Lorsque je sélectionne celle ci, là encore j'obtiens quelque chose d'étrange : un disque dur divisé en 3 partitions alors que le système de partitions de windows ne m'en trouve que deux.

http://www.hostingpics.net/viewer.php?i … MG0034.jpg

Je continue les étapes d'installation manuelle (creation d'une partition swap + racine) et j'obtiens un autre message d'erreur : http://www.hostingpics.net/viewer.php?i … MG0035.jpg.

J'ai essayé plusieurs version d'Ubuntu mais c'est toujours la même chose. Je sais aussi après vérification que mon disque dur démarre en mode EFI et qu'il est de type GPT. 

Merci d'avance

Dernière modification par Spyware93 (Le 22/11/2012, à 01:36)


SONY Vaio SVS 1311C5E

Hors ligne

#2 Le 20/11/2012, à 14:03

malbo

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Peut-être des solutions dans ce post : http://forum.ubuntu-fr.org/viewtopic.ph … #p11372761


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#3 Le 20/11/2012, à 17:25

Spyware93

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Pas ça non plus... sad


SONY Vaio SVS 1311C5E

Hors ligne

#4 Le 20/11/2012, à 17:49

malbo

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Dans le lien que j'ai donné dans le post #2, il y a ça :

Naviguer vers l'onglet Security pour retirer le secure boot (disabled)

Est-ce que tu as pu modifier le réglage de Secure Boot pour le passer à "disabled" ou bien est-ce que tu n'as pas pu trouver ce réglage ?

Dernière modification par malbo (Le 20/11/2012, à 17:50)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#5 Le 20/11/2012, à 17:51

Spyware93

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Non, ce réglage n'existe pas dans l'onglet sécurité du VAIO care de mon PC.


SONY Vaio SVS 1311C5E

Hors ligne

#6 Le 21/11/2012, à 09:02

malbo

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Je reviens sur la vue du post #1 : le message t'invite à créer une partition "Bios Boot" dont tu peux voir les caractéristiques dans ce paragraphe "3.2 Créer une partition BIOS-Boot" de la doc : http://doc.ubuntu-fr.org/gpt#creer_une_ … _bios-boot
J'en déduis que lorsque tu as eu ce message, tu étais démarré en "mode Bios" (non-EFI) sur ton support d'installation de Ubuntu.
Pour aller vite vers la solution, je te prie de répondre à cette demande : http://doc.ubuntu-fr.org/tutoriel/boot-info
Pour créer ce Boot-Info, tu peux être démarré en mode Bios ou en mode EFI sur ton support Ubuntu (liveCD ou liveUSB), ça m'est égal.

D'autre part, peux-tu préciser directement en modifiant ton post #1 le modèle de ton "Sony VAIO" afin que cette discussion puisse servir à d'autres utilisateurs du même modèle que le tien.

Dernière modification par malbo (Le 21/11/2012, à 09:18)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#7 Le 21/11/2012, à 09:31

Spyware93

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Oui ça démarre surement en mode Bios sur mon LiveCD d'Ubuntu.

Voilà mon Boot-Info : http://paste.ubuntu.com/1374262/

En tout cas, merci de l'attention que tu portes à mon problème smile


SONY Vaio SVS 1311C5E

Hors ligne

#8 Le 21/11/2012, à 09:46

malbo

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Dans le Boot-Info, on a bien confirmation que Windows est préinstallé en mode EFI dans ton disque dur. Par conséquent, selon le principe de ce tuto, tu dois installer Ubuntu en mode EFI dans ce disque dur. Bien qu'il soit possible d'installer Ubuntu en mode Bios (Installer Ubuntu sur un PC récent sans se soucier de l'EFI) puis convertir ensuite cette installation en mode EFI (Convertir Ubuntu en mode EFI), je désapprouve ce procédé et je considère comme un préalable que tu puisses démarrer une session live (choix Essayer) de Ubuntu en mode EFI dans le but de faire bien du premier coup pour installer Ubuntu directement en EFI sans avoir à faire ces magouilles.
Des conseils généraux sont donnés dans la doc EFI (Régler le démarrage en mode EFI ou classique) pour t'aider à démarrer en mode EFI sur ton LiveCD (ou ta liveUSB. A ce propos, peux-tu préciser ce que tu utilises liveCD ou bien liveUSB ?) mais comme on peut le comprendre à la lecture de ce paragraphe, le ou les réglages à faire dans le "Bios" sont différents pour tel fabricant de PC et tel autre et il est possible que tu aies un réglage à faire qui soit un peu caché...

Dernière modification par malbo (Le 21/11/2012, à 09:55)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#9 Le 21/11/2012, à 10:02

Spyware93

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

J'utilise le LiveCD Ubuntu 12.10 Secure Remix 64 bits. Mon Bios ressemble très fortement à celui ci : http://pix.toile-libre.org/upload/origi … 270332.jpg, il est bien configuré en UEFI et pourtant mon LiveCD démarre chaque fois en mode non-EFI...

Dernière modification par Spyware93 (Le 21/11/2012, à 10:12)


SONY Vaio SVS 1311C5E

Hors ligne

#10 Le 21/11/2012, à 11:00

malbo

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Peut-être l'as-tu déjà fait le parcours mais je te suggère de coller la ligne qui suit dans le champ de recherche de Google :

SVS1311C5E site:forum.ubuntu-fr.org

et d'examiner les résultats.
j'ai trouvé ceci (post de black_sun_2012) : http://forum.ubuntu-fr.org/viewtopic.ph … #p11156811
On y voit qu'il n'est pas possible d'installer Ubuntu en EFI dans ce modèle. Sauf qu'il a peut-être coulé assez d'eau sous le pont pour que ton fabricant propose une mise à jour du Bios pour ton modèle. Si c'est la cas, bien que je déteste conseiller cela parce que ce n'est pas anodin de faire une mise à jour du Bios et qu'il y a des risques que le résultat soit désastreux, je te suggère de le faire quand même. Ou alors, tu installes en mode Bios suivant les détails donnés dans le lien par black_sun_2012. Mais il y a les inconvénients mentionnés par lui, à savoir "pour passer de win7 <-> ubuntu il faudra à chaque fois changer le mode boot dans le bios (efi ou legacy), personnellement ça me va bien car je n'utilise pas win7. Après je comprend que ça puisse rebuter".

Dernière modification par malbo (Le 21/11/2012, à 11:05)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#11 Le 21/11/2012, à 11:09

Spyware93

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Ou alors réinstaller Windows 7 en mode bios si cela est possible... Y a t-il de gros avantages à être en mode UEFI plutôt qu'en mode bios?


SONY Vaio SVS 1311C5E

Hors ligne

#12 Le 21/11/2012, à 11:50

malbo

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Spyware93 a écrit :

Y a t-il de gros avantages à être en mode UEFI plutôt qu'en mode bios?

J'aimerais bien qu'on me contredise sur ce point pour avoir un os à ronger mais je dois dire que s'agissant d'un disque dur de 320 Go, il n'y a aucun intérêt à utiliser un partitionnement GPT et par conséquent, aucun intérêt à installer Windows 7 (et même Windows 8) en mode EFI sur ce disque dur. Si tu sais comment installer Windows 7 en mode Bios (mode classique), je te suggère de démarrer en mode Bios sur ton liveCD Ubuntu en session live (choix Essayer), de lancer Gparted pour supprimer la totalité des partitions et reconstruire une table de partition nouvelle de type MSDOS au lieu de GPT. Puis tu crées une seule partition primaire en format NTFS de 100 Go au début du disque dur destinée à devenir le disque C: de Windows 7 en laissant une place libre supérieure à 200 Mo avant le début de cette partition (réserve pour pouvoir créer ultérieurement si nécessaire une partition de Boot pour Ubuntu).
Ensuite, tu fais l'installation de Windows 7 sur ce disque dur en lui imposant de rentrer dans cette unique partition de 100 Go (oui, il va aller à la niche bien gentiment. Moi, je le fais coucher dans 30 Go au pain sec et à l'eau alors 100 Go c'est le luxe).
Quand l'installation de Windows 7 sera faite et fonctionnelle, je te propose de réaliser l'installation de Ubuntu en adoptant ce schéma :
- partition primaire 100 Go format NTFS pour Windows 7 déjà créée, on n'y touche plus.
- partition primaire 20 Go format ext4 pour la racine de Ubuntu 
- partition étendue sur tout le reste du disque dur qui contient les partitions logiques suivantes :
          - partition logique pour la swap dont la taille est à déterminer suivant la doc
          - partition logique en NTFS occupant tout le reste de l'espace de la partition étendue destinée à la partition de partage de données avec Windows

Dans cette "partition de partage de données", il conviendra de stocker toutes tes données, celles crées sous Windows et celles crées sous Ubuntu. Cette partition sera accessible en lecture/écriture depuis chacun des deux OS (Windows la verra comme un "disque D: "). Personnellement, je déplace "Mes documents" de Windows dans la "partition de partage de données" ; si tu es très prudent, tu n'es pas obligé de faire comme moi mais dans ce dernier cas, il faut s’astreindre à ne rien stocker en passant par "Mes documents" de Windows sinon ton disque C: grossit à vue d’œil alors que le principe de ce partitionnement c'est bien que tout soit dans la "partition de partage de données". Cette partition est placée en fin de partition étendue parce que si tu dois installer d'autres OS - Linux ou bien Windows 8 (en plus de Windows 7, pour une phase de test de Win8 qui peut s'installer chez moi dans une partition unique de 30 Go) - il est très facile de diminuer la taille de cette partition pour libérer la place nécessaire à l'installation du futur OS, puis d'installer ce futur OS dans les partitions nouvelles qui viendront s'ajouter aux partitions logiques existantes.

Dernière modification par malbo (Le 21/11/2012, à 12:53)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#13 Le 21/11/2012, à 14:44

Spyware93

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Ok merci beaucoup de ton aide. Je vais chercher comment transformer mon DD en MBR et tout réinstaller alors...


SONY Vaio SVS 1311C5E

Hors ligne

#14 Le 21/11/2012, à 15:25

malbo

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Spyware93 a écrit :

Je vais chercher comment transformer mon DD en MBR

Je t'ai détaillé comment faire dans mon post plus haut. C'est là :

démarrer en mode Bios sur ton liveCD Ubuntu en session live (choix Essayer), de lancer Gparted pour supprimer la totalité des partitions et reconstruire une table de partition nouvelle de type MSDOS au lieu de GPT.

Après remplacement de la table de partition GPT par une table de partition MSDOS, c'est bon, tu as basculé de l'autre côté : du côté BIOS/MBR (au lieu de EFI)

Dernière modification par malbo (Le 21/11/2012, à 15:26)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#15 Le 21/11/2012, à 18:56

Spyware93

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Je dois "juste" reformater mon disque dur avec le shéma que tu m'as donné et ensuite installer windows sur la partition de 100go? Sans oublier de modifier dans le Bios le boot en Legacy. Et avec tout ça mon disque sera de type MBR?


SONY Vaio SVS 1311C5E

Hors ligne

#16 Le 21/11/2012, à 19:15

Marclg

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Salut, j'ai le même PC que toi !

Jusqu'ici je travaillais sur Virtualbox (vu tous les problèmes pour installer Linux en DualBoot) mais là j'ai décidé d'installer définitivement avec ce tuto :

http://www.jonathanhaehnel.fr/blog/arti … aio-s.html

En espérant que ça va marcher ! wink


Sony Vaio S series SVS 13 11C5E

Hors ligne

#17 Le 21/11/2012, à 19:36

Spyware93

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Super merci beaucoup ! Je comptais justement faire un clean install de Windows 7. J'essaye ça ce soir et je dirai quoi smile


SONY Vaio SVS 1311C5E

Hors ligne

#18 Le 21/11/2012, à 20:05

malbo

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Quelques commentaires par rapport au tuto de jonathanhaehnel.fr
L'auteur décrit toutes ses aventures et errances dont la conversion GPT vers MBR dans son paragraphe "Installation de Linux" mais je propose dans le #12 d'éviter cela en partitionnant dès le départ (et avant installation de Windows 7) directement en MSDOS (MSDOS ou MBR, ça veut dire la même chose).
Par ailleurs, installer Ubuntu depuis une liveUSB réalisée avec LiLi est une bonne chose que je vous conseille d'adopter également d'autant plus qu'elle a bien fonctionne pour l'auteur du tuto.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#19 Le 21/11/2012, à 20:53

Spyware93

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Je vais directement mettre en MSDOS comme dit malbo alors ! Je suis en train de le faire, je vous tiens au courant smile J'en ai surement pour 2-3 bonnes heures (surtout pour réinstaller tous les drivers).
Il vaut mieux passer par la clé USB comme dit dans le tuto plutôt qu'un Live Cd ubuntu 12.04?


SONY Vaio SVS 1311C5E

Hors ligne

#20 Le 21/11/2012, à 21:37

malbo

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Spyware93 a écrit :

Il vaut mieux passer par la clé USB comme dit dans le tuto plutôt qu'un Live Cd ubuntu 12.04?

Puisque tu as déjà en main le liveCD, utilise-le mais pour ceux qui n'ont pas encore réalisé leur support d'installation, je recommande la liveUSB. D'une façon générale, je considère qu'une installation par liveUSB est plus fiable (pas d'erreur de gravure, pas d'erreur de lecture comme on peut avoir avec les liveCD), c'est pourquoi, quand j'ai lu que l'auteur du tuto avait utilisé une liveUSB, j'ai cru bon d'en rajouter une louche pour inciter à faire comme lui.

Dernière modification par malbo (Le 21/11/2012, à 21:38)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#21 Le 21/11/2012, à 23:52

Marclg

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Terrible nouvelle, je pense avoir fait une grosse connerie en suivant le tuto et la je sais plus trop quoi faire...

Pour ne pas faire du hors-sujet, j'ai fait un nouveau sujet ici : http://forum.ubuntu-fr.org/viewtopic.ph … #p11594351


Sony Vaio S series SVS 13 11C5E

Hors ligne

#22 Le 22/11/2012, à 01:02

Spyware93

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Je te suggère de plutôt suivre ce que malbo disait dans le poste #12. J'ai suivi son guide : mettre directement le disque dur en MSDOS pour cela tu boot sur le LiveCD Ubuntu, tu ouvres Gparted, tu effaces toutes tes partitions. Ensuite tu clique sur "Nouvelle table de partition" il va te dire que par défaut la table sera en MSDOS (parfait c'est ce qu'il nous faut) puis tu créés la partition qui va accueillir Win7. Sans oublier de changer dans ton bios le boot par défaut en mode "Legacy" Par la suite tu peux suivre ce que malbo explique et le tour est joué wink  C'est ce que j'ai fait sur mon SVS 1311C5E et tout fonctionne enfin parfaitement !

Un grand merci à toi malbo pour ton aide précieuse smile

Dernière modification par Spyware93 (Le 22/11/2012, à 01:03)


SONY Vaio SVS 1311C5E

Hors ligne

#23 Le 22/11/2012, à 01:17

Marclg

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Spyware93 a écrit :

Je te suggère de plutôt suivre ce que malbo disait dans le poste #12. J'ai suivi son guide : mettre directement le disque dur en MSDOS pour cela tu boot sur le LiveCD Ubuntu, tu ouvres Gparted, tu effaces toutes tes partitions. Ensuite tu clique sur "Nouvelle table de partition" il va te dire que par défaut la table sera en MSDOS (parfait c'est ce qu'il nous faut) puis tu créés la partition qui va accueillir Win7. Sans oublier de changer dans ton bios le boot par défaut en mode "Legacy" Par la suite tu peux suivre ce que malbo explique et le tour est joué wink  C'est ce que j'ai fait sur mon SVS 1311C5E et tout fonctionne enfin parfaitement !

Un grand merci à toi malbo pour ton aide précieuse smile

Au fait, je crois que finalement pour le faire correctement, je dois de toute faon virer la table GPT, par contre ici, pour creer la partition qui va accueillir win7 dans Gparted tu le configures comment ?

Une question finalement : Avec cette methode t as pu recuperer tous tes donnees sous windows ? car si c'est le cas, je ne peux proceder comme ca, car y a des donnees que je ne voudrais pas perdre sur windows

Merci


Sony Vaio S series SVS 13 11C5E

Hors ligne

#24 Le 22/11/2012, à 01:23

Spyware93

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

La méthode que j'ai utilisée nécessite de formater entièrement le disque dur et donc oui, de perdre ses données Win. Je n'ai par contre pas la solution pour passer en mode MSDOS sans tout effacer...


SONY Vaio SVS 1311C5E

Hors ligne

#25 Le 22/11/2012, à 01:32

Marclg

Re : [Résolu]Problème à l'installation en dual boot [VAIO SVS 1311C5E].

Ok merci quand meme,

Je pense que je vais essayer de d'abord recuperer l'ancienne table de partition avec testdisk puis sauvegarder les donnees importants et puis reessayer.


Sony Vaio S series SVS 13 11C5E

Hors ligne

Haut de page ↑