Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 30/10/2012, à 01:05

yoyo.thebest

[Résolu]language selector

bonjour
Dans mon kubuntu 12.10, quand je vais dans configuration système \ localisation \ language system, j'ai une erreur bizarre :
" le service "language du sytème ne fournit pas d'interface "kCModule" avec le mot clès "language-slector/language-selector.py" la fabrique ne prend pas en charge la création de composant spécifié."

J'ai tenté de réinstallé language-selector KDE mais cela n'a rien réglé.
est ce que cela parle à l'un d'entre vous ?

Je suis allé voir le post :http://forum.ubuntu-fr.org/viewtopic.php?id=946221
language-selector-kde est bien installé
les language-pack-fr sont bien installés

et j'ai bien le fichier /usr/share/kde4/apps/language-selector/language-selector.py

quand je lance la commande "kcmshell4 language-selector" j'ai la fenêtre avec le message d'erreur vu au dessus et j'ai dans ma console :

kcmshell(8935)/python (plugin): Failed to import module
Traceback (most recent call last):
  File "/usr/share/kde4/apps/language-selector/language-selector.py", line 4, in <module>
    from LanguageSelector.qt.QtLanguageSelector import QtLanguageSelector
ImportError: No module named LanguageSelector.qt.QtLanguageSelector
kcmshell(8935)/python (plugin): Failed to import module
kcmshell(8935)/kcontrol KCModuleLoader::loadModule: This module has no valid entry symbol at all. The reason could be that it's still using K_EXPORT_COMPONENT_FACTORY with a custom X-KDE-FactoryName which is not supported anymore

une idée

Dernière modification par yoyo.thebest (Le 25/11/2012, à 23:56)

Hors ligne

#2 Le 30/10/2012, à 09:04

φlip

Re : [Résolu]language selector

Tu n'aurais pas fait de mélanges de versions de KDE avec des ppa ?
que dit ceci:

apt-cache policy kde-plasma-desktop
apt-cache policy language-selector-kde

Dernière modification par φlip (Le 30/10/2012, à 09:06)

Hors ligne

#3 Le 30/10/2012, à 09:10

yoyo.thebest

Re : [Résolu]language selector

cela donne :
pour apt-cache policy kde-plasma-desktop

kde-plasma-desktop:
  Installé : (aucun)
  Candidat : 5:76~pre1ubuntu3
  Table de version :
     5:76~pre1ubuntu3 0
        500 http://mirror.ovh.net/ubuntu/ quantal/universe amd64 Packages

et pour apt-cache policy language-selector-kde

language-selector-kde:
  Installé : 0.90
  Candidat : 0.90
  Table de version :
*** 0.90 0
        500 http://mirror.ovh.net/ubuntu/ quantal/universe amd64 Packages
        100 /var/lib/dpkg/status

Hors ligne

#4 Le 30/10/2012, à 09:20

φlip

Re : [Résolu]language selector

Un peu surpris que tu n'aies pas de kde-plasma-desktop.
Installe le, pour voir.
+ que dit ceci:

dpkg -l python3-py*|grep ^i | awk '{print $2,"\t",$3}'

Dernière modification par φlip (Le 30/10/2012, à 10:05)

Hors ligne

#5 Le 30/10/2012, à 09:33

yoyo.thebest

Re : [Résolu]language selector

je viens de rajouter kde-plasma-desktop et  cela me donne ca

apt-cache policy kde-plasma-desktop

En dehors de m'avoir installer Kwrite, KDM, Konqueror et un autre truc (pas noté lequel).
Au final j'ai encore le même pb

et pour ta commande

dpkg -l python3-py*|grep ^i | awk '{print $2,"\t",$3}'
python3-pykde4   4:4.9.2-0ubuntu2
python3-pyqt4    4.9.3-4

Dernière modification par yoyo.thebest (Le 30/10/2012, à 09:34)

Hors ligne

#6 Le 30/10/2012, à 09:34

φlip

Re : [Résolu]language selector

Tu as installé Quantal de quelle manière ?
+ que dit ceci:

dpkg -l *lang* kde-l*n-*|grep ^i |awk '{print $2,"\t",$3}'

Dernière modification par φlip (Le 30/10/2012, à 09:38)

Hors ligne

#7 Le 30/10/2012, à 09:42

yoyo.thebest

Re : [Résolu]language selector

j'ai ceci

kde-l10n-engb    4:4.9.2-0ubuntu1
kde-l10n-fr      4:4.9.2-0ubuntu1
language-pack-en         1:12.10+20121009
language-pack-en-base    1:12.10+20121009
language-pack-fr         1:12.10+20121009
language-pack-fr-base    1:12.10+20121009
language-pack-gnome-fr   1:12.10+20121009
language-pack-gnome-fr-base      1:12.10+20121009
language-pack-kde-en     1:12.10+20121005.1
language-pack-kde-fr     1:12.10+20121005.1
language-selector-common         0.90
language-selector-kde    0.90
libslang2:amd64          2.2.4-15ubuntu1

Je ne vois rien d'incohérent

Je n'ai fait qu'une simple migration de Kubuntu 12.04 vers 12.10

Hors ligne

#8 Le 30/10/2012, à 09:44

φlip

Re : [Résolu]language selector

yoyo.thebest a écrit :

Je n'ai fait qu'une simple migration de Kubuntu 12.04 vers 12.10

Il y a eu des problèmes de pythonerie.
Essaie ça:

sudo apt-get install --reinstall python-kde4 

Délogue toi, rerelogue toi.

Dernière modification par φlip (Le 30/10/2012, à 09:45)

Hors ligne

#9 Le 30/10/2012, à 09:48

yoyo.thebest

Re : [Résolu]language selector

Ok je teste
uqand je regarde le poste 44 ici http://forum.kubuntu-fr.org/viewtopic.p … 009881&p=2 je vois que je suis pas le seul à avoir un soucis

Hors ligne

#10 Le 30/10/2012, à 09:50

φlip

Re : [Résolu]language selector

Ce souci n'existe plus dans Quantal (propre).
C'est suite à ta migration.

Hors ligne

#11 Le 30/10/2012, à 10:05

yoyo.thebest

Re : [Résolu]language selector

la réinstallation de  python-kde4  et le reboot n'a rien réglé

Hors ligne

#12 Le 30/10/2012, à 10:07

φlip

Re : [Résolu]language selector

Alors je jette l'éponge (c'est une image bien sûr).
Plus qu'à attendre qu'un expert te donne un coup de main.
Sorry man.

Hors ligne

#13 Le 30/10/2012, à 10:11

yoyo.thebest

Re : [Résolu]language selector

Pas de pb, c'est embêtant mais pas bloquant.
merci d'avoir partagé avec moi

Hors ligne

#14 Le 30/10/2012, à 10:12

φlip

Re : [Résolu]language selector

Quand tu auras 10 mn .... refais une install propre de Quantal.
Quand c'est propre, c'est mieux.

Hors ligne

#15 Le 23/11/2012, à 14:32

Nicologx

Re : [Résolu]language selector

Salut à tous,

J'ai ce problème sur 2 postes (bureau et portable) depuis la mise à niveau vers kubuntu 12.10.
J'ai suivi les liens, les indications, réinstallé les différents paquets avec le gestionnaire de paquets Muon… mais rien n'y fait…

Avez-vous trouvé une solution depuis?


Kubuntu 14.04 - Site officiel | Chakra (en mode découverte…) - Site officiel - Présentation en français
Membre de RotomaLUG (à Rouen)

Hors ligne

#16 Le 23/11/2012, à 19:00

yoyo.thebest

Re : [Résolu]language selector

Bonjour

j'ai essayé de suivre http://forum.ubuntu-fr.org/viewtopic.php?id=946221
J'ai désinstallé et réinstallé python-kde4 et les language-selector ( avec un bonne frayeur python-kde4  que j'ai du faire à la main avec une réinstallation de plusieurs paquets qui en faisaient appel) et ..... rien
Je continue  à avoir mes 3 icônes et avec une erreur sur la dernière "language system".
J'ai néanmoins l’impression qu'elle  fait doublon avec "Pays / Régions & langues" / langues.
A voir, je n'ose pas changer de langue de peur de me retrouver avec une version berbère de mon beau petit Kubuntu

Dernière modification par yoyo.thebest (Le 23/11/2012, à 22:10)

Hors ligne

#17 Le 23/11/2012, à 21:12

Nicologx

Re : [Résolu]language selector

ouais…
J'ai fait pareil et j'ai même laissé un post disant que le problème persistait avec un lien vers ce forum…
Cela dit, il semblerait que certaines nouvelles versions d'applis (comme Amarok) ne soient pas encore traduites. Mais la majeure partie du système est en français, donc le problème n'est pas si grave…
Je vais quand même essayer de passer le système en anglais pour voir…


Kubuntu 14.04 - Site officiel | Chakra (en mode découverte…) - Site officiel - Présentation en français
Membre de RotomaLUG (à Rouen)

Hors ligne

#18 Le 24/11/2012, à 22:35

yoyo.thebest

Re : [Résolu]language selector

Amarok n'est effectivement pas encore traduite.
Tu as pu passer dans la langue de la perfide albion sans Pb ?

Hors ligne

#19 Le 25/11/2012, à 15:57

Nicologx

Re : [Résolu]language selector

Finalement, j'ai pas changé la langue système…
J'ai essayé le live-DVD, pour voir, et dans Configuration du système > localisation , il n'y a pas Langue du système.
Alors j'ai viré language-selector-kde qui était bizarrement en conflit avec language-selector-qt (introuvable ou inexistant dans la liste des paquets) et j'ai maintenant le même menu de configuration que dans le live-DVD.
Je crois que la traduction n'est pas complète et qu'il faut tout simplement attendre… ou participer.


Kubuntu 14.04 - Site officiel | Chakra (en mode découverte…) - Site officiel - Présentation en français
Membre de RotomaLUG (à Rouen)

Hors ligne

#20 Le 25/11/2012, à 23:56

yoyo.thebest

Re : [Résolu]language selector

Bonsoir

Effectivement supprimer language-selector-kde revient à supprimer l’icône langue système.
Bon comme je ne cherche pas à passer au swahili ou au grec ancien, je m'en passerai.
merci
Je clôture le pb

Hors ligne

Haut de page ↑