Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 29/11/2012, à 15:50

Elyooon

Problème suite à une mise à jour (low-graphics mode)

Bonjour ! smile

J'utilise ubuntu depuis quelques mois et j'ai encore bien du mal à me débrouiller avec. Je rencontre un bug tenace qui me prive de mon interface graphique, si bien que je viens demander votre aide.
J'ai installé il y a quelques jours une mise à jour sur mon ordinateur (un notebook eee pc qui fonctionne avec la version 12.04) que j'ai ensuite éteint. Au démarrage suivant, j'ai rencontré le message d'erreur suivant :

The system is running in low-graphics mode

Suivi de

What would you like to do ?

Ce deuxième écran est suivi de quatre propositions (run in low-graphics mode just for one session ; reconfigure graphics ; troubleshoot the error ; exit ton console login). C'est à ce moment que les choses se corsent. Il m'est impossible de valider un de ces choix. Il n'y a que la touche echap qui marche.

J'arrive sur un écran noir qui me demande mon login puis mon mot de passe (pas de problème).
J'ai effectué une petite recherche sur internet pour voir si d'autres avaient déjà rencontré le même problème (je me suis limitée au français : je suis encore trop novice sur ubuntu pour essayer de comprendre dans une langue qui m'est moins familière un sujet que je maîtrise mal)
J'ai tapé la commande

sudo apt-get update

Message d'erreur selon lequel le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés ou les anciens ont été utilisés à la place (après un petit temps de chargement et des lignes "impossible de récupérer [...] ne parvient pas à résoudre [...]"
J'ai tenté

sudo apt-get upgrade

Après un message plutôt encourageant, un message me demande si je souhaite continuer [O/n]

J'inscris "O"

S'affiche la chose suivante :

Impossible de récupérer quelques archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix missing

Je tente donc :

apt-get upgrade --fix-missing

Eeeet je bloque. "Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/) Avez-vous les privilèges du superutilisateur ?"

J'avoue que je ne sais pas  comment continuer à cette étape et j'ai peur de faire une bêtise. Je suis la seule utilisatrice de cet ordinateur, donc je dois les avoir ... Je ne sais pas les activer (de ce que j'ai compris, les permissions ne sont pas données par défaut comme sur windows pour éviter des maladresses de l'utilisateur).


Navrée de vous poser des questions qui doivent sans doute être triviales ! neutral Et merci d'avance pour le coup de main

Hors ligne

#2 Le 29/11/2012, à 21:54

ambilly

Re : Problème suite à une mise à jour (low-graphics mode)

Bonjour
J'ai eu ce même problème sur une ubuntu 12.10 ; j'utilise lightdm et non pas GDM ( c'est plus rapide et moins lourd en mémoire).

voila comment je l'ai résolu :

1) qd tu as cet écran tu fqit CTRL-ALT F1 ce qui t’amène sur une des consoles
     (pour revenir au GUI : CTR-ALT F7) ; logue toi en root
     teste si lightdm fonctionne : service lightdm start
2) assure toi que tu utilise lightdm : dpkg-reconfigure gdm
3)  enlève GDM : apt-get purge gdm
4) reinstalle lightdm :  apt-get install --reinstall lightdm
5) redémarre : reboot

Dernière modification par ambilly (Le 29/11/2012, à 22:33)

Hors ligne

#3 Le 01/12/2012, à 17:16

Elyooon

Re : Problème suite à une mise à jour (low-graphics mode)

Merci beaucoup !

Je viens d'essayer ton conseil et j'ai encore un petit problème. J'ai essayé de me loguer en root mais je crois que je n'y parviens pas Lorsque je teste si lightdm fonctionne, j'obtiens ce message :

usr/sbin/dpkg-reconfigure doit être lancé par le superutilisateur

Tu pourrais m'indiquer ce que tu inscris pour te loguer en root, s'il te plaît ?

Hors ligne

#4 Le 01/12/2012, à 19:19

alca94

Re : Problème suite à une mise à jour (low-graphics mode)

bonjour
il faut mettre "sudo" devant (avec un espace)

un peu de lecture  http://doc.ubuntu-fr.org/sudo

En ligne

#5 Le 01/12/2012, à 20:34

syl-a

Re : Problème suite à une mise à jour (low-graphics mode)

pour être en root sous ubuntu tu dois mettre "sudo" avant chaque commande et il te demandera le mot de passe de ta session


netbook HP Mini 210-2240ez 2GB DDR2 1066MHz 11.10+W7HP
MacBook 2.13Ghz 4GB DDR2 800Mhz/

Hors ligne

#6 Le 01/12/2012, à 23:22

Elyooon

Re : Problème suite à une mise à jour (low-graphics mode)

Merci pour votre aide,

Je galère toujours un petit peu (mais j'ai au moins l'impression d'avancer). Je rencontre deux nouvelles réactions qui me bloquent :

Après avoir inscrit testé "service lightdm start" en sudo, je retombe sur l'interface qui me proposait

un in low-graphics mode just for one session ; reconfigure graphics ; troubleshoot the error ; exit ton console login

et il est toujours impossible de faire un choix. Lorsque je tente la ligne de commandes suivante dans celles proposées  par ambilly, je tombe sur ce message d'erreur:

/usr/sbin/dpkg-reconfigure: gdm n'est pas installé

Donc plutôt que de faire une bêtise, je viens demander votre aide,

Merci d'avance

Hors ligne

#7 Le 01/12/2012, à 23:31

alca94

Re : Problème suite à une mise à jour (low-graphics mode)

Ce deuxième écran est suivi de quatre propositions (run in low-graphics mode just for one session ; reconfigure graphics ; troubleshoot the error ; exit ton console login). C'est à ce moment que les choses se corsent. Il m'est impossible de valider un de ces choix. Il n'y a que la touche echap qui marche.

Vous ne pouvez pas en sélectionner un avec les touches fléchées et faire "Entrée"
en commençant par le premier choix = "reconfigure graphics"

En ligne

#8 Le 03/12/2012, à 00:16

Elyooon

Re : Problème suite à une mise à jour (low-graphics mode)

alca94  : La touche entrée ne donne aucun résultat, tout comme les flèches.  sad

Hors ligne

#9 Le 04/12/2012, à 15:06

ambilly

Re : Problème suite à une mise à jour (low-graphics mode)

Petits rappels :
pour ouvrir une console depuis n'importe quel ecran :
CTL-ALT F1 pour la 1ere console
CTL-ALT F2 pour la deuxième console etc (jusqu'a F5 )
CTL-ALT F7 pour l'interface graphique
CTL-ALT F8 pour une deuxième interface graphique

Pour executer des commandes en root en console , 3 solutions :

1) en console a la question login ; entrer : root
    Si vous ne vous rappelez pas du mdp root , entrer avec votre login habituel et taper : sudo passwd
    Cela va changer le mot de passe a celui que vous mettez

2) si vs êtes entrés avec un login autre que root, faite preceder les commandes de sudo ; ex
    sudo apt-get update
3) taper su -
   il vous sera demandé le mdp root
   la, il n'est plus necessaire de faire preceder les commandes de sudo car vous etes root
   (si vous le faite qd meme cela ne nuit pas...)
   pour revenir a l'utilisateur prédedent, taper : exit

Hors ligne

#10 Le 04/12/2012, à 15:21

ambilly

Re : Problème suite à une mise à jour (low-graphics mode)

Pour revenir au probleme "low-graphics mode" la solution que j'ai donné plus haut fonctionne mais n'est pas permanente.... ce vilain ecran reviens qd meme..

Apres des heures de googlage , j'en viens a la conclusion qu 'il ne s'agit pas d'un probleme de driver
en effet si lors du "vilain ecran" vous ouvrez une console (CTR-ALT-F1) et vous taper "sudo service lightdm restart", lightdm démarre normalement; il doit s'agir plutot d'un probleme de timing (lightdm demarre trop tot). ce probleme varie donc d'ordinateur a ordinateur selon le processeur et la vitesse.


Je n'ai pas encore trouvé de solutions a ce probleme
Mais......

j'ai trouvé 2 méthodes pour tourner autour de ce probleme :

1 dans /etc/rc.local il faut rajouter  juste avant la ligne exit 0
service lightdm restart
service lightdm restart

( oui deux fois la ligne....)

2 toujours dans le fichier /etc/rc.local juste avant la ligne exit 0
sleep 4 ( essayez avec d'autres valeurs...)
service lightdm restart

Je sais c'est très laid comme solution mais ça marche (temporairement)

Hors ligne

#11 Le 04/12/2012, à 15:38

ambilly

Re : Problème suite à une mise à jour (low-graphics mode)

Je viens d'essayer une methode qui pour l'instant a lair de fonctionner :

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

j'ai pu enlever les lignes de /etc/rc.local et pour l'instant ça redémarre comme il faut
PS j'ai remarque que après un reboot le "vilain écran" ne revenait presque jamais alors qu'il revenait très souvent après un poweroff ; donc envoyer la commande "sudo poweroff" au lieu de "sudo reboot"

a suivre.....

Hors ligne

#12 Le 04/12/2012, à 18:08

Elyooon

Re : Problème suite à une mise à jour (low-graphics mode)

Merci pour cette aide, ambilly

J'avoue avoir un peu de mal à saisir le moment / fichier où il faudrait taper avant la ligne

dans /etc/rc.local il faut rajouter  juste avant la ligne exit 0

Où se trouve cette ligne ? Après quelle commande ?

de plus, la commande

sudo add-apt-repository ppa:makson96/fglrx

n'a pas marché

Hors ligne

#13 Le 04/12/2012, à 18:18

alca94

Re : Problème suite à une mise à jour (low-graphics mode)

@Elyooon
il faut faire dans le terminal

gksudo gedit /etc/rc.local

et ça vous ouvres la fenêtre apres avoir saisi votre mot de passe ,vous modifier et enregistrez et après vous faites la suite du tuto

En ligne

#14 Le 04/12/2012, à 22:34

ambilly

Re : Problème suite à une mise à jour (low-graphics mode)

pour moi ça marche toujours après un dizaine de reboot.....et vous ??

Hors ligne

#15 Le 31/05/2013, à 04:45

Pentector

Re : Problème suite à une mise à jour (low-graphics mode)

ambilly a écrit :

pour moi ça marche toujours après un dizaine de reboot.....et vous ??

MERCI !!!

4 heures que j'étais bloqué avec ce problème sur une VM de Vmare player.
Peux être que c'est pas très joli, mais ca fonctionne. :-)

Hors ligne

Haut de page ↑