Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 30/11/2012, à 13:09

DJ Raging-Bull

[ Résolu ] Problème suite à l'activation des pilotes propriétaires

Bonjour,

Je viens d'installer Ubuntu 12.10 sur le PC de ma copine équipé comme suit:

Intel Core i7 2600 @ 3,4 GHz
Corsaire Vengeance 2*4 Go DDR3 @ 1600 MHz
Asus P8P67 Pro
SLI 2x GeForce GTX 560 Ti
Disque dur Western Digital Caviar Blue 500 Go 7200 trs/min
Sur un écran de 22" 1080p Acer

Le reste n'a que peu d'intérêt à mon avis, bref: au départ tout fonctionne très bien avec le pilote libre "nouveau" à part les bugs qu'on lui connait, des phrases qui disparaissent, des artéfacts, etc mais la résolution est bien à 1080p, ça affiche bien Unity, l'écran d'accueil est beau.

Par soucis de fluidité et pour pas que ma copine se retrouve avec des phrases qui disparaissent, ce qui est assez gênant, surtout pour écrire sur Writer, j'ai voulu installer le pilote propriétaire. J'avais 5 choix, sachant que c'était réglé sur celui du milieu (alternatif, libre) j'ai pris le premier "propriétaire, testé" en me disant que ça serait nickel puisque testé, mais voilà ... lors du redémarrage, Unity disparaît et la résolution se met en 640*480, et là peu importe mon choix ça ne se remet pas comme avant. Le seul mieux c'est quand je remet sur "nouveau" Unity réapparaît, mais la résolution ne s'améliore pas.

Quand je fais un CTRL ALT+T et que je tape "nvidia-settings" ça me dit que le système n'utilise pas le pilote NVIDIA et que je dois faire un "nvidia-xconfig" en tant que super-user, ce que j'ai déjà fais, et ça n'a rien changé.

Si quelqu'un a une idée ... ça fait déjà 2 fois que je réinstalle, j'ai déjà testé en débranchant complètement la deuxième carte graphique car je sais bien que parfois ce genre de configuration est un peu capricieuse.

Le PC est en dual boot avec Windows 7 qui ne pose aucun problème, ceci pour dire que matériellement tout a l'air de bien fonctionner.

Dernière modification par DJ Raging-Bull (Le 30/11/2012, à 17:43)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD & HDD
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 8 Go DDR3 - SSD 128 Go
OS: GNU/Linux Ubuntu 13.10 Saucy Salamander - 64 bits & Microsoft Windows 7 Édition Intégrale - 64 bits

Hors ligne

#2 Le 30/11/2012, à 13:57

GP974

Re : [ Résolu ] Problème suite à l'activation des pilotes propriétaires

Bonjour
as tu appliquer les recommandation de cette page?


Ubunteros depuis 10.04 | Restez libre avec linux
Fixe : i7 i930@2.8ghz | 8go(1866Mhz) |Gtx 570@nvidia-331 | Samsung 840evo(120Go) | Ubuntu 12.04.4 & 14.04
Portable(asus N75SF) : i5 2410@2.3ghz | 8go(1333Mhz)  | IntelHD3000/GT555m@nvidia-331 | Vertex2(180go)| Arch & 12.04.4 & 14.04(dev)
Stop windows8!

Hors ligne

#3 Le 30/11/2012, à 14:27

DJ Raging-Bull

Re : [ Résolu ] Problème suite à l'activation des pilotes propriétaires

Non, mais sachant que le comportement de l'ordinateur est exactement le même avec ou sans la 2 ème carte graphique, je ne suis pas vraiment sur que le problème vienne de là.
Ceci dit, je veux bien appliquer ces recommandations, si ça peut éliminer définitivement une possibilité.

Edit: donc je suis les instructions à la lettre, par contre quand je tente de modifier le fichier xorg.conf depuis la console, ça ne réagit pas du tout.

Console

Dernière modification par DJ Raging-Bull (Le 30/11/2012, à 14:40)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD & HDD
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 8 Go DDR3 - SSD 128 Go
OS: GNU/Linux Ubuntu 13.10 Saucy Salamander - 64 bits & Microsoft Windows 7 Édition Intégrale - 64 bits

Hors ligne

#4 Le 30/11/2012, à 14:59

DJ Raging-Bull

Re : [ Résolu ] Problème suite à l'activation des pilotes propriétaires

DJ Raging-Bull a écrit :

Non, mais sachant que le comportement de l'ordinateur est exactement le même avec ou sans la 2 ème carte graphique, je ne suis pas vraiment sur que le problème vienne de là.
Ceci dit, je veux bien appliquer ces recommandations, si ça peut éliminer définitivement une possibilité.

Edit: donc je suis les instructions à la lettre, par contre quand je tente de modifier le fichier xorg.conf depuis la console, ça ne réagit pas du tout.

http://img202.imageshack.us/img202/228/ … 133611.jpg

Edit 2: j'ai modifié le fichier d'une autre manière finalement et là en redémarrant ça m'affiche "youre system is running in low graphic mode" avec 4 choix possible:

Run in low graphics mode for just one session
Reconfigure graphics
Troubleshoot the error
Exit to console login

Quelque soit mon choix, ça n'y change rien, au redémarrage ça reste en 640x480 sans Unity, parfois la résolution est un peu plus élevée mais toujours sans Unity, et toujours sans que "Nvidia-Settings" ne détecte que j'utilise les pilotes NVIDIA, pourtant dans les sources de logiciel c'est bien indiqué que j'utilise les pilotes propriétaires testés.

Là j'ai l'impression que quoi que je fasse ça ne change rien du tout et c'est très désagréable, d'autant que c'est pas la première fois que j'ai des soucis avec une GTX série 500 sous Ubuntu.

Dernière modification par DJ Raging-Bull (Le 30/11/2012, à 15:53)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD & HDD
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 8 Go DDR3 - SSD 128 Go
OS: GNU/Linux Ubuntu 13.10 Saucy Salamander - 64 bits & Microsoft Windows 7 Édition Intégrale - 64 bits

Hors ligne

#5 Le 30/11/2012, à 15:14

GP974

Re : [ Résolu ] Problème suite à l'activation des pilotes propriétaires

des pilotes plus a jours fonctionnerons peut  être mieux

je te conseille de virer les pilotes nvidia actuel de redémarrer et d'installer les pilotes les plus récent avec une seule carte si ca fonctionne on s'occupera du SLI ensuite
en commande ça donne

sudo apt-get remove nvidia* && sudo apt-get autoremove && sudo reboot

l'ordi redemare ensuite toujours dans la console

sudo add-apt-repository ppa:xorg-edgers/ppa && sudo apt-get update && sudo apt-get install nvidia-current && sudo apt-get dist-upgrade && sudo reboot

Dernière modification par GP974 (Le 30/11/2012, à 15:15)


Ubunteros depuis 10.04 | Restez libre avec linux
Fixe : i7 i930@2.8ghz | 8go(1866Mhz) |Gtx 570@nvidia-331 | Samsung 840evo(120Go) | Ubuntu 12.04.4 & 14.04
Portable(asus N75SF) : i5 2410@2.3ghz | 8go(1333Mhz)  | IntelHD3000/GT555m@nvidia-331 | Vertex2(180go)| Arch & 12.04.4 & 14.04(dev)
Stop windows8!

Hors ligne

#6 Le 30/11/2012, à 16:00

inbox

Re : [ Résolu ] Problème suite à l'activation des pilotes propriétaires

Salut,

Après avoir installé aptitude, si nécessaire, donne le retour de cette commande :

aptitude search linux-headers | grep ^i

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

En ligne

#7 Le 30/11/2012, à 17:42

DJ Raging-Bull

Re : [ Résolu ] Problème suite à l'activation des pilotes propriétaires

GP974 a écrit :

des pilotes plus a jours fonctionnerons peut  être mieux

je te conseille de virer les pilotes nvidia actuel de redémarrer et d'installer les pilotes les plus récent avec une seule carte si ca fonctionne on s'occupera du SLI ensuite
en commande ça donne

sudo apt-get remove nvidia* && sudo apt-get autoremove && sudo reboot

l'ordi redemare ensuite toujours dans la console

sudo add-apt-repository ppa:xorg-edgers/ppa && sudo apt-get update && sudo apt-get install nvidia-current && sudo apt-get dist-upgrade && sudo reboot

Comment te dire ... cette commande a été comme une révélation !
Magnifique, au redémarrage tout fonctionnait parfaitement bien et ce, même en SLI.

Par contre en regardant dans mes sources de logiciels, j'ai vu ça et ça m'a paru bizarre:

Pilotes NVIDIA libres

Mais tout fonctionne parfaitement bien et en allant dans les options NVIDIA je me suis assuré que ce sont bien les pilotes NVIDIA propriétaires (à moins que NVIDIA aie tout d'un coup changé de politique) qui sont utilisés.

En tout cas, un IMMENSE merci. big_smile

Dernière modification par DJ Raging-Bull (Le 30/11/2012, à 17:43)


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD & HDD
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 8 Go DDR3 - SSD 128 Go
OS: GNU/Linux Ubuntu 13.10 Saucy Salamander - 64 bits & Microsoft Windows 7 Édition Intégrale - 64 bits

Hors ligne

#8 Le 30/11/2012, à 17:59

GP974

Re : [ Résolu ] Problème suite à l'activation des pilotes propriétaires

Content que ça fonctionne smile.
C'etais donc bien des drivers pas assez récent pour ta carte graphique.
Avec le ppa x-org tu aura des drivers plus récent que ceux inclus de base d'ubuntu donc accées aux dernière correction de beug et optimisation de nvidia


Ubunteros depuis 10.04 | Restez libre avec linux
Fixe : i7 i930@2.8ghz | 8go(1866Mhz) |Gtx 570@nvidia-331 | Samsung 840evo(120Go) | Ubuntu 12.04.4 & 14.04
Portable(asus N75SF) : i5 2410@2.3ghz | 8go(1333Mhz)  | IntelHD3000/GT555m@nvidia-331 | Vertex2(180go)| Arch & 12.04.4 & 14.04(dev)
Stop windows8!

Hors ligne

#9 Le 01/12/2012, à 09:10

DJ Raging-Bull

Re : [ Résolu ] Problème suite à l'activation des pilotes propriétaires

Sympa, je fais faire la même chose sur le fixe de ma signature du coup, ça pourrait booster un peu les performances médiocres que j'ai en ce moment, même si tout fonctionne correctement.

C'est parfois tout bête, m'enfin c'est bizarre que ça ne fonctionnait pas correctement, la GTX 560 Ti a plus d'un an maintenant et la version 304 des pilotes NVIDIA devraient la prendre en charge parfaitement, il devait y avoir un bug pour cette carte en particulier, dommage, c'est une des plus utilisées de la série 500.

Sinon j'espère qu'un jour ils régleront le problème de l'écran de chargement affreux... j'ai bien vu des solutions, mais aucune n'a fonctionné sur aucun de mes PC équipés de NVIDIA.


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD & HDD
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 8 Go DDR3 - SSD 128 Go
OS: GNU/Linux Ubuntu 13.10 Saucy Salamander - 64 bits & Microsoft Windows 7 Édition Intégrale - 64 bits

Hors ligne

#10 Le 17/12/2012, à 14:15

ambilly

Re : [ Résolu ] Problème suite à l'activation des pilotes propriétaires

Bonjour

En fait j'ai eu ce probleme et je ne crois pas que cela vienne du driver; cela doit plutot venir de lightdm
ce probleme m'apparait aleatoirement apres une Maj.
Verifie aussi le fichier /etc/lightdm; si il y a une erreur dedans ou si une action prend trop de temps cela provoque toujours ce probleme ( c'est reproduisible)


je le resoud come ca :

Logue toi sur une  console (CTRL-ALT F1)
il faut reinstaller lightdm :

sudo apt-get install --reinstall lightdm -y

redemarre

sudo reboot
ca devrait le faire....

Hors ligne

#11 Le 17/12/2012, à 16:23

derecktom

Re : [ Résolu ] Problème suite à l'activation des pilotes propriétaires

ambilly a écrit :

Bonjour

En fait j'ai eu ce probleme et je ne crois pas que cela vienne du driver; cela doit plutot venir de lightdm
ce probleme m'apparait aleatoirement apres une Maj.
Verifie aussi le fichier /etc/lightdm; si il y a une erreur dedans ou si une action prend trop de temps cela provoque toujours ce probleme ( c'est reproduisible)


je le resoud come ca :

Logue toi sur une  console (CTRL-ALT F1)
il faut reinstaller lightdm :

sudo apt-get install --reinstall lightdm -y

redemarre

sudo reboot
ca devrait le faire....

Ou y'a une solution alternative :

apt-get remove lightdm && apt-get install gdm && service gdm restart

Bon après gdm c'est l'interface de prédilection des utilisateurs de Gnome... roll

Hors ligne

#12 Le 23/12/2012, à 12:08

DJ Raging-Bull

Re : [ Résolu ] Problème suite à l'activation des pilotes propriétaires

Bah vu que l'installation des derniers pilotes a tout résolu pour moi et ce depuis un moment, ça ne devait pas être le même problème.


Desktop: Intel Core i7 2600K - 16 Go DDR3 - GeForce GTX 590 - Asus P8P67 - Sound Blaster X-Fi Titanium 7.1 - SSD & HDD
Laptop: Lenovo ThinkPad X201 - Intel Core i5 520M - 8 Go DDR3 - SSD 128 Go
OS: GNU/Linux Ubuntu 13.10 Saucy Salamander - 64 bits & Microsoft Windows 7 Édition Intégrale - 64 bits

Hors ligne

Haut de page ↑