Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 30/11/2012, à 17:27

Zugol

GDM repasse mon clavier en query

Bonjour,

Je galère vraiment avec un problème de langue sur l'une de mes deux machine, gdm repasse systématiquement le clavier en qwerty. J'ai déjà beaucoup cherché sur le net mais je ne trouve que des solution pour des versions antérieures à la 12.10.

J'ai fais le tours des 1001 endroits où l'on peut changer des paramètres de langue dans Ubuntu (de la à dire que c'est la bazar...) mais rien n'y fait, un ndeconnexion et me voilà revenu en qwerty.

J'ai réussi à supprimer les langues additionnelles y compris le chinois installé pour je ne sais quelle raison et j'ai lancé à peu près tous les dpkg-reconfigure de la terre. Bref, je ne comprends pas surtout dans la mesure où j'utilise la même version de gdm sur mes deux machines... Du coup je me dis que ça vient peut être d'ailleurs, mais où ?? La plupart des fichiers à éditer dans les solutions trouvées n'existent plus dans Ubuntu depuis bien des versions...

Merci de votre aide.


Ordineux depuis 1988

Hors ligne

#2 Le 30/11/2012, à 17:56

ljere

Re : GDM repasse mon clavier en query

est ce que si tu tapes

setxkbmap fr

dans un terminal tu récuperes l'azerty
si oui tu mets cette commande dans les application à démarrer ce qui donnera

sh -c "sleep 5; setxkbmap fr;"

athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog
administrateur du forum ubuntu-fr.org

Hors ligne

#3 Le 30/11/2012, à 18:22

Zugol

Re : GDM repasse mon clavier en query

Oui, cette commande fonctionne mais dans gdm j'aurai toujours le qwerty, ce qui est très problématique pour les passwords...


Ordineux depuis 1988

Hors ligne

#4 Le 30/11/2012, à 18:41

ljere

Re : GDM repasse mon clavier en query


athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog
administrateur du forum ubuntu-fr.org

Hors ligne

#5 Le 30/11/2012, à 19:32

Zugol

Re : GDM repasse mon clavier en query

ça ne fonctionne pas non plus.
ça m'informe du coup que ça n'a rien à voir avec gdm.

même lightdm se retrouve en qwerty....


Ordineux depuis 1988

Hors ligne

#6 Le 30/11/2012, à 19:38

Zugol

Re : GDM repasse mon clavier en query

bon, choisir français ne change rien ni à lightdm ni à ma session gnome...
Bon sang mais c'est quoi la différence avec mon autre machine ? Qu'est ce qu'il y a de magique là dedans ?


Ordineux depuis 1988

Hors ligne

#7 Le 30/11/2012, à 20:29

Zugol

Re : GDM repasse mon clavier en query

Visiblement c'est un bug avec certains clavier logitech dont le mien.
On a beau parfaitement définir partout que c'est un clavier FR azerty (ré-installation et vérification faite) on repasse systématiquement en qwerty dès qu'on quitte la session (unity / gnome-shell).

Bref, il va falloir que je me fasse à cette improbable régression.


Ordineux depuis 1988

Hors ligne

#8 Le 30/11/2012, à 20:35

ljere

Re : GDM repasse mon clavier en query

je suis désolé je n'ai pas trop d'idée si j'en trouve une autre je t'en informerai


athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog
administrateur du forum ubuntu-fr.org

Hors ligne

#9 Le 01/12/2012, à 11:35

Zugol

Re : GDM repasse mon clavier en query

Encore plus fort. Ce matin, je me rend compte qu'en tty mon clavier est français...

Xorg ??


Ordineux depuis 1988

Hors ligne

#10 Le 01/12/2012, à 13:13

ljere

Re : GDM repasse mon clavier en query

oui c'est une piste interessante donne le retour de
cat /etc/X11/xorg.conf
il y a de grande chance qu'il n'y en a pas donc tu devras le créer suivant ta carte graphique on pourra voir quel méthode utiliser


athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog
administrateur du forum ubuntu-fr.org

Hors ligne

#11 Le 02/12/2012, à 09:16

Zugol

Re : GDM repasse mon clavier en query

Section "Device"
	Identifier	"Default Device"
	Option	"NoLogo"	"True"
EndSection

Depuis quelques version d'Ubuntu le xorg.conf est presque vide.


Ordineux depuis 1988

Hors ligne

#12 Le 02/12/2012, à 10:35

ljere

Re : GDM repasse mon clavier en query

on va essayer de rajouter

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr"
    Option        "XkbVariant"    "latin9"
EndSection

sinon de mémoire pour reconfigurer xorg

sudo dpkg-reconfigure xserver-xorg

athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openboxubuntu 14.10 64 bit
Mon Blog
administrateur du forum ubuntu-fr.org

Hors ligne

Haut de page ↑