Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1176 Le 26/11/2012, à 02:02

magestik

Re : La Stereo-3D sous Linux

@b&nder: bizarre surtiut si tu utilises une sortie HDMI 3D.

@fredz: j'ai une théorie : l'écran peut monter jusqu'à 240 Hz mais en entrée tu peux très bien être limité a 24 Hz. Donc pour activer la 3D tu dois passer en résolution 3D (frame packing).

De toute façon il faut que tu ajoutes le mode dans le serveur x avec xrandr avant de vouloir le sélectionner. Regarde le post de jean un peu plus haut wink

Hors ligne

#1177 Le 26/11/2012, à 11:04

b&nder

Re : La Stereo-3D sous Linux

@Magestik: pas de hdmi pour l'écran 3d j'utilise le dvi.
C'est bizarre j'essaye de le reproduire mais c'est encore trop aléatoire mais les lunettes s'allument et semblent faire une sorte de calibrage(clignotement successifs des verres et la diode s'allume).

Hors ligne

#1178 Le 26/11/2012, à 18:33

magestik

Re : La Stereo-3D sous Linux

@b&nder: tu utilises un cable DVI mais en fait tu lui envoi une résolution qui fait partie des normes HDMI 1.4 (frame-packing). Quand ton écran reçoit cette résolution (1280x1470) il comprend que c'est de la 3D même si ça ne vient pas de l'entrée HDMI. Tous les écrans n'en sont pas capables : pour certain le frame-packing ne peut venir que de la prise HDMI donc si ça vient du DVI tu auras une erreur sur l'OSD de ton écran. J’arrête là pour les explications, maintenant, pour en revenir à ton problème (et si j'ai bien compris = tu utilises une résolution HDMI ?), tant que tu ne changes pas ta résolution alors tes lunettes devraient être désactivées.

Question : est-ce que tu utilises glQuadBufferEmu ?


@fredz : je vais réexpliquer parce que mon explication d'hier était un peu rapide (il étais tard et j'étais pas sur mon ordi). Donc ce que je voulais dire c'est que peut-être que ton écran est capable d'afficher 240 images par secondes mais peut-être qu'il ne peut pas prendre autant en entrée. Et ce serait loin d'être anormal,  il y a beaucoup de télé capable d'afficher du 600 Hz depuis des années, mais elles ne peuvent pas prendre une fréquence si importante en entrée. C'est en interne qu'elle calcule des images intermédiaires pour améliorer (soit disant) la fluidité. Dans ton cas je pense que tu ne peux pas utiliser le mode 240 Hz ni le mode 120 Hz directement. Soit tu utilises une source HDMI 3D (le fameux frame-packing qu'on sait utiliser depuis quelques temps grâce aux expériences de jean-le-petit) soit tu utilises une source 2D et tu es alors limité à une fréquence plus "normale" comme le 24 Hz (voir 60 Hz si t'as de la chance) en HDMI Full HD.

Hors ligne

#1179 Le 27/11/2012, à 12:34

b&nder

Re : La Stereo-3D sous Linux

Non pas d'utilisation de  glQuadBufferEmu!
J'ai pas enregistre le mode compatible dans xrandr donc quand j'en ai besoin je tape les commandes de jean-le-petit et je l'active.
Par contre quand je parlai de calibrage des lunettes cela ce se passe sans que j'ai renseigné xrandr d'un mode 3d existant. Je vois pas ce qui pourrait interferer avec les lunettes vu que j'ai pas d'autres peripheriques IR chez moi...

Hors ligne

#1180 Le 27/11/2012, à 20:57

magestik

Re : La Stereo-3D sous Linux

Désolé mais je peux rien faire : ca ne vient pas de glQuadBufferEmu puisque tu ne l'utilises pas et je n'utilise ni l'HDMI 3D ni les lunettes Nvidia tongue

Mais puisque tu parles je verrais bien un problème d'interférence : une autre source qui emet des IR et qui active les lunettes ... Ce serait quand même bizarre ...

Hors ligne

#1181 Le 28/11/2012, à 20:14

freewee

Re : La Stereo-3D sous Linux

Bonjour
Je ne pensais pas que le forum avait bougé, car je n' avais pas eu d' avertissement mail! je vois que les choses avancent, et suis prêt à tester sur mon portable, émetteur intégré.
Je ne suis pas chez moi pour tester la commande décrite plus haut pour tester mon Ecran de PC.
Par contre, je suis vraiment novice Ubuntu, et j' aurais besoin d' un minimum d' explications (une trame) pour installer ça!
J' utilise actellement le pilote 304 propriétaire, les autres pilotes  semblant créer quelques problèmes!
Puis-je partir de cette base?
Les fichiers prérequis pour OpenGL???
J' ai téléchargé le dossier glQuadBufferEmu-master sur mon bureau; j' en fais quoi? Excusez mon inexpérience!
Quelles sont les applications compatibles 3D? Lire les mkv doit être possible, mais les BD 3D???
Merci de vous mettre à la place d' un novice! Qui veut progresser! big_smile
Merci

Hors ligne

#1182 Le 02/12/2012, à 14:12

magestik

Re : La Stereo-3D sous Linux

Désolé en ce moment j'ai pas trop le temps de répondre ou de m'occuper du projet.

@freewee : je pourrais te donner une explication rapide mais si tu es novice tu comprendrais pas tout et tu serais dégouté. Donc tu vas devoir patienter un peu, le temps que je me remette dedans et que je simplifie un peu l'installation.

Par contre je peux répondre à tes questions :
- ça ne pose pas de problème que tu utilises les pilotes propriétaires;
- il te faudra les librairies OpenGL et les paquets de développement pour la compilation;
- les applications compatibles 3D sont toutes les applications supportant le Quad-Buffer d'OpenGL nativement ... c'est-à-dire pas grand chose pour le moment. Mais il y a quelques lecteurs de vidéos (Bino, mplayer entre autres), des visionneurs d'images, quelques jeux. Su le wiki la liste des logiciels compatibles est à peu près à jour je crois.
- les mkv 3D sont lisibles avec Bino (et surement avec mplayer) par contres tu peux oublier les Blu-Ray 3D pour le moment : les Blu-Ray sont déjà difficilement lisibles alors en 3D ...

Mais ne t'inquiète pas, tu y arriveras wink

Hors ligne

#1183 Le 02/12/2012, à 14:35

freewee

Re : La Stereo-3D sous Linux

Merci beaucoup pour cette réponse!
J' avance doucement dans le fonctionnement Linux, et j' ai une période de vacances qui va me permettre d' approfondir les choses!
Gnome MPlayer me lit déjà correctement les mkv 3d , je vais retourner un peu en arrière dans le forum pour essayer de me dépatouiller!
Il est certain que je manque un peu de bases, mais j' avance doucement!
Encore merci et bon courage!!

Hors ligne

#1184 Le 02/12/2012, à 14:51

magestik

Re : La Stereo-3D sous Linux

Si ça peut t'aider je peux te donner les commandes à utiliser pour la compilation et l’exécution, ce sera mieux que de revenir en arrière et te "dépatouiller" mais je sais pas si ça va beaucoup t'aider.

Déjà il faut commencer par installer tous les paquets nécessaires, dont je ne connais pas les noms exacts : OpenGL, GLX, libusb 1.0 et un autre paquet dont je retiens jamais le nom ^^

Bref, pour la compilation il faut utiliser la commande "make". Il faut au préalable se place dans le bon dossier (c'est-à-dire le dossier ou se trouve ce que tu as téléchargés sur github) grâce à la commande cd /home/NOM/Bureau/glQuadBufferEmu  (ici c'est comme si tu avais mis téléchargé les fichiers sur ton bureau dans le dossier glQuadBufferEmu).

Pour l'utilisation ça se passe aussi en ligne de commande (en étant dans le même dossier) : LD_PRELOAD=./glQuadBufferEmu.so nomduprogramme.

Par exemple : LD_PRELOAD=./glQuadBufferEmu.so glxgears -stereo (qui lancera un programme de démo en 3D, même si la 3D est pas super ^^).


Si tu n'y arrives pas (ou si tu ne comprends pas) ne désespère pas, Linux c'est pas toujours comme ça, là c'est spécial parce que c'est un logiciel en cours de développement, une beta test en quelque sorte.

Hors ligne

#1185 Le 02/12/2012, à 15:31

freewee

Re : La Stereo-3D sous Linux

Merci

Je ré ouvre mon portable dès que possible, mon PC de bureau avec écran ViewSonic à émetteur intégré ne devant pas être encore compatible!

Hors ligne

#1186 Le 02/12/2012, à 15:58

magestik

Re : La Stereo-3D sous Linux

freewee a écrit :

Merci

Je ré ouvre mon portable dès que possible, mon PC de bureau avec écran ViewSonic à émetteur intégré ne devant pas être encore compatible!

Et bien si, il est compatible ! Avec le pilote propriétaire il suffit de rajouter une ligne dans le fichier /etc/xorg.conf. Et si il supporte l'HDMI 3D alors il faut relire les messages de jean un peu plus haut wink

Normalement tout marche à peu près, il faut juste que je prenne un peu de temps pour tout remettre en forme, faire des instructions d'installation etc ... Mais en ce moment j'ai pas vraiment le temps, j'ai pas mal de choses à faire pour la fac ... et il me reste moins de 3 semaines ^^ Après ça ira mieux. J'espère.

Hors ligne

#1187 Le 02/12/2012, à 16:29

freewee

Re : La Stereo-3D sous Linux

magestik a écrit :

Et bien si, il est compatible ! Avec le pilote propriétaire il suffit de rajouter une ligne dans le fichier /etc/xorg.conf. Et si il supporte l'HDMI 3D alors il faut relire les messages de jean un peu plus haut wink

Je vais relire ça! J' ai dejà testé mon portable sur l' écran du PC de bureau, en HDMI 1.4a (en 1.3 aussi et je n' ai pas vu de différence), ça fonctionne bien. Mais mon PC de bureau est branché actuellement en DVI sur le ViewSonic, le 3D Vision fonctionne bien; y at'il une chance que ça marche en DVI?
En tout cas merci, je m' attelle à la tâche!

Hors ligne

#1188 Le 02/12/2012, à 17:23

magestik

Re : La Stereo-3D sous Linux

freewee a écrit :
magestik a écrit :

Et bien si, il est compatible ! Avec le pilote propriétaire il suffit de rajouter une ligne dans le fichier /etc/xorg.conf. Et si il supporte l'HDMI 3D alors il faut relire les messages de jean un peu plus haut wink

Je vais relire ça! J' ai dejà testé mon portable sur l' écran du PC de bureau, en HDMI 1.4a (en 1.3 aussi et je n' ai pas vu de différence), ça fonctionne bien. Mais mon PC de bureau est branché actuellement en DVI sur le ViewSonic, le 3D Vision fonctionne bien; y at'il une chance que ça marche en DVI?
En tout cas merci, je m' attelle à la tâche!

Oui, on sait activer tous les modes 3D, HDMI 3D ou DVI 3D.

Le DVI 3D c'est une résolution 120 Hz avec une petite modification au niveau des timings. Si tu veux tu peux aussi faire passer un signal frame-packed (résolution qui appartient normalement à la norme HDMI 1.4) dans une câble DVI.

Pour portable c'est glQuadBufferEmu qui s'occupera de contrôler les lunettes alors que sur ton écran de bureau ce sera juste un changement de résolution (pour le moment il faut le faire manuellement) qui les activera les lunettes.

J'ai pas de 3D active donc j'ai jamais vraiment pu tester les résolutions 3D donc ce que je te conseille c'est de lire en priorité les messages de jean-le-petit vu que c'est vraiment lui qui a fait des recherches et beaucoup de tests.

Voilà.

Dernière modification par magestik (Le 02/12/2012, à 17:24)

Hors ligne

#1189 Le 04/12/2012, à 11:51

freewee

Re : La Stereo-3D sous Linux

Bonjour

Je pense que le prérequis est installé, je n' ai plus de message d' erreur lors de la compilation de glQuadBufferEmu, mais un essai de lancement du programme d' essai m' indique une erreur Glxgear

dominique@dominique-Dell-System-XPS-L702X:~/Bureau/glQuadBufferEmu$ LD_PRELOAD=./glQuadBufferEmu.so glxgears -stereo
[**] Opening library "libdl.so"
[**] __libc_dlsym() ... Ok
[**] dlsym wrapper initialized.
[**] Opening library "libGL.so"
[**] Opening library "libX11.so"
Erreur de segmentation (core dumped)
dominique@dominique-Dell-System-XPS-L702X:~/Bureau/glQuadBufferEmu$ 

Par ailleurs, lorsque j' édite le fichier xorg.conf (par l' interface NVidia Xserver settings), l' option "10" pour la stereo est rejetée en tête de section "removed", j' ai essayé "3" à tout hasard mais c' est pareil!
Je suis un peu dans l' impasse!

Hors ligne

#1190 Le 09/12/2012, à 17:21

magestik

Re : La Stereo-3D sous Linux

Est-ce que tu as téléchargé le firmware ?

Je viens d'accepter une modification sur github venant de PKN_zeta (ça faisait longtemps big_smile ). Normalement la compilation devrait marcher correctement !

Hors ligne

#1191 Le 09/12/2012, à 18:13

freewee

Re : La Stereo-3D sous Linux

Bonjour

Non je n' avais pas téléchargé le nvstusb,ce que je viens de faire et l' ai placé dans lib/firmware à tout hasard (excuse l' inexpérience), puis redémarré.
Je n' ai pas de changement , toujours la même erreur Glxgears au lancement du programme de démo... sad

Hors ligne

#1192 Le 09/12/2012, à 18:40

magestik

Re : La Stereo-3D sous Linux

freewee a écrit :

Bonjour

Non je n' avais pas téléchargé le nvstusb,ce que je viens de faire et l' ai placé dans lib/firmware à tout hasard (excuse l' inexpérience), puis redémarré.
Je n' ai pas de changement , toujours la même erreur Glxgears au lancement du programme de démo... sad

Non au contraire tu l'as placé juste ou on devrait le placer, sauf que pour le moment faut que tu le place à côté de glQuadBufferEmu.so (j'ai trouvé ça plus simple pour le moment) wink

Hors ligne

#1193 Le 09/12/2012, à 21:21

freewee

Re : La Stereo-3D sous Linux

magestik a écrit :

Non au contraire tu l'as placé juste ou on devrait le placer, sauf que pour le moment faut que tu le place à côté de glQuadBufferEmu.so (j'ai trouvé ça plus simple pour le moment) wink

Hum hum!
Je viens de tester ça sur le le portable et le PC de Bureau, mais même sanction! roll

Hors ligne

#1194 Le 11/12/2012, à 13:04

yayel

Re : La Stereo-3D sous Linux

Bonjour !

Nous sommes en train de tester un ASUS G75V (carte NVidia GT670M) avec écran stéréo et lunettes Nvidia (3D Vision 2). La stéréo fonctionne bien ... sous Windows :-(

Comme visiblement, il y a eu beaucoup d'évolution depuis la création de cette discussion, nous ne savons pas trop bien par où commencer...

Pour l'instant tout e qu'on a fait jusque là (à part installer Ubuntu 12.10...), c'est d'ajouter   

Option         "Stereo" "10"

dans le fichier xorg.conf

Mais on a bien l'impression que ce n'est pas suffisant pour activer l'émetteur IR intégré à l'écran.

Que faut-il faire de plus ? Existe-t-il une page à jour qui centralise ce qu'il faut faire (car pour l'instant toutes celles que nous avons trouvées finissent par pointer sur des solutions abandonnées ou qui ne sont pas mises à jour...).

Merci d'avance !
Yayel

Hors ligne

#1195 Le 12/12/2012, à 21:53

magestik

Re : La Stereo-3D sous Linux

Est-ce que tu utilises le pilote propriétaire ou le pilote libre (nouveau) ? L'option "Stereo 10" ne marche que pour le pilote propriétaire !

Si tu utilises le pilote libre tu vas devoir utiliser une résolution personnalisée qui activera la stéréoscopie.

Dès que je serai en vacances je m'occuperais de remettre au propre le driver et la doc, promis tongue

Hors ligne

#1196 Le 14/12/2012, à 17:54

yayel

Re : La Stereo-3D sous Linux

Hello !

On a testé avec le pilote proprio et on ne voit pas de différence... Quel outils utiliser pour afficher des images (pns ou jps) ?

Ok pour aider à remettre la doc à jour une fois qu'on aura compris comment ça marche et vivement les vacances !!

Yayel

Hors ligne

#1197 Le 16/12/2012, à 15:35

freewee

Re : La Stereo-3D sous Linux

magestik a écrit :

Est-ce que tu utilises le pilote propriétaire ou le pilote libre (nouveau) ? L'option "Stereo 10" ne marche que pour le pilote propriétaire !

Bonjour
Je reviens au forum, étant un peu absorbé comme "beta testeur" de Stereodata maker!
Bon en ce qui me concerne, j' utilise le pilote propriétaire 304 NVidia, et lorsque j' essai d' introduire la valeur "10" en passant par l' interface NVidia X server setting, elle semble acceptée, mais lorsque je réouvre le fichier, je retrouve

# Removed Option "Stereo" "10"

en tête de section!!!
Merci

Hors ligne

#1198 Le 16/12/2012, à 22:46

magestik

Re : La Stereo-3D sous Linux

Faut voir avec jean, c'est lui l'expert ^^

Sinon faut essayer de modifier la résolution avec xrandr.

Dernière modification par magestik (Le 16/12/2012, à 22:52)

Hors ligne

#1199 Le 03/01/2013, à 17:21

magestik

Re : La Stereo-3D sous Linux

Bonjour à tous, et bonne année !

En ce moment j'ai pas trop le temps d'avancer sur glQuadBufferEmu. Je travaille sur un jeu en OpenGL pour mes études donc je peux pas repousser, faut que je le finisse à temps et c'est un projet assez conséquent. Par contre j'apprends plein de choses en OpenGL ça devrait beaucoup me servir quand j'aurais un peu de temps pour me remettre sur glQuadBufferEmu. Il reste pas tant que ça a faire pour avoir quelque chose de correct !

Désolé pour tout ceux qui attendent que j'avance ... Mais je vais vraiment essayer de prendre quelques heures pour faire un peu de ménage (supprimer les trucs qui servent plus) et compléter un peu les différents points essentiels.

Allez perdez pas espoir wink

Hors ligne

#1200 Le 23/01/2013, à 19:43

Lechuck Norris

Re : La Stereo-3D sous Linux

freewee a écrit :
magestik a écrit :

Est-ce que tu utilises le pilote propriétaire ou le pilote libre (nouveau) ? L'option "Stereo 10" ne marche que pour le pilote propriétaire !

Bonjour
Je reviens au forum, étant un peu absorbé comme "beta testeur" de Stereodata maker!
Bon en ce qui me concerne, j' utilise le pilote propriétaire 304 NVidia, et lorsque j' essai d' introduire la valeur "10" en passant par l' interface NVidia X server setting, elle semble acceptée, mais lorsque je réouvre le fichier, je retrouve

# Removed Option "Stereo" "10"

en tête de section!!!
Merci

Salut, à tous, je découvre ubuntu depuis une semaine, et je suis plutôt emballé. J'ai voulu essayer la 3D avec 3Dvison de nvidia sur ce bel OS. J'ai installé les pilotes propriétaires Nvidia 310.32 sur ubuntu 12.10 x64 pour 2 GTX570 en SLI, et réussi à mettre la led au vert sur l'émetteur iR pour les lunettes. J'ai modifié la ligne:

    Option         "Stereo" "0"

en:

    Option         "Stereo" "10"

avec gedit dans /etc/X11/xorg.conf, mais lorsque je lance trine 2 ou amnesia (des jeux en 3D dispo sur steam), l'affichage sur l'écran se fait tout à fait normalement (c.a.d. pas de stéréoscopie) et quand je vais observer le fichier xorg.conf par l'intermédiaire nvidia x server setting alors seulement il rajoute la ligne:

# Removed Option "Stereo" "10"

Comme chez freewee.
Mais ça ne change rien, toujours aucune stéréoscopie. c'est pourça que je remonte le topic.

Il y a bien quelque lignes dans l'aide de nvidia x server setting à propos de la stéréocsopie:

Stereo Eye

The Display Passive Stereo Eye drop-down allows you to select a desired stereo eye the display should output when Passive Stereo (Mode 4) is enabled.

Le réglage devrait se trouver entre Mode Name et Orientation, mais je ne le trouve pas. sad
J'ai aussi essayé

 sudo nvidia-xconfig --stereo=10

mais sans succès.

Dernière modification par Lechuck Norris (Le 23/01/2013, à 20:15)

Hors ligne

Haut de page ↑