Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 04/12/2012, à 12:11

FdHP

Dual boot Ubuntu/Windows et UEFI - Boot-repair ne repare pas

Bonjour,

Je post ce petit message car je n'ai pas trouvé de solution malgré mes différentes recherches sur Internet.
Dans le cadre de mon travail j'ai obtenu un pc Dell XPS 13 L322X avec Windows 8. J'ai voulu faire une installation de Ubuntu en dual boot.
Comme il y a un UEFI avec l'option secure boot j'ai suivi le tuto présent sur le site officiel d'Ubuntu (celui-ci : https://help.ubuntu.com/community/UEFI).
Le Dell ne me permettait pas de booter la clé USB en mode UEFI j'ai donc utilisé boot repair.
Le problème c'est que depuis je ne peux plus lancer Windows... L'option "Windows" n’apparaît même pas dans les choix de Grub au démarrage.
J'ai donc tenté d'ajouter manuellement une entrée en modifiant le fichier /etc/grub.d/40_custom
Pour ce faire j'ai suivi les conseils sur plusieurs forum : j'ai essayé plusieurs méthodes mais aucune ne marche.

Je suis donc toute ouïe car j'ai épuisé mes dernières ressources...

PS : Je ne suis absolument pas contre la possibilité de supprimer complètement Ubuntu pour restaurer Windows (je pourrais toujours me débrouiller pour installer Ubuntu autrement) mais encore une fois je n'arrive pas à lancer l'utilitaire de restauration. Le site Dell indique qu'il faut utiliser la touche F8 au démarrage mais sans succès chez moi...

Dernière modification par FdHP (Le 04/12/2012, à 13:08)

Hors ligne

#2 Le 04/12/2012, à 14:29

malbo

Re : Dual boot Ubuntu/Windows et UEFI - Boot-repair ne repare pas

Dans la majorité des cas, il est possible de réparer Grub pour obtenir dans le menu Grub  des entrées pour Windows qui fonctionnent. Je te prie de répondre à cette demande (Boot-Info) : http://doc.ubuntu-fr.org/tutoriel/boot-info
Le rapport Boot-Info contiendra les infos qui me permettront de te dire avec un bonne fiabilité ce qu'il faut faire pour réparer.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#3 Le 04/12/2012, à 16:31

FdHP

Re : Dual boot Ubuntu/Windows et UEFI - Boot-repair ne repare pas

Voici le rapport de boot-info :
Rapport boot-info

Dans le fichier 40_custom (dans /etc/grub.d), j'avais également essayé ceci :

menuentry "Windows 8" {
    search --fs-uuid --no-floppy --set=root 71E2-7A83
    chainloader (${root})/efi/Microsoft/Boot/bootmgfw.efi
}

En tout cas, merci de votre intérêt pour mon problème smile

Dernière modification par FdHP (Le 04/12/2012, à 16:46)

Hors ligne

#4 Le 04/12/2012, à 18:45

malbo

Re : Dual boot Ubuntu/Windows et UEFI - Boot-repair ne repare pas

FdHP,
Le concepteur de Boot-Repair est en train de galérer dans des mises à jour calamiteuses (voir ici ) qui concernent justement la réparation des entrées pour Windows. Ce n'est pas de chance pour toi. Je ne suis pas du tout sûr que tu pourras utiliser Boot-Repair ce soir pour faire ta réparation parce que je crois bien que ça fait déjà deux jours que ça merdouille et rien ne dit que la version prochaine sera la bonne parce que hier ça devait être le version 3.195~ppa21 qui devait résoudre et ce soir, je constate qu'une version "3.195~ppa23~precise" de Boot-Repair est proposée en mise à jour. Faut attendre que la crème se dépose...

Dernière modification par malbo (Le 04/12/2012, à 18:51)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#5 Le 04/12/2012, à 19:18

FdHP

Re : Dual boot Ubuntu/Windows et UEFI - Boot-repair ne repare pas

Arf! Mince :s
Je ne perds pas espoir alors! Je réessayerait dans les jours à venir. Je ne suis pas trop pressé non plus, j'ai d'autres PC sur lesquels bosser.

Et selon toi, je ne peux résoudre mon problème "manuellement"?

Hors ligne

#6 Le 04/12/2012, à 19:58

malbo

Re : Dual boot Ubuntu/Windows et UEFI - Boot-repair ne repare pas

FdHP a écrit :

Et selon toi, je ne peux résoudre mon problème "manuellement"?

Je ne sais pas si c'est faisable.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#7 Le 05/12/2012, à 00:08

FdHP

Re : Dual boot Ubuntu/Windows et UEFI - Boot-repair ne repare pas

OK! Merci quand même. Je tacherais de mettre à jour cette discussion quand j'aurais résolu le problème.

Hors ligne

#8 Le 06/12/2012, à 16:49

malbo

Re : Dual boot Ubuntu/Windows et UEFI - Boot-repair ne repare pas

Il semble que Boot-Repair soit lui-même réparé. Voir ici (ça a marché pour will4211 avec boot-repair dans sa version 3.195~ppa26~precise) : http://forum.ubuntu-fr.org/viewtopic.ph … #p11768121

Dernière modification par malbo (Le 06/12/2012, à 16:52)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

Haut de page ↑