Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 29/10/2005, à 14:30

juanitomaille

rpm suse traduit par alien, pk ca ne se lance pas?

bjour!;)

j'ai téléchargé kdepim/pi pour synchroniser mon pda sous linux (zaurus).
le plus paradoxal c'est que ça marche nickel en 2 secondes sous windows mais pas sous ubuntu.

j'ai fais sudo alien -i kdepimpi*,
une fois dans /opt/kdepimpi/ j'ai des fichiers sans extensions kopi, kapi, kammu... mais rien à faire pour les lancer sad
c'est du Qt (ben oui, kde:P)

une idée?
ce serait con de devoir garder un boot windows pour ça!!!!!:mad:

Dernière modification par juanitomaille (Le 29/10/2005, à 14:31)


blog: http://www.fil2blog.com

Hors ligne

#2 Le 31/10/2005, à 12:45

juanitomaille

Re : rpm suse traduit par alien, pk ca ne se lance pas?

voila le mode d'emploi pour compiler soi-même le paquet vu que l'insatll par alien ne donne rien (et que personne ne semble savoir non plus)

seulement je n'y arrive pas non plus...

Howto Compile+Run KO/Pi Desktop for Linux Desktop:

Remove all Makefile files first!

Set the needed environment variables to compile a Qt program.
(e.g. QTDIR, ,... )
Do a
qmake

c quoi qmake??Jamais vu et ça marche pas...

make clean
make
in this directory.

ne compile pas car il n'y a pas de plateforme configurée

After compilation, you will find the binary and the libs in ./bin.


Goto ./bin  in console and type type ./kopi

Now kopi starts.
(UPDATE : Now you have probably to copy the libs to /usr/lib to run KO/Pi).
This can be done by the following prodedure:

Howto build the KDE sync command line tools:

Goto
./desktop
Adjust the paths ( KDEDIR and  KDE_DEV_DIR ) in the Makefile there.
Type there
make
to build the KDE sync command line tools.
Now switch to super user mode with
su
Copy everything in the right place with
make install
(Comment out the lines in the makefile which try to copy files, which are not there, e.g. the line "cp -fr /home/polo/eigene/apps/* /opt/kdepimpi/" ).
Now build a rpm with
make dist

make dist uses the rpm spec in ./desktop/rpm/kdepim_rpm.

This all works for a SuSE 9.2.
For other distris you have to adjust some settings.

En fait je pensais faire

./configure
make
make install

mais ça ne marche pas

Pffff, c'est dur linux....

Dernière modification par juanitomaille (Le 31/10/2005, à 12:46)


blog: http://www.fil2blog.com

Hors ligne

#3 Le 31/10/2005, à 13:35

dawar

Re : rpm suse traduit par alien, pk ca ne se lance pas?

Heuu, et tu ne trouves pas tout cela dans les paquets d'Ubuntu plutot que de le compiler ???


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#4 Le 02/11/2005, à 19:56

juanitomaille

Re : rpm suse traduit par alien, pk ca ne se lance pas?

Euh non malheureusement pas...
dans les dépots, il y a kdepim or ce qui m'interresse c'est kdepim/pi que l'on trouve sur le site http://www.pi-sync.net.
Il permet la synchro avec un Zaurus.
Donc 2 solutions pour l'install
traduire le rpm pour suse de kdepim/pi en .deb avec Alien ou complier les sources.
La première solution donne des fichiers dans /opt/kdepim sans extension mais ne sont pas executables...
bref la memerde quoi.


blog: http://www.fil2blog.com

Hors ligne

Haut de page ↑