Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 08/12/2012, à 19:19

bilouck

[résolu]Dépendances non satisfaites : plus de mises à jour..

Depuis des semaines :

Les paquets suivants ont des dépendances non-satisfaites :

linux-image-generic-pae: Depends: linux-image-3.2.0-33-generic-pae mais il n'est pas installé


Et donc bonsoir à la communauté et d'avance merci !
Je suis une archi débutante.

Dernière modification par bilouck (Le 09/12/2012, à 13:21)

Hors ligne

#2 Le 08/12/2012, à 19:35

louis94

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Bonjour,

sudo apt-get install linux-image-3.2.0-33-generic-pae

Louis

Hors ligne

#3 Le 08/12/2012, à 19:37

PPdM

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Salut
Puis

sudo apt-get update && sudo apt-get dist-upgrade

et cela devrait rouler


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

En ligne

#4 Le 08/12/2012, à 19:54

bilouck

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Salut et merci mais ça n'a pas fonctionné sad

Hors ligne

#5 Le 08/12/2012, à 19:56

bilouck

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Au cours de la première opération ça cause d'erreurs à partir d'ici :
dpkg-deb (sous-processus) : données : erreur de lecture interne de bzip2 : « DATA_ERROR »
dpkg-deb : erreur : le sous-processus <decompress> a retourné une erreur de sortie d'état 2
dpkg : erreur de traitement de /var/cache/apt/archives/linux-image-3.2.0-33-generic-pae_3.2.0-33.52_i386.deb (--unpack) :
lecture courte (short read) lors d'une copie de buffer pour backend dpkg-deb pendant « ./lib/firmware/3.2.0-33-generic-pae/bnx2x/bnx2x-e1h-6.2.9.0.fw »
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-33-generic-pae /boot/vmlinuz-3.2.0-33-generic-pae
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-33-generic-pae /boot/vmlinuz-3.2.0-33-generic-pae
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/linux-image-3.2.0-33-generic-pae_3.2.0-33.52_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Et après la seconde opération, à la fin j'ai ça :
W: Impossible de récupérer gzip:/var/lib/apt/lists/partial/fr.archive.ubuntu.com_ubuntu_dists_precise-updates_universe_binary-i386_Packages  Somme de contrôle de hachage incohérente

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Dernière modification par bilouck (Le 08/12/2012, à 19:59)

Hors ligne

#6 Le 08/12/2012, à 19:59

louis94

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Essaye peut-être

sudo apt-get clean

avant la première commande. Si c'est le paquet que tu as téléchargé il y a longtemps qui est corrompu, ça l'effacera.

Hors ligne

#7 Le 08/12/2012, à 20:01

PPdM

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

A quel moment tu as cette erreur !

Dernière modification par pierguiard (Le 08/12/2012, à 20:01)


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

En ligne

#8 Le 08/12/2012, à 20:12

bilouck

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

De quelle erreur parle-tu ?

sudo apt-get clean  ne fonctionne pas, enfin rien ne se passe wink

Hors ligne

#9 Le 08/12/2012, à 20:18

PPdM

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

alors essayes

sudo apt-get autoremove -purge

Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

En ligne

#10 Le 08/12/2012, à 20:19

bilouck

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

E: L'option « p » de la ligne de commande [d'origine -purge] est inconnue.

Hors ligne

#11 Le 08/12/2012, à 20:20

bilouck

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Là je sors, je m'y remettrai demain, en tout cas merci !!

Hors ligne

#12 Le 08/12/2012, à 20:20

PPdM

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

J'ai fais une faute

 sudo apt-get autoremove --purge

Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

En ligne

#13 Le 08/12/2012, à 20:24

bilouck

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
linux-image-generic-pae : Dépend: linux-image-3.2.0-33-generic-pae mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

Hors ligne

#14 Le 08/12/2012, à 20:32

PPdM

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Ben, fait ce qu'il te dit !


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

En ligne

#15 Le 09/12/2012, à 09:06

bilouck

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Bonjour, c'est reparti big_smile

apt-get -f install
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ?

>> euh, logiquement je devrais avoir les privilèges en question sinon je ne vois pas qui d'autre mais vu que ça ne me demande pas de réponse à cette question, ben.... stand by.

Bon dimanche à tous.

Hors ligne

#16 Le 09/12/2012, à 09:09

PPdM

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

tu a oublié de faire précéder la commande de sudo

sudo apt-get -f install

Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

En ligne

#17 Le 09/12/2012, à 09:28

bilouck

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Réception de : 1 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main linux-generic-pae i386 3.2.0.34.37 [1 722 B]
Réception de : 2 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main linux-image-generic-pae i386 3.2.0.34.37 [2 564 B]
4 286 o réceptionnés en 0s (20,0 ko/s)       
dpkg : des problèmes de dépendances empêchent la configuration de linux-image-generic-pae :
linux-image-generic-pae dépend de linux-image-3.2.0-33-generic-pae ; cependant :
  Le paquet linux-image-3.2.0-33-generic-pae n'est pas installé.
dpkg : erreur de traitement de linux-image-generic-pae (--configure) :
problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                dpkg : des problèmes de dépendances empêchent la configuration de linux-generic-pae :
linux-generic-pae dépend de linux-image-generic-pae (= 3.2.0.33.36) ; cependant :
Le paquet linux-image-generic-pae n'est pas encore configuré.
dpkg : erreur de traitement de linux-generic-pae (--configure) :
problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Des erreurs ont été rencontrées pendant l'exécution :
linux-image-generic-pae
linux-generic-pae
E: Sub-process /usr/bin/dpkg returned an error code (1)



En fait c'est ce paquet linux image generic pae qui bloque mais hier avec mon frère on essayé de le chercher et de l'installer ou de le désinstaller mais on ne peut rien faire, c'est le serpent qui se mord la queue hmm

Hors ligne

#18 Le 09/12/2012, à 10:00

PPdM

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

bilouck a écrit :
Réception de : 1 [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise-updates/main linux-generic-pae i386 3.2.0.34.37 [1 722 B]
Réception de : 2 [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise-updates/main linux-image-generic-pae i386 3.2.0.34.37 [2 564 B]
4 286 o réceptionnés en 0s (20,0 ko/s)        
dpkg : des problèmes de dépendances empêchent la configuration de linux-image-generic-pae :
 linux-image-generic-pae dépend de linux-image-3.2.0-33-generic-pae ; cependant :
  Le paquet linux-image-3.2.0-33-generic-pae n'est pas installé.
dpkg : erreur de traitement de linux-image-generic-pae (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                dpkg : des problèmes de dépendances empêchent la configuration de linux-generic-pae :
 linux-generic-pae dépend de linux-image-generic-pae (= 3.2.0.33.36) ; cependant :
 Le paquet linux-image-generic-pae n'est pas encore configuré.
dpkg : erreur de traitement de linux-generic-pae (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                                Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-generic-pae
 linux-generic-pae
E: Sub-process /usr/bin/dpkg returned an error code (1)

En fait c'est ce paquet linux image generic pae qui bloque mais hier avec mon frère on essayé de le chercher et de l'installer ou de le désinstaller mais on ne peut rien faire, c'est le serpent qui se mord la queue hmm

Prend l'habitude de donner le retour de console entre deux balises code bt_pre.png.
Sinon je viens de regarder dans synaptic le paquet existe, [linux-image-3.2.0-33-generic-pae]

Essayes

sudo apt-get install linux-image-3.2.0-33-generic-pae

ou alors par synaptic.


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

En ligne

#19 Le 09/12/2012, à 11:38

bilouck

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Hé ben ça alors !
ça a fonctionné !

Un GRAND merci pierguiard ! cool

Hors ligne

#20 Le 09/12/2012, à 11:47

PPdM

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

Pour finaliser

sudo apt-get autoremove --purge

Pour nettoyer puis

 sudo apt-get update && sudo apt-get dist-upgrade

pour tout mettre a jour


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

En ligne

#21 Le 09/12/2012, à 13:20

bilouck

Re : [résolu]Dépendances non satisfaites : plus de mises à jour..

fait, nickel !
encore merci.

Hors ligne

Haut de page ↑