Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 03/10/2010, à 08:59

TheJoker02200

Team Fortress 2 on Linux (Topic français ;))

Bonjour à tous ou bonsoir,

Voilà, je voudrai faire passer Team Fortress 2 sur mon Ubuntu mais ca rame énormément. Donc, j'ai une 8800 GT, 2 Go de ram, Un 4200+ (dual core et AMD). Mon Ubuntu est en 64 bits comme Windows 7. Je fais un dual Win7/Ubuntu.

Mon Ubuntu est sur mon autre disque dur. Mais, vous pouvez m'aider ? Le Wine est à jour ver 1.2.
Donc voilà, j'espère vraiment que Valve vont nous faire un p'tit Steam sur Linux :bave:

Donc là, en attendant leur platforme sous Linux, pouvez vous m'aidez ? Pour y jouer, car j'ai 10 fps sur le jeux sous Ubuntu, alors que sous Windows 7 (évidant...) j'ai 60 / 50 fps.

Cordialement, TheJoker.

Hors ligne

#2 Le 03/10/2010, à 11:22

MoKraD

Re : Team Fortress 2 on Linux (Topic français ;))

1) Configurer wine

Lancer regedit.exe (wine regedit.exe ) dans /home/ton_home/.wine/drive_c/windows/
Créer un fichier XXX.reg
Dans regedit, importe ton fichier XXX.reg dans lequel tu aura copié ça:

REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Direct3D]
"AllowMultiSampling"="enabled"
"OffscreenRenderingMode"="fbo"
"PixelShaderMode"="enabled"
"UseGLSL"="enabled"
"VertexShaderMode"="hardware"
"VideoMemorySize"="896"  //quantité de ram de ta carte graphique en Mo

2) Mettre à jour le driver de ta carte graphique

http://doc.ubuntu-fr.org/nvidia

Ajoute le ppa qui va bien à ta version d'ubuntu

3) Regarde pour info ce post 

http://forum.ubuntu-fr.org/viewtopic.php?id=417950

3) Si tu n'a pas assez de fps 

Lance le jeux en mode -dxlevel 81 (à ajouter dans les options de lancement dans steam)

Dernière modification par MoKraD (Le 03/10/2010, à 11:24)

Hors ligne

#3 Le 03/10/2010, à 12:27

TheJoker02200

Re : Team Fortress 2 on Linux (Topic français ;))

Pouvez-vous m'expliqué comment ajouté un PPA merci. neutral

EDIT 1 : Trouver
EDIT 2 : Petite erreur helpp siouplay

capturelg.png

Dernière modification par TheJoker02200 (Le 03/10/2010, à 12:37)

Hors ligne

#4 Le 03/10/2010, à 12:50

MoKraD

Re : Team Fortress 2 on Linux (Topic français ;))

A priori, tu as l'air d'utiliser steam en version anglaise ce qui est mieux pour éviter les crashs lors d'une domination.
Si non, je vois pas trop pour ton message d'erreur. Quand apparait-il ?
Où en est tu au niveau des fps ? si tu as des problèmes peut-être teste en déactivant steam in game.

Hors ligne

#5 Le 03/10/2010, à 12:55

TheJoker02200

Re : Team Fortress 2 on Linux (Topic français ;))

Alors, problème réglé avec l'érreur, niveau FPS, j'ai testé que sur la map training. Et, je met toujours Steam en anglais x).

Sinon, t'aurais pas MSN ? Je t'envoi un MP avec mon adresse. (y'a pas de mp yikes ?)

/// EDIT : Comment activé anti crélénage / anti aliasing parce que c'est moche tout plein d'pixels ! <<

// Edit 2 : Autre problème, quand je fais continuer après le motd.

http://img825.imageshack.us/img825/5575/capture2yg.png

Dernière modification par TheJoker02200 (Le 03/10/2010, à 13:29)

Hors ligne

#6 Le 03/10/2010, à 19:22

MoKraD

Re : Team Fortress 2 on Linux (Topic français ;))

1) pour anti crénelage, normalement tu peux l'actvier dans le jeux dans option -> video -> avancé (par contre, les réglages ne sont pas enregistré, faut refaire la manip à chaque foi)

2) jamais vu l'erreur que tu as. peux-être lance le jeux en déactivant compiz

3) As-tu la dernière version de wine ?

Hors ligne

#7 Le 04/10/2010, à 06:09

TheJoker02200

Re : Team Fortress 2 on Linux (Topic français ;))

1) Non, aucune option pour réglé, la case AA est grisé.

2) Compiz désactivé, toujours bug. neutral

3) Oui.

Hors ligne

#8 Le 04/10/2010, à 06:50

MoKraD

Re : Team Fortress 2 on Linux (Topic français ;))

1) Effectivement, après vérif., je n'ai que le filtrage anisotropique de dégrisé. Question con, tu lance le jeux à la résolution native de ton écran ? (option de lancement ex :-width 1920 -height 1200)

2) Pas d'idée

3) Normalement c'est mieux

Hors ligne

#9 Le 06/10/2010, à 15:32

TheJoker02200

Re : Team Fortress 2 on Linux (Topic français ;))

1) Non, je le lance en mode fenêtré en petite résolution

2) ... sad

3) Je ne vois aucun différance.

Désolé du retard ^^'

~ Rétrogradage de 10.10 à 10.8.

Dernière modification par TheJoker02200 (Le 06/10/2010, à 18:40)

Hors ligne

#10 Le 06/10/2010, à 20:17

MoKraD

Re : Team Fortress 2 on Linux (Topic français ;))

C'est pas clair pour moi. t'en est où ?
As tu assez de fps en plein écran ?
Nota: la dernière version de wine est la 1.3.4 et pas 1.2

Hors ligne

#11 Le 07/10/2010, à 12:41

TheJoker02200

Re : Team Fortress 2 on Linux (Topic français ;))

J'ai bien la version 1.3.4 de Wine. Et pour l'instant je n'essaye pas en pleine écran car, je n'est pas accès au Steam Community In-Game.

Hors ligne

#12 Le 10/12/2012, à 06:40

medoc974

Re : Team Fortress 2 on Linux (Topic français ;))

La révolution est en marche!!!

Vos premier retour TF2 Linux sans wine? vs Windows?

PS: dsl du déterrage la flemme qd tu nous tiens...

Hors ligne

#13 Le 11/12/2012, à 19:35

Horigo

Re : Team Fortress 2 on Linux (Topic français ;))

Pour ma part avec les pilotes amd 12.11 beta j'ai un écran noir pendant 15 secondes puis le jeu se ferme.

Hors ligne

#14 Le 11/12/2012, à 19:54

abelthorne

Re : Team Fortress 2 on Linux (Topic français ;))

Horigo a écrit :

Pour ma part avec les pilotes amd 12.11 beta j'ai un écran noir pendant 15 secondes puis le jeu se ferme.

Pareil, mais avec les pilotes ATI des dépôts (pas testé les bêta).

Hors ligne

#15 Le 11/12/2012, à 21:06

MoKraD

Re : Team Fortress 2 on Linux (Topic français ;))

Pour moi en nvidia 560GTX, TF2 fonctionne bien hors mis:
- random crash (mais je peux jouer longtemps)
- problème d'affichage des textes sur certains serveurs (ex: nom des joueurs et chat) / la plus part des caractères sont manquants mais cela n’empêche pas de jouer

Dernière modification par MoKraD (Le 11/12/2012, à 21:07)

Hors ligne

#16 Le 11/12/2012, à 21:57

abelthorne

Re : Team Fortress 2 on Linux (Topic français ;))

MoKraD a écrit :

- problème d'affichage des textes sur certains serveurs (ex: nom des joueurs et chat) / la plus part des caractères sont manquants mais cela n’empêche pas de jouer

Ils sont remplacés par des carrés ? Parce qu'il y a ce genre de problème sous Windows quand des joueurs ont des caractères non latins dans leur pseudo (polices manquantes, je suppose).

Hors ligne

#17 Le 11/12/2012, à 22:49

MoKraD

Re : Team Fortress 2 on Linux (Topic français ;))

non par rien: du vide. Mais j'ai vu que ce bug est signalé dans le forum de steam linux. Il y a une vidéo explicative:
http://www.youtube.com/watch?feature=pl … mOgePPEQs0
voir vers la fin de la vidéo

Hors ligne

Haut de page ↑