Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 14/12/2012, à 15:06

popol06

Webdav + apache

Bonjour,

j'ai monté un serveur apache avec un accès webdav pour les utilisateur (connecté dérrière un LDAP), on y accède via une adresse du type :
http://nom-de_domaine/nom_d'utilisateur
Tout cela fonctionne bien, mais (car il y toujours un mais), voici mon soucis :
tout d'abord voici un fichier de conf type pour un utilisateur :

Alias /toto /var/www/html/webdav/toto
<Directory "/var/www/html/webdav/toto">
   DAV On
   AuthType Basic
   AuthName "Webdav"
   AuthBasicProvider ldap
   AuthzLDAPAuthoritative on
   AuthLDAPURL ldap://localhost/o=gouv,c=fr?uid?sub?(objectclass=*)
   Options FollowSymLinks
   AllowOverride None
   Options Indexes FollowSymLinks MultiViews
   AllowOverride None
   Options +FollowSymLinks
   Require user toto
   Options +Indexes
   IndexIgnore ..
   IndexOptions -IconsAreLinks NameWidth=* FancyIndexing SuppressLastModified FoldersFirst
   IndexOrderDefault Ascending Name
   Order Allow,Deny
   Allow from All
</Directory>

En fait les utilisateurs vont directement taper dans leur /home (car /var/www/html/webdav/toto et en fait un lien symbolique qui pointe vers /home/utilisateur)
les utilisateurs accèdent à leur /home soit par le webdav soit par une session windows. Le soucis est que quand l’utilisateur crée un fichier/dossier depuis sa session windows, le dossier/fichier est au nom de

utilisateur:son_groupe

tandis que l'accès via webdav se fait avec

www-data

ce qui fait que les documents crées / édités depuis windows sont interdits (lecture / écriture..) depuis l'accès via webdav...

Piste explorée :
faire un

chown -R www-data:www-data /home/utilsateur

mais le problème est que tout nouveau doculents crées n'hérite pas de ces droits, pareil avec des setfacl....
j'ai bien pensé à un script dans une cron mais je trouve pas ça propre...

ma question est : est-ce qu'il y a un moyen que lorsqu'on arrive via le webdav, on se fasse passer non pas pour www-data mais par nom_d'utilisateur ?

j'espère avoir été assez clair.....

merci d'avance

Hors ligne

Haut de page ↑