Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 19/12/2012, à 23:06

didli

[Astuce] Freeze du boot : ata1: softreset failed (device not ready)

Salut à tous !

ata1: softreset failed (device not ready)
ata1: applying PMP SRST workaround and retrying

Pour certains, ce message n'a aucunes incidences particulières, pour d'autres, c'est un kernel panic, ou encore un ralentissement significatif du boot et pour d'autres encore un freeze du boot (mon cas).
Cette saleté a son lot de possibilités faramineuses de causes et de solutions.
Je vais essayer ici de faire rapidement un tour d'horizon, vu que je viens de me prendre la tête pendant 2 jours et fait le tour du launchpad, du debian wiki et autres pour avoir un comportement PC "correct". N'hésitez pas ici même à faire profiter de vos connaissances si les miennes sont incomplètes/fausses/inexactes (rayez la mention inutile).

(A)- Votre HDD est mort, ou sur le point de l'être. Rare, au fond, mais plausible. Si booter en mode recovery ne fonctionne pas ... c'est quand même mauvais signe ...
(B)- Le câble SATA est endommagé. Changez-le.
(C)- C'est le lecteur/graveur DVD qui a un souci, et non pas le disque dur. Débranchez le juste pour tester. Changez sa connexion à l'alim si vous le pouvez (SATA ou MOLEX). A tester avec les HDD aussi.
(D)- Vous avez un chipset VIA ou AMD, notamment les machine de type AMD64 et vous avez les options Legacy IDE mode / Native IDE mode / AHCI dans votre bios. Changez pour Legacy IDE ou AHCI et vérifiez s'il y a un changement.
(E)- Astuce : Ajouter une option dans GRUB2 et tester son efficacité (voir plus bas)

Pour ma part, c'est une option à ajouter dans GRUB2 qui m'aura permis de contourner ce souci (et non pas le résoudre). Voici une liste des options (à prendre avec des pincettes svp) qu'il convient de tester, et celle qui a fonctionné pour moi :
1. Modifions /etc/default/grub :

sudo gedit /etc/default/grub

2. ... et cherchez la ligne :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

3 On ajoute une option entre les guillemets, comme suit :

GRUB_CMDLINE_LINUX_DEFAULT="irqpool quiet splash"

- Options à tester :
irqpool
all_generic_ide
noacpi
rootdelay=60 (le chiffre représente un délai et doit être adapté à votre cas). C'est l'option qui a fonctionné pour moi.

Voilà ! En espérant que cela réduise considérablement le temps de recherche des personnes qui pourraient être concernées par ce type de message.

Dernière modification par didli (Le 19/12/2012, à 23:11)


Plan B : réessayer le Plan A jusqu'à ce qu'il fonctionne.
http://www.mediaklan.com/

Hors ligne