Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 22/12/2012, à 23:11

Yog Sothoth

Empêcher un tiers d'éteindre ma machine

Bonjour,

Voila mon problème: un petit malin éteint ma machine quand je ne suis pas la. Cela interrompt mes calculs. Le bouton d'alimentation est règlé dans le BIOS pour ne pas réagir quand la machine est allumée donc pas de danger de ce coté la. Vérrouiller l'écran ne suffit pas, on peut délogguer sans le mot de passe. Je dois donc protèger ma session sans interrompre mes calculs ni l'accès à internet.

Une recherche google n'a rien donné.

Par ailleurs, la page d'accueil du forum déconne pour l'instant chez moi.


Intel 4770K@4.1 Ghz GTX 560 8Go RAM corsair DDR3. Xubuntu 13.10

Hors ligne

#2 Le 22/12/2012, à 23:16

Shanx

Re : Empêcher un tiers d'éteindre ma machine

Si tu fais ctrl + alt + L ?


« En vérité, je ne voyage pas, moi, pour atteindre un endroit précis, mais pour marcher : simple plaisir de voyager. » R. L. Stevenson
--
Blog et randos

En ligne

#3 Le 22/12/2012, à 23:21

Yog Sothoth

Re : Empêcher un tiers d'éteindre ma machine

smile Je ne suis pas sur ma tour la mais la machine sur laquelle je tape mon message est sous mint 12. Si je tape ctrl + alt + L cela fait exactement la même chose que lorsque je vais dans le menu et que je choisis "vérrouiller l'écran". Et cela n'empêche pas d'éteindre sans mot de passe.


Intel 4770K@4.1 Ghz GTX 560 8Go RAM corsair DDR3. Xubuntu 13.10

Hors ligne

#4 Le 22/12/2012, à 23:27

Shanx

Re : Empêcher un tiers d'éteindre ma machine

Tu peux utiliser xlock.
Pour l’installer : sudo apt-get install xlock
Pour le lancer, xlock dans un terminal. L’écran devient tout noir, il faut taper le mot de passe en aveugle pour déverrouiller.


« En vérité, je ne voyage pas, moi, pour atteindre un endroit précis, mais pour marcher : simple plaisir de voyager. » R. L. Stevenson
--
Blog et randos

En ligne

#5 Le 22/12/2012, à 23:28

The Uploader

Re : Empêcher un tiers d'éteindre ma machine

Salut

Tu veux dire qu'il l'éteint en restant appuyé 4 secondes sur le bouton power ?

Je ne sais vraiment pas comment éviter ça.
(bon j'avais mal lu ton post)

Sinon dans le gestionnaire de paramètres => Gestionnaire d'alimentation tu peux régler le comportement du gestionnaire d'alimentation lorsque le bouton d'alimentation est appuyé (en plus d'autres paramètres évidemment). C'est géré et "écouté" par xfce4-power-manager directement, indépendamment du BIOS.

Yog Sothoth a écrit :

Vérrouiller l'écran ne suffit pas, on peut délogguer sans le mot de passe. Je dois donc protèger ma session sans interrompre mes calculs ni l'accès à internet.

Normalement sous Xubuntu xscreensaver verouille l'écran (c'est xfce4-power-manager qui le lance lors du verrouillage, qui peut être configuré encore une fois dans ses paramètres. Il ne reconnaît que xscreensaver et gnome-screensaver) et ne permet pas cela.

Dernière modification par The Uploader (Le 22/12/2012, à 23:35)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#6 Le 22/12/2012, à 23:31

Yog Sothoth

Re : Empêcher un tiers d'éteindre ma machine

Merci à vous deux. Vos réponses sont très claires et je vais tester ça dès mon retour. smile


Intel 4770K@4.1 Ghz GTX 560 8Go RAM corsair DDR3. Xubuntu 13.10

Hors ligne

#7 Le 22/12/2012, à 23:50

The Uploader

Re : Empêcher un tiers d'éteindre ma machine

Pour installer xscreensaver au cas où il manquerait :

sudo apt-get install xscreensaver

Sinon, je me corrige : il semblerait que xfce4-power-manager sache reconnaître aussi xlock, xlockmore, et kdescreensaver, mais je ne peux pas le confirmer. On ne peut pas choisir lequel il lancera pour verouiller : je crois qu'il lance le premier qu'il trouve (à moins que ce ne soit un paramètre xfconf qui n'est pas dans l'interface graphique de configuration de XFPM, mais j'ai un gros doute).

C'est vrai que ce serait moins bourrin d'installer juste xlock/xlockmore plutôt qu'un screensaver doublé d'un locker (xscreensaver) même si on peut lui dire d'éviter de lancer une animation pour uniquement éteindre l'écran (ça évitera de ralentir les calculs), en plus de le verrouiller (ce qu'il fait de toutes façons).

Par ailleurs, xscreensaver devrait s'intégrer au gestionnaire de paramètres (élément nommé "Écran de veille") une fois installé.

Dernière modification par The Uploader (Le 22/12/2012, à 23:54)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#8 Le 23/12/2012, à 00:53

VPCL

Re : Empêcher un tiers d'éteindre ma machine

Bonsoir à tous,
une idée qui me vient:obliger l' utilisateur à passer par une console pour éteindre ton ordinateur.Il suffirait d’ôter les boutons de déconnexion présents à l' écran en espérant que le "petit malin" ne sache pas les restaurer.

Bonne soirée,VPCL.

Hors ligne

#9 Le 23/12/2012, à 00:55

The Uploader

Re : Empêcher un tiers d'éteindre ma machine

Un Alt-F4 sur le bureau Xfce les affiche dans une fenêtre, mais il ne le sait pas forcément.


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#10 Le 23/12/2012, à 11:05

Shanx

Re : Empêcher un tiers d'éteindre ma machine

Je pense que la solution xlock est la plus légère et la plus simple à mettre en place. J'ai utilisé ça pendant un certain temps, ça marche bien.

Bon, maintenant j'utilise awesome, y'a pas besoin de verrouiller, personne ne sait l'utiliser. big_smile


« En vérité, je ne voyage pas, moi, pour atteindre un endroit précis, mais pour marcher : simple plaisir de voyager. » R. L. Stevenson
--
Blog et randos

En ligne

#11 Le 23/12/2012, à 13:41

Haleth

Re : Empêcher un tiers d'éteindre ma machine

Et ton petit malin, il peut pas débrancher la prise ?


Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#12 Le 23/12/2012, à 13:53

DAnGk41

Re : Empêcher un tiers d'éteindre ma machine

Haleth a écrit :

Et ton petit malin, il peut pas débrancher la prise ?

Bah ! à mon avis la meilleure chose à faire : surveillance vidéo (genre webcam) pour authentifier le "petit malin" et une bonne paire de baffes (voir plus) pour lui passer l'envie de recommencer... Quelquefois il faut être énergique et ça paie tongue


promis, je vais penser à me moderniser ==> http://i43.servimg.com/u/f43/11/83/24/66/pb090210.jpg

Hors ligne

#13 Le 27/12/2012, à 12:51

Yog Sothoth

Re : Empêcher un tiers d'éteindre ma machine

Bon... xlockmore installé. Mais quand je tape xlock il m'affiche ceci:

xlock: can not find font: -*-helvetica-medium-r-*-*-24-*-*-*-*-*-*, using fixed...
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  131 (DPMS)
  Minor opcode of failed request:  6 (DPMSForceLevel)
  Serial number of failed request:  349
  Current serial number in output stream:  355

Je ne vois pas très bien dans le manuel ce que je pourrais faire. Désactiver tout texte ?


Intel 4770K@4.1 Ghz GTX 560 8Go RAM corsair DDR3. Xubuntu 13.10

Hors ligne

#14 Le 27/12/2012, à 13:26

The Uploader

Re : Empêcher un tiers d'éteindre ma machine

Cela fonctionne-t-il avec xscreensaver installé, configuré pour ne pas afficher d'écran de veille (mais il verrouille l'ordi de toute façon, ce qui exige un mot de passe pour le déverrouiller), et Xfce4-power-manager (le gestionnaire d'alimentation) configuré pour verrouiller l'ordi quand le bouton d'alimentation est utilisé (mais aussi quand l'ordi ne fait rien, etc...) ?

Par ailleurs, tu peux lancer le verrouillage de xscreensaver tout de suite en ligne de commande :

xscreensaver-command -lock

xfce4-power-manager peut aussi être configuré pour ne rien faire quand le bouton d'alimentation est utilisé.

Dernière modification par The Uploader (Le 27/12/2012, à 13:32)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#15 Le 27/12/2012, à 17:58

Yog Sothoth

Re : Empêcher un tiers d'éteindre ma machine

Le problème c'est que le vérrouillage de xscreensaver ne vérrouille pas du tout l'ordinateur comme je l'ai déja indiqué plusieurs fois. wink Il affiche un écran avec plusieurs options dont une est "new login" qui permet de sortir de la session et d'éteindre.

Xscreensaver empêche juste un tiers d'accèder à ta session, pas d'en ouvrir une nouvelle.

Le bouton d'alimentation est déja désactivé. smile


Intel 4770K@4.1 Ghz GTX 560 8Go RAM corsair DDR3. Xubuntu 13.10

Hors ligne

#16 Le 27/12/2012, à 17:59

Haleth

Re : Empêcher un tiers d'éteindre ma machine

Le bouton d'alimentation est déja désactivé.

Et le fil, il est désactivé ?


Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#17 Le 27/12/2012, à 18:08

The Uploader

Re : Empêcher un tiers d'éteindre ma machine

Yog Sothoth a écrit :

Le problème c'est que le vérrouillage de xscreensaver ne vérrouille pas du tout l'ordinateur comme je l'ai déja indiqué plusieurs fois. wink Il affiche un écran avec plusieurs options dont une est "new login" qui permet de sortir de la session et d'éteindre.

Xscreensaver empêche juste un tiers d'accèder à ta session, pas d'en ouvrir une nouvelle.

Le bouton d'alimentation est déja désactivé. smile

Ah, bizarre, j'ai jamais eu ce comportement / cette option. O_o

Tout ce que j'ai jamais eu dans le mode verouillage de xscreensaver, c'est une demande de mot de passe !

Ça se désactive pas dans les options de xscreensaver ?

Yog Sothoth a écrit :

Bon... xlockmore installé. Mais quand je tape xlock il m'affiche ceci:

xlock: can not find font: -*-helvetica-medium-r-*-*-24-*-*-*-*-*-*, using fixed...
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  131 (DPMS)
  Minor opcode of failed request:  6 (DPMSForceLevel)
  Serial number of failed request:  349
  Current serial number in output stream:  355

Je ne vois pas très bien dans le manuel ce que je pourrais faire. Désactiver tout texte ?

Cette recherche me donne surtout des liens vers un bug dans xlock non résolu... Ce sujet avec une erreur similaire en parle aussi mais la solution est de ne pas utiliser le mode "Éteindre l'écran seulement" de xscreensaver (vu qu'il semble utiliser xlock pour le verrouillage), ce qui n'aide pas vraiment...

Dernière modification par The Uploader (Le 27/12/2012, à 18:09)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#18 Le 27/12/2012, à 18:23

Yog Sothoth

Re : Empêcher un tiers d'éteindre ma machine

Merci pour ton attention en tout cas ! Quelque soit le réglage de xscreensaver, si je bouge la souris j'ai le menu "new login". Le bug serait-il résolu sur 12.10 ? Je suis sur 12.04


Intel 4770K@4.1 Ghz GTX 560 8Go RAM corsair DDR3. Xubuntu 13.10

Hors ligne

#19 Le 02/01/2013, à 21:03

The Uploader

Re : Empêcher un tiers d'éteindre ma machine

La FAQ de xscreensaver dit ceci :

FAQ a écrit :

If gdmflexiserver is installed on your system, there should be a "New Login" button on xscreensaver's unlock dialog. If that doesn't appear or doesn't work right, check the setting of the "newLoginCommand" preference in the XScreenSaver.ad app-defaults file.

Si tu vires le paquet auquel appartient le binaire gdmflexiserver, ça devrait enlever le bouton "new login".

Évidemment, cela enlèvera la possibilité d'avoir plusieurs utilisateurs connectés en même temps.

edit : bon sauf que ça fait longtemps que lightdm a remplacé gdm et gdmflexiserver. A vérifier, mais tu ne devrais pas avoir de binaire appelé gdmflexiserver.
D'après ce que je trouve, désactiver le compte "Invité" désactive aussi la possibilité d'avoir plusieurs utilisateurs connectés en même temps (surtout s'il n'y de toutes façons qu'un seul compte utilisateur) :

FAQ Xubuntu 12.04  a écrit :

7. How do I disable guest login? How do I enable autologin?

Edit the file /etc/lightdm/lightdm.conf;

    To disable guest login, set allow-guest to false

http://xubuntu.org/news/faq-1204-precise/

Au pire tu peux remplacer xscreensaver par gnome-screensaver (que xfce4-power-manager reconnaît. C'est ce que j'utilise, j'ai juste eu à désinstaller xscreensaver). Normalement il ne devrait pas donner de bouton "New login", et au pire ça se désactive avec dconf-editor

Dernière modification par The Uploader (Le 02/01/2013, à 21:33)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#20 Le 04/01/2013, à 20:11

freecds

Re : Empêcher un tiers d'éteindre ma machine

VPCL a écrit :

Bonsoir à tous,
une idée qui me vient:obliger l' utilisateur à passer par une console pour éteindre ton ordinateur.Il suffirait d’ôter les boutons de déconnexion présents à l' écran en espérant que le "petit malin" ne sache pas les restaurer.

Tu m'a coupé l'herbe sous le pied : je rajouterais de mettre bien en évidence sur le bureau  un lanceur avec la commande gksu poweroff qui l'incite à éteindre en passant par là.
Il est même possible d'exécuter un script en passant qui prendrait une photo ou une courte capture vidéo via une webcam, mais c'est juste une idée ^^

Sinon,  j'ai Xscreensaver qui me bloque systématiquement  après l'écran de veille, demande un mot de passe et indique même le nombre de tentatives  de login ratées. (Cet écran est très moche et old fashionned mais pour le moins efficace.)
Il y a juste une case à cocher dans  menu xfce > gestionnaire de paramètres > paramètres > économiseur d'écran > mode d'affichage.

Hors ligne

#21 Le 04/01/2013, à 20:16

freecds

Re : Empêcher un tiers d'éteindre ma machine

Oops, je n'avais pas tout lu, pardon.

Je n'ai pas mieux à dire que le dernier post de The Uploader qui devrait marcher je pense.

Hors ligne

#22 Le 04/01/2013, à 20:30

pires57

Re : Empêcher un tiers d'éteindre ma machine

débranche l'écran et planque le câble ?
sinon j'ai peut être une piste, interdire à certains utilisateurs d'arreter le pc en demandant la saisis d'un mot de passe admin


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.

Hors ligne

#23 Le 11/01/2013, à 12:56

The Uploader

Re : Empêcher un tiers d'éteindre ma machine

update : xfce4-power-manager est compatible avec xlockmore, xscreensaver, et gnome-screensaver.

Si ça peut aider...


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#24 Le 11/01/2013, à 21:18

Yog Sothoth

Re : Empêcher un tiers d'éteindre ma machine

Merci. Je crois que le problème est que xlockmore bugge avec ubuntu 12.04. Pour l'instant je me débrouille en débranchant clavier et souris. Ca à l'air de marcher. Pourtant la tour fait du bruit...


Intel 4770K@4.1 Ghz GTX 560 8Go RAM corsair DDR3. Xubuntu 13.10

Hors ligne

#25 Le 11/01/2013, à 21:54

mazarini

Re : Empêcher un tiers d'éteindre ma machine

Un message sur un feuille posée sur le clavier : Merci de ne pas éteindre, calcul en cours
Si c'est par connerie, il pourra toujours l'éteindre en débranchant/enlevant la batterie...

On avait mis longtemps à comprendre que la femme de ménage débranchait notre sps9 pour brancher son aspirateur. Mais elle le rebranchait après. Suffisait de lui expliquer.


Je suis désolé de t'avoir blessé en te traitant de con. Je croyais que tu le savais déjà...

Hors ligne

Haut de page ↑