Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 26/12/2012, à 15:49

Gaara

[résolu] gnome-panel ne se lance pas au démarrage

Bonjour a tous

je suis utilisateur de 12.10 avec gnome-shell, mais pour lancer des jeux, j'aurais besoin d'utiliser gnome classic, moins gourmand en ressources.
Or je suis obligé avec un terminal (ctrl-alt-t) de faire

gnome-panel --replace

pour que tout fonctionne. (barre du haut, applets, racourcis, etc)
Y aurait-il pas une solution pour qu'au démarrage de session, tout se lance automatiquement?
Je précise que dans Application au démarrage, il y a dejà gnome-shell --replace pour lancer gnome-shell, uniquement sur la-dite session.  Ajouter gnome-panel pourrait créer un conflit.

Dernière modification par gaara92 (Le 28/12/2012, à 12:10)


Kubuntu!!
Notification de mises à jour automatiques
Téléchargement des vidéos Pluzz
                                              <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne

#2 Le 26/12/2012, à 18:47

tiramiseb

Re : [résolu] gnome-panel ne se lance pas au démarrage

gnome-panel ne fait plus partie de GNOME 3. Il disparaitra a priori pour la prochaine version de GNOME.
GNOME Shell est son remplaçant.

Si tu souhaites utiliser un environnement ressemblant à GNOME 2, je te conseille de te tourner vers MATE ou Cinnamon.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#3 Le 27/12/2012, à 00:04

Gaara

Re : [résolu] gnome-panel ne se lance pas au démarrage

merci de la réponse, MATE est installé et fonctionne bien.

Mais quel est cet environnement ?

118787Capturedu20121226225657.png


Kubuntu!!
Notification de mises à jour automatiques
Téléchargement des vidéos Pluzz
                                              <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne

#4 Le 27/12/2012, à 00:06

tiramiseb

Re : [résolu] gnome-panel ne se lance pas au démarrage

Je ne comprend pas ta question...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#5 Le 27/12/2012, à 00:37

Gaara

Re : [résolu] gnome-panel ne se lance pas au démarrage

eh bien j'aimerais pouvoir démarrer sur cette version de gnome - qui semble etre la version 3.6 - mais qui n'utilise pas toute la mémoire graphique comme le fait gnome-shell.


Kubuntu!!
Notification de mises à jour automatiques
Téléchargement des vidéos Pluzz
                                              <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne

#6 Le 27/12/2012, à 08:31

tiramiseb

Re : [résolu] gnome-panel ne se lance pas au démarrage

Dans ce cas il faut choisir "GNOME Classic" (je crois) lors de la connexion


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#7 Le 27/12/2012, à 08:35

J5012

Re : [résolu] gnome-panel ne se lance pas au démarrage

gnome-shell --replace pour lancer gnome-shell au demarrage de la session ?
il ya qqchose de bizarre la dedans ! c'est toi qui l'y a mis ? si oui tu t'y prends tres mal ...

Hors ligne

#8 Le 27/12/2012, à 10:49

Gaara

Re : [résolu] gnome-panel ne se lance pas au démarrage

Tout est la mon soucis: j'ai été obligé de rajouter gnome-shell --replace au démarrage de gnome-shell (en modifiant l'autostart) pour avoir l'interface et le coin actif.
Pour gnome classic, l'interface ne se lance pas, j'ai essayé gnome-panel --replace au démarrage, mais rien n'y fait...

voici l'autostart du gnome classic: /home/guillaume/.config/autostart/gnome-panel.desktop


[Desktop Entry]
Comment[fr]=
Comment=
Exec=gnome-panel
Hidden=false
Name[fr]=gnome-panel
Name=gnome-panel
NoDisplay=false
Type=Application
X-GNOME-Autostart-enabled=true
OnlyShowIn=GNOME
AutostartCondition=GNOME3 if-session gnome-fallback

(voir ce fil)


Soit j'ai loupé un truc pour ne pas modifier les applications au démarrage, soit mon autostart du gnome-panel est faux...


Kubuntu!!
Notification de mises à jour automatiques
Téléchargement des vidéos Pluzz
                                              <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne

#9 Le 27/12/2012, à 21:45

J5012

Re : [résolu] gnome-panel ne se lance pas au démarrage

que se passe-t-il quand tu ne mets aucune commande replace ? qu'obtiens-tu ?

au niveau du login de sessions avec lightdm, l'utilisateur choisit d'abord le type de session avant de mettre nom de login et pass
les types de session disponibles dependent des paquets installes :
- session gnome-shell, les paquets gnome-shell sont installes
- session gnome-unity, les paquets unity sont installes
- session gnome classic, les paquets gnome-fallback sont installes

Hors ligne

#10 Le 27/12/2012, à 21:52

J5012

Re : [résolu] gnome-panel ne se lance pas au démarrage

la fonction autostart n'est pas utilisee pour lancer les environnements mais seulement les applications eventuellement residentes de l'utilisateur, ex :
- le presse papiers
- un coffre pour stocker les cles d'autentification
- l'economiseur d'ecran
- l'appliquette son
- l'appliquette reseau
- la gestion de l'alim
- l'ouverture de logiciels bureautique pour pouvoir travailler plus vite

Hors ligne

#11 Le 27/12/2012, à 22:03

Gaara

Re : [résolu] gnome-panel ne se lance pas au démarrage

Sans replace, tout est chargé (gestionnaire de fenetre inclus) mais pas la (les) barre(s) de taches (interface graphique de l'environnement de bureau). Obligé de faire ctrl-alt-t pour avoir un terminal.
Tous les paquets sont installés:

gnome-shell
gnome-panel
gnome-fallback
gnome-session
mutter
compiz
ligthdm

et seulement unity se charge correctement.


edit: oui mais c'est le seul moyen que j'ai trouvé pour charger gnome3, solution de dépannage certes, mais qui me permet de charger gnome-shell sans devoir ouvrir un terminal. pour gnome classic, ça ne marche pas.

Dernière modification par gaara92 (Le 27/12/2012, à 22:05)


Kubuntu!!
Notification de mises à jour automatiques
Téléchargement des vidéos Pluzz
                                              <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne

#12 Le 27/12/2012, à 22:04

tiramiseb

Re : [résolu] gnome-panel ne se lance pas au démarrage

Sans replace, tout est chargé (gestionnaire de fenetre inclus)

Quelle session, quel gestionnaire de fenêtre ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#13 Le 27/12/2012, à 22:10

Gaara

Re : [résolu] gnome-panel ne se lance pas au démarrage

Quelle session, quel gestionnaire de fenêtre ?

pour la session gnome classic. Et mutter je crois, mais je ne suis pas certain.


Kubuntu!!
Notification de mises à jour automatiques
Téléchargement des vidéos Pluzz
                                              <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne

#14 Le 27/12/2012, à 22:17

J5012

Re : [résolu] gnome-panel ne se lance pas au démarrage

es-tu en demarrage de session automatique ?
d'apres ce que tu dis sans le dire, tu n'a pas acces au choix de sessions ?!

- unity se charge completement : tu demarres en session unity
- pour charger uniquement gnome classic : tu dois demarrer en session gnome classic ou fallback

Hors ligne

#15 Le 27/12/2012, à 22:24

Gaara

Re : [résolu] gnome-panel ne se lance pas au démarrage

Je demarre automatiquement avec gnome-shell. Parfois pour lancer certaines applis, j'ai besoin d'avoir un environnement plus léger, gnome-classic par exemple. Je deconnecte et me reconnecte avec le gnome sans effet 3D. C'est là que le bogue apparait.


Kubuntu!!
Notification de mises à jour automatiques
Téléchargement des vidéos Pluzz
                                              <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne

#16 Le 27/12/2012, à 22:53

J5012

Re : [résolu] gnome-panel ne se lance pas au démarrage

peux-tu afficher ici ton autostart et aussi le contenu de : ~/.config/autostart et de : /etc/xdg/autostart

Hors ligne

#17 Le 27/12/2012, à 23:33

Gaara

Re : [résolu] gnome-panel ne se lance pas au démarrage

~/.config/autostart

-rw-rw-r-- 1 guillaume guillaume 179 déc.  13 15:03 amarok.desktop
-rw-rw-r-- 1 guillaume guillaume 241 nov.  12 13:07 blueman.desktop
-rw-rw-r-- 1 guillaume guillaume 467 déc.  11 18:24 bluetooth-applet.desktop
-rw-rw-r-- 1 guillaume guillaume 230 déc.  24 14:56 cairo-dock.desktop
-rw-rw-r-- 1 guillaume guillaume 230 déc.  24 14:55 cairo-dock.desktop~
-rw-rw-r-- 1 guillaume guillaume 399 mai    8  2012 deja-dup-monitor.desktop
-rw-rw-r-- 1 guillaume guillaume 228 déc.  13 15:03 elegance-colors-process.desktop
-rw-rw-r-- 1 guillaume guillaume 164 déc.  12 20:46 empathy.desktop
-rw-rw-r-- 1 guillaume guillaume 278 déc.  27 10:16 gnome-panel.desktop
-rw-rw-r-- 1 guillaume guillaume 239 déc.  24 16:46 gnome-panel.desktop~
-rw-rw-r-- 1 guillaume guillaume 516 déc.  11 18:23 gnome-screensaver.desktop
-rw-rw-r-- 1 guillaume guillaume 274 déc.  27 10:06 gnome-shell.desktop
-rw-rw-r-- 1 guillaume guillaume 204 déc.  24 14:04 gnome-shell.desktop~
-rw-rw-r-- 1 guillaume guillaume 354 déc.  11 18:24 gnome-user-share.desktop
-rw-rw-r-- 1 guillaume guillaume 398 déc.  12 20:46 gwibber.desktop
-rw-rw-r-- 1 guillaume guillaume 182 nov.   9 14:14 Indicator.desktop
-rw-rw-r-- 1 guillaume guillaume   0 déc.  27 22:28 liste.txt
-rw-rw-r-- 1 guillaume guillaume 178 déc.  12 20:46 nemo-autostart.desktop
-rw-rw-r-- 1 guillaume guillaume 316 déc.  12 20:46 orca-autostart.desktop
-rw-rw-r-- 1 guillaume guillaume 188 mai   31  2012 remmina-applet.desktop
-rw-rw-r-- 1 guillaume guillaume 182 déc.  13 15:03 Rhythmbox.desktop
-rw-rw-r-- 1 guillaume guillaume 183 nov.  28 11:10 synaptiks_init_config.desktop
-rw-rw-r-- 1 guillaume guillaume 495 déc.  11 18:24 telepathy-indicator.desktop
-rw-rw-r-- 1 guillaume guillaume 185 déc.  12 20:46 transmission.desktop
-rw-rw-r-- 1 guillaume guillaume 177 déc.  26 14:33 Transmission.desktop
-rw-rw-r-- 1 guillaume guillaume 170 déc.  14 09:20 WallchLiveEarthOnBoot.desktop
-rw-rw-r-- 1 guillaume guillaume 381 déc.  12 20:46 zeitgeist-datahub.desktop

/etc/xdg/autostart:

-rw-r--r-- 1 root root  306 sept. 28 00:26 at-spi-dbus-bus.desktop
-rw-r--r-- 1 root root  422 sept. 28 00:33 bluetooth-applet.desktop
-rw-r--r-- 1 root root  227 sept. 28 00:33 bluetooth-applet-unity.desktop
-rw-r--r-- 1 root root  287 sept.  9 06:06 caribou-autostart.desktop
-rw-r--r-- 1 root root  381 sept. 27 01:00 deja-dup-monitor.desktop
-rw-r--r-- 1 root root  486 sept. 28 21:51 evolution-alarm-notify.desktop
lrwxrwxrwx 1 root root   60 nov.   7 02:40 extras-indicator-stickynotes.desktop -> /usr/share/applications/extras-indicator-stickynotes.desktop
-rwxr-xr-x 1 root root  309 déc.  27 10:26 gnome classic.desktop
-rw-r--r-- 1 root root  369 sept. 29 11:58 gnome-fallback-mount-helper.desktop
-rw-r--r-- 1 root root  464 oct.  24 08:50 gnome-keyring-gpg.desktop
-rw-r--r-- 1 root root  484 oct.  24 08:50 gnome-keyring-pkcs11.desktop
-rw-r--r-- 1 root root  477 oct.  24 08:50 gnome-keyring-secrets.desktop
-rw-r--r-- 1 root root  459 oct.  24 08:50 gnome-keyring-ssh.desktop
-rw-r--r-- 1 root root  522 sept. 28 00:30 gnome-screensaver.desktop
-rw-r--r-- 1 root root  297 sept. 29 11:58 gnome-settings-daemon.desktop
-rw-r--r-- 1 root root  527 oct.   3 22:27 gnome-sound-applet.desktop
-rw-r--r-- 1 root root  309 sept. 28 03:21 gnome-user-share.desktop
-rw-r--r-- 1 root root  279 sept. 17 10:47 gsettings-data-convert.desktop
-rw-r--r-- 1 root root  353 oct.   4 18:24 gwibber.desktop
-rw-r--r-- 1 root root    0 déc.  27 22:30 liste.txt
-rw-r--r-- 1 root root 8643 juil. 15 01:01 mate-at-session.desktop
-rw-r--r-- 1 root root 3482 nov.   4 23:32 mate-bluetooth-applet.desktop
-rw-r--r-- 1 root root  290 juil.  7 01:12 mateconf-gsettings-data-convert.desktop
-rw-r--r-- 1 root root 3249 juil.  9 14:58 mate-keyring-gpg.desktop
-rw-r--r-- 1 root root 5429 juil.  9 14:58 mate-keyring-pkcs11.desktop
-rw-r--r-- 1 root root 5102 juil.  9 14:58 mate-keyring-secrets.desktop
-rw-r--r-- 1 root root 4164 juil.  9 14:58 mate-keyring-ssh.desktop
-rw-r--r-- 1 root root 7114 juil. 16 06:53 mate-power-manager.desktop
-rw-r--r-- 1 root root 7707 juil. 15 21:50 mate-screensaver.desktop
-rw-r--r-- 1 root root 2844 juil. 14 23:37 mate-settings-daemon.desktop
-rw-r--r-- 1 root root  210 oct.   5 19:54 nautilus-autostart.desktop
-rw-r--r-- 1 root root  133 déc.  13 03:26 nemo-autostart.desktop
-rw-r--r-- 1 root root  342 oct.   4 23:22 nm-applet.desktop
-rw-r--r-- 1 root root  294 juin   8  2012 notification-daemon.desktop
-rw-r--r-- 1 root root  244 sept. 19 04:51 onboard-autostart.desktop
-rw-r--r-- 1 root root  311 sept. 28 03:15 orca-autostart.desktop
-rw-r--r-- 1 root root  358 août   8 16:15 polkit-gnome-authentication-agent-1.desktop
-rw-r--r-- 1 root root 4585 juil. 14 04:55 polkit-mate-authentication-agent-1.desktop
-rw-r--r-- 1 root root  390 sept. 28 02:53 print-applet.desktop
-rw-r--r-- 1 root root 3920 oct.   4 18:21 pulseaudio.desktop
-rw-r--r-- 1 root root  633 oct.   4 18:21 pulseaudio-kde.desktop
-rw-r--r-- 1 root root  450 août  27 20:13 telepathy-indicator.desktop
-rw-r--r-- 1 root root  222 oct.   3 22:46 ubuntuone-launch.desktop
-rw-r--r-- 1 root root 8938 oct.  10 00:41 update-notifier.desktop
-rw-r--r-- 1 root root  312 juil. 19 17:13 user-dirs-update-gtk.desktop
-rw-r--r-- 1 root root  372 sept. 28 00:10 vino-server.desktop
-rw-r--r-- 1 root root  336 avril 11  2012 zeitgeist-datahub.desktop

Kubuntu!!
Notification de mises à jour automatiques
Téléchargement des vidéos Pluzz
                                              <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne

#18 Le 28/12/2012, à 06:54

J5012

Re : [résolu] gnome-panel ne se lance pas au démarrage

aie aie aie ...

tu as des appli desktop qui ne devrait pas s'y trouver ... comme je l'ai dit plus haut, il existe d'autres mecanismes que autostart pour lancer differents environnements ...

tu dois d'abord faire le menage :
- supprimer tous les desktop des interfaces gui : gnome panel, mate, gnome classic, gnome-shell
- supprimer tous les gestionnaires de bureau : nautilus, nemo?, mate, cairo-dock

l'environnement gnome-shell et gnome classic installent deja gnome-panel, quand chacun se lance via leur mecanisme de session, les differents composants utiles sont lances aussi ...
l'environnement mate a aussi son mecanisme de session
mais pas cairo-dock que tu dois inscrire dans le mecanisme de session desiree...

pour gnome-shell qui est gnome3, c'est gnome-session
pour gnome classic, c'est gnome-session-fallback

Hors ligne

#19 Le 28/12/2012, à 10:09

tiramiseb

Re : [résolu] gnome-panel ne se lance pas au démarrage

Je pense qu'il ne faut pas supprimer les fichier de /etc/xdg/autostart.
Il me semble que'ils ne sont utilisés que par telle ou telle session.
J'ai pour ma part de nombreux fichiers qui sembleraient en conflit dans ce répertoire mais mon système fonctionne très bien.

Par contre je pense aussi, comme J5012, qu'il faut faire le ménage dans ~/.config/autostart.
Un bon début serait de supprimer l'intégralité des fichiers de ce répertoire (ou de les déplacer ailleurs pour les garder de côté) puis de réessayer.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#20 Le 28/12/2012, à 12:10

Gaara

Re : [résolu] gnome-panel ne se lance pas au démarrage

Merci a vous car le ~/.config/autostart est vide maintenant, et gnome classique se lance très bien (gnome-shell aussi).
Pour la question de némo, il remplace nautilus, que je trouve pas très pratique a l'usage.
Je remet un a un les entrées de mes logiciels et c'est résolu. Merci encore.


Kubuntu!!
Notification de mises à jour automatiques
Téléchargement des vidéos Pluzz
                                              <code>zenity  --question --title "Alert"  --text "Microsoft Windows has been found! Would you like to remove it?"</code>

Hors ligne

Haut de page ↑