Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 26/12/2012, à 15:52

nikoh

probleme de montage de partitions [Résolu]

Bonjour,
je suis tout nouveau sur le forum, et merci pour tout ce que vous faites.
Mais je viens d'installer un nouveau Hdd sur mon ordi portable et j'ai installé en parallèle de windows XP SP2 (pour utiliser les logiciels du boulot) ubuntu 12-10, j'ai fait des partitions sur mon disque afin que les données et autres soient accessibles aussi bien de windows que d'ubuntu, et depuis j'ai le message suivant au demarrage:
"Appuyer sur S pour le montage ou M pour recuperer manuellement..."
j'appuie sur S et après cela marche bien aussi bien du coté de Windows que de celui d'Ubuntu!!!!
J'ai lu plusieurs message autour de ce genre de probleme mais j'ai peur de faire des conneries...
alors voilà j'ai fait quelques commandes terminal et voilà les résultats qui vont peut etre vous aider à comprendre:
sudo fdisk -l

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 têtes, 63 secteurs/piste, 91201 cylindres, total 1465149168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Identifiant de disque : 0xa527a527

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1              63   204796619   102398278+   7  HPFS/NTFS/exFAT
La partition 1 ne débute pas sur une frontière de cylindre physique.
/dev/sda2       204797950  1465147391   630174721    5  Étendue
La partition 2 ne débute pas sur une frontière de cylindre physique.
/dev/sda5      1460977664  1465147391     2084864   82  partition d'échange Linux / Solaris
/dev/sda6   *   204797952   264118264    29660156+  83  Linux
/dev/sda7       264118272   420368383    78125056    7  HPFS/NTFS/exFAT
/dev/sda8       420370432   908650495   244140032    7  HPFS/NTFS/exFAT
/dev/sda9       908652544  1299275775   195311616    7  HPFS/NTFS/exFAT
/dev/sda10     1299277824  1460967423    80844800    7  HPFS/NTFS/exFAT

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

ensuite:
cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
UUID=1bb286c2-571a-4a48-955f-1fa82ecc3ea9 /               ext4    errors=remount-ro 0       1
# /media/Donnees was on /dev/sda7 during installation
UUID=ea0eabff-63a7-4154-840e-27897742e51b /media/Donnees  ext4    defaults        0       2
# /media/Lamotte was on /dev/sda10 during installation
UUID=606701f8-15f2-4109-8586-b9782bf7e652 /media/Lamotte  ext4    defaults        0       2
# /media/Multimedia was on /dev/sda8 during installation
UUID=95446758-dbd7-4c5e-9cb9-d20532a035f3 /media/Multimedia ext4    defaults        0       2
# /media/Prof was on /dev/sda9 during installation
UUID=a6468281-84c3-4a4a-9a23-22f0cbe2d04d /media/Prof     ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=d8e8e143-fff4-4d08-a997-ee134ca22269 none            swap    sw              0       0

et enfin:
sudo blkid
/dev/sda1: UUID="3048F06B48F03168" TYPE="ntfs"
/dev/sda5: UUID="d8e8e143-fff4-4d08-a997-ee134ca22269" TYPE="swap"
/dev/sda6: UUID="1bb286c2-571a-4a48-955f-1fa82ecc3ea9" TYPE="ext4"
/dev/sda7: LABEL="Lamotte" UUID="74DC20B4DC207292" TYPE="ntfs"
/dev/sda8: LABEL="Multimedia" UUID="08807C44807C39F0" TYPE="ntfs"
/dev/sda9: LABEL="Prof" UUID="26384E0B384DDB07" TYPE="ntfs"
/dev/sda10: LABEL="Donnees" UUID="0E9C18709C185515" TYPE="ntfs"

voilà, j’espère que cela vous aidera à comprendre!!!
je vous remercie
nikoh

Dernière modification par nikoh (Le 27/12/2012, à 18:30)

Hors ligne

#2 Le 26/12/2012, à 17:19

ljere

Re : probleme de montage de partitions [Résolu]

bonjour on voit qu'il y a des incohérences entre le fstab et blkid
cette partie est correcte

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# swap was on /dev/sda5 during installation
UUID=d8e8e143-fff4-4d08-a997-ee134ca22269    none            swap    sw              0       0
# / was on /dev/sda6 during installation
UUID=1bb286c2-571a-4a48-955f-1fa82ecc3ea9    /               ext4    errors=remount-ro 0       1

si je veux respecter tes labels sda7 ne peut pas être Données mais Lamotte quand à l'uuid il est aussi incorrect ainsi que le format

# /media/Lamotte was on /dev/sda7 during installation
UUID=74DC20B4DC207292    /media/Lamotte    ntfs    ro,uid=1000,gid=1000        0        2

sda8 est bien Multimédia sda 9 est bien Prof quand à sda10 il devient Données pour l'uuid et le format ils sont tous faux
ce qui donne donc

# /media/Multimedia was on /dev/sda8 during installation
UUID=08807C44807C39F0    /media/Multimedia    ntfs    ro,uid=1000,gid=1000        0        2
# /media/Prof was on /dev/sda9 during installation
UUID=26384E0B384DDB07    /media/Prof    ntfs    ro,uid=1000,gid=1000        0        2
# /media/Donnees was on /dev/sda10 during installation
UUID=0E9C18709C185515    /media/Donnees    ntfs    ro,uid=1000,gid=1000        0        2

Modérateur d'ubuntu-fr.org
amd 3000+, nvidia FX5200 et 2 Go de ram sur voyager 12.04 en 32 bit
Toshiba satellite_c670d-11l sur openbox 14.04 en 64 bit
Mon Blog et Une découverte

En ligne

#3 Le 26/12/2012, à 17:22

ljere

Re : probleme de montage de partitions [Résolu]

ouvrir fstab avec

sudo gedit /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# swap was on /dev/sda5 during installation
UUID=d8e8e143-fff4-4d08-a997-ee134ca22269    none            swap    sw              0       0
# / was on /dev/sda6 during installation
UUID=1bb286c2-571a-4a48-955f-1fa82ecc3ea9    /               ext4    errors=remount-ro 0       1
# /media/Lamotte was on /dev/sda7 during installation
UUID=74DC20B4DC207292    /media/Lamotte    ntfs    ro,uid=1000,gid=1000        0        2
# /media/Multimedia was on /dev/sda8 during installation
UUID=08807C44807C39F0    /media/Multimedia    ntfs    ro,uid=1000,gid=1000        0        2
# /media/Prof was on /dev/sda9 during installation
UUID=26384E0B384DDB07    /media/Prof    ntfs    ro,uid=1000,gid=1000        0        2
# /media/Donnees was on /dev/sda10 during installation
UUID=0E9C18709C185515    /media/Donnees    ntfs    ro,uid=1000,gid=1000        0        2

Modérateur d'ubuntu-fr.org
amd 3000+, nvidia FX5200 et 2 Go de ram sur voyager 12.04 en 32 bit
Toshiba satellite_c670d-11l sur openbox 14.04 en 64 bit
Mon Blog et Une découverte

En ligne

#4 Le 26/12/2012, à 17:24

malbo

Re : probleme de montage de partitions [Résolu]

Je ne vois pas où se trouve ta partition système de Windows XP. Je te prie de répondre à cette demande : http://doc.ubuntu-fr.org/tutoriel/boot-info
Comme ça, j'aurai la réponse et plus encore.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#5 Le 26/12/2012, à 17:38

Maisondouf

Re : probleme de montage de partitions [Résolu]

nikoh a écrit :

j'ai fait des partitions sur mon disque afin que les données et autres soient accessibles aussi bien de windows que d'ubuntu,

C'est là que tu as mal compris...
Si tes partitions sont en NTFS, elles seront accessibles en tant que partition data par les deux OS.
Mais tu ne peux pas les monter dans le fstab de Ubuntu comme des partition ext4 puisqu'elles sont en NTFS.
"blkid" a toujours le dernier mot

nikoh a écrit :

sudo blkid
/dev/sda1: UUID="3048F06B48F03168" TYPE="ntfs"
/dev/sda5: UUID="d8e8e143-fff4-4d08-a997-ee134ca22269" TYPE="swap"
/dev/sda6: UUID="1bb286c2-571a-4a48-955f-1fa82ecc3ea9" TYPE="ext4"
/dev/sda7: LABEL="Lamotte" UUID="74DC20B4DC207292" TYPE="ntfs"
/dev/sda8: LABEL="Multimedia" UUID="08807C44807C39F0" TYPE="ntfs"
/dev/sda9: LABEL="Prof" UUID="26384E0B384DDB07" TYPE="ntfs"
/dev/sda10: LABEL="Donnees" UUID="0E9C18709C185515" TYPE="ntfs"

Donc il y ne faut pas avoir cette ligne dans fstab

UUID=606701f8-15f2-4109-8586-b9782bf7e652 /media/Lamotte  ext4    defaults        0       2

mais plutôt:

UUID=74DC20B4DC207292 /media/Lamotte  ntfs    defaults        0       2

En partant bien sur du fait que le point de montage /media/Lamotte existe...


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#6 Le 27/12/2012, à 13:20

nikoh

Re : probleme de montage de partitions [Résolu]

bonjour à tous,
merci pour toutes ces réponses.
j'ai essayé la procedure demandé par Malbo
en démarrant sur le cd live :
et en tapant la commande:
sudo add-apt-repository ppa:yannubuntu/boot-repair
et il me dit pour add-apt-repository      command not found?
donc je n'ai pas pu continuer...

enfin windows est installé sur:
/dev/sda1: UUID="3048F06B48F03168" TYPE="ntfs"
J'ai fait les partitions d'abord sur ubuntu en ext4 et ensuite je me suis mis sous windows et je les ai transformées en nftfs!!!
cela ne viendrai pas de là??

merci
Nikoh

Hors ligne

#7 Le 27/12/2012, à 13:47

Maisondouf

Re : probleme de montage de partitions [Résolu]

Oui, bien sur, mais c'est le seul moyen pour que Windows les lise.
W$ ne sait pas lire le ext4.
Donc comme je te l'ai dit au post #5 et comme ljere te l'a suggéré plus haut, il faut modifier ton fichier /etc/fstab pour que Linux monte les partitions NTFS.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#8 Le 27/12/2012, à 14:31

men-go

Re : probleme de montage de partitions [Résolu]

Salut,

        Une de mes fstab se présente ainsi:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / 
LABEL=TUB64-UBUNTU				/			ext4    errors=remount-ro	0       1
# swap 
LABEL=CRIOS-SWAP 				none			swap    sw			0       0
# /home  
LABEL=TUB64-home				/home			ext4    rw,nosuid,nodev,uhelper=hal	0       0
# /usr/local
/home/USR_local.fsloop				/usr/local		ext2    rw,loop				0       0

# RHEA 
LABEL=RHEA-DATA					/media/RHEA-DATA	ext4    rw,nosuid,nodev,uhelper=hal	0       0
LABEL=RHEA-home					/media/RHEA-home	ext4    rw,nosuid,nodev,uhelper=hal	0       0
LABEL=RHEA-UBUNTU				/media/RHEA-UBUNTU	ext4	rw,nosuid,nodev,uhelper=hal	0       0

# CRIOS
LABEL=CRIOS-DATA				/media/CRIOS-DATA	ext4    rw,nosuid,nodev,uhelper=hal	0       0
LABEL=CRIOS-home				/media/CRIOS-home	ext4    rw,nosuid,nodev,uhelper=hal	0       0
LABEL=CRIOS-UBUNTU				/media/CRIOS-UBUNTU	ext4	rw,nosuid,nodev,uhelper=hal	0       0

# RAM fs
/dev/ram0					/media/RAM		ramfs	rw				0	0
#
# GAIA: Sauvegardes, Bibliothèques 
LABEL=GAIA					/media/GAIA	ntfs-3g rw,nosuid,nodev,allow_other    0       0
#

      Maintenant tu peux toujours continuer à utiliser les UUID, mais sache que juste avant que le message "Appuyer sur S pour le montage ou M pour recuperer manuellement..." soit affiché, il est affiché soit l'UUID soit le label en fonction de ce qui a été paramétré dans fstab. En plus si dans la fstab, on met des labels elle sera valable quelque soit l'UUID de la partition.

      Gparted est capable de créer des partitions NTFS, il était inutile d'aller sur Windows. Ceci étant, le fait de reformater une partition change son UUID. Mais si tu avais spécifié des labels dans fstab, le changement d'UUID n'aurait eu aucune incidence.

Hors ligne

#9 Le 27/12/2012, à 14:51

ljere

Re : probleme de montage de partitions [Résolu]

je vois bien l’intérêt de m’être embêter à te refaire ton fstab si tu ne l'essaye même pas roll


Modérateur d'ubuntu-fr.org
amd 3000+, nvidia FX5200 et 2 Go de ram sur voyager 12.04 en 32 bit
Toshiba satellite_c670d-11l sur openbox 14.04 en 64 bit
Mon Blog et Une découverte

En ligne

#10 Le 27/12/2012, à 16:44

nikoh

Re : probleme de montage de partitions [Résolu]

salut,
ça y est!!! ça a marché de changer le fstab!!!!
le problème pour cette partition a disparu
Il faut que je fasse la même pour les 3 autres!!!
donc:
# /media/Donnees was on /dev/sda7 during installation
UUID=ea0eabff-63a7-4154-840e-27897742e51b /media/Donnees  ext4    defaults        0       2

remplacé par:
/dev/sda10: LABEL="Donnees" UUID="0E9C18709C185515" TYPE="ntfs"

# /media/Multimedia was on /dev/sda8 during installation
UUID=95446758-dbd7-4c5e-9cb9-d20532a035f3 /media/Multimedia ext4    defaults        0       2

remplacé par: /dev/sda8: LABEL="Multimedia" UUID="08807C44807C39F0" TYPE="ntfs"

# /media/Prof was on /dev/sda9 during installation
UUID=a6468281-84c3-4a4a-9a23-22f0cbe2d04d /media/Prof     ext4    defaults        0       2

remplacé par:
/dev/sda9: LABEL="Prof" UUID="26384E0B384DDB07" TYPE="ntfs"

c'est bien ça?????
Il faut dire que je ne comprend pas tout quand vous me répondez
mais là je crois que j'ai capter un truc!!!
merci

Hors ligne

#11 Le 27/12/2012, à 16:50

ljere

Re : probleme de montage de partitions [Résolu]

oui c'est bien ça, mais bon je ne comprend pas trop pourquoi? tu t'obstines à le faire toi même alors que je te l'ai déjà rempli dans mes premiers post

Dernière modification par ljere (Le 27/12/2012, à 16:54)


Modérateur d'ubuntu-fr.org
amd 3000+, nvidia FX5200 et 2 Go de ram sur voyager 12.04 en 32 bit
Toshiba satellite_c670d-11l sur openbox 14.04 en 64 bit
Mon Blog et Une découverte

En ligne

#12 Le 27/12/2012, à 16:56

Maisondouf

Re : probleme de montage de partitions [Résolu]

@ljere: oui mais ça lui permet de comprendre ....


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#13 Le 27/12/2012, à 17:40

nikoh

Re : probleme de montage de partitions [Résolu]

merci les gars
avec le copier coller ça va beaucoup plus vite!!
n'est ce pas ljere!!!
je n'avais pas compris au moment où tu m'as envoyer le message #3
Plus de probleme au démarrage!!!
deux dernières questions:
- quelle est la différence avec le fstab et le blkid???
- où faut il mettre que le problème est résolu??
merci
Nikoh

Hors ligne

#14 Le 27/12/2012, à 17:52

ljere

Re : probleme de montage de partitions [Résolu]

fstab est un fichier qui contient les points de montage pour chacun des systèmes de fichiers utilisés couramment sur le système
alors que blkid est un utilitaire en ligne de commande pour trouver ou afficher les attributs de tes partitions
pour passer ton post en résolu tu modifies ton premier message et tu ajoutes [Résolu]


Modérateur d'ubuntu-fr.org
amd 3000+, nvidia FX5200 et 2 Go de ram sur voyager 12.04 en 32 bit
Toshiba satellite_c670d-11l sur openbox 14.04 en 64 bit
Mon Blog et Une découverte

En ligne

Haut de page ↑