Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 27/12/2012, à 17:29

cepamoi

Détection automatique d'une clé TNT

Bonjour,

J'ai une clé TNT Hauppauge WinTV MiniStick HD. Elle fonctionne bien sous Kubuntu 12.04 64 bits.

Elle est branchée en permanence sur mon PC. Mais depuis quelques temps, la clé n'est plus reconnue au démarrage. Je suis obligé de la débrancher et de la rebrancher pour qu'elle soit reconnue. Je ne saurais pas dire depuis combien de temps le problème est apparu, car je ne me sers que très ponctuellement de la clé.

Au démarrage, la clé semble bien trouvée. En effet, si on je tape :

lsusb | grep Hauppauge

J'obtiens :

Bus 002 Device 005: ID 2040:c000 Hauppauge Windham

Par contre :

dmesg | grep dvb

ne retourne rien.

Si je débranche et de la rebranche la clé, alors dmesg | grep dvb
retourne :

[  856.361249] smscore_set_device_mode: firmware download success: sms1xxx-hcw-55xxx-dvbt-02.fw

Et là, tout marche correctement.

Franchement, c'est assez pénible de devoir débrancher et rebrancher la clé pour qu'elle fonctionne.

Une idée d'où vient le problème ?

Merci d'avance.

Hors ligne

#2 Le 27/12/2012, à 17:32

Korak

Re : Détection automatique d'une clé TNT

Bonjour,

Je ne vais pas pouvoir t'aider mais te donner un conseil:

cepamoi a écrit :

je ne me sers que très ponctuellement de la clé.

Puisque tu ne t'en sert que rarement, branche cette clé uniquement quand tu en as besoin.


OS: Ubuntu 12.04.3 64 bits + Windows 8 64 bits en dualboot
PC portable: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#3 Le 27/12/2012, à 19:42

cepamoi

Re : Détection automatique d'une clé TNT

Bonjour,

Korak a écrit :

Puisque tu ne t'en sert que rarement, branche cette clé uniquement quand tu en as besoin.

Non, désolé. La clé est branchée derrière le PC qui est par terre sous le bureau. Il est donc très peu pratique de débrancher et de brancher la clé.

Quelqu'un a-t-il une idée d'où vient le problème ?

Hors ligne

#4 Le 27/12/2012, à 20:02

Korak

Re : Détection automatique d'une clé TNT

cepamoi a écrit :

La clé est branchée derrière le PC qui est par terre sous le bureau.

Effectivement, dans ce cas il n'est pas très pratique de la brancher/débrancher.

Un HUB USB alimenté par transfo sur le bureau peut-être.....

Plus sérieusement, as-tu fait toutes les mises-à-jour de ton Kubuntu?


OS: Ubuntu 12.04.3 64 bits + Windows 8 64 bits en dualboot
PC portable: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#5 Le 27/12/2012, à 22:58

cepamoi

Re : Détection automatique d'une clé TNT

Korak a écrit :

Plus sérieusement, as-tu fait toutes les mises-à-jour de ton Kubuntu?

Oui, je fais régulièrement les mises à jour. D'ailleurs, peut-être est-ce une mise à jour qui a provoqué le problème ?

Hors ligne

#6 Le 27/12/2012, à 23:11

Korak

Re : Détection automatique d'une clé TNT

Ben là, je ne sais pas.

As-tu installé un logiciel pour cette carte "à la main"?


OS: Ubuntu 12.04.3 64 bits + Windows 8 64 bits en dualboot
PC portable: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#7 Le 28/12/2012, à 00:23

cepamoi

Re : Détection automatique d'une clé TNT

Korak a écrit :

As-tu installé un logiciel pour cette carte "à la main"?

Non, j'ai simplement suivi la documentation dans wintv_hd.
J'ai donc installé le paquet "linux-firmware-nonfree" et la carte a été reconnue immédiatement.

A tout hasard, j'ai essayé de désinstaller et de réinstaller la paquet en question, mais ça n'a rien changé.

Hors ligne

#8 Le 01/01/2013, à 20:46

cepamoi

Re : Détection automatique d'une clé TNT

En regardant dans le log du kernel, j'ai ceci qui me parait suspect :

Jan  1 19:27:41 kobaia kernel: [   14.997334] smscore_detect_mode: line: 754: MSG_SMS_GET_VERSION_EX_REQ failed first try
Jan  1 19:27:46 kobaia kernel: [   19.982897] smscore_set_device_mode: line: 828: mode detect failed -62
Jan  1 19:27:46 kobaia kernel: [   19.982952] smsusb_init_device: line: 382: smscore_start_device(...) failed
Jan  1 19:27:46 kobaia kernel: [   19.983110] smsusb_onresponse: line: 118: error, urb status -2, 0 bytes
Jan  1 19:27:46 kobaia kernel: [   19.983353] smsusb_onresponse: line: 118: error, urb status -2, 0 bytes
Jan  1 19:27:46 kobaia kernel: [   19.983601] smsusb_onresponse: line: 118: error, urb status -2, 0 bytes
Jan  1 19:27:46 kobaia kernel: [   19.983849] smsusb_onresponse: line: 118: error, urb status -2, 0 bytes
Jan  1 19:27:46 kobaia kernel: [   19.984102] smsusb_onresponse: line: 118: error, urb status -2, 0 bytes
Jan  1 19:27:46 kobaia kernel: [   19.984350] smsusb_onresponse: line: 118: error, urb status -2, 0 bytes
Jan  1 19:27:46 kobaia kernel: [   19.984602] smsusb_onresponse: line: 118: error, urb status -2, 0 bytes
Jan  1 19:27:46 kobaia kernel: [   19.984817] smsusb_onresponse: line: 118: error, urb status -2, 0 bytes
Jan  1 19:27:46 kobaia kernel: [   19.984919] smsusb_onresponse: line: 118: error, urb status -2, 0 bytes
Jan  1 19:27:46 kobaia kernel: [   19.985066] smsusb_onresponse: line: 118: error, urb status -2, 0 bytes
Jan  1 19:27:46 kobaia kernel: [   19.985131] sms_ir_exit: 
Jan  1 19:27:46 kobaia kernel: [   19.987383] smsusb: probe of 2-1.5:1.0 failed with error -62
Jan  1 19:27:46 kobaia kernel: [   19.987398] usbcore: registered new interface driver smsusb

Si je boote sans la clé TNT, je n'ai pas tous ces messages.

Quelqu'un aurait-il une idée ?

Hors ligne

Haut de page ↑