Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 27/12/2012, à 11:23

ChubiChuba

squid avec authentification via Active directory

Bonjour,

Je suis en entreprise et je dois installé un squid avec authentification avec active directory et j'ai suivi ce tuto.
Ensuite tout c'est bien passé mais lorsque je veux surfer sur internet via le proxy il me demande un login et un MDP cela est normal.
Je rentre mon login utilisateur et mon mot de passe utilisateur mais il ne le reconnait pas. Il ne reconnait que l'administrateur réseau et non pas les utilisateurs du réseau.

Hors ligne

#2 Le 27/12/2012, à 15:42

Maisondouf

Re : squid avec authentification via Active directory

Ça vient peut-être de l'appartenance ou pas des utilisateurs au groupe géré par squid.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 27/12/2012, à 16:15

ChubiChuba

Re : squid avec authentification via Active directory

Le serveur est bien dans le domaine j'ai fais la commande sudo /usr/bin/ntlm_auth --helper-protocol=squid-2.5-basic pour verifier que je suis bien dedans il me retourne OK.
Quand je lance webmin et que je vais sur Squid pour regarder proxy authentification il n'y a aucun user alors qu'il est censé prendre les utilisateurs du fichier
--helper-protocol=squid-2.5-basic. En ACL, j'ai applique 192.168.2.0/24 pour qu'il prenne en compte tout le reseau. Je ne sais pas si cela a une incidence sur le serveur.

Hors ligne

#4 Le 27/12/2012, à 16:21

Maisondouf

Re : squid avec authentification via Active directory

je parlais d'un groupe sur le PC comme 'winbind' ou 'windbind_perso'
fait un

cat /etc/group

pour voir les groupes déclarés par squid, samba et windbind, mais c'est peut-être une fausse piste

tu dis:  Il ne reconnait que l'administrateur réseau et non pas les utilisateurs du réseau.
Il s'agit d'utilisateur déclarés où ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#5 Le 28/12/2012, à 11:06

ChubiChuba

Re : squid avec authentification via Active directory

Quand il s'agit d'utilisateur déclarés c'est à dire qu'ils sont reconnus dans le samba. Je pense que la commande cat/etc/group marche et je n'ai rien au niveau des utilisateurs et des groupes.
Pourtant quand j'utilise la commadne wbinfo -u ou wbinfo -g je vois ce qu'il y a dans l'AD. Mais le serveur Squid ne prend pas les utilisateurs present dans l'AD pour les authentifier.

Hors ligne

#6 Le 31/07/2014, à 13:15

tsioritafita

Re : squid avec authentification via Active directory

Est-ce que le problème est résolu parce que moi aussi j'ai rencontré ce type d'erreur.

Hors ligne

Haut de page ↑