Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 27/12/2012, à 18:49

JNic

[RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Bonjour, bonjour.

Voici le topo:

Insatisfait de la version 12.10 que j'ai galéré à installer sur un Asus Eee Pc (problème de grub résolu grâce à Maisondouf: http://forum.ubuntu-fr.org/viewtopic.ph … #p11965481), j'ai voulu passé à la version précédente 12.04.1 64bits. Et oui, les cartes graphique ATI....

Bref, j'ai un nouveau problème de bootloader. Sensiblement différent cette fois-ci. Je maitrise pas vraiment la chose je dois dire.

Le pc est vierge de tout OS. J'ai installé Ubuntu 12.04.1 64bits via un live USB. J'ai pour cela créé manuellement les partitions suivantes:
- Swap
- EFI
- Principale
- Boot (là j'étais pas sûr de moi)

Le bios est de type EFI.

L'installation s'est déroulée sans encombre à première vue, sauf qu'au démarrage j'ai un joli écran noir avec écris:

file system unknown: 
grub rescue

Les seules infos que je trouve sur le net ont lien avec un dual boot windows. Ce qui n'est pas mon cas. J'ai tenté un boot-repair. Voici le lien du log file:

http://paste.ubuntu.com/1470192/

Il ne m'est pas d'une grande utilité car il n'indique visiblement pas d'erreur (selon mes connaissances succinctes). La tentative de réparation me donne un message d'erreur: pas de partition Bios/boot.

Si parmi vous quelqu'un a une idée pour me dépanner...

Merci par avance!





EDIT: Solution trouvée

Récapitulatif du problème:

Difficultés à installer correctement Ubuntu 12.04.1 64Bits sur ASUS EEE Pc 1215B en mode EFI. Malgré un partitionnement minutieux en manuel via GParted en suivant les conseils de Malbo ici http://forum.ubuntu-fr.org/viewtopic.php?id=757311, l'installation plantait systématiquement au moment d'installer le grub.

Solution trouvée:

J'ai finalement réglé le problème en installant en mode classique en suivant la procédure suivante:
* Booter le liveUSB en mode Legacy: dans le bios, sélectionner dans l'onglet "boot" le mode legacy en suivant les exemples donnés ici http://forum.ubuntu-fr.org/viewtopic.ph … #p11507071.
* Lancer "Essayer Ubuntu"
* A l'aide de GParted partitionner le disque comme suit (pour plus de détails: http://doc.ubuntu-fr.org/tutoriel/parti … eur_ubuntu):
      - Créer une nouvelle table (Attention ceci efface toutes données) en conservant le choix par défaut MSDOS.
      - 1 partition de type ext4 d'une taille d'environ 100Mo avec le drapeau boot
      - 1 partition de type swap
      - 1 partition de type ext4 (servira à accueillir le home)
* Lancer l'installation d'Ubuntu via l'icône disponible
* Choisir la gestion manuelle du partitionnement et modifier la seconde partition ext4 (Racine) en prenant soin de:

Malbo a écrit :

Il faut la sélectionner et cliquer sur le bouton "modifier" puis faire les réglages suivants
- utiliser comme : sélectionner "système de fichiers journalisés ext4"
- cochez "formater la partition"
- point de montage : sélectionner "/"(qui veut dire qu'on prend cette partition pour partition racine)

Et voilà...

Une dernière chose, le liveUSB doit être monté sur une clé formatée en fat16 maximum (pas fat32) pour pouvoir être bootée en mode legacy avec ce PC. Cette opération est faisable via GParted.

ju

Dernière modification par JNic (Le 30/12/2012, à 19:03)

Hors ligne

#2 Le 27/12/2012, à 18:56

sinbad83

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Salut,
tu devrais regarder la doc Ubuntu sur le sujet (http://doc.ubuntu-fr.org/efi), l'EFI est un peu spécial...

Dernière modification par sinbad83 (Le 27/12/2012, à 19:06)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop Quad8800 Ubuntu 14.04.1 et Seven,  Samsung N150 U14.04.1 et Seven, HP Pavillon G6 U14.04.1 et Seven, Serveurs Ubuntu 14.04.1, Serveur virtualisation Proxmox

Hors ligne

#3 Le 27/12/2012, à 19:23

JNic

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

ok, merci sinbad83.

Je n'arrive pas à voir ce que j'ai fait de travers. J'ai bien installé la version officielle internationnale, et donc compatible efi. J'ai créé une partition efi en suivant justement les conseils de cette page...

J'ai déjà installé il n'y a pas longtemps la version 12.10 sans avoir été confronté à ce problème. Pour info je n'ai pas de secureboot et je n'ai vu nulle part l'option fastboot (pourtant présent sur les eee pc) dans les paramètre du bios.

Qu'est-ce que tu me conseilles de faire? Réinstaller sans se soucier du efi?

Ju

Hors ligne

#4 Le 27/12/2012, à 20:10

sinbad83

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Désolé, je n'y connais rien en EFI. As-tu utilisé le CD Secure-Remix ? Je suppose qu'il suffit de suivre la doc...


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop Quad8800 Ubuntu 14.04.1 et Seven,  Samsung N150 U14.04.1 et Seven, HP Pavillon G6 U14.04.1 et Seven, Serveurs Ubuntu 14.04.1, Serveur virtualisation Proxmox

Hors ligne

#5 Le 28/12/2012, à 07:39

malbo

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Je te conseille de tout réinstaller en n'utilisant pas de partition /boot
Fais bien attention de vérifier (dans le Bios) que tu vas démarrer en mode EFI sur ta liveUSB pour faire l'installation : http://doc.ubuntu-fr.org/efi#identifier … n_mode_efi
Sinon, tu vas faire une installation bâtarde.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#6 Le 28/12/2012, à 15:18

JNic

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Merci Malbo de t'intéresser à mon problème.

J'ai suivi ton conseil et réinstallé le system en m'assurant que je bootais bien en mode efi avec le live usb. Je n'ai pas créé de partition /boot cette fois-ci.

L'installation ne s'est pas bien déroulée. En toute fin un écran noir est apparu avec une seccession de ligne de code. J'ai fait une photo mais je n'ai pas pour le moment les moyens de l'uploader. Voici un extrait:

[  996.168018]  [<fffffff81661ec2>] ? system_call_fastpath+0x16/0x1b

Le system plante sur cette page (la ligne ci-dessus n'est pas la dernière). J'ai du (au bout de 30 min) forcer le redémarrage du system.

Maintenant j'ai au démarrage un nouveau message d'erreur lié au grub:

file ************.mod not present
grub rescue

Quelque chose dans ce gout là. J'ai donc tenté un boot-repair avec le live usb. Comme d'habitude j'ai le même message d'erreur: "GPT detected. Please create a BIOS-Boot partition"

Voici le lien du log file:
http://paste.ubuntu.com/1472439/

Je suis quelqu'un de très patient, mais j'avoue là que je commence à saturer. Je vais peut-être me résigner à réinstaller la version 12.10, et tant pis si la carte graphique n'est pas reconnue.

Ju

Hors ligne

#7 Le 28/12/2012, à 16:43

malbo

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Extrait du Boot-Info du post #1 :

============================= Boot Info Summary: ===============================

 => Grub2 (v2.00) is installed in the MBR of /dev/sda and looks at sector 
    616269904 of the same hard drive for core.img. core.img is at this 
    location and looks in partition 1 for (,gpt2)/boot/grub.

Extrait du Boot-Info du post #6 :

============================ Boot Info Summary: ===============================

 => Grub2 (v2.00) is installed in the MBR of /dev/sda and looks at sector 
    616269904 of the same hard drive for core.img. core.img is at this 
    location and looks in partition 1 for (,gpt2)/boot/grub.

Ce chargeur d'amorçage de Grub 2 n'a rien à faire là. Avec Gparted, je te prie de supprimer la totalité des partitions et de créer une nouvelle table de partition en GPT afin que ce chargeur d'amorçage n'existe plus. Il faut absolument qu'au prochain Boot-Info que tu feras, on voit à cet endroit :

============================= Boot Info Summary: ===============================

 => No boot loader is installed in the MBR of /dev/sda.

Important : si après cela et après réinstallation de Ubuntu ça continue à ne pas marcher, ne fais pas la "Réparation recommandée" de Boot-Repair mais fais seulement un rapport Boot-Info et poste-le ici . Motif : Dans certains cas, la "Réparation recommandée" pourrait être inadaptée, c'est pourquoi il vaut mieux faire le Boot-Info parce que ce dernier présente la réparation qu'il propose et ainsi on peut contrôler que c'est correct ou pas. Par exemple dans le Boot-Info du post #6, tu peux lire tout à la fin :

=================== Default settings
Recommended-Repair
This setting would purge (in order to fix packages) and reinstall the grub2 of sda2 into the MBR of sda.
Additional repair would be performed: unhide-bootmenu-10s

Cela signifie que si tu faisais une nouvelle "Réparation recommandée", Boot-Repair réinstallerait un chargeur d'amorçage de Grub dans le MBR du disque dur et ce n'est pas du tout ce qu'il faut dans ton cas : c'est dans ta partition EFI qu'il doit y avoir un chargeur d'amorçage (un fichier .efi) pas dans le MBR du disque dur.

Dernière modification par malbo (Le 28/12/2012, à 16:53)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#8 Le 28/12/2012, à 18:36

JNic

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

OK, merci beaucoup. Je vais faire ça de suite.

Est-ce que tu pourrais me confirmer cette table:
1/ EFI (environ 150 Mo, sans point de montage spécifié, type efi)
2/ Swap (4000 Mo - 3Go de ram sur le pc en question, pas de point de montage)
3/ Principale (type: ext4, monté sur /)

Une dernière chose. J'ai jusqu'à présent créé manuellement mes tables uniquement à partir du gestionnaire proposé en début d'installation. Je n'ai pas souvenir d'y avoir vu l'option GPT ou MBR. Dois-je passer par Gparted via un autre moyen, est-ce automatique (j'en doute mais bon) ou suis-je passé à côté de quelque chose?

En tout cas je te remercie vivement. Même si mon problème n'est pas résolu, je progresse et je comprends mieux la chose. Et c'est déjà pas mal!

Ju

Hors ligne

#9 Le 28/12/2012, à 19:13

malbo

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Tes 3 points sont corrects.
Je te suggère de préparer toutes les partitions avec Gparted en t'inspirant de ce Tuto : http://forum.ubuntu-fr.org/viewtopic.php?id=757311
Puis de faire l'installation, à priori en continuant à t'inspirer du Tuto notamment pour ce qui concerne la partition EFI.

Edit : moi, j'avais utilisé le liveCD Gparted (à l'époque où j'ai écrit le tuto, j'avais eu quelques soucis) mais à mon avis,aujourd'hui tu peux tout faire avec le support d'installation de Ubuntu puisqu'il contient Gparted

Dernière modification par malbo (Le 28/12/2012, à 19:17)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#10 Le 28/12/2012, à 19:25

JNic

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

OK, parfait.

Pour être tout à fait honnête, je m'étais arrêter à : "Ce tuto est obsolète pour Ubuntu 12.04" smile

Je viens de le parcourir en entier. Je vais m'y atteler dans ce cas.

Ju

Hors ligne

#11 Le 28/12/2012, à 21:34

JNic

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Bon bon...

Je passe à côté de quelque chose. J'ai suivi à la lettre tes conseils tirés d'ici http://forum.ubuntu-fr.org/viewtopic.php?id=757311. L'installation s'est mieux déroulée (pas de freeze à la fin de l'installation). Cette fois-ci cependant j'ai obtenu le message d'erreur suivant (à peu près): Impossible d'installer grub-efi..

Au redémarrage j'ai de nouveau:

file system unknown: 
grub rescue

De plus, j'ai exactement le même entête pour le log de boot-repair qu'auparavant... Cette fois-ci j'ai pris soin de ne pas lancer la réparation automatique:

http://paste.ubuntu.com/1473790/

Pas facile. C'est une belle mer*e ce mode EFi..

Ju

Hors ligne

#12 Le 29/12/2012, à 07:18

malbo

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

JNic a écrit :

j'ai exactement le même entête pour le log de boot-repair qu'auparavant...

Je pense que c'est parce que j'ai oublié de te le redire ou bien que tu n'as pas compris l'importance de cette étape mais je pense que tu n'as pas fait ce que j'avais écrit plus haut : "Avec Gparted, je te prie de supprimer la totalité des partitions et de créer une nouvelle table de partition en GPT afin que ce chargeur d'amorçage n'existe plus".
Je suis convaincu que tu n'as pas su faire l'action de création de la nouvelle table de partition telle qu'elle est décrite là : http://gparted.sourceforge.net/display- … tion-table
Il faudra donc que tu repartes encore à zéro en faisant bien cette opération et sans oublier ce qui est décrit dans l'item 3 "Si vous voulez une table de partitions autre que MSDOS, cliquez sur le bouton « Avancé » et sélectionnez un type de table de partitions dans la liste." sinon par défaut, Gparted créera une table de partition MSDOS. Toi, il faut que tu sélectionnes GPT.
Tu verras un AVERTISSEMENT : ceci va SUPPRIMER TOUTES LES DONNÉES sur l'ENSEMBLE DU DISQUE. C'est très bon signe et il faudra que tu valides cette action.
Cette fois, au lieu de tout faire et de démouler à la fin, façon tarte tatin, je te suggère la procédure suivante : après avoir créé la nouvelle table de partitions et créé tes partitions, faire un Boot-Info pour vérifier que l'entête indésirable a disparu. Si tu constates qu'elle a bien disparu, tu peux faire l'installation sinon ce n'est pas la peine.

Dernière modification par malbo (Le 29/12/2012, à 07:25)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#13 Le 29/12/2012, à 11:44

sinbad83

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Salut,
on n'est pas obligé de passer par le BootInfoScript, il suffit de faire Gparted->Affichage->Informations sur le périphérique. On voit tout de suite le type de table de partitions du disque.


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop Quad8800 Ubuntu 14.04.1 et Seven,  Samsung N150 U14.04.1 et Seven, HP Pavillon G6 U14.04.1 et Seven, Serveurs Ubuntu 14.04.1, Serveur virtualisation Proxmox

Hors ligne

#14 Le 29/12/2012, à 12:35

JNic

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Bonjour,

Malbo, tu as raison. J'ai bien noté ta remarque sur la nécessité de créer un partition en GPT, mais je ne voyais pas où le faire. Le tuto sur GParted est clair. Je pense que tu as mis le doigt sur ce qui m'avais échappé. Je vais refaire l'installation propre pas à pas depuis le début. J'ai bon espoir de réussir cette fois-ci! big_smile

Ju

Hors ligne

#15 Le 29/12/2012, à 17:32

JNic

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Bon. C'est pas encore ça.

J'ai retenté à deux reprises aujourd'hui l'installation en m'assurant que les tables de partitions étaient correctement configurées (surtout en GPT via Gparted). J'ai fait une tentative avec le liveUSB que j'avais déjà, et une autre avec le même ISO mais monté avec un autre soft (tuxboot), parce qu'on sait jamais...

Dans les deux cas, l'installation plante juste après l'installation de grub2. Plus précisément au moment où il fait "dummy grub installation". Une fenêtre noire s'ouvre, avec les lignes de codes dont j'ai déjà parlé plus haut.

Une amélioration cependant. Maintenant mon boot-info m'indique:

No boot loader is installed in the MBR of /dev/sda.

http://paste.ubuntu.com/1475279/

J'avais exactement le même problème lorsque j'ai voulu installé la version 12.10. J'avais créé le topic suivant:
http://forum.ubuntu-fr.org/viewtopic.ph … #p11969211

Résolu en montant la partition ext4 primaire et en installant manuellement le grub de cette façon:

sudo grub-install --root-directory=/mnt /dev/sda

J'ai essayé cette méthode à nouveau. J'obtiens tout comme la fois précédente un message d'erreur:

ubuntu@ubuntu:~$ sudo grub-install --root-directory=/mnt /dev/sda
/usr/sbin/grub-bios-setup: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
/usr/sbin/grub-bios-setup: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
/usr/sbin/grub-bios-setup: error: will not proceed with blocklists.

La fois précédente, lors du reboot j'obtenais le grub en appuyant à plusieurs reprises sur supr. au démarrage (technique de sioux). Mais pas cette fois-ci.

Je me demande si finalement ça vaut le coup de s'emm**der avec ce mode EFI. Après tout je n'ai pas de dual boot windows quelqu'il soit, ni de disque dur dépassant les 2,2To, ni un partitionnage supérieur à 4... Qu'est-ce que vous en pensez? j'ai déjà commencé à me renseigner sur une telle alternative.

Ju

Hors ligne

#16 Le 29/12/2012, à 17:57

malbo

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

On peut très bien vivre en installant Windows 8 en mode Bios et Ubuntu en mode Bios dans un ordi qui a été livré pré-installé Windows 8 en mode EFI. Il faut seulement tout réinstaller de fond en comble avec création d'une table de partitions MSDOS au lieu de GPT.
Je me suis même fendu de ce tuto pour aider les possesseurs de machine Asus à le faire : http://forum.ubuntu-fr.org/viewtopic.ph … #p11507071
A plus forte raison, quand on ne veut pas de Windows 8 dans l'ordi mais seulement Ubuntu, c'est sans regret pour passer en MSDOS.

Dernière modification par malbo (Le 29/12/2012, à 18:04)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#17 Le 30/12/2012, à 18:08

JNic

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

C'est bon, j'ai finis par réussir l'installation. big_smile

Merci à vous deux pour toute l'aide apportée. J'ai édité mon premier poste ainsi que l'intitulé pour plus de précisions.

En résumer, j'ai réussi à booter le live USB en mode legacy. Le bios installé sur ce PC est plus ancien que ceux montrés dans ton lien Malbo et il est encore moins explicite...  J'ai juste eu à formater ma clé USB en fat16 au lieu de fat32 car pas accepté lors du boot. Mise à part ça (et une lenteur impressionnante) l'installation s'est passée comme un charme et le PC boot normalement sur Ubuntu.

Pff... J'ai jamais autant galéré que sur ce problème de EFI. ça m'ennuie un peu d'avoir dû contourner le problème. Finalement je ne saurais peut-être jamais ce qui coinçait!

Merci encore!

Ciao

Ju

Hors ligne

#18 Le 01/11/2013, à 12:31

capaalek008

Re : [RESOLU] Installation 12.04.1 ASUS EEE Pc 1215B (EFI Pb)

Je suis tout nouveau et je debute sous Ubuntu ..je reconnais avoir pas mal cherché aussi pour mon asus 1215B mod Siv et pour finir j ai trouve un outil extremement pratique pour pouvoir installer grub afin de pouvoir enfin booter sur ubuntu apres l avoir installé  http://www.clubic.com/telecharger-fiche … sybcd.html 
Je vous envois ce lien qui m a etait d une utilité indispensable avec toute la modestie du debutant ...;)
C eest un amorcage de disque il suffit juste d ajouter une entreé et de choisir le sysyteme installe ....ca a parfaitemant fonctionné pour moi ...etant nouveau j espere ne pas m etre trompe ni enfreint les regles afin de repondre a ce post ..merci

Dernière modification par capaalek008 (Le 01/11/2013, à 12:33)

Hors ligne

Haut de page ↑