Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 02/01/2013, à 15:22

-Mätic-

Impossible de monter une partition ext4

Bonjour,

Une partition en ext4 est inmontable depuis que j'ai voulu passer à la version 12.10.
Au démarrage le grub m'affiche "grub rescue>".
J'ai essayé de le réinstaller grub, mais impossible sans monter la partition.

Error mounting: mount: wrong fs type, bad option, bad superblock on /dev/sdb,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
ubuntu@ubuntu:~$ dmesg | tail
[ 1339.504459] sd 5:0:0:0: [sdb] Write Protect is off
[ 1339.504464] sd 5:0:0:0: [sdb] Mode Sense: 43 00 00 00
[ 1339.504467] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[ 1339.507720] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[ 1339.507727]  sdb: sdb1
[ 1339.510463] sd 5:0:0:0: [sdb] Assuming drive cache: write through
[ 1339.510469] sd 5:0:0:0: [sdb] Attached SCSI removable disk
[ 1410.641577] nautilus[4675]: segfault at 1c ip 002b90f0 sp bffa3260 error 4 in libgtk-x11-2.0.so.0.2200.0[110000+3c8000]
[ 1461.120756] EXT4-fs (sda8): ext4_check_descriptors: Block bitmap for group 0 not in group (block 2553887680)!
[ 1461.120769] EXT4-fs (sda8): group descriptors corrupted!

J'ai alors essayé de monter la partition avec les superblocs de secours, aucun n'a fonctionné..
Y-a-t-il encore une solution pour me sauver du formatage ? (et sauver mes données..)

Merci d'avance pour votre aide

Hors ligne

#2 Le 02/01/2013, à 16:44

slasher-fun

Re : Impossible de monter une partition ext4

Bonjour,

J'ai l'impression que tu tentes de monter /dev/sdb (le disque) au lieu de /dev/sdb8 (la partition)

Hors ligne

#3 Le 02/01/2013, à 16:54

-Mätic-

Re : Impossible de monter une partition ext4

Autant pour moi, je suis allé un peu vite (flemme de sortir la clé usb pour copier le message d'erreur exact, j'en ai pris un que je pensais similaire sur un autre sujet.. et au final c'était pas le meme.. hmm ).
j'ai bien ça :

ubuntu@ubuntu:~$ sudo mount /dev/sda8 /mnt
mount: wrong fs type, bad option, bad superblock on /dev/sda8,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

Hors ligne

#4 Le 02/01/2013, à 17:46

sinbad83

Re : Impossible de monter une partition ext4

Salut,
il faudrait savoir de quoi on parle. Démarre en LiveCD et donne le retour de sudo fdisk -l. Identifie bien la racine, monte-la en /mnt et donne le retour de

cat /mnt/etc/fstab

Tu peux en profiter pour réinstaller grub avec

sudo grub-install  --root-directory=/mnt/ /dev/sda

et regarde si tu redémarres bien. Sinon, envoie les retours des commandes.

Dernière modification par sinbad83 (Le 02/01/2013, à 17:48)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: http://coursinforev.org/dokuwiki/doku.php
Desktop Quad8800 Ubuntu 14.04, Cinnamon 14.04 et XP,  Samsung N150 U13.04 et Seven, HP Pavillon G6 U14.04 et Seven, Serveurs Ubuntu 12.04 et 14.04, Serveur virtualisation Proxmox

Hors ligne

#5 Le 02/01/2013, à 17:56

-Mätic-

Re : Impossible de monter une partition ext4

Voilà les résultats demandés :

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xb8000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1          13      104391   de  Dell Utility
/dev/sda2              14        1319    10485760    7  HPFS/NTFS
/dev/sda3   *        1320       11761    83875365    7  HPFS/NTFS
/dev/sda4           11762       30402   149727081+   f  W95 Ext'd (LBA)
/dev/sda5           30075       30402     2620416   dd  Unknown
/dev/sda6           11762       16613    38969838+  83  Linux
/dev/sda7           29327       30074     6008278+  82  Linux swap / Solaris
/dev/sda8           16613       28804    97922048   83  Linux
/dev/sda9           28804       29326     4197376   82  Linux swap / Solaris

Partition table entries are not in disk order
ubuntu@ubuntu:~$ sudo mount /dev/sda8 /mnt
mount: wrong fs type, bad option, bad superblock on /dev/sda8,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

Toujours impossible de monter la partition, est-ce que je m'y prend bien de la bonne façon ?
Voilà les résultats des autres commandes :

ubuntu@ubuntu:~$ cat /mnt/etc/fstab
cat: /mnt/etc/fstab: No such file or directory

ubuntu@ubuntu:~$ sudo grub-install --root-directory=/mnt/ /dev/sda
/usr/sbin/grub-probe: error: cannot find a device for /mnt//boot/grub (is /dev mounted?).

Rien de neuf au redémarrage

Hors ligne

#6 Le 02/01/2013, à 18:03

sinbad83

Re : Impossible de monter une partition ext4

Les réponses sont cohérentes avec le non-montage de sda8.
Regarde si la partition sda8 est saine. Démarre en LiveCD et lance

sudo fsck /dev/sda8

La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: http://coursinforev.org/dokuwiki/doku.php
Desktop Quad8800 Ubuntu 14.04, Cinnamon 14.04 et XP,  Samsung N150 U13.04 et Seven, HP Pavillon G6 U14.04 et Seven, Serveurs Ubuntu 12.04 et 14.04, Serveur virtualisation Proxmox

Hors ligne

#7 Le 02/01/2013, à 18:17

-Mätic-

Re : Impossible de monter une partition ext4

J'ai répondu "oui" à chaque fois qu'on me l'a demandé, j'ai bien peur que ça ne soit pas très sain.. hmm
J'ai abrégé le résultats aux "(...)", ça faisait trop long.

ubuntu@ubuntu:~$ sudo fsck /dev/sda8
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext4: Les descripteurs de groupe semblent en mauvais état... tentons d'utiliser les blocs de sauvetage...
le bitmap de blocs pour le groupe 0 n'est pas dans le groupe. (bloc 2553887680)
Relocaliser<o>? oui

le bitmap d'i-noeuds pour le groupe 0 n'est pas dans le groupe. (bloc 33554432)
Relocaliser<o>? oui

la table d'i-noeuds pour le groupe 0 n'est pas dans le groupe. (bloc 456367872)
AVERTISSEMENT : PERTE SÉVÈRE DE DONNÉES POSSIBLE.
Relocaliser<o>? oui

Le checksum d'un ou de plusieurs descripteurs de groupe de bloc est invalide. Corriger<o>? oui

Le checksum du descripteur de groupe 0 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 1 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 3 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 4 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 5 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 6 est invalide. CORRIGÉ.
(...)
Le checksum du descripteur de groupe 553 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 554 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 555 est inve checksum du descripteur de groupe 2 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 3 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 4 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 5 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 6 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 7 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 8 est invalide. CORRIGÉ.
(...)
Le checksum du descripteur de groupe 634 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 635 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 636 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 637 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 638 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 639 est invalide. CORRIGÉ.
le bitmap de blocs pour le groupe 640 n'est pas dans le groupe. (bloc 2553887680)
Relocaliser<o>? oui

la table d'i-noeuds pour le groupe 640 n'est pas dans le groupe. (bloc 389259008)
AVERTISSEMENT : PERTE SÉVÈRE DE DONNÉES POSSIBLE.
Relocaliser<o>? oui

Le checksum du descripteur de groupe 640 est invalide. CORRIGÉ.
le bitmap d'i-noeuds pour le groupe 641 n'est pas dans le groupe. (bloc 1996503040)
Relocaliser<o>? oui

la table d'i-noeuds pour le groupe 641 n'est pas dans le groupe. (bloc 167772160)
AVERTISSEMENT : PERTE SÉVÈRE DE DONNÉES POSSIBLE.
Relocaliser<o>? oui

Le checksum du descripteur de groupe 641 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 642 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 643 est invalide. CORRIGÉ.
(...)
Le checksum du descripteur de groupe 744 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 745 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 746 est invalide. CORRIGÉ.
Le checksum du descripteur de groupe 747 est invalide. CORRIGÉ.
fsck.ext4: e2fsck_read_bitmaps : bloc(s) de bitmap illégal(aux) pour /dev/sda8

Hors ligne

#8 Le 02/01/2013, à 18:21

sinbad83

Re : Impossible de monter une partition ext4

On comprend mieux pourquoi sda8 ne montait pas.


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: http://coursinforev.org/dokuwiki/doku.php
Desktop Quad8800 Ubuntu 14.04, Cinnamon 14.04 et XP,  Samsung N150 U13.04 et Seven, HP Pavillon G6 U14.04 et Seven, Serveurs Ubuntu 12.04 et 14.04, Serveur virtualisation Proxmox

Hors ligne

#9 Le 02/01/2013, à 18:44

-Mätic-

Re : Impossible de monter une partition ext4

Et alors ? Y-a-t-il une solution pour arranger ça ?

Hors ligne

#10 Le 02/01/2013, à 20:11

sinbad83

Re : Impossible de monter une partition ext4

Rien d'évident... Sans doute, essayer avec testdisk, mais ce n'est pas un outil facile pour tout le monde.
Question subsidiaire, ton /home est sur une partition séparée ?


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: http://coursinforev.org/dokuwiki/doku.php
Desktop Quad8800 Ubuntu 14.04, Cinnamon 14.04 et XP,  Samsung N150 U13.04 et Seven, HP Pavillon G6 U14.04 et Seven, Serveurs Ubuntu 12.04 et 14.04, Serveur virtualisation Proxmox

Hors ligne

#11 Le 02/01/2013, à 20:18

-Mätic-

Re : Impossible de monter une partition ext4

Je suis justement en train de voir ce que je peux faire avec testdisk, j'ai une première erreur :

Warning: the current number of heads per cylinder is 124 but the correct value may be 255.

Est-ce que mon disque est toujours viable pour envisager une réinstallation complète de tout le systeme ou vaut-il mieux le changer ?

Mon /home doit être sur cette partition.

Hors ligne

#12 Le 02/01/2013, à 20:33

sinbad83

Re : Impossible de monter une partition ext4

Sur le forum, le spécialiste des récupérations est rmy. Contacte-le directement après l'avoir cherché dans la liste des membres du forum (Onglet Navigation). Il te donnera son avis.


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: http://coursinforev.org/dokuwiki/doku.php
Desktop Quad8800 Ubuntu 14.04, Cinnamon 14.04 et XP,  Samsung N150 U13.04 et Seven, HP Pavillon G6 U14.04 et Seven, Serveurs Ubuntu 12.04 et 14.04, Serveur virtualisation Proxmox

Hors ligne

#13 Le 02/01/2013, à 20:34

-Mätic-

Re : Impossible de monter une partition ext4

D'accord, merci pour ton aide, je vais faire ça.

Hors ligne

Haut de page ↑