Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 01/01/2013, à 20:52

black_sun_2012

[RESOLU] Icone manquante dans les menus d'applications Qt

ceci est un remake d'une question déjà posé sur debian facile mais comme je n'ai pas eu de réponse je la recolle ici, en ésperant être plus chanceux (je suis sur debian sid)

"Sous gnome shell j'ai deux logiciel (http://qelectrotech.org/index.html et http://librecad.org/cms/home.html) dont les icônes des différent menu n'apparaissent pas.
J'ai vérifier en mettant bien les thème d'origine de gnome shell (adwaita) mais sa ne change rien. Sous ubuntu avec gnome shell je n'ai pas ce problème. Le seul point commun avec ces deux logicielle c'est qu'il sont écrit avec Qt  donc je pense que le problème se situe ici..... sûrement un simple paquet ou une option dans dconf ou gconf..... pas trouvé."

petite précision, j'ai ce problème sur mon fixe et mon laptop (donc sa vient bien de debian et pas un bug sur une de mes machine) , vlc est aussi touché (ecrit avec Qt aussi).
Sur mon laptop avec ma debian j'ai installé kde à coté de gnome shell. Sou kde j'ai bien les icônes des différentes entré  des menus (fichier, édition, outils, etc...) mais dès que je reviens sous gnome shell, plus d’icônes. (j'ai essayé le pack d’icône oxygen sous gnome shell mais pas mieux).
Bref si quelqu'un a une petite idée car je suis persuadée que c'est pas grand chose au final.

Bonne année à tous.

Dernière modification par black_sun_2012 (Le 20/05/2013, à 14:52)


laptop sony vaio svs131B12M--4Go ram, i5 3210M, intel HD 4000 intégré . //fixe packard bell nvidia g250, 1Go ram, intel core2duo 1,8GHz  OS full 64bits
debian testing (gnome shell) - laptop fixe -> OS utilisé || ubuntu 12.04 (unity/gnome shell) - laptop fixe || windows 7 - laptop

Dev QElectrotech

Hors ligne

#2 Le 02/01/2013, à 21:30

Heliox

Re : [RESOLU] Icone manquante dans les menus d'applications Qt

Salut,

Essaie ces deux formules magiques :

# gtk-update-icon-cache -f '/usr/share/icons/gnome'
# gtk-update-icon-cache -f '/usr/share/icons/hicolor'

wink

#3 Le 03/01/2013, à 03:38

black_sun_2012

Re : [RESOLU] Icone manquante dans les menus d'applications Qt

Merci enfin quelqu'un qui me répond.
Mais bon ce n’était pas sa pour autant. Je suis vraiment perplexe sur ce problème bien ciblé. Surtout que la solution existe car sur ubuntu y'a pas de soucis.


laptop sony vaio svs131B12M--4Go ram, i5 3210M, intel HD 4000 intégré . //fixe packard bell nvidia g250, 1Go ram, intel core2duo 1,8GHz  OS full 64bits
debian testing (gnome shell) - laptop fixe -> OS utilisé || ubuntu 12.04 (unity/gnome shell) - laptop fixe || windows 7 - laptop

Dev QElectrotech

Hors ligne

#4 Le 03/01/2013, à 22:09

misaine

Re : [RESOLU] Icone manquante dans les menus d'applications Qt

peut-être qt4-qtconfig


la roue tourne...c'est sûr! c'est même pour ça qu'on l'a inventée.

Hors ligne

#5 Le 03/01/2013, à 22:17

black_sun_2012

Re : [RESOLU] Icone manquante dans les menus d'applications Qt

misaine a écrit :

peut-être qt4-qtconfig

Déjà fait, sauf erreur de ma part il n'y a rien qui s'apparente à sa dedans.


laptop sony vaio svs131B12M--4Go ram, i5 3210M, intel HD 4000 intégré . //fixe packard bell nvidia g250, 1Go ram, intel core2duo 1,8GHz  OS full 64bits
debian testing (gnome shell) - laptop fixe -> OS utilisé || ubuntu 12.04 (unity/gnome shell) - laptop fixe || windows 7 - laptop

Dev QElectrotech

Hors ligne

#6 Le 04/01/2013, à 00:56

Heliox

Re : [RESOLU] Icone manquante dans les menus d'applications Qt

(Je viens de relire attentivement et viens de réaliser que ma réponse ne concernait pas ton problème yikes)

C'est vrai que depuis que Gnome-Shell est arrivé, il n'y a plus d'icônes ni dans les menus ni sur les boutons.
La piste de dconf me paraît la plus plausible. Installe en premier lieu l'éditeur de configuration dconf (paquet dconf-tools chez Debian, dconf-editor chez Fedora) si ce n'est pas déjà fait et va dans la section : org > gnome > desktop > applications > interface , et coche les cases des deux options "buttons-have-icons" et "menus-have-icons", ça devrait résoudre ton problème.

wink

#7 Le 04/01/2013, à 15:09

black_sun_2012

Re : [RESOLU] Icone manquante dans les menus d'applications Qt

Heliox. Ta encore mal lue car c'est pas exactement sa mon problème hmm. Mon problème ne concerne que les applications Qt.

"Buttons-have-icons" et "menus-have-icons" sont déjà activé. D'ailleurs il y a plus simple que de passé par dconf pour sa, c'est d'utilisé "gnome-tweak-tool" qui est valable  pour toute les distribution avec gnome shell ou "ubuntu-tweak" (qui n'est valable que pour ubuntu évidement).

Merci quand même de t'intéressé à mon problème smile


laptop sony vaio svs131B12M--4Go ram, i5 3210M, intel HD 4000 intégré . //fixe packard bell nvidia g250, 1Go ram, intel core2duo 1,8GHz  OS full 64bits
debian testing (gnome shell) - laptop fixe -> OS utilisé || ubuntu 12.04 (unity/gnome shell) - laptop fixe || windows 7 - laptop

Dev QElectrotech

Hors ligne

#8 Le 06/01/2013, à 11:52

Heliox

Re : [RESOLU] Icone manquante dans les menus d'applications Qt

Pour le coup, j'ai bien compris ton problème. big_smile
Mais je pensais que les applications Qt mimeraient le comportement des applications de l'environnement d'où mon hypothèse.
Et sinon pourquoi ne pas lancer le centre de contrôle KDE directement depuis Gnome ? Alt + F2, systemsettings, catégore "apparence des applications" et (re)cocher la case correspondant aux icônes dans les menus. Mais je dois dire qu'à part ça, je sèche un peu… hmm

#9 Le 06/01/2013, à 20:56

black_sun_2012

Re : [RESOLU] Icone manquante dans les menus d'applications Qt

Toujours pas sad
Je garde l’espoir que debian mettra la solutions dans un metapackage de gnome ou alors que le problème disparaisse dans les future version de gnome.


laptop sony vaio svs131B12M--4Go ram, i5 3210M, intel HD 4000 intégré . //fixe packard bell nvidia g250, 1Go ram, intel core2duo 1,8GHz  OS full 64bits
debian testing (gnome shell) - laptop fixe -> OS utilisé || ubuntu 12.04 (unity/gnome shell) - laptop fixe || windows 7 - laptop

Dev QElectrotech

Hors ligne

#10 Le 20/05/2013, à 14:50

black_sun_2012

Re : [RESOLU] Icone manquante dans les menus d'applications Qt

Je répond à ce vieux post car je vient d'avoir la réponse.  Alors pour Heliox, tu n’était vraiment pas loin, car ça ne ce passe pas dans dconf mais gconf.
voici les liens qui m'ont aidé à résoudre ce problème que je traîne depuis un moment.
post #14 en particulié

gconftool-2 --type boolean --set /desktop/gnome/interface/buttons_have_icons true
gconftool-2 --type boolean --set /desktop/gnome/interface/menus_have_icons true

mais aussi,  pour avoir les icônes système et le thème gtk système:
http://www.webupd8.org/2012/01/get-bett … ns-in.html

gconftool-2 --set --type string /desktop/gnome/interface/gtk_theme THEME-NAME
gconftool-2 --set --type string /desktop/gnome/interface/icon_theme THEME-NAME

Et pour faire tout ça en GUI, installé le paquet: gconf-editor (sa permet de voir les autres options existante)


laptop sony vaio svs131B12M--4Go ram, i5 3210M, intel HD 4000 intégré . //fixe packard bell nvidia g250, 1Go ram, intel core2duo 1,8GHz  OS full 64bits
debian testing (gnome shell) - laptop fixe -> OS utilisé || ubuntu 12.04 (unity/gnome shell) - laptop fixe || windows 7 - laptop

Dev QElectrotech

Hors ligne

  • Accueil
  • » Forum
  • » Gnome3
  • » [RESOLU] Icone manquante dans les menus d'applications Qt

Haut de page ↑