Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 31/12/2012, à 08:27

tokinstit

Impossible de capturer une vidéo DV

Bonjour,

Tout d'abord toutes mes excuses si je ne suis pas dans le bon forum pour poser cette question.
J'ai migré vers Ubuntu puis Xubuntu 12.04 depuis quelques semaines (je suis donc novice) et je n'arrive plus à capturer mes vidéos DV.
J'utilise une caméra DV Panasonic NV-MX500 depuis plusieurs années. Auparavant, j'étais sous Win XP et je n'avais aucun souci pour capturer mes vidéos via la carte FireWire.

J'ai donc fait quelques recherches avant de venir présenter mon problème ici mais sans succès...

à partir de ce que j'ai trouvé sur les différents forums et sites que j'ai visités, voilà les informations que je peux fournir :

Une fois la caméra branchée et connectée via la carte Firewire, en lançant dvgrab :

xxxxx@xxxxx-bureau:~$ dvgrab
Error: no camera exists

Kino me dit aussi qu'il n'y a aucune caméra branchée.

J'ai donc recherché si ma carte était reconnue; il semble que oui :

xxxxx@xxxxx-bureau:~$ lspci | grep 1394
01:02.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394 Controller (Link)

Au niveau des modules firewire, j'ai ceci :

xxxxx@xxxxx-bureau:~$ lsmod | grep firewire
firewire_ohci          40180  0 
firewire_core          56940  1 firewire_ohci
crc_itu_t              12627  1 firewire_core

Lorsque je cherche à charger les modules :

xxxxx@xxxxx-bureau:~$ modprobe ohci1394
murieljf@murieljf-bureau:~$ modprobe raw1394
FATAL: Module raw1394 not found.

Le test avec libraw me dit :

xxxxx@xxxxx-bureau:~$ testlibraw
successfully got handle
current generation number: 0
0 cards found

La commande dmesg me donne tout un tas de lignes qui ressemblent à la première du code ci-dessous et les 2 dernières sont :

[24567.832176] firewire_ohci: node ID not valid, new bus reset in progress
[24567.832356] firewire_core: skipped bus generations, destroying all nodes
[24568.332050] firewire_core: rediscovered device fw0

J'ai cru comprendre qu'il y avait un problème avec la capture de vidéos DV depuis les dernières versions de linux mais j'avoue que je patauge vraiment et que j'ai besoin d'aide.

En vous remerciant par avance et vous souhaitant une bonne année 2013,

Hors ligne

#2 Le 31/12/2012, à 12:08

Maisondouf

Re : Impossible de capturer une vidéo DV

Il y a un article sur le site de Kino qui explique qu'il y a une manipulation à faire sur Ubuntu pour activer correctement le 1394 : http://www.kinodv.org/
Il parlent de Ubuntu 10.04, mais je pense que les modifs ne sont pas à faire avec la 12.04.
Sur ma 12.04, j'ai ça dans ma blacklist (/etc/modprobe.d/blacklist-firewire.conf) :

# Select the legacy firewire stack over the new CONFIG_FIREWIRE one.

blacklist ohci1394
blacklist sbp2
blacklist dv1394
blacklist raw1394
blacklist video1394

#blacklist firewire-ohci
#blacklist firewire-sbp2

Donc c'est fait d'origine dans la 12.04.
Par contre, ça laisse voir que les modules que tu cherches à activer ne doivent pas être activés.
Sur cette autre page du site (http://www.kinodv.org/article/static/3), ils précisent les dépendances de Kino

    libglade2
    gtk 2.6 (and related dependencies)
    libxml2
    libdv
    libsamplerate
    libasound
    libXv
    libpthread
    ffmpeg, libavformat, and libavcodec
    libraw1394
    libiec61883
    libavc1394

Il faudrait vérifier que toutes sont installées


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 01/01/2013, à 06:20

tokinstit

Re : Impossible de capturer une vidéo DV

Merci pour la réponse.

Effectivement, ma blacklist montre la même liste.

J'ai installé toutes les dépendances à part gtk 2.6 qui n'apparait pas dans synaptic.

Cependant dvgrab et kino me disent toujours qu'il n'y a pas de caméra branchée.

Se pourrait-il tout simple que cela vienne du cable/ de la prise de carte (j'en doute car c'est les mêmes qu'avant) ? ou que Xubuntu ne reconnaisse pas cette caméra ?

Je continue mes recherches...

Hors ligne

#4 Le 01/01/2013, à 06:32

Maisondouf

Re : Impossible de capturer une vidéo DV

Tu peux toujours démarrer ton PC sur un Live version Ubuntu et regarder si ta caméra est détectée en installant un minimum de chose dans la session live.
Si Ubuntu fonctionne, il y aura moyen de repérer ce qu'il active pour ça et de reporter ça dans ton Xubuntu.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#5 Le 03/01/2013, à 18:29

Pympc

Re : Impossible de capturer une vidéo DV

Bonsoir

pour infos, ma caméra une JVC GR-DV720E n'est plus reconnu depuis quelques années. Seul un ancien PC sous Xp la reconnaît. W8 ne la connaît pas et aucune des distrib linux testées la reconnaisse. Je pense qu'il y a du avoir une modification de quelque chose dans le monde fireware laissant de coté certains produits.
Aujourd'hui je passe par un graveur de salon, c'est la seule solution trouvée yikes

Hors ligne

#6 Le 03/01/2013, à 20:29

Maisondouf

Re : Impossible de capturer une vidéo DV


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#7 Le 06/01/2013, à 07:31

tokinstit

Re : Impossible de capturer une vidéo DV

Bonjour,

Merci pour vos réponses.
Après achat d'un nouveau câble i-Link, et essais avec live CD ubuntu 12.04 et 10.04, le constat reste le même et dvgrab me dit toujours : "error : no camera exists".

Je pense donc que je suis dans le cas d'obsolescence programmée dont parle Maisondouf.

Je vais donc devoir trouver un Win XP et l'installer à côté de mon Xubuntu pour récupérer mes vidéos. Ca ne m'enchante pas mais je ne vois plus d'autre solution... hmm

Hors ligne

#8 Le 06/01/2013, à 14:53

Pympc

Re : Impossible de capturer une vidéo DV

Je ne veux pas t'inquiéter mais XP en pack3 ne reconnaît plus mon camescope JVC  mad:mad:

Hors ligne

Haut de page ↑