Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 29/12/2012, à 19:21

Papy Octet

[Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

Bonjour,
Voilà qui me perturbe pas mal.
Alors qu'avec 12.04 il me suffisait de connecter un accessoire sur une prise USB pour qu'il soit reconnu et actif immédiatement.

Avec 12.10 ... ça ne marche pas ! Quand je connecte (j'allume) un accessoire USB ... je dois redémarrer l'ordi en laissant l'accessoire branché pour qu'il soit vu par le système. Même la souris n'est pas active si je la change simplement de place dans mes connecteurs USB !
C'est difficile à gérer. Imaginez, j'ai deux imprimantes et un scanner que j'utilise de temps à autres et maintenant, pour les avoir disponibles je suis contraint de les laisser allumés tout le temps sans quoi je dois fermer mes application (Writer, Inkscape, ...), éteindre l'ordi et redémarrer avant de pouvoir imprimer, scanner.

Ce n'est pas très normal, non ?

Une idée pour corriger cela ?
Merci.

Dernière modification par Papy Octet (Le 06/04/2013, à 10:55)


AMD A6-3500 HD6530D 2.1 ghz Triple core FM1 3mb - CM GIGABYTE GA-A75M-UD2H - 8 GiO ram DDR3 - HDD 1TO WD GREEN + WD Gaviar Black 1TO + externe IOMEGA 500GiO - Carte écran nvidia GeForce 210 Silent avec 1GiO cache DDR3 - Ubuntu
Portable HP - Intel Centrino - 1 Go DDR2 - DD 120 Go - Mint 14
Imprim. Samsung ML-1670 et CLP-315, scanner Epson Perfection V30, ... Linuxgraphic.org, LibreOffice.org

Hors ligne

#2 Le 30/12/2012, à 01:24

Maisondouf

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

C'est du tout un fonctionnement normal....
Tu as fait une installation neuve de la 12.10 ou une mise à niveau 12.04->12.10 ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 30/12/2012, à 07:51

Papy Octet

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

Maisondouf a écrit :

...
Tu as fait une installation neuve de la 12.10 ou une mise à niveau 12.04->12.10 ?

Tout est tout neuf : le PC et 12.10 (+ les 250 mises-à-jour proposées après l'installation).
Le seul matériel réemployé ... c'est moi roll


AMD A6-3500 HD6530D 2.1 ghz Triple core FM1 3mb - CM GIGABYTE GA-A75M-UD2H - 8 GiO ram DDR3 - HDD 1TO WD GREEN + WD Gaviar Black 1TO + externe IOMEGA 500GiO - Carte écran nvidia GeForce 210 Silent avec 1GiO cache DDR3 - Ubuntu
Portable HP - Intel Centrino - 1 Go DDR2 - DD 120 Go - Mint 14
Imprim. Samsung ML-1670 et CLP-315, scanner Epson Perfection V30, ... Linuxgraphic.org, LibreOffice.org

Hors ligne

#4 Le 30/12/2012, à 10:13

Maisondouf

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

Je viens de lire la doc de ta carte mère, il y a un contrôleur USB3 dessus.
Est ce qu'il apparaît correctement dans un "lsusb" ?

EDIT: C'est un contrôleur mono-chip AMD A75 (codename Hudson-D3) qui gère SATA3, USB3, VGA, etc, etc
http://en.wikipedia.org/wiki/Comparison … _.28FCH.29
Il faut savoir si le firmware adéquate est dans les dépôts ou ailleurs...

Dernière modification par Maisondouf (Le 30/12/2012, à 10:29)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#5 Le 30/12/2012, à 10:38

J5012

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

est-ce que la fonction legacy usb est activee dans le bios ?

Hors ligne

#6 Le 30/12/2012, à 16:13

Papy Octet

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

Bonjour Maisondouf,
Voici ce que retourne la console sur lsusb :

Bus 002 Device 002: ID 058f:6364 Alcor Micro Corp. AU6477 Card Reader Controller
Bus 006 Device 002: ID 045e:0023 Microsoft Corp. Trackball Optical
Bus 007 Device 002: ID 059b:0070 Iomega Corp. 
Bus 008 Device 002: ID 056a:00d1 Wacom Co., Ltd Bamboo Pen & Touch (CTH-460-DE)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

En connectant mon disque dur et ma clé USB sur les connexion USB2 et 3 de la face avant, il sont reconnus et montés quand j'allume mon ordi après la connexion.
Mais je constate, ce matin, après avoir éteint mon ordi pour la nuit, que le branchement à chaud d'une clé USB sur une connexion en face avant de mon ordi fonctionne pour le moment.
Pourquoi pas hier malgré plusieurs redémarrages ???? Mystèèèèèère !

Je n'ai pas encore regardé pour l'option dans le bios (legacy). Je vois cela demain matin quand je redémarrerai ma machine mais je pense qu'elle doit être active puisque la connexion à chaud d'une clé usb et le déplacement de la connexion de mon clavier sur différentes prises USB (4*usb2 + 2*usb3 en face arrière et 4*usb3 + 1*usb2 en face avant) de ma machine semblent bien fonctionner à chaud.

C'est une toute nouvelle machine (mise en service pour la première fois hier smile ) suite au crash de la carte-mère de ma précédente machine après 5 ans de services ininterrompu 24h/24 et 365j/an. La carte-mère me détruisait les rams !

Linux a été installé tout seul sur un HDD de 1TO tout neuf et vierge de tout Windows big_smile.
A+
Merci pour vos aides précieuses.

BONNE ANNÉE ET MEILLEURS VŒUX POUR 2013.


AMD A6-3500 HD6530D 2.1 ghz Triple core FM1 3mb - CM GIGABYTE GA-A75M-UD2H - 8 GiO ram DDR3 - HDD 1TO WD GREEN + WD Gaviar Black 1TO + externe IOMEGA 500GiO - Carte écran nvidia GeForce 210 Silent avec 1GiO cache DDR3 - Ubuntu
Portable HP - Intel Centrino - 1 Go DDR2 - DD 120 Go - Mint 14
Imprim. Samsung ML-1670 et CLP-315, scanner Epson Perfection V30, ... Linuxgraphic.org, LibreOffice.org

Hors ligne

#7 Le 30/12/2012, à 16:17

compte supprimé

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

Salut,
Même problème avec un port USB3. D'ailleurs ça fait pareils sous w7. Ce qui fonctionne pour moi :

lsusb -v

ou

sudo lsusb -v

#8 Le 30/12/2012, à 16:28

Papy Octet

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

Mais il se passe des choses "curieuses":/
Je viens de connecter une clé USB2 sur un port USB2 en face avant alors que sur un de sports USB3 en face avant, j'ai mon HDD externer Iomega 500 GiO connecté et actif.
Subitement, sans aucune raison apparente, mon HDD externe est démonté tout seul.
Je déconnecte puis reconnecte le HDD et il est monté automatiquement et la clé USB reste montée et accessible.

Les mystèèèères insondables de l'informatique mad

lsusb -t retourne :

guy@guy-GA-A75M-UD2H:~$ lsusb -t
/:  Bus 09.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
/:  Bus 08.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=HID, Driver=wacom, 12M
    |__ Port 1: Dev 2, If 1, Class=HID, Driver=wacom, 12M
/:  Bus 07.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
    |__ Port 2: Dev 3, If 0, Class=stor., Driver=usb-storage, 5000M
/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=HID, Driver=usbhid, 1.5M
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=ohci_hcd/2p, 12M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=ohci_hcd/5p, 12M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=ohci_hcd/5p, 12M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci_hcd/5p, 480M
    |__ Port 2: Dev 3, If 0, Class=stor., Driver=usb-storage, 480M
    |__ Port 3: Dev 2, If 0, Class=stor., Driver=usb-storage, 480M
    |__ Port 3: Dev 2, If 1, Class=HID, Driver=usbhid, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci_hcd/5p, 480M

Dernière modification par Papy Octet (Le 30/12/2012, à 16:31)


AMD A6-3500 HD6530D 2.1 ghz Triple core FM1 3mb - CM GIGABYTE GA-A75M-UD2H - 8 GiO ram DDR3 - HDD 1TO WD GREEN + WD Gaviar Black 1TO + externe IOMEGA 500GiO - Carte écran nvidia GeForce 210 Silent avec 1GiO cache DDR3 - Ubuntu
Portable HP - Intel Centrino - 1 Go DDR2 - DD 120 Go - Mint 14
Imprim. Samsung ML-1670 et CLP-315, scanner Epson Perfection V30, ... Linuxgraphic.org, LibreOffice.org

Hors ligne

#9 Le 30/12/2012, à 17:55

Maisondouf

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

Te casse pas la tête avec l'option legacy, ça ne sert que sous MSDOS.
Aujourd'hui, à part les soft de flashage de BIOS, il n'y plus grand chose qui utilise MSDOS ou ses dérivés.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#10 Le 30/12/2012, à 19:30

Papy Octet

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

De toute façon, je suis sous Linux exclusivement wink


AMD A6-3500 HD6530D 2.1 ghz Triple core FM1 3mb - CM GIGABYTE GA-A75M-UD2H - 8 GiO ram DDR3 - HDD 1TO WD GREEN + WD Gaviar Black 1TO + externe IOMEGA 500GiO - Carte écran nvidia GeForce 210 Silent avec 1GiO cache DDR3 - Ubuntu
Portable HP - Intel Centrino - 1 Go DDR2 - DD 120 Go - Mint 14
Imprim. Samsung ML-1670 et CLP-315, scanner Epson Perfection V30, ... Linuxgraphic.org, LibreOffice.org

Hors ligne

#11 Le 03/01/2013, à 10:40

J5012

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

j'ai eu un "bug" comme ca avec une cle et un usb3 : j'avais trop enfonce le periph usb : il a suffi que je le retire de qqs millimetres, et hop le periph a ete monte ...

Hors ligne

#12 Le 03/01/2013, à 11:03

Papy Octet

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

J'avais envisagé, un temps, cette possibilité mais mon ordinateur est tout neuf, fraîchement sorti de sa boîte et tous les ports USB réagissaient de la même manière. Et j'en ai une douzaine (!) installés sur ma machine. De plus, je venais d'installer Ubuntu 12.10 sur un HDD interne tout neuf aussi et sans Windows.

Après avoir testé chacun des ports USB sans résultat, et après avoir éteint et rallumé ma chine, toujours en vain, j'ai laissé mon HDD externe et trois clés USB sur différents ports (pour utiliser chacun des 5 "hubs" de la machine. Après avoir éteint une nouvelle fois mon ordi puis le redémarrer à froid, tous les ports sont maintenant "activables" à chaud avec tous mes appareils USB (clé, HDD, lecteur de cartes, et même acquisition de données).

Mais je me demande encore si ce comportement de Ubuntu est normal : pour qu'il détecte correctement les ports USB disponibles et les rende activable à chaud, il faut qu'il y ait une "charge" sur les ports (ou les hubs) lors d'un premier démarrage.

Pour le moment, ça fonctionne correctement et je ne vais pas m'en plaindre même si je voudrais comprendre.

BONNE ANNÉE à tous ceux qui me liront.


AMD A6-3500 HD6530D 2.1 ghz Triple core FM1 3mb - CM GIGABYTE GA-A75M-UD2H - 8 GiO ram DDR3 - HDD 1TO WD GREEN + WD Gaviar Black 1TO + externe IOMEGA 500GiO - Carte écran nvidia GeForce 210 Silent avec 1GiO cache DDR3 - Ubuntu
Portable HP - Intel Centrino - 1 Go DDR2 - DD 120 Go - Mint 14
Imprim. Samsung ML-1670 et CLP-315, scanner Epson Perfection V30, ... Linuxgraphic.org, LibreOffice.org

Hors ligne

#13 Le 03/01/2013, à 21:03

J5012

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

je pense que c'est toujours en lien avec ce que font les fabricants, ubuntu et gnulinux en general n'ont pas acces a toutes les docs tech : bien qu'il y ait des directives officiels pour implementer l'usb 1.1 , 2.1 , 3.0 , il n'y a pas d'obligation de resultats (j'ignore le % de tolerance pour obtenir la compatibilite normee), en plus du fait que chaque fabricant voudra se detacher de la concurrence ...

Hors ligne

#14 Le 04/01/2013, à 08:13

Papy Octet

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

Oui. Peut-être.
Mais je n'arrive pas à comprendre pourquoi les ports USB sont reconnus (et fonctionnent selon leur norme respective (d'après quelques tests réalisés) : USB 2 et/ou 3) une fois que l'ordi démarre avec un périphérique connecté (mais qui n'est pas obligatoirement fonctionnel, lui, le périphérique. Je pense à mon scanner, mes imprimantes) alors qu'il ne les reconnaît pas si je laisse ceux-ci vides au tout premier démarrage.

Mais bon. Comme je l'ai déjà écrit plus haut : maintenant, ça fonctionne correctement et c'est tant mieux.
Le pourquoi ... plus tard peut-être.


AMD A6-3500 HD6530D 2.1 ghz Triple core FM1 3mb - CM GIGABYTE GA-A75M-UD2H - 8 GiO ram DDR3 - HDD 1TO WD GREEN + WD Gaviar Black 1TO + externe IOMEGA 500GiO - Carte écran nvidia GeForce 210 Silent avec 1GiO cache DDR3 - Ubuntu
Portable HP - Intel Centrino - 1 Go DDR2 - DD 120 Go - Mint 14
Imprim. Samsung ML-1670 et CLP-315, scanner Epson Perfection V30, ... Linuxgraphic.org, LibreOffice.org

Hors ligne

#15 Le 12/02/2013, à 21:57

jeannot13116

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

Sur un autre post, j'ai évoqué ce problème que j'ai eu en installant 12.10. En fait je suis nouveau sur Linux et avec le même PC je suis passé de Xp à Ubuntu. Pareil , obligé de démarrer avec les usb branchés pour qu'ils soient reconnus. En fait j'ai mis un hub usb externe 4 ports alimenté sur secteur sur lequel j'ai mis ma webcam Logitech qui semble me perturber l'usb. Je pense à un problème de H/w plus sensible avec Linux, car je n'avais pas ce pb avec XP. Tous les USB que j'allume ou connecte à chaud sont branchés sur ce hub, notamment mon imprimante et mes clefs ,et autres DD externes.
ps: j'ai un desktop Ibm/lenovo thinkcentre.

Hors ligne

#16 Le 06/04/2013, à 10:54

Papy Octet

Re : [Résolu : ram défaillante] Ubuntu 12.10 : usb non fonctionnel à chaud.

En fin de compte, la carte mère de ma machine était défectueuse et elle détruisait mes cartes mémoire.
Il est plus que probable que Linux "chargeait" les instructions de gestion des connexions USB quelque part dans une zone de mes rams qui sont défectueuses et donc n'y a plus accès. Quand on redémarre après avoir connecté un appareil, les instructions de gestion sont peut-être inscrites ailleurs dans la ram et donc sont devenues accessibles.
J'extrapole mais je ne vois pas d'autre explication surtout que le même genre de problème est arrivé avec une machine toute neuve que je viens d'acquérir et qui avait un problème de faux contact dans une barrette de ram. Une fois le contact rétabli, tout est rentré dans l'ordre semblant confirmer mes soupçons.

A+


AMD A6-3500 HD6530D 2.1 ghz Triple core FM1 3mb - CM GIGABYTE GA-A75M-UD2H - 8 GiO ram DDR3 - HDD 1TO WD GREEN + WD Gaviar Black 1TO + externe IOMEGA 500GiO - Carte écran nvidia GeForce 210 Silent avec 1GiO cache DDR3 - Ubuntu
Portable HP - Intel Centrino - 1 Go DDR2 - DD 120 Go - Mint 14
Imprim. Samsung ML-1670 et CLP-315, scanner Epson Perfection V30, ... Linuxgraphic.org, LibreOffice.org

Hors ligne

Haut de page ↑