Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 04/01/2013, à 21:37

Flori@n.B

Problème Carte Graphique ! (Technologie Optimus)

Bonjour, bonjour,

Donc voilà mon problème : j'ai installé un jeu, mais il doit utiliser la carte graphique Nvidia et non l'autre carte !

Mais voilà, le jeu ne veut pas se lancer ! Donc j'ai chercher de l'aide sur le forum officiel du jeu ! Et j'ai eu la grande chance de trouver un autre utilisateur de ce jeu sur Linux !

Il m'a aidé, mais nous avons pas réussi à régler le problème ! Donc il m'a conseiller de venir vous voir ! Car quand je lance le jeu j'ai des message d'erreurs qui se lance :

LIBGL_DEBUG=verbose optirun ./run_fgfs.sh 
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
libGL error: failed to load driver: swrast
Error: Not able to create requested visual.
getDefaultWindow: failed to create GraphicsContext
Error: Not able to create requested visual.
getDefaultWindow: failed to create GraphicsContext
Error: Not able to create requested visual.
  GraphicsWindow has not been created successfully.
Viewer::realize() - failed to set up any windows
Segmentation fault (core dumped)

J'ai déjà lu toutes la partie sur la technologie optimus et du fait que Linux le prend mal en charge ! J'ai donc installé comme indiqué sur le forum le paquet "BlumBee", mais voilà rien n'y fait il y a encore les messages qui s'affichent, même quand on lance le jeu avec le préfixe "Optirun" !

Auriez vous une solution a me proposer ?

Je vous en remercie d'avance !

Florian


Supportons et Défendons les logiciels libre et Open Source et leurs communautés ! ~ Retrouvez-moi sur Zeste de Savoir ~ Mon GitHub

Hors ligne

#2 Le 05/01/2013, à 20:02

ArchangeGabriel

Re : Problème Carte Graphique ! (Technologie Optimus)

Il faudrait essayer avec primus, soit en utilisant le ppa le proposant actuellement, soit en attendant le support côté Bumblebee.

Hors ligne

Haut de page ↑