Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 13/10/2012, à 15:03

servius

Knoda - comment obtenir un paquet fonctionnant sous Ubuntu 12.04

Depuis plusieurs années j'utilise Knoda pour gérer mes bases de données MySQL. Ce logiciel permet de fabriquer rapidement des formulaires assez complexes avec des bases MySQL, SQLite ou autres . Il est devenu pour moi un outil indispensable!
Malheureusement il a disparu des distributions Linux et les seuls logiciels pouvant prétendre à le remplacer , Kexi et LibreOffice_Base, ne me permettent pas d'obtenir les mêmes formulaires (ceci avec le niveau de connaissance que j'en ai...). Et je n'ai plus le courage de me lancer dans des développements php... J'envisage donc de revenir à Windows/Access, ce qui m'ennuierait beaucoup, mais si c'est la seule solution...

Ma question : quelqu'un peut-il m'indiquer le moyen d'obtenir un paquet "Knoda" fonctionnant avec la dernière version d'Ubuntu (12.04LTS)?

Hors ligne

#2 Le 13/10/2012, à 15:08

Jeff_05

Re : Knoda - comment obtenir un paquet fonctionnant sous Ubuntu 12.04

Bonjour,

Je ne sais pas si cela peut être utile... :
http://knoda.sourceforge.net/

A +


Ubuntu 10.04 sur ordinosaure (512 Mo - Intel Pentium IV 2,4 GHz - NVidia MX440 AGP 8)

Ubuntu 12.04 sur portable (1 Go - Intel DualCore T5200 1,6 Ghtz x2)

Hors ligne

#3 Le 13/10/2012, à 15:19

servius

Re : Knoda - comment obtenir un paquet fonctionnant sous Ubuntu 12.04

J'y suis déja allé mais cela ne ma pas permis de résoudre mon problème.
Merci pour ta réponse

Hors ligne

#4 Le 05/11/2012, à 18:27

servius

Re : Knoda - comment obtenir un paquet fonctionnant sous Ubuntu 12.04

Je pense que je dois être le seul à utiliser encore Knoda... car peu de réponses. Dommage car ce logiciel était vraiment pratique et simple à mettre oeuvre. Ce qui n'est pas le cas pour Kexi ou LibreOffice-base ...

J'en suis réduit à rester sous UBUNTU 11.04 mais cela marche bien.

Hors ligne

#5 Le 06/01/2013, à 19:10

GloW

Re : Knoda - comment obtenir un paquet fonctionnant sous Ubuntu 12.04

Je viens d'expliquer ici :

comment installer knoda sur la dernière version d'Ubuntu :
http://forum.kde.org/viewtopic.php?f=221&t=109542

Vous allez avoir besoin de pas mal de paquets datant de lucid, ainsi que d'un patch pour le faire fonctionner, tous dispo dans un tar ball.
http://www.2shared.com/file/azfgCAMM/kn … 64bit.html

Dernière modification par GloW (Le 07/01/2013, à 18:25)

Hors ligne

#6 Le 06/01/2013, à 23:03

robert leleu

Re : Knoda - comment obtenir un paquet fonctionnant sous Ubuntu 12.04

A Servius
Je suis de votre avis au sujet de Knoda. Toutefois j'ai réussi à fabriquer un ersatz de mon application "Knoda" sous Kexi' mais bien moins commode. Le gros défaut, temporaire semble-t-il est l'impossibilité d'accrocher des scripts. C'est pourquoi je suis tout heureux que mon informaticien de petit-fils GloW ai pu accrocher Knoda sous Ubuntu 12.04 (en fait Mint).

Ttfois les rapports ne sont pas visibles. J'ai eu le même pb en 2009
http://sourceforge.net/mailarchive/foru … nth=200907

Je vais voir avec GloW si il peut installer le "vieux" Kghostview (2009)
https://launchpad.net/ubuntu/hardy/amd64/kghostview

et même kprinter pour imprimer

Hors ligne

#7 Le 06/01/2013, à 23:30

J5012

Re : Knoda - comment obtenir un paquet fonctionnant sous Ubuntu 12.04

salut, perso j'ai cherche avec google (je suis en u12.04 64b/unity-2d) : knoda.deb :
http://pkgs.org/ubuntu-10.04/ubuntu-uni … 6.deb.html
comme je suis en 64b , j'ai pris le lien suivant :
http://pkgs.org/ubuntu-10.04/ubuntu-uni … 4.deb.html

son execution avec gdebi donne une dependance manquante que je n'ai pas cherche a obtenir :

Erreur : La dépendance ne peut être satisfaite : kdelibs4c2a (>= 4:3.5.9)

edit : la libs kde4 ici : https://launchpad.net/ubuntu/oneiric/+p … delibs4c2a

Dernière modification par J5012 (Le 06/01/2013, à 23:35)

En ligne

#8 Le 06/01/2013, à 23:35

servius

Re : Knoda - comment obtenir un paquet fonctionnant sous Ubuntu 12.04

Merci à Robert Leleu pour les infos! Je vais examiner cela à partir de demain.

Merci à J5012 : mais j'ai déja suivi cette piste et j'ai renoncé face au nombre de dépendances manquantes...

Hors ligne

#9 Le 06/01/2013, à 23:39

J5012

Re : Knoda - comment obtenir un paquet fonctionnant sous Ubuntu 12.04

je crois que c'est parce qu'il n'y avait plus de mainteneur developpeur pour faire evoluer le paquet : passer de kde3 kde4 puis kde5

sur u12.04 c'est kde5 que j'ai ... le lien que j'ai indique : knoda.deb est pour kde4 alors qu'a l'origine de sf c'est kde3
avec un peu de temps comme u12.04 est une lts, on aura un knoda.deb avec les dependances kde5 ...

En ligne

#10 Le 07/01/2013, à 10:42

GloW

Re : Knoda - comment obtenir un paquet fonctionnant sous Ubuntu 12.04

@servius et J5012, comme je l'ai déjà expliqué, il est possible d'installer knoda sur la dernière version d'ubuntu quantal.

la liste des paquets est la suivante :
kdelibs4c2a_3.5.10.dfsg.1-3ubuntu2.10.04.1_amd64
kdelibs-data_3.5.10.dfsg.1-3ubuntu2.10.04.1_all
knoda_0.8.3-3ubuntu2_amd64
libavahi-qt3-1_0.6.25-1ubuntu6.2_amd64
libdb4.8_4.8.24-1ubuntu1_amd64
libhk-classes15ldbl_0.8.3-7build1_amd64
libhk-classes-mysql_0.8.3-7build1_amd64
libhk-kdeclasses7_0.8.3-3ubuntu2_amd64
libmysqlclient16_5.1.66-0ubuntu0.10.04.3_amd64
libpython2.6_2.6.5-1ubuntu6.1_amd64
libqt3-mt_3.3.8-b-6ubuntu2_amd64
python2.6_2.6.5-1ubuntu6.1_amd64
python2.6-minimal_2.6.5-1ubuntu6.1_amd64
python-hk-classes_0.8.3-7build1_amd64

tous disponibles directement sur http://packages.ubuntu.com/, (bien choisir lucid)

je les ai réuni dans une tar ball pour se simplifiez la vie ici : http://www.2shared.com/file/azfgCAMM/kn … 64bit.html, voir mon message précédent.


effectivement il n'y aura plus d'évolution pour les paquets knoda, n'empeche qu'il sont toujours utilisable.

Dernière modification par GloW (Le 07/01/2013, à 18:24)

Hors ligne

#11 Le 07/01/2013, à 18:24

GloW

Re : Knoda - comment obtenir un paquet fonctionnant sous Ubuntu 12.04

Avec rleleu, nous avons resolu tout les bugs présent dans les dernières versions de knoda, en particulier les bugs "hk_classes-python", "preview report" et "kprinter".

J'ai ainsi fait un résumé du processus d'installation ici :http://forum.kde.org/viewtopic.php?f=221&t=109542
Une tar ball qui contient tout le nécessaire pour installer knoda sur Ubuntu 12.* ou Linux Mint 14 est disponible ici : http://www.2shared.com/file/azfgCAMM/kn … 64bit.html

voici la liste exhaustive de tout les packages necessaire pour installer knoda :
from lucid :
kdelibs4c2a_3.5.10.dfsg.1-3ubuntu2.10.04.1_amd64
kdelibs-data_3.5.10.dfsg.1-3ubuntu2.10.04.1_all
knoda_0.8.3-3ubuntu2_amd64
libavahi-qt3-1_0.6.25-1ubuntu6.2_amd64
libdb4.8_4.8.24-1ubuntu1_amd64
libhk-classes15ldbl_0.8.3-7build1_amd64
libhk-classes-mysql_0.8.3-7build1_amd64
libhk-kdeclasses7_0.8.3-3ubuntu2_amd64
libmysqlclient16_5.1.66-0ubuntu0.10.04.3_amd64
libpython2.6_2.6.5-1ubuntu6.1_amd64
libqt3-mt_3.3.8-b-6ubuntu2_amd64
python2.6_2.6.5-1ubuntu6.1_amd64
python2.6-minimal_2.6.5-1ubuntu6.1_amd64
python-hk-classes_0.8.3-7build1_amd64
gs_8.71.dfsg.1-0ubuntu5.5_all

from hardy :
kdeprint_3.5.9-0ubuntu7_amd64
kghostview_3.5.10-0ubuntu1~hardy1.1_amd64

voir le message sur le forum de kexi pour plus de details, en particulier en ce qui concerne le launcher de knoda pour eviter le bug de hk_classes-python.

Dernière modification par GloW (Le 07/01/2013, à 18:27)

Hors ligne

Haut de page ↑