Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 04/01/2013, à 18:47

Zedex

Installer Qt 5.0

Bien le bonjour !
Je souhaiterais commencer à utiliser la bibliothèque Qt, mais je ne parviens pas à l'installer sur mon ordinateur. A partir du site Qt j'ai téléchargé et installé Qt Creator qui semble bien fonctionner (je ne peux juste pas créer de projet car qt n'est pas installé).
J'ai alors téléchargé Qt 5.0.0 au format .tar.gz et effectué les commandes suivantes :

cd Téléchargements
tar -zxvf qt-everywhere-opensource-src-5.0.0.tar.gz
cd qt-everywhere-opensource-src-5.0.0
sudo ./configure

Et ensuite je ne peux plus rien faire car aucun makefile n'est créé (un qmake, mais je suppose qu'il est destiné à Qt créator). J'ai essayé avec Qt 4.8.4 mais c'est la même chose. Je ne sais pas si c'est de chez eux ou de chez moi, mais je rencontre aussi des difficultés avec mon ordinateur sous windows (il ne compile tout bonnement pas).

Avez-vous des idées/solutions ? Je vous en remercie profondément d'avance smile

P.S.: je fonctionne avec ubuntu 10.04

Hors ligne

#2 Le 05/01/2013, à 09:35

J5012

Re : Installer Qt 5.0

pourquoi te compliquer a compiler le source ?
http://qt-project.org/downloads

Hors ligne

#3 Le 05/01/2013, à 21:04

Zedex

Re : Installer Qt 5.0

J'ai essayé d'installer les fichiers .run suivant ce post mais je n'arrive pas à l'installer :

cedric@cedric-laptop:~$ cd Téléchargements/
cedric@cedric-laptop:~/Téléchargements$ sudo qt-linux-opensource-5.0.0-x86-offline.run 
[sudo] password for cedric: 
sudo: qt-linux-opensource-5.0.0-x86-offline.run: command not found

cedric@cedric-laptop:~/Téléchargements$ sudo sh qt-linux-opensource-5.0.0-x86-offline.run 
qt-linux-opensource-5.0.0-x86-offline.run: 1: ELF4K4: not found
qt-linux-opensource-5.0.0-x86-offline.run: 2: Syntax error: Unterminated quoted string

Pourtant, j'ai déjà réussi à installer des .run

Hors ligne

#4 Le 05/01/2013, à 22:00

J5012

Re : Installer Qt 5.0

quand tu lances un binaire a partir du terminal, le systeme va le chercher dans la serie de chemins indiques par /etc/environment , et le chemin relatif courant n'y es pas indique, donc tu dois l'indiquer meme si tu t'y trouves !
sudo ./qt-linux-etc

Hors ligne

#5 Le 08/01/2013, à 10:01

Zedex

Re : Installer Qt 5.0

Cette fois, le message d'erreur est différent, mais cela ne fonctionne toutjours pas.

cedric@cedric-laptop:~/Téléchargements$ sudo ./qt-linux-opensource-5.0.0-x86-offline.run 
[sudo] password for cedric: 
./qt-linux-opensource-5.0.0-x86-offline.run: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./qt-linux-opensource-5.0.0-x86-offline.run)

Hors ligne

#6 Le 08/01/2013, à 10:15

J5012

Re : Installer Qt 5.0

une dependance so.6 ! as-tu le paquet libstdc++6 ? version mini 3.4.15
sous u12.04 j'ai la libstdc++6 version 4.6.3

Hors ligne

#7 Le 08/01/2013, à 10:17

Zedex

Re : Installer Qt 5.0

Alors là, je ne saurais te dire...

Hors ligne

#8 Le 08/01/2013, à 10:30

J5012

Re : Installer Qt 5.0

ben tu regarde dans synaptic, ou tu listes avec dpkg -l ?

Hors ligne

#9 Le 08/01/2013, à 10:39

Zedex

Re : Installer Qt 5.0

Dans Synaptic, il semblerait que j'ai d'installé libstdc++6-4.4 (version la plus récente pour la distribution apparemment).

Hors ligne

#10 Le 08/01/2013, à 11:05

J5012

Re : Installer Qt 5.0

libstdc++6-4.4 ? tu veux dire : libstdc++6 4.4 ?

ha oui je vois : libstdc++6-4.4 est en fait une version dev qui depend de libstdc++6
es-tu en 32b ? ou 64b ? tu as telecharge la version qt5 32b ...

si 32b la libs doit etre 32b et qt5 aussi
si 64b la libs doit etre 64b et qt5 aussi

Hors ligne

#11 Le 08/01/2013, à 11:07

Zedex

Re : Installer Qt 5.0

Là par contre j'ai bien téléchargé la version 32b, qui correspond à ma version. Pour la lib je ne sais pas, mais je pense qu'il l'a fait automatiquement.

Dernière modification par Zedex (Le 08/01/2013, à 11:08)

Hors ligne

#12 Le 08/01/2013, à 11:13

J5012

Re : Installer Qt 5.0

non la lib c'est ton systeme !

que raconte la commande : dpkg -l libstdc++6

Hors ligne

#13 Le 08/01/2013, à 11:17

Zedex

Re : Installer Qt 5.0

cedric@cedric-laptop:~$ dpkg -l libstdc++6
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom            Version        Description
+++-==============-==============-============================================
ii  libstdc++6     4.4.3-4ubuntu5 The GNU Standard C++ Library v3

Hors ligne

#14 Le 08/01/2013, à 21:28

J5012

Re : Installer Qt 5.0

perso j'ai teste hier soir avant coucher et j'ai meme pas eu a faire sudo ! ca a marche (j'avais coche l'option executable) ...
je suis sous u12.04 64b, et j'ai donc telecharge qt5 64b

ha mais quel bete! je viens de voir ton erreur ci-dessus : il rouspete sur la glibcxx 3.4.15 qui doit etre presente pour que la libstdc++6 fonctionne  : je n'en ais pas tenu compte car dans ma config il est inconcevable d'avoir des libstdc++ sans glibc (j'avais pris le xx pour une sous-version alors que ca faisait partie du nom) ...

une discussion sur le forum arch permettra peut-etre d'avancer :
https://bbs.archlinux.org/viewtopic.php?pid=1065388

en resume : la personne a trouve une libstdc++6 aussi bien dans /usr/lib que dans lib mais sa commande strings qui permet de fouiller l'interieur d'une lib n'a pas trouve la meme version glibcxx 3.4.15; selon elle le chemin /lib avait priorite sur le chemin /usr/lib, et je crois qu'elle est en 32b parce que j'ai un chemin /usr/lib/x86_64-linux-gnu et pas elle ...

Hors ligne

#15 Le 10/01/2013, à 10:56

Zedex

Re : Installer Qt 5.0

En fait il faudrait que j'(ré)installe glibcxx 3.4.15 ? J'ai regardé ton lien et vois à partir d'où il arrive à corriger son erreur, mais pas comment.

Hors ligne

#16 Le 10/01/2013, à 21:25

J5012

Re : Installer Qt 5.0

non la glibcxx 3.4.15 n'est pas un paquet qu'on installe, elle fait partie du code binaire de la libstdc++6 , et elle peut se voir avec la commande : strings

regarde juste dans ton dossier /lib si il n'y a pas de libstdc++6 comme il y en a un dans /usr/lib

si oui alors il est possible que tu tombes dans le meme cas que cette personne : a savoir un conflit de versions libstdc++6 , l'une contenant une glicxx 3.4.15 , et l'autre non ! (dans le contexte de cette personne, le dossier /lib semblait avoir priorite d'execution sur la /usr/lib)

Hors ligne

#17 Le 12/01/2013, à 13:07

Zedex

Re : Installer Qt 5.0

J'ai fait des recherches dans les dossiers /usr/lib et dans /lib, et voici les résultats : il semblerait que je n'ai pas les fichiers libstdc++6 dans mon /lib. En effet j'ai trouvé dans /usr/lib 4 fichiers (en cherchant libstd via Nautilus) :

  • libstdc++.a

  • libstdc++.so

  • libstdc++.so.6

  • libstdc++.so.6.0.13

Mais rien dans /lib.
(J'ai tenté d'effectuer une recherche avec la console, mais comme je ne maitrise pas vraiment je n'ose afficher les résultats).

Dois-je les copier dans /lib ?

[EDIT 1 :] J'ai copié le fichier libstdc++.so.6.0.13 (les autre "n'existant pas"), mais rien n'y fait, j'ai toujours la même erreur sur glibcxx :

./qt-linux-opensource-5.0.0-x86-offline.run: /usr/lib/libstdc++.so.6: version
`GLIBCXX_3.4.15' not found (required by./qt-linux-opensource-5.0.0-x86-offline.run)

[EDIT 2 :]

cedric@cedric-laptop:~/Téléchargements$ strings /usr/lib/libstdc++.so.6
| grep GLIBC
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBC_2.0
GLIBC_2.3
GLIBC_2.4
GLIBC_2.1
GLIBC_2.3.4
GLIBC_2.1.3
GLIBC_2.3.2
GLIBC_2.2
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH

[EDIT 3 :] En suivant ce tutoriel et notamment de ces lignes de code :

sudo add-apt-repository ppa:ubuntu-toolchain-r/test 
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Finalement l'installation s'est lancée. Merci beaucoup pour ton aide J5012 !

Dernière modification par Zedex (Le 14/01/2013, à 23:26)

Hors ligne