Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 15/09/2009, à 11:44

theculte121

Langue clavier / partage synergy

Bonjour,

Je suis plutôt novice sur ubuntu, et je viens de me monter une machine sous la version 9.04.

J'ai un pc sous windows XP, et un pc Ubuntu connectés tous les deux à une freebox, et en filaire RJ45 pour plus de rapidité avec synergy. Mon clavier et ma souris sont donc connectés sur mon poste windows et partagé par synergy au poste sur ubuntu.

Seulement, je n'arrive pas à utiliser les caractère spéciaux sur ubuntu tels que le @ par exemple. Je suis donc allé explorer la configuration clavier qui est "USA".
J'ai donc forcément commencé par la et j'ai ajouté la langue français et mon clavier dans cette interface, seulement, lorsque je réalise ces modifications, mon clavier passe en qwerty (alors que je choisi bien français).
Je trouve étrange d'ailleurs que ma configuration de base "USA" soit en AZERTY.

J'ai cherché pas mal d'informations, j'en ai trouvé beaucoup concernant les claviers, mais aucune spécifiquement avec l'utilisation de synergy en partage de clavier.

Aussi, quelqu'un aurait il rencontré ce genre de désagréments avec une telle configuration, ou avez vous une idée ?

Pour information dans mon fichier xorg.conf, le clavier est configuré par Defaut en "Keybord0" et j'ai juste une autre ligne "keybord", pas de ligne pour placer le "fr" (comme je l'ai lu sur d'autres post). Je n'ai pas osé modifier ce fichier, pensant que l'utilisation de synergy ne nécessitait peu être pas de modifications au niveau de ce fichier.

Bref plutôt que de faire une bêtise, je préfère demander conseil.

D'avance merci s'il vous est possible de m'aider/m'aiguiller.

Hors ligne

#2 Le 16/09/2009, à 21:12

theculte121

Re : Langue clavier / partage synergy

Je me permets un petit up, car je n'arrive pas à venir à bout de ce problème.

Hors ligne

#3 Le 14/11/2009, à 16:10

denix

Re : Langue clavier / partage synergy

3Sqlut 0 tous<

Comme vous le voyez ci−dessus c'est la meme chose pour moi...

Depuis Synergy, le clavier est en qwerty.

Si quelqu'un a la solution, je suis preneur...

Merci par avance.


Systeme Multiscreen − Dual Os
Dell XPS16 − Vista − Bi ecran 23" wide par Matrox Triple Head
Acer E800−CB72 − Ubuntu Karmic Koala − 1 ecran 23" wide
Synergy pour partage clavier souris

Hors ligne

#4 Le 11/02/2010, à 10:29

diabs

Re : Langue clavier / partage synergy

Salut

bon ce topic date de quelques mois cela dit, j'avais le même soucis et j'ai trouvé une solution (pour moi en tt cas)

Je tourne sur une debian avec KDE als je ne sais pas si la solution (ridicule de simplicité) fonctionnera pour tt le monde.

Mon clavier etait bien en AZERTY sur ma debian, cependant sous KDE je n'avais activé l'option "keyboard layout" pour passer le clavier en FR. (logique vous me direz, puisque le clavier etait deja configuré en FR sous Xorg)
Et bien, le simple fait de forcer le FR dans KDE a réglé mon probleme.

voila

Hors ligne

#5 Le 31/03/2011, à 16:54

neoby

Re : Langue clavier / partage synergy

Bonjour à tous,

Je viens de me heurter exactement au même problème que décrit dans le premier post.
En fouillant le net, il semble que ça puisse provenir d'un bug xorg qui ne prend pas au sérieux le changement de layout clavier effectué dans le gestionnaire de fenêtre. Pour moi, il a suffit de taper dans la console :
  $setxkbmap fr
pour régler le problème (vous pouvez bien sûr l'ajouter à votre .bashrc ou équivalent)

Bonne continuation

Ps my2cents :
Je me suis inscrit même si je ne suis pas spécialement ce forum. Étant donné que ce thread est le premier résultat google pour "synergy azerty" et que je déteste ce picotement quand on trouve une discussion décrivant mot pour mot le problème mais ne donnant pas de solution fonctionnelle...

Hors ligne

#6 Le 16/10/2011, à 11:49

seblem

Re : Langue clavier / partage synergy

@neoby, merci ça a résolu le même soucis que je rencontrais.
Pour info cela fonctionnait tres bien entres deux 11.04 et le problème est apparu lors de la migration d'un de mes deux Pcs vers la 11.10.

Hors ligne

#7 Le 11/01/2012, à 00:27

martin.sam

Re : Langue clavier / partage synergy

Idem avec mon clavier Logitech G510. J'utilise Windows 7 en tant que serveur pour bénéficier des macros et d'un support total. En revanche côté client - Ubuntu le mapping clavier est en qwerty, très ennuyeux donc.

J'utilise côté client quicksynergy 1.3.8 et côté serveur la version 1.4.5 beta

Hors ligne

#8 Le 13/01/2012, à 02:44

martin.sam

Re : Langue clavier / partage synergy

J'ai désormais un parfait mapping des touches entres  mes deux machines.

Machine Serveur : Windows 7 ultimate , clavier logitech G510, GamePanel installé
Machine Cliente : Linux Ubuntu 11.10.

Il y a eu deux moments,et malheureusement je suis incapable de définir le paramètre responsable. Suite à l'installation de synergy et quelques tests, je me suis retrouvé avec un clavier qwerty côté  client. Après un redémarrage et quelques "bidouilles hasardeuses" je me suis retrouvé avec un mapping azerty des deux côtés, avec pour grande différence l'absence totale des accents côtés "client"  et pas mal de petit détail comme l'accès aux accolades.

Dans Paramètres systèmes > Clavier > Saisie > Paramètres d'agencement je me suis rendu compte que c'est c'était un joyeux bordel, lorsque j'appuyais sur la touche "a" au clavier je percevais sur l'écran virtuel la touche "q" s'enfoncer, même si dans un bloc note la touche "a" était imprimée. Bref pas évident de comprendre le problème. Au hasard j'ai changé de clavier pour passer à "Anglais (Cameroun, qwerty)   et là MIRACLE j'ai le bon mapping côté client synergy.

NOTE : Si maintenant je branche physiquement un clavier azerty côté PC client, c'est désormais un clavier qwerty qui est reconnu, alors que l'émulation du clavier synergy est lui compris à l'envers c'est à dire en azerty.. Va comprendre..

Hors ligne

#9 Le 09/01/2013, à 13:53

Laloi

Re : Langue clavier / partage synergy

neoby a écrit :

Bonjour à tous,

Je viens de me heurter exactement au même problème que décrit dans le premier post.
En fouillant le net, il semble que ça puisse provenir d'un bug xorg qui ne prend pas au sérieux le changement de layout clavier effectué dans le gestionnaire de fenêtre. Pour moi, il a suffit de taper dans la console :
  $setxkbmap fr
pour régler le problème (vous pouvez bien sûr l'ajouter à votre .bashrc ou équivalent)

Bonne continuation

Ps my2cents :
Je me suis inscrit même si je ne suis pas spécialement ce forum. Étant donné que ce thread est le premier résultat google pour "synergy azerty" et que je déteste ce picotement quand on trouve une discussion décrivant mot pour mot le problème mais ne donnant pas de solution fonctionnelle...

Merci beaucoup ! Ce problème vient de m'arriver (alors que tout fonctionnait parfaitement depuis 2 ans), et la commande $setxkbmap fr dans l'ordinateur client a résolu mon problème !

[Edit] En fait pour que ça fonctionne, je dois redémarrer le client (synergyc) après avoir tapé la commande (sinon je me retrouve avec un clavier allemand). Et comme le killall nécessite un sudo, je ne trouve pas comment le faire automatiquement à chaque démarrage.

Dernière modification par Laloi (Le 09/01/2013, à 14:46)

Hors ligne

Haut de page ↑