Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash vient d'être divulguée, il est recommandé de mettre à jour son système (plus de détails)

*** 28 sept. nouvelle mise à jour (4.2-2ubuntu2.5 ou 4.3-7ubuntu1.4) *** pour mettre à jour, lancez dans un terminal :
sudo apt-get update ; sudo apt-get upgrade bash

#1 Le 14/11/2011, à 23:47

JessicoAlbo

[Résolu] Pas de son HDMI avec Ubuntu 11.10 et "RS880 Audio Device"

Salut,

Je viens de trouver la solution à mon problème sur le forum anglophone askubuntu.com. Elle est simplissime, même pour un gros débutant comme moi, mais il m'a fallu plusieurs jours avant de trouver les bons mots-clés qui m'y ont fait tomber dessus. Comme je n'ai pas vu que cette solution a été proposée ici, je la poste en décrivant en détail ma configuration, en espérant qu'ainsi ceux qui auront le même problème que moi seront orientés dessus durant leurs recherches.

Alors voilà, j'ai un écran lcd Iiyama ProLite B2409HDS qui possède des hauts-parleurs intégrés. Problème : après installation de Ubuntu 11.10 Oneiric Ocelot 64 bits, avec l'écran connecté en HDMI à mon pc, j'obtenais l'image mais aucun son.
Ma carte-mère est une Asus M5A88-V EVO. Elle possède un chipset northbridge AMD 880G (nom de code RS880) qui intègre un processeur graphique ATI Radeon HD 4250 et utilise un CODEC audio Realtek ALC892.
Avec cette configuration, dans Paramètres système --> Son --> Matériel --> Sélectionner un périphérique à configurer, j'ai deux périphériques :

  • Audio interne, pour lequel je peux paramétrer plusieurs profils de sorties analogiques ;

  • RS880 Audio Device [Radeon HD 4200], pour lequel il n'y a qu'un profil possible : Sortie numérique (HDMI) Output, que je peux activer ou éteindre.

Les sorties analogiques marchent sans problème, mais le test des hauts-parleurs sur la sortie HDMI ne donne aucun son.

Pour les moins anglophones, voici une traduction de la résolution du problème trouvée ici  :

  1. Ouvrir le terminal et taper :

     sudo gedit /etc/default/grub 
  2. Dans l'éditeur, changer la ligne :

     GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 
  3. en :

     GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1" 
  4. Enregistrer la modification, et taper dans le terminal :

     sudo update-grub 
  5. Réamorcer.

En espérant que ça marche pour vous comme ça a marché pour moi…

(PS : l'explication donnée dans le post original est que « l'audio HDMI est désactivé par défaut dans le kernel 3.0+ car il entraîne un écran noir sur certains moniteurs ».)


Ubuntu 14.04 LTS Trusty Tahr ; clavier TypeMatrix 2030 ; Bépo avec modif perso

Hors ligne

#2 Le 07/11/2012, à 12:00

desi

Re : [Résolu] Pas de son HDMI avec Ubuntu 11.10 et "RS880 Audio Device"

Merci pour l'astuce!!
A+

Hors ligne

#3 Le 07/11/2012, à 12:39

JessicoAlbo

Re : [Résolu] Pas de son HDMI avec Ubuntu 11.10 et "RS880 Audio Device"

Re-salut !

Puisque j'ai le plaisir de voir que que ça a marché pour au moins une personne d'autre que moi, j'en profite pour ajouter que je viens d'installer Ubuntu 12.04 LTS Precise Pangolin et que j'ai dû refaire exactement la même manip et que ça marche tout aussi bien.
En espérant que ça vous soit utile…


Ubuntu 14.04 LTS Trusty Tahr ; clavier TypeMatrix 2030 ; Bépo avec modif perso

Hors ligne

#4 Le 07/11/2012, à 12:47

JessicoAlbo

Re : [Résolu] Pas de son HDMI avec Ubuntu 11.10 et "RS880 Audio Device"

Pardon, soyons précis : dans la version 12.04, la sortie audio idoine s'appelle désormais :

"HDMI / DisplayPort
RS880 HDMI Audio [Radeon HD 4200 series]"

Voilà.


Ubuntu 14.04 LTS Trusty Tahr ; clavier TypeMatrix 2030 ; Bépo avec modif perso

Hors ligne

#5 Le 08/11/2012, à 17:03

desi

Re : [Résolu] Pas de son HDMI avec Ubuntu 11.10 et "RS880 Audio Device"

Salut JessicoAlbo,

Moi j'ai la dernière ubuntu 12.10 avec exactement la même manip que tu as décrite, et tout bon comme soluce!

Merci

Hors ligne

#6 Le 08/11/2012, à 22:56

JessicoAlbo

Re : [Résolu] Pas de son HDMI avec Ubuntu 11.10 et "RS880 Audio Device"

Salut desi,

et merci, j'en prends bonne note, pour quand je passerai en 12.10. Il m'a fallu 6 mois pour me décider pour Precise, donc pas tout de suite… C'est trop de sueurs froides pour un nulos comme moi smile

À +


Ubuntu 14.04 LTS Trusty Tahr ; clavier TypeMatrix 2030 ; Bépo avec modif perso

Hors ligne

#7 Le 10/01/2013, à 15:40

Lifesaver

Re : [Résolu] Pas de son HDMI avec Ubuntu 11.10 et "RS880 Audio Device"

Chez moi ça n'a pas fonctionné...


Dell Studio 17, Core2Duo P8600, 4Go RAM, ATI HD3650 avec pilotes libres, Rosa Desktop Fresh 2012 64 bits KDE 4.9

Hors ligne

#8 Le 25/01/2013, à 19:21

s_Frantz

Re : [Résolu] Pas de son HDMI avec Ubuntu 11.10 et "RS880 Audio Device"

Merci pour la solution, je commençais à désespérer !
Ça marche chez moi pour une 12.10.
J'ai ajouté la manip' dans la doc.

Hors ligne

#9 Le 17/01/2014, à 14:19

dreamincoco

Re : [Résolu] Pas de son HDMI avec Ubuntu 11.10 et "RS880 Audio Device"

Bonjour,

J'ai un portable Toshiba Tecra r950 avec une ATI 7570M et j'utilise Ubuntu 13.10. La sortie DisplayPort n'avait pas l'audio, j'ai donc fait la manip indiquée sur la config de GRUB et ça marche très bien, la sortie audio apparaît dans les paramètres de son (j'ai juste à switcher quand j'utilise la sortie DisplayPort, typiquement quand je branche le portable sur ma TV).

Par contre lorsque je ferme l'écran de mon portable la sortie DisplayPort se coupe aussi, ça doit être lié à l'extinction de l'écran qui se produit à ce moment-là. Savez-vous comment résoudre ce problème (éteindre l'écran du portable sur fermeture mais conserver la sortie DisplayPort) ?

Merci d'avance pour votre aide.

Dernière modification par dreamincoco (Le 17/01/2014, à 14:19)

Hors ligne

#10 Le 17/01/2014, à 14:31

dreamincoco

Re : [Résolu] Pas de son HDMI avec Ubuntu 11.10 et "RS880 Audio Device"

Bon je me réponds à moi même smile

J'ai résolu le problème tout bêtement en utilisant une souris externe : lorsque je ferme l'écran du portable la sortie DisplayPort se coupe aussi mais si ensuite je clique avec une souris externe (pas le choix vu que lorsque l'écran est fermé le pavé tactile et le clavier sont inaccessibles), l'image réapparaît sur ma TV. J'imagine que ça marche aussi avec un clavier externe.

C'est un peu bizarre mais ça me va, pb résolu pour de bon !

Hors ligne

Haut de page ↑