Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 09/01/2013, à 17:44

Mobidique

[RESOLU] Wine : pulseaudio occupe 50% du proc

'jour,

J'ai installé à mon gamin mon vieux P4 2.66 GHz avec 1GO de RAM et une carte ATI AGP assez récente pour être prise en charge par le pilote proprio FRGLX. La machine sous XP faisait tourner sans pb Dungeon siege.

J'y met Wine 1.5.20 et j'y installe Dungeon siege, sans pb. J'y joue un peu dimanche : ha ça c'est pas la fête du FPS, ça culmine à 13 FPS avec quasi tout au min (640*480*16, pas d'ombre filtre bilinéaire rien en dessous de toute façon, textures au plus bas).

Aujourd'hui mon gamin se le lance, puis viens me voir "Pôpa, ça rame
- Oui non mais c'est normal mais ça reste jouab'
- Oui mais non. "
Je vais voir  : 6FPS et non c'est pas jouab'. Je lance le gestionnaire des tâches (xubuntu (voyager) 12.04 i686 inside) : pulseaudio --start -logblablabla => 50% CPU
Ca va pas du tout ça. D'autant que c'est pas systématique, des fois c'est comme la première fois ~13 FPS et dans ce cas pulseaudio n'est pas à 50%

Sur LOTRO , il y a quelques temps, sur ma propre machine, j'utilisais OSS préférentiellement à ALSA. Aujourd’hui, je ne peux plus faire ce choix dans winecfg.

Bref :
Est-ce que quelqu'un a déjà rencontré ce pb ? C'est quoi le pb avec pulseaudio ?
Quelle soluce envisageable ? L'utilisation d'OSS voire OSS4 est-elle préférable à ALSA ? est-ce qu'il faut virer PulseAudio pour utiliser ALSA directement voire OSS (ou OSS4) ?

A noter que je n'ai rien installé de plus que wine sur le PC de mon gamin. Je veux dire par là que je n'ai pas fait un tour par winetrick pour installer les vcrun2003, vcrun2005, vcrun2008 et dx3dx9. Est-ce que ça arrangerait le truc ? J'ai l'intention de regarder cela ce soir, si j'ai le temps ...

Merci d'avance pour toute aide
@+

Dernière modification par Mobidique (Le 14/01/2013, à 15:11)


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

Hors ligne

#2 Le 09/01/2013, à 17:57

abelthorne

Re : [RESOLU] Wine : pulseaudio occupe 50% du proc

Il me semble qu'on peut choisir la sortie son (ALSA, OSS...) en passant par Winetricks.

Hors ligne

#3 Le 09/01/2013, à 18:38

Mobidique

Re : [RESOLU] Wine : pulseaudio occupe 50% du proc

HA !
Je vais regarder cela, merci.


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

Hors ligne

#4 Le 10/01/2013, à 16:18

Mobidique

Re : [RESOLU] Wine : pulseaudio occupe 50% du proc

J'ai installé vcrun2003, vcrun2005, vcrun2008 et dx3dx9 : rien de mieux

J'ai comparé avec mon dell studio 17, T4300 2.1 Ghz (dual core) 4GO, ati HD4650 (je crois) xubuntu (voyager) amd64 : pulseaudio tourne toujours à moins de 10%. Ok les proc n'ont pas du tout les mêmes puissance et 10% au plus chez l'un peut occuper l'autre à 50%, mais tout de même ça me paraît énorme comme différence. Hardware mis à part, tout est identique entre les 2 OS sauf le fait d'avoir un i686 d'un coté et un amd64 de l'autre, dans ce dernier wine est forcé dans une architecture 32bits via un WINEARCH=32.

Pas trouvé le forçage d'OSS dans winetricks. Je m'y replonge ce soir. HA oui : je trouve moche qu'un PGM qui marche probablement bien sous XP sur la machine marche pas bien avec Wine, m'enfin bon ...


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

Hors ligne

#5 Le 10/01/2013, à 17:16

abelthorne

Re : [RESOLU] Wine : pulseaudio occupe 50% du proc

Mobidique a écrit :

Pas trouvé le forçage d'OSS dans winetricks. Je m'y replonge ce soir.

1) Select the default wine prefix (pour choisir le préfixe : ~/.wine par défaut, à exporter via $WINEPREFIX si tu utilises un autre dossier avant de lancer Winetricks)
2) Change settings
Là, dans les paramètres, tu as "sound=alsa", "sound=oss", etc.

HA oui : je trouve moche qu'un PGM qui marche probablement bien sous XP sur la machine marche pas bien avec Wine, m'enfin bon ...

Tu compares le fonctionnement d'un jeu dans l'environnement pour lequel il est prévu avec le fonctionnement dans un environnement qui n'est pas censé le faire tourner, qui simule le bon comme il peut, avec la gestion des graphismes et du son complètement différents...
Faut bien être conscient que Wine c'est de la bidouille aux résultats complètement aléatoires. Si tu veux que tes jeux Windows tournent comme attendu, le seul moyen fiable c'est de le faire sous Windows.

Hors ligne

#6 Le 11/01/2013, à 14:08

Mobidique

Re : [RESOLU] Wine : pulseaudio occupe 50% du proc

Oui je sais bien. J'avais plutôt eut de bonne surprise jusqu'à présent, des tomb raider qui s'installaient et tournaient direct, un lego star wars et lego batman qui tournent également probablement direct, LOTRO aussi, DDO, NWN2 ... mais bon tout ça c'est sur mon portable, je n'avais sans doute pas mesuré le travail réalisé par le proc ...

Merci pour le Winetricks.
@+


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

Hors ligne

#7 Le 14/01/2013, à 15:10

Mobidique

Re : [RESOLU] Wine : pulseaudio occupe 50% du proc

Back.

Winetricks permet de choisir si on rend le son par ALSA (défaut) ou OSS mais toujours en passant par pulsaudio apparemment, pas de contournement. Il existe sur WineHQ une astuce pour brancher direct wine sur ALSA sans passer par pulseaudio, mais à mettre en oeuvre à ses risque et péril (comme d'hab' quoi) avec le risque que d'autres programmes ne retrouvent plus leurs petits ... Comme le PC sert aussi à de la musique et de la lecture de DVD, je ne prend pas le risque de tout foutre en l'air ...

Au même endroit que le choix alsa/oss on peut aussi demander à ce que le rendu soit fait en OPENGL et spécifier la mémoire de la CG. J'ai demandé l'openGL et spécifié les 512 MO de la carte, d'un coup ça marche mieux, genre plus de 20 FPS dans l'interface de lancement du jeu, encore ~15 FPS dans le jeux sans le son et ~10 avec le son, c'est jouab'. Par contre ... Étrangeté ... Il faut commencer par lancer le jeu sans le son, commencer une nouvelle partie et ensuite ajouter le son ... Sinon on tombe à 6 FPS, plus jouab'. Plus fort. Si on lance le jeux sans le son (NB: c'est un raccourci qui existe à l'installation de Dungeon siege) et que l'on charge une partie là encore on est à 6 FPS. Il faut donc lancer le jeu sans le son, commencer une nouvelle partie, charger l'ancienne et finalement remettre le son.

8o

Bref, je passe cela en résolu ...

Dernière modification par Mobidique (Le 14/01/2013, à 18:07)


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

Hors ligne

#8 Le 19/02/2013, à 15:51

Mobidique

Re : [RESOLU] Wine : pulseaudio occupe 50% du proc

M'étant résolu à l'achat d'un second disque dur et à la réinstallation d'un XP SP2 (c'est ici) j'y ai installé Dungeon siege pour voir : 35 FPS en plein écran. Tant pis.


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

Hors ligne

#9 Le 28/02/2013, à 22:40

Mobidique

Re : [RESOLU] Wine : pulseaudio occupe 50% du proc

abelthorne a écrit :

Tu compares le fonctionnement d'un jeu dans l'environnement pour lequel il est prévu avec le fonctionnement dans un environnement qui n'est pas censé le faire tourner, qui simule le bon comme il peut, avec la gestion des graphismes et du son complètement différents...

DarkVador.jpg

Votre manque de foi me consterne ...

Blague à part ...
Après les modifs évoquées ici :
http://forum.ubuntu-fr.org/viewtopic.php?id=1205871
à savoir suppression de pulseaudio, installation de xvba-va-driver et je crois surtout désactivation du compositeur j'ai installé dungeon siege dans un wine 1.5.24, no pb et ça tourne dans un bureau 1024*768*32, tout à fond à 15 FPS bien constants.
C'est jouab', à l'aise.

@+


Xubuntu 12.04 LTS 64bits (voyager), job & home laptops.
Xubuntu 12.04 LTS x86 (voyager), son's desktop & wife's laptop.

Hors ligne

Haut de page ↑