Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 09/01/2013, à 14:00

Donald

Probleme installation Bumblebee.

Bonjour tout le monde !

Ca fait pas mal de temps que j'ai plus utilisé ubuntu donc là je m'y remet depuis que Steam a lancé son application sur linux.

En bref, je suis en train d'installer Bumblebee en suivant les démarches sur ce site : https://wiki.ubuntu.com/Bumblebee.
L'objectif étant de lancer les jeux Steam en utilisant Primus ( étant plus efficace que Optimus , comme indiqué ici : http://steamcommunity.com/app/221410/di … 395110175/ )

Malheureusement , arrivé a l'étape : sudo apt-get update , ca affiche :

E: Le type « ain » est inconnu sur la ligne 3 dans la liste des sources /etc/apt/sources.list.d/bumblebee-stable-precise.list
E: La liste des sources ne peut être lue.

Merci de m'aider ! smile

Hors ligne

#2 Le 09/01/2013, à 15:33

tiramiseb

Re : Probleme installation Bumblebee.

Et si tu éditais la ligne 3 du fichier /etc/apt/sources.list.d/bumblebee-stable-precise.list en remplaçant "ain" par "main" ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

En ligne

#3 Le 09/01/2013, à 15:56

Donald

Re : Probleme installation Bumblebee.

Ça n'a pas marché en remplaçant "ain" par "main", par contre , ça a marché en supprimant carrément la ligne .

Merci pour le coup de main smile

Maintenant je voudrais savoir si possible comment faire pour installer Primus de manière simple ^^

Hors ligne

#4 Le 09/01/2013, à 16:00

tiramiseb

Re : Probleme installation Bumblebee.

Je ne sais pas.
J'ai trouvé cette page sur le net :
http://www.webupd8.org/2012/11/primus-b … -less.html


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

En ligne

#5 Le 09/01/2013, à 16:30

Donald

Re : Probleme installation Bumblebee.

D'accord je suis les instructions et je te dirais ce qu'il en est smile

Merci pour le coup de main !

Hors ligne

#6 Le 09/01/2013, à 16:51

Donald

Re : Probleme installation Bumblebee.

J'ai installé Primus et ça a l'air de fonctionner parce que " primusrun glxspheres " a fonctionné.

Par contre , " primusrun glxspheres " et " glxspheres " me donnent à peu près le même FPS hmm

A ton avis est ce que c'est due à la petite remarque dans le site " 64bit systems: to get 32bit applications to work with Primus on 64bit, also install the "primus-lib:i386" package "

Hors ligne

#7 Le 09/01/2013, à 17:04

tiramiseb

Re : Probleme installation Bumblebee.

Je ne sais pas. Désolé.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

En ligne

#8 Le 09/01/2013, à 18:03

GP974

Re : Probleme installation Bumblebee.

si les 2 stagne a 60 fps c'est normal primus limite le nombre de fps sur la syncro de l'ecran
pour eviter ca rajouter vblank_mode=0
ce qui donne

vblank_mode=0 primusrun glxspheres 

Ubunteros depuis 10.04 Restez libre avec Linux :)
Fixe : i7 i930@2.8ghz | 8go(1866Mhz) |Gtx 570@nvidia-340 | Samsung 840evo(120Go) | Ubuntu 12.04.4 & 14.04
Portable(asus N75SF) : i5 2410@2.3ghz | 8go(1333Mhz)  | IntelHD3000/GT555m@nvidia-340 | Vertex2(180go)| Arch & 12.04.4 & 14.10(dev)
Développeur de nvidiux

Hors ligne

#9 Le 09/01/2013, à 19:07

ArchangeGabriel

Re : Probleme installation Bumblebee.

Mais ça sert à rien à part pour du benchmark, car ton écran ne peut pas afficher plus de 60 fps de toutes façons. C'est un progrès de primus par rapport à optirun.

Hors ligne

#10 Le 11/01/2013, à 17:18

Donald

Re : Probleme installation Bumblebee.

J'ai effectivement essayé vblank_mode=0 primusrun glxspheres et mon FPS a boosté .
Par contre c'est après avoir installé le nouveau driver 310 pour Nvidia que j'ai eu pas mal de problemes.
Je n'arrive plus a lancer Steam , et quand je tape " glxspheres " , ca me met :

Polygons in scene: 62464
Xlib:  extension "GLX" missing on display ":0".
ERROR (593): Could not obtain RGB visual with requested properties

et c'est la meme chose avec " vblank_mode=0 primusrun glxspheres "

J'ai installé le driver pour Nvidia de maniere a ce qu'il marche avec Bumblebee en utilisant ce tutoriel : http://www.webupd8.org/2012/12/use-nvid … s-310.html

Est ce que le problème vient du driver et je dois donc le désinstaller ?

Hors ligne

#11 Le 11/01/2013, à 17:56

ArchangeGabriel

Re : Probleme installation Bumblebee.

Est-ce que ceci résout ton problème :

sudo apt-get install --reinstall bumblebee-nvidia

Hors ligne

#12 Le 22/09/2013, à 00:51

alex033

Re : Probleme installation Bumblebee.

Bonjour la communauté

Voici un rappel des faits :
Je possède un Asus N75S i5 avec la technologie Optimus (carte intel + geforce 635m)
J'installe Bumblebee je remarque que si je lance les applications tels que firefox avec la cmd optirun il y a les accélération 3D (120 mgp/sec contre 60 cf glxspheres)
Cependant dans les paramètres systèmes la carte Nvidia n'est pas reconnue
De plus, je n'arrive pas a bénéficier de ces performances sur steam. je peux lancer steam avec optirun mais après dans un jeu (ex Killing Floor), il n'y pas l'option carte 3D dans les paramètres, je ne peux qu'obtenir l'Opengl
J'ai essayé d'installé le pilote propriétaire avec Xorg sans succès.
En tout cas j'y est passé qq heures, j'ai appris des choses mais je butte sur un obstalce:(

Ma requête principale est de comprendre comment faire reconnaître la carte au système et de plus l'activer pour les jeux de steam
D'avance merci à ce qui ont réglé ou qui savent régler ce pb et de ne pas s'étaler sur des problèmes analogues, intéréssant mais que ne sont pas le sujet, merci de rester centré sur la requête

A++

Hors ligne

#13 Le 22/09/2013, à 07:14

GP974

Re : Probleme installation Bumblebee.

il faut aussi lancer tes jeux steam avec optirun et pas seulement steam lui meme


Ubunteros depuis 10.04 Restez libre avec Linux :)
Fixe : i7 i930@2.8ghz | 8go(1866Mhz) |Gtx 570@nvidia-340 | Samsung 840evo(120Go) | Ubuntu 12.04.4 & 14.04
Portable(asus N75SF) : i5 2410@2.3ghz | 8go(1333Mhz)  | IntelHD3000/GT555m@nvidia-340 | Vertex2(180go)| Arch & 12.04.4 & 14.10(dev)
Développeur de nvidiux

Hors ligne

#14 Le 22/09/2013, à 09:49

alex033

Re : Probleme installation Bumblebee.

Salut GP974,
Après avoir lancer stream via optirun, si je lance un jeu via le terminal ( en écrivant le chemin) ou si j'écris optirun dans les options de lancement de jeu le résultat est le même.
Je rajoute que la NVIDIA 635m n'est pas supporté par Ubuntu si l'on se fît au tableau des cartes graphiques supporteees par les version d'Ubuntu du site.
A+

Hors ligne

#15 Le 22/09/2013, à 10:09

GP974

Re : Probleme installation Bumblebee.

hum ok
quel est a la version de tes pilotes nvidia et quel version d'ubuntu utilise tu ?
a tu essayer avec primus ?


Ubunteros depuis 10.04 Restez libre avec Linux :)
Fixe : i7 i930@2.8ghz | 8go(1866Mhz) |Gtx 570@nvidia-340 | Samsung 840evo(120Go) | Ubuntu 12.04.4 & 14.04
Portable(asus N75SF) : i5 2410@2.3ghz | 8go(1333Mhz)  | IntelHD3000/GT555m@nvidia-340 | Vertex2(180go)| Arch & 12.04.4 & 14.10(dev)
Développeur de nvidiux

Hors ligne

Haut de page ↑