Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 12/01/2013, à 12:41

gigiair

$HOME trop sweet

Sous root, $HOME ne s'expanse pas correctement. (Ubuntu 12.04)

ubntjjr@lise:~$ whoami
ubntjjr
ubntjjr@lise:~$ echo $HOME
/home/ubntjjr
ubntjjr@lise:~$ sudo -s
[sudo] password for ubntjjr: 
root@lise:~# echo $HOME
/home/ubntjjr
root@lise:~# whoami
root

Ça peut être très embêtant . J'ai manqué quelque chose, ou il faut faire un rapport de bug ?

Si j'initialise une session root depuis le menu grub, je n'ai pas ce souci. $HOME s'expanse en /root.

Dernière modification par gigiair (Le 12/01/2013, à 12:43)


--
JJR.

Hors ligne

#2 Le 12/01/2013, à 12:51

f.x0

Re : $HOME trop sweet

Bonjour gigiair,

je ne pense pas que $HOME ne s'expanse pas correctement.
je crois que cela provient plutôt de sudo -s.

Testes ces commandes

ubntjjr@lise:~$ whoami
ubntjjr
ubntjjr@lise:~$ echo $HOME
/home/ubntjjr
ubntjjr@lise:~$ sudo -s
[sudo] password for ubntjjr: 
root@lise:~# whoami
root
root@lise:~# echo $HOME
/home/ubntjjr
ubntjjr@lise:~$ sudo -i
[sudo] password for ubntjjr: 
root@lise:~# whoami
root
root@lise:~# echo $HOME
/root
ubntjjr@lise:~$ sudo su
[sudo] password for ubntjjr: 
root@lise:~# whoami
root
root@lise:~# echo $HOME
/root

SOPI

Hors ligne

#3 Le 12/01/2013, à 12:57

gl38

Re : $HOME trop sweet

Ça m'a l'air normal, pour être vraiment root il y a sudo -i ou su.
Cordialement,
Guy

Hors ligne

#4 Le 12/01/2013, à 13:13

gigiair

Re : $HOME trop sweet

Réponse aux deux :
Sous Debian quand $USERi= root, j'ai toujours $HOME=/root, quelque soit la manière de se connecter.
Sous Ubuntu, c'est seulement quand je me connecte au boot.
Vous trouvez ça normal ? Comment je peux savoir dans mes scripts comment $HOME va s'expanser ?
Quel test faut-il faire  ?

Dernière modification par gigiair (Le 12/01/2013, à 13:13)


--
JJR.

Hors ligne

#5 Le 12/01/2013, à 13:38

gl38

Re : $HOME trop sweet

Il me semble que sudo fait ce qu'il y a dans le man.
C'est l'option -i qu'il te faut :

 -i [command]
                   The -i (simulate initial login) option runs the shell
                   specified in the passwd(5) entry of the target user as a
                   login shell.  This means that login-specific resource
                   files such as .profile or .login will be read by the
                   shell.  If a command is specified, it is passed to the
                   shell for execution.  Otherwise, an interactive shell is
                   executed.  sudo attempts to change to that user's home
                   directory before running the shell.  It also initializes
                   the environment, leaving DISPLAY and TERM unchanged,
                   setting HOME, SHELL, USER, LOGNAME, and PATH, as well as
                   the contents of /etc/environment on Linux and AIX systems.
                   All other environment variables are removed.

Cordialement,
Guy

Hors ligne

#6 Le 12/01/2013, à 13:58

f.x0

Re : $HOME trop sweet

En usage normal, sous debian le sudo n'est pas activé il me semble.

Le passage root se fait avec

su

SOPI

Hors ligne

#7 Le 12/01/2013, à 14:27

gigiair

Re : $HOME trop sweet

Sous Debian il suffit de déclarer le USER dans les sudoers.
Sous Ubuntu, il faut passer par sudo., sauf si on a attribué un mot de passe à root, ce qui n'est pas encouragé, je crois.
J'avoue ne pas avoir trop lu le man sudo.


--
JJR.

Hors ligne

#8 Le 12/01/2013, à 15:26

f.x0

Re : $HOME trop sweet

je ne suis pas sûr que cela soit la même chose
de déclarer le USER dans les sudoers
et de passer en root avec su.

Je pense que :
- déclarer le USER dans les sudoers → ami administrateur
- passer en root avec su → super administrateur


SOPI

Hors ligne

#9 Le 12/01/2013, à 15:44

gigiair

Re : $HOME trop sweet

Sous Debian, c'est exactement la même chose. Je suis désolé, mais c'est là ou je suis né. J'ai bien noté et je vais vivre avec, ce n'est pas un problème. Le problème c'est de l'ignorer. Grand merci de m'avoir informé.


--
JJR.

Hors ligne

#10 Le 12/01/2013, à 19:56

f.x0

Re : $HOME trop sweet

Je suis aussi sur Debian (wheezy) et J'ADORE ...

mais je n'y suis pas né.

C'est pour cela que j'écrivais je ne suis pas sûr et Je pense que.
Merci d'avoir éclairé ma lanterne.

En revanche c'est qui est quasi certain c'est que ce n'est pas le cas avec sudo (surtout sur Ubuntu).


SOPI

Hors ligne

Haut de page ↑