Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 11/01/2013, à 01:27

BABIS

Probleme de mise a jour

Bonjour,

Je débute avec linux et j'ai un soucis avec mes mises a jour.
Je suis sous la version 10.04 ubuntu et je ne peu pas passer a une autre car j'ai ce message quand je lance mes mises a jour:

Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dis … ackages.gz  404  Not Found
Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dis … ackages.gz  404  Not Found
Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dis … ackages.gz  404  Not Found
Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dis … ackages.gz  404  Not Found
Impossible de récupérer http://archive.ubuntu.com/ubuntu/dists/ … ackages.gz  404  Not Found [IP : 91.189.92.202 80]
Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Hors ligne

#2 Le 11/01/2013, à 02:09

xabilon

Re : Probleme de mise a jour

Salut

Tu as installé Ubuntu pour processeur ARM ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 11/01/2013, à 09:25

tiramiseb

Re : Probleme de mise a jour

Apparemment, si tu utilises un ordinateur basé sur un processeur ARM (c'est à dire pas Intel et pas AMD, donc pas un ordinateur classique), il faut utiliser les dépôts suivants :

deb http://ports.ubuntu.com/ lucid main restricted universe multiverse
deb http://ports.ubuntu.com/ lucid-updates main restricted universe multiverse
deb http://ports.ubuntu.com/ lucid-security main restricted universe multiverse

(dans le fichier /etc/apt/sources.list).

http://doc.ubuntu-fr.org/depots_lucid

Et si tu as un ordinateur tout à fait classique, alors je me demande par quelle manipulation bizarre la référence "armel" serait venue dans ta configuration...

Dernière modification par tiramiseb (Le 11/01/2013, à 09:25)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#4 Le 11/01/2013, à 17:35

BABIS

Re : Probleme de mise a jour

Salut

Pour répondre a vos questions, j'ai un netbook ecafé
J'ai rajouté les 3 dépots que tiramiseb m'a donné, une mise a niveau de 4 heures s'est effectuée pour au bout du compte me signaler un echec de mise a niveau paquet:

linux-image-2.6.31-612-imx51

J'ai tenté de relancer une mise a jour et toujours le meme probleme:


Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dis … ackages.gz  404  Not Found
Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dis … ackages.gz  404  Not Found
Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dis … ackages.gz  404  Not Found
Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dis … ackages.gz  404  Not Found
Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.


J'y est cru au bout de 4 heures de mise a niveau, mais il y a du mieu donc j'ai de l'espoir avec de l'aide

Hors ligne

#5 Le 11/01/2013, à 17:59

xabilon

Re : Probleme de mise a jour

Il faut aussi retirer les dépôts qui n'existent pas en version ARM.
Donc les fr.archive.ubuntu.com/ubuntu lucid main, restricted, universe et multiverse

Ensuite on s'occupera de ton paquet qui ne peut pas se mettre à jour : une fois les dépôts enlevés, fais :

sudo apt-get update
sudo apt-get install -f

Normalement tu ne devrais plus avoir d'erreur à la 1ère commande, mais donne-nous les erreurs après la 2e commande.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#6 Le 11/01/2013, à 18:20

BABIS

Re : Probleme de mise a jour

Re

Plus aucunes erreurs a la premiére commande et donc erreur a la deuxiéme commande comme tu le prévoyais :



Des erreurs ont été rencontrées pendant l'exécution :
linux-image-2.6.31-612-imx51
linux-image-imx51
linux-imx51
E: Sub-process /usr/bin/dpkg returned an error code (1)


On avance !!!!

Dernière modification par BABIS (Le 11/01/2013, à 18:21)

Hors ligne

#7 Le 11/01/2013, à 18:23

tiramiseb

Re : Probleme de mise a jour

Plus haut il doit y avoir le détail de l'erreur rencontrée


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#8 Le 11/01/2013, à 18:46

BABIS

Re : Probleme de mise a jour

Paramétrage de linux-image-2.6.31-612-imx51 (2.6.31-612.34) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.31-612-imx51
Running postinst hook script /usr/sbin/flash-kernel.
Unsupported platform.
User postinst hook script [/usr/sbin/flash-kernel] exited with value 1
dpkg : erreur de traitement de linux-image-2.6.31-612-imx51 (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de linux-image-imx51 :
linux-image-imx51 dépend de linux-image-2.6.31-612-imx51 ; cependant :
Le paquet linux-image-2.6.31-612-imx51 n'est pas encore configuré.
dpkg : erreur de traitement de linux-image-imx51 (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de linux-imx51 :
linux-imx51 dépend de linux-image-imx51 (= 2.6.31.612.12) ; cependant :
Le paquet linux-image-imx51 n'est pas encore configuré.
dpkg : erreur de traitement de linux-imx51 (--configure) :
problèmes de dépendances - laissé non configuré
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                                                                  Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                                                       Des erreurs ont été rencontrées pendant l'exécution :
linux-image-2.6.31-612-imx51
linux-image-imx51
linux-imx51
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#9 Le 11/01/2013, à 19:32

xabilon

Re : Probleme de mise a jour

Running postinst hook script /usr/sbin/flash-kernel.
Unsupported platform.

Étrange, apparemment le noyau imx ne gère pas ton ordinateur. Que donnent ces deux commandes ?

uname -a
dpkg -l | grep linux-image

Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#10 Le 11/01/2013, à 19:59

BABIS

Re : Probleme de mise a jour

slash@slash-laptop:~$ uname -a
Linux slash-laptop 2.6.35.4-ecafe-v4C #36 PREEMPT Mon Oct 24 17:18:51 CEST 2011 armv7l GNU/Linux
slash@slash-laptop:~$ dpkg -l | grep linux-image
ii  linux-image-2.6.31-607-imx51           2.6.31-607.13                                   Linux kernel image for version 2.6.31 on I.M
iF  linux-image-2.6.31-612-imx51           2.6.31-612.34                                   Linux kernel image for version 2.6.31 on I.M
ii  linux-image-2.6.35.4-ecafe             2.6.35.4-v4C                                    Linux kernel image for version 2.6.35 on eCA
ii  linux-image-ecafe                      2.6.35.4-v4c                                    Linux-image meta-package for eCAFE ARM Netbo
iU  linux-image-imx51                      2.6.31.612.12                                   Linux kernel image for imx51 machines
slash@slash-laptop:~$

Hors ligne

#11 Le 12/01/2013, à 05:07

xabilon

Re : Probleme de mise a jour

Bon, apparemment tu tournes sur un noyau plus récent, le 2.6.35.4-ecafe, donc tu n'as pas forcément besoin du 2.6.31-612-imx51
Y-a-t'il une raison particulière pour laquelle le noyau imx51 est installé (je précise que je ne connais pazs grand chose aux architectures ARM...) ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#12 Le 12/01/2013, à 13:24

BABIS

Re : Probleme de mise a jour

Salut

De mon coté je n'y connais pas grand chose, maintenant mon gestionnaire de mise a jour est bloqué au niveau d'une mise a niveau partielle, elle se lance et apres plus rien, pas de fenetre pour me signaler une erreur.

Hors ligne

#13 Le 12/01/2013, à 14:34

BABIS

Re : Probleme de mise a jour

Re

Je pense faire une restauration compléte et  mettre les bon dépots avant de lancer mes mises a jour car au départ apparement ce n'etais pas les bon en plus a force d'essayer de résoudre le probléme j'ai cocher plusieurs choses qu'il ne fallait peut etre pas.
Qu'en pensez vous ? et pourriez vous me donner les bon ports svp et peut etre la bonne configuration pour le gestionnaire de mise a jour ?
SVP

Dernière modification par BABIS (Le 12/01/2013, à 15:08)

Hors ligne

#14 Le 12/01/2013, à 14:35

xabilon

Re : Probleme de mise a jour

Je pense que tu n'as pas besoin de ce noyau imx51. De plus, j'ai trouvé ce bug toujours non résolu (c'est la version précédente du noyau imx51).

Peux-tu donner le résultat de :

apt-cache showpkg linux-image-2.6.35.4-ecafe

et

apt-cache showpkg linux-image-2.6.31-612-imx5

Sinon, mis à part ce souci causé par ce paquet, Ubuntu fonctionne correctement, non ? Si on enlève ce paquet, il n'y aura plus de problème.

Dernière modification par xabilon (Le 12/01/2013, à 14:37)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#15 Le 12/01/2013, à 15:18

BABIS

Re : Probleme de mise a jour

Re

Pour ta question, oui ubuntu marche correctement, j'aimerais juste passer de la version 10.04 a la derniére version.
Je te donne le resultat :


slash@slash-laptop:~$ apt-cache showpkg linux-image-2.6.35.4-ecafe
Package: linux-image-2.6.35.4-ecafe
Versions:
2.6.35.4-v4C (/var/lib/dpkg/status)
Description Language:
                 File: /var/lib/dpkg/status
                  MD5: c1dd359ad00c1f69ff2f0e49cf1a17e9


Reverse Depends:
  linux-image-ecafe,linux-image-2.6.35.4-ecafe 2.6.35.4-v4C
Dependencies:
2.6.35.4-v4C - initramfs-tools (2 0.36ubuntu6) coreutils (16 (null)) fileutils (2 4.0) module-init-tools (2 3.3-pre11-4ubuntu3) wireless-crda (0 (null)) dpkg (2 1.10.24) fdutils (0 (null)) linux-ecafe-doc-2.6.35 (16 (null)) linux-ecafe-source-2.6.35 (0 (null)) flash-kernel (0 (null)) hotplug (3 0.0.20040105-1)
Provides:
2.6.35.4-v4C -
Reverse Provides:
slash@slash-laptop:~$ apt-cache showpkg linux-image-2.6.31-612-imx5
W: Impossible de trouver le paquet linux-image-2.6.31-612-imx5
slash@slash-laptop:~$

Hors ligne

#16 Le 12/01/2013, à 15:25

xabilon

Re : Probleme de mise a jour

Désolé, j'ai fait une faute de frappe, la 2e commande est :

apt-cache showpkg linux-image-2.6.31-612-imx51

c'est pour voir si on peut virer ce paquet qui te bloque tout, sans danger


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#17 Le 12/01/2013, à 19:17

BABIS

Re : Probleme de mise a jour

slash@slash-laptop:~$ apt-cache showpkg linux-image-2.6.31-612-imx51
Package: linux-image-2.6.31-612-imx51
Versions:
2.6.31-612.34 (/var/lib/apt/lists/ports.ubuntu.com_ubuntu-ports_dists_lucid-security_main_binary-armel_Packages) (/var/lib/apt/lists/ports.ubuntu.com_ubuntu-ports_dists_lucid-updates_main_binary-armel_Packages) (/var/lib/dpkg/status)
Description Language:
                 File: /var/lib/apt/lists/ports.ubuntu.com_ubuntu-ports_dists_lucid-security_main_binary-armel_Packages
                  MD5: ff7b78804734f94e895e82ad6d87a8ae


Reverse Depends:
  linux-image-imx51,linux-image-2.6.31-612-imx51
Dependencies:
2.6.31-612.34 - initramfs-tools (2 0.36ubuntu6) coreutils (16 (null)) fileutils (2 4.0) module-init-tools (2 3.3-pre11-4ubuntu3) wireless-crda (0 (null)) dpkg (2 1.10.24) fdutils (0 (null)) linux-fsl-imx51-doc-2.6.31 (16 (null)) linux-fsl-imx51-source-2.6.31 (0 (null)) flash-kernel (0 (null)) hotplug (3 0.0.20040105-1)
Provides:
2.6.31-612.34 -
Reverse Provides:
slash@slash-laptop:~$


Désolé j'ai du m'absenter

Hors ligne

#18 Le 12/01/2013, à 19:34

xabilon

Re : Probleme de mise a jour

Je ne pense pas qu'il y ait trop de risques :

sudo apt-get remove  linux-image-imx51 linux-image-2.6.31-612-imx51

si pas d'erreur, retente la mise à jour


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#19 Le 12/01/2013, à 20:06

BABIS

Re : Probleme de mise a jour

slash@slash-laptop:~$ sudo apt-get remove  linux-image-imx51 linux-image-2.6.31-612-imx51
[sudo] password for slash:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-2.6.31-607-imx51 linux-headers-2.6.32-204-dove linux-headers-2.6.33-500-omap linux-headers-2.6.32-204
  linux-headers-2.6.33-500
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  linux-image-2.6.31-612-imx51 linux-image-imx51 linux-imx51
0 mis à jour, 0 nouvellement installés, 3 à enlever et 1174 non mis à jour.
3 partiellement installés ou enlevés.
Après cette opération, 44,1Mo d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 203343 fichiers et répertoires déjà installés.)
Suppression de linux-imx51 ...
Suppression de linux-image-imx51 ...
Suppression de linux-image-2.6.31-612-imx51 ...
The link /boot/vmlinuz is a damaged link
Removing symbolic link vmlinuz
you may need to re-run your boot loader[grub]
The link /boot/vmlinuz.old is a damaged link
Removing symbolic link vmlinuz.old
you may need to re-run your boot loader[grub]
The link /boot/initrd.img is a damaged link
Removing symbolic link initrd.img
you may need to re-run your boot loader[grub]
The link /boot/initrd.img.old is a damaged link
Removing symbolic link initrd.img.old
you may need to re-run your boot loader[grub]
slash@slash-laptop:~$

J'espere que j'ai pas fait de connerie en disant oui je veu continuer, si non que doit faire maintenant je prefere te demander

Hors ligne

#20 Le 12/01/2013, à 22:02

BABIS

Re : Probleme de mise a jour

J'ai tenté de relancer une mise a niveau, elle se lance mais a l'étape " évaluation des modifications " tout se coupe, plus rien
En faite mon gestionnaire de mise a jour est bloqué sur mise  a niveau partielle et se bloque quand je la lance a l'étape " évaluation des modifications"

Hors ligne

#21 Le 13/01/2013, à 02:45

xabilon

Re : Probleme de mise a jour

On va essayer la mise à niveau depuis le terminal.
Peux-tu montrer le résultat de ces 2 commandes :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d

Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#22 Le 13/01/2013, à 03:25

BABIS

Re : Probleme de mise a jour

Re

En fait j'ai fait une restauration du systeme car il commencait a avoir pas mal de beug
J'ai commencé par faire les mises a jour, nikel tout c'est bien passé
Ensuite j'ai rajouté les 3 ports que l'on ma donné un peu plus haut dans le sujet pour pouvoir migrer vers la 12.04 et la ca me dit que tous les paquets ne peuvent s'installer car les clés public ne sont pas disponible
Voila ou j'en suis, existe t'il des ports  avec des clés valide ?
En tout cas je te remerci enormément de ton aide

Hors ligne

#23 Le 13/01/2013, à 04:02

xabilon

Re : Probleme de mise a jour

Ça c'est pas grave, ce sont les clés d'authentification. Tu auras un avertissement, mais ça ne t'empêchera pas de faire les mises à jour.
Si tu ne veux plus avoir cet avertissement, il faut importer la clé du dépôt ; elle doit être fournie par le dépôt lui-même, mais je ne sais pas où elle est smile

Et que veux-tu dire par "restauration système" ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#24 Le 13/01/2013, à 05:09

BABIS

Re : Probleme de mise a jour

J'ai fait une restauration systeme via le site hercules, en faite je l'ai restauré comme dans le début que je l'ai eu
En ce qui concerne les mises  a jours, ca me propose de faire une mise a niveau partielle qui n'abouti pas car les paquets ne peuvent pas s'installer a cause de ses fameuses clés
Enfin bref, je crois que je vais rester avec cette version 10.04 et laisser tomber
En tout cas merci encore pour ton aide

Hors ligne

#25 Le 13/01/2013, à 15:54

BABIS

Re : Probleme de mise a jour

Re

Voici le message d'erreur, si quelqu'un connait on ne sait jamais



W: Erreur GPG : http://ports.ubuntu.com lucid Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 40976EAF437D05B5
W: Erreur GPG : http://ports.ubuntu.com lucid-updates Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 40976EAF437D05B5
W: Erreur GPG : http://ports.ubuntu.com lucid Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 40976EAF437D05B5
W: Erreur GPG : http://ports.ubuntu.com lucid-security Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 40976EAF437D05B5
W: Erreur GPG : http://ports.ubuntu.com lucid-updates Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 40976EAF437D05B5
W: Erreur GPG : http://ports.ubuntu.com lucid-security Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 40976EAF437D05B5

Hors ligne