Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 04/09/2012, à 20:19

tobiasBora

Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

Bonjour !

Il y a un problème récurrent dans les versions de kubuntu : la demande systématique du mot de passe kdewallet à l'ouvertude de session... Le seul moyen de désactiver cette demande intempestive étant... de supprimer le mot de passe de kdewallet... et donc n'importe qui à accès sans problème à nos mots de passes.

Je voulais savoir si ce bug avait trouvé sa solution ? Et je voulais aussi savoir pourquoi est-ce qu'il est si long à réparer ? Est-ce un problème du côté technique (dur à implanter) ou par manque de bénévoles ? Car en somme, je ne vois pas ce qui pose problème à son ouverture : il suffirait de vérifier si le mot de passe tapé lors de la connexion correspond :
1. A la session
2. Au portefeuille
Et si c'est le cas, l'ouvrir automatiquement. Je suis peux être très simpliste dans ma manière de concevoir la solution, mais mes compétences informatiques ne me permettent pas de voir ce qui peux poser problème outre mesure (et vu que je suis curieux... !).

J'ai également un autre bug à mon avis lié à celui là : une fois que j'ai tapé le mot de passe de kdewallet, il me faut retaper à chaque connexion celui de la wifi dans une petite invite qui le demande. Si on ne met rien, le mot de passe enregistré dans le portefeuille pour la connection wifi est supprimé... Ce qui est très embêtant de devoir tout le temps le retaper.

Merci d'avance.

--EDIT--
Quoi que ce problème me parait plus subtil : de temps en temps il me demande le mot de passe du portefeuille... de temps en temps il me le demande pas ! Si quelqu'un à une explication...

Dernière modification par tobiasBora (Le 04/09/2012, à 20:27)

Hors ligne

#2 Le 04/09/2012, à 22:17

louis94

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

Bonjour,

Le problème n'est pas si subtil que ça : le portefeuille te demande le mot de passe lorsqu'une application demande à l'ouvrir. Donc, si aucune application ne demande rien, le Kdewallet non plus.
Si j'ai bien compris, le fait que le portefeuille demande toujours le mot de passe est un choix. Il est considéré que le choix « sécurisé » devrait toujours inclure un mot de passe différent de celui de la session. Utiliser le même mot de passe revient à permettre l'accès au portefeuille à quiconque a pu ouvrir la session. [Je ne suis pas tout à fait d'accord, puisqu'on peut accéder aux fichiers de la session sans le mot de passe si /home n'est pas crypté.]

Quant à ton mot de passe de WiFi, je n'ai pas le même problème. Est-ce qu'il n'y a pas une case « se souvenir du mot de passe » ?

Louis

En ligne

#3 Le 05/09/2012, à 15:36

tobiasBora

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

Bonjour,

Merci pour ta réponse.

Pourtant, la wifi s'active automatiquement au démarrage, et elle est configurée de telle sorte que le mot de passe soit stocké dans kwallet. D'ailleurs, kwallet semble s'ouvrir dans les processus car la commande

ps -u user

renvoie :

 1861 ?        00:00:00 kwalletd

Il semble donc bien ouvert, et pourtant sans me demander le mot de passe.

Et personnellement ça me gène beaucoup plus de devoir taper deux fois mon mot de passe plutôt que d'autoriser tous ceux qui connaissent mon mot de passe à ouvrir mon kwallet : je suis le seul à le connaître. Je ne pense pas qu'enlever le mot de passe pour ne plus avoir ce message soit réellement plus sécurisé... Si je voulais vraiment vraiment un portefeuille plus sécurisé, je me créerais un autre portefeuille cette fois avec un autre mot de passe.

En fait il me demande le mot de passe wifi dés que je suis amené à taper le mot de passe kwallet. Pour le moment je n'en ai pas eu l'occasion, je te ferai un imprim écran quand ça se présentera.

Hors ligne

#4 Le 11/10/2012, à 19:42

Doori

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

Je remonte ce sujet du fil car même problème pour moi. A chaque redémarrage de session, Kwallet me demande mon mot de passe, et, bien que j'écrive le bon, il persevère et me redemande mon mdp. Avec une petite phrase genre "erreur code 9 - mot de passe invalide".
Je dois, à chaque démarrage, annuler les demandes de kwallet et rentrer ma clé de sécurité wifi. Cela dit, après quelques démarrages, on l'a connait par coeur!
Merci d'avance pour vos réponses/indications,
Cordialement,

Doori.


Xubuntu 13.10 64 bits sur Netbook X201E (1Ghz /4Go)

Hors ligne

#5 Le 12/10/2012, à 10:19

mioPalmo

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

bonjour,
lancer kwalletmanager et voir s'il y a plusieurs portefeuilles.

s'il n'y en a qu'1 seul alors
rechercher kdewallet.kwl
ou *.kwl

( il y a peut être un dans .kde et un autre dans .kde4 ? )

le/les   supprimer/sauvegarder
reboot

à la prochaine utilisation de kdewallet tu devras re-creer le portefeuille + mot de passe
le problème ne se reproduira peut être plus ?

Hors ligne

#6 Le 12/10/2012, à 17:23

Doori

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

Bah non, ça continue ...
Je pense que c'est plutôt un soucis au niveau de la wifi. Je n'ai pas de carte wifi mais une vieille clé branché au bout d'un cable. bien que cela marche bien avec les autres os utilisés, je pense néanmoins que le soucis se situe là.
En tout cas merci mioPalmo,
cordialement,

Doori.


Xubuntu 13.10 64 bits sur Netbook X201E (1Ghz /4Go)

Hors ligne

#7 Le 13/10/2012, à 10:50

tobiasBora

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

Sinon tu peux peut être essayer d'aller dans les paramètres du wifi et activer le stockage du mot de passe dans un fichier (pour le moment il est certainement sur kdewallet). C'est pas très propre mais ça devrait fonctionner.

Hors ligne

#8 Le 13/10/2012, à 16:11

mioPalmo

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

dommage !
tu as bien qu'un seul fichier *.kwl ?

tu devrais regarder dans kwalletmanager si une entrée se crée à chaque fois que tu rentres ton mot de passe
( si une entrée se crée à chaque fois c'est qu'il y a un problème de récup de l'id de ta borne wifi )
- tu doubles clique sur le portefeuille
- tu déplis Network Management
- tu déplis carte
moi j'ai 2 entrées pour chaque borne à laquelle je me suis connecté
et le mot de passe est stocké dans l'entrée : xxxxxx;802-11-wireless-security   
dans la clé : psk
tu peus peut être rentrer manuellement le mot de passe s'il est vide ?

Dernière modification par mioPalmo (Le 13/10/2012, à 16:13)

Hors ligne

#9 Le 11/01/2013, à 08:27

LampeRouge

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

Je suis tout seul sur mon PC et je trouve pénible de m'autoriser des autorisations partout. Ça me gonfle. Comment peut-on faire pour avoir kwallet sans password ?  J'ai bien essayé au départ de valider sans rien mettre pour que kwallet comprenne que je ne veux pas de password, mais c'est refusé. Alors comment faire  ?  Merci.


La Champagne: Un peu avant la banquise...

Hors ligne

#10 Le 11/01/2013, à 13:21

louis94

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

Bonjour,

Pour supprimer le mot de passe, il aller dans le menu K > Applications > Système > Outil de gestion de portefeuilles. Ensuite, clic droit sur le portefeuille > Modifier le mot de passe et en utiliser un vide.

Louis

En ligne

#11 Le 12/01/2013, à 18:07

φlip

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

sudo mv /usr/bin/kwalletd /usr/bin/kwalletd.mv 
sudo ln -s /bin/true /usr/bin/kwalletd 

Hors ligne

#12 Le 13/01/2013, à 12:23

cherrak

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

@φlip : Est-ce que cette manipulation marche si tu as un mot de passe autre que "rien du tout" ?

#13 Le 13/01/2013, à 12:50

φlip

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

kwallet est une vraie plaie quand on n'en a pas besoin.
Le problème est que ne pas installer ou désinstaller kwallet ne suffit pas puisque /usr/bin/kwalletd est inclus dans kde-runtime.
Ça parait aberrant, mais c'est ainsi.
Ça fait penser à kmail qui a besoin de nepomuk pour remplir l'adresse email de l'expéditeur à chaque envoie de mails (aberration totale / usine à gaz)

La manip ci-dessus devrait suffire, mais a pour inconvénient d'être écrasée lors de mise à jour.

Pour ne plus être embetté par kwallet, il peut être nécessaire d'aussi configurer ~/.kde/share/config/kwalletrc comme suit:

[Wallet]
Enabled=false
First Use=false
Prompt on Open=false

Dernière modification par φlip (Le 13/01/2013, à 12:59)

Hors ligne

#14 Le 13/01/2013, à 13:09

cherrak

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

Oui je comprends, personnellement je n'utilise pas kmail car il faut activer akonadi qui me bouffe 200M de ram, je prefere trojita meme si le mot de passe est stocke en clair (tout comme claws-mail que j'utilisais avant).

Je comprends ensuite que le soucis premier des dev est de fournir quelque chose de securise, quitte a construire une usine a gaz mais je pense qu'a l'heure actuelle, le parametrage de kwallet est le plus gros defaut de kde (<troll>qui en a si peu compare a gnome tongue </troll>).

#15 Le 13/01/2013, à 13:23

φlip

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

cherrak a écrit :

je n'utilise pas kmail car il faut activer akonadi qui me bouffe 200M de ram

J'avais juste réessayé kmail par curiosité depuis son portage de KDE3 à KDE4 et ses phases akonadiques cahotiques, mais je ne l'utilise pas pour les mêmes raisons que toi.
Mais quand kmail m'a réclamé nepomuk pour remplir le champ 'expéditeur', je me suis vraiment dit: là c'est trop, il y a quelqu'un qui a pété les plombs dans l'équipe de développement.
J'utilise Thunderbird depuis des lustres, mais aussi Opera mail, intégré au navigateur (c'est pratique).
trojita: je ne connais pas; je vais regardé par curiosité, mais c'est un autre sujet.
edit: trojita ne gère que l'IMAP.

Dernière modification par φlip (Le 13/01/2013, à 13:27)

Hors ligne

#16 Le 13/01/2013, à 16:06

cherrak

Re : Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

Oui Thunderbird est vraiment complet mais mal integre a KDE, c'est vraiment dommage (meme si des applis comme Oxygen gtk aident beaucoup mais au niveau des libs, c'est pas trop ca)
Trojita est un projet de these concernant le protocole IMAP d'ou la gestion de ce protocole uniquement, il gere bien la securite d'envoi mais ne gere qu'une seul boite mail en reception (ou alors je suis trop con pour trouver ce qui est loin d'etre impossible tongue) et plusieurs en envoi, ce que j'aime bien en revanche avec Trojita c'est qu'il utilise QT et pour ainsi dire pas grand chose d'autre (je n'ai rien eu a installer d'autre en tous cas). Qui plus est , il a ete integrer au projet KDE recemment.

  • Accueil
  • » Forum
  • » KDE/Plasma
  • » Désactiver mot de passe kdewallet : du nouveau ? + mdp wifi redemandé

Haut de page ↑