Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 13/01/2013, à 12:06

pvm

Probleme de fstab [RESOLU]

Bonjour.
J'ai migré de gnome à XFE mais j'ai un pb au démarrage et je ne capte pas l'origine du pb.

J'ai le message suivant :
"une erreur est survenue lors du montage de /etc/fstab:.
Appuyez sur s pour passer le montage ou M pour la recuperation manuelle."

Voici mon fstab :


# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc	/proc	proc	nodev,noexec,nosuid	0	0
#Entry for /dev/sda1 :
UUID=dc1d3a9f-7021-41c2-bd0c-debd90af5be2	/	ext4	errors=remount-ro	0	1
#Entry for /dev/sdb1 :
UUID=64DAE3105EF3F674	/media/MesDocuments	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0
#Entry for /dev/sda5 :
UUID=177c095c-a7eb-43bc-95a6-2a6584d1489b	none	swap	sw	0	0
/dev/fd0	/media/floppy0	auto	rw,user,noauto,exec,utf8	0	0


Merci pour votre aide.
PVM

Dernière modification par pvm (Le 16/01/2013, à 12:30)


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#2 Le 13/01/2013, à 12:57

Babdu89

Re : Probleme de fstab [RESOLU]

Bonjour ...

Je ne vois pas d'erreur dans le " fstab " ...

La seule chose qu'il puisse y avoir, c'est,  que si tu as changé de version de noyau 12.04 ==> 12.10 et +  ...

Les point de montage des partitions changent , avec le changement de version de noyau ...

Pour ta partition /dev/sdb1 le point de montage deviendrait ==>   /media/<nom utilisateur>/MesDocuments

Si ,il n'y a pas de changement de version de noyau, que tu sois resté sur la 12.04 ... Je ne vois pas ...

@+.   Babdu89   .

Dernière modification par Babdu89 (Le 15/01/2013, à 22:14)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#3 Le 13/01/2013, à 14:04

The Uploader

Re : Probleme de fstab [RESOLU]

salut

que donne le résultat de la commande :

sudo blkid

La dernière fois que j'ai eu ça, c'était à cause d'un UUID (partition) qui n'existait plus.


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#4 Le 13/01/2013, à 14:43

pvm

Re : Probleme de fstab [RESOLU]

salut.
sudo blkid de donne rien


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#5 Le 13/01/2013, à 15:02

The Uploader

Re : Probleme de fstab [RESOLU]

Il te manque peut-être le paquet util-linux (détails du paquet sur la 12.04) qui installe le programme blkid dans /sbin.


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#6 Le 13/01/2013, à 15:07

pvm

Re : Probleme de fstab [RESOLU]

il est installé et ça ne marche pas.


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#7 Le 13/01/2013, à 15:10

The Uploader

Re : Probleme de fstab [RESOLU]

ls /sbin/blkid

?


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#8 Le 13/01/2013, à 15:16

pvm

Re : Probleme de fstab [RESOLU]

toujours rien.

root@pvm-System-Product-Name:/home/pvm# ls /sbin/blkid
/sbin/blkid
root@pvm-System-Product-Name:/home/pvm# 

" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#9 Le 13/01/2013, à 15:19

The Uploader

Re : Probleme de fstab [RESOLU]

ls le liste bien. Le programme existe donc.

si tu fais :

sudo su
/sbin/blkid

Tu n'as pas un truc du genre :

[sudo] password for max: 
/dev/sda1: LABEL="Jeux Windows" UUID="300B8002205A8E7C" TYPE="ntfs" 
/dev/sda2: LABEL="home" UUID="fd0c8ebf-e894-4bf9-87d5-1fcf176e671f" TYPE="ext4" 
/dev/sdb1: LABEL="Arch" UUID="7c92ecef-908f-49f6-b362-58f72ae950dc" TYPE="ext4" 
/dev/sdb2: LABEL="RM-CM-)servM-CM-) au systM-CM-(me" UUID="DEEE1999EE196AD3" TYPE="ntfs" 
/dev/sdb3: LABEL="Windows 7" UUID="292DF5B302944DF7" TYPE="ntfs" 

?

Sinon il y a d'autres manière de connaitre les UUID et de les comparer à celles utilisés par /etc/fstab. La doc sur les UUID mentionne notamment gnome-device-manager


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#10 Le 13/01/2013, à 15:21

pvm

Re : Probleme de fstab [RESOLU]

rîen.

root@pvm-System-Product-Name:/home/pvm# ls /sbin/blkid
/sbin/blkid
root@pvm-System-Product-Name:/home/pvm# sudo su
root@pvm-System-Product-Name:/home/pvm# /sbin/blkid

" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#11 Le 13/01/2013, à 15:25

pvm

Re : Probleme de fstab [RESOLU]

gnome-device-manager est introuvable dans synaptic, quels depots?


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#12 Le 13/01/2013, à 15:30

pvm

Re : Probleme de fstab [RESOLU]

j'ai fini par trouver ça:

root@pvm-System-Product-Name:/home/pvm# sudo blkid /dev/sd*
/dev/sda1: UUID="dc1d3a9f-7021-41c2-bd0c-debd90af5be2" TYPE="ext4" 
/dev/sda5: UUID="177c095c-a7eb-43bc-95a6-2a6584d1489b" TYPE="swap" 
/dev/sdb1: LABEL="MesDocuments" UUID="64DAE3105EF3F674" TYPE="ntfs" 
root@pvm-System-Product-Name:/home/pvm#

Dernière modification par pvm (Le 13/01/2013, à 15:37)


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#13 Le 13/01/2013, à 15:55

pvm

Re : Probleme de fstab [RESOLU]

Pour infos je viens de constater que :
le gestionnaire de disques, l'outil de configuration ntfs et Gparted, ne fonctionnent plus.


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#14 Le 13/01/2013, à 16:10

Babdu89

Re : Probleme de fstab [RESOLU]

Bonjour...

Les UUID correspondent bien au partitions ...

Question ;
Stp, quelle est la version de ton Xubuntu et noyau?...

@+. Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#15 Le 13/01/2013, à 16:19

pvm

Re : Probleme de fstab [RESOLU]

Version xubuntu 12.10
pour le noyau j'ai ça:

root@pvm-System-Product-Name:/home/pvm# cat /proc/version
Linux version 3.5.0-22-generic (buildd@panlong) (gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1) ) #34-Ubuntu SMP Tue Jan 8 21:41:11 UTC 2013
root@pvm-System-Product-Name:/home/pvm# 

" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#16 Le 13/01/2013, à 16:34

Babdu89

Re : Probleme de fstab [RESOLU]

OK!!.. version 12.10 ...
Reprendre ce que je dis dans mon premier post#2 ...
Et modifier le fichier fstab, en conséquence ... Point de montage de la partition /dev/sdb1   ...

/media/<nom utilisateur>/MesDocuments

Tu parles de gestionnaire de disque ...
Si tu avais installé le paquet  "disk-manager" ...

http://doc.ubuntu-fr.org/disk-manager

C'est le fichier " fstab-disk-manager-save " qu'il faut modifier ...

Bon courage ...

@+.   Babdu89   .

Dernière modification par Babdu89 (Le 13/01/2013, à 16:38)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#17 Le 13/01/2013, à 16:57

pvm

Re : Probleme de fstab [RESOLU]

le paquet  "disk-manager est installé
Le fait de rajouter le nom d'utilisateur ne change rien. j'ai essayé dans les deux fichiers (fstab et fstab-disk-manager-save )
la seule différence est que "Mes documents" s'ouvre automatiquement au démarrage, ce qui n'est pas utile.


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#18 Le 13/01/2013, à 17:23

Babdu89

Re : Probleme de fstab [RESOLU]

le paquet  "disk-manager est installé

Ah oui !!! ..... OK!! ... c'est vrai ...

J'avais testé cet outil sur Xubuntu 12.10 ...  j'en parle ici ...

http://forum.ubuntu-fr.org/viewtopic.ph … #p11359281

C'est vrai que le fait de changer manuellement le point de montage manuellement dans le fichier  " fstab-disk-manager-save " ne servait pas à grand chose ...
Il faut le faire à partir de l'interface graphique de disk-manager... Sélectionner les partitions à monter automatiquement, les démonter, changer les points de montage dans la boîte de dialogue qui s'ouvre en cliquant sur "modifier" en bas à gauche...
Pour le NTFS ,ouvrir le champ "Drivers ..." Changer l'option ,pour avoir un affichage   "ntfs-3g " dans l'interface de disk-manager" ...
Ensuite cocher la coche de chaque partition à gauche pour valider et monter la partition avec son nouveau point de montage ...

Mais , comme les partition sous Xfce , a partir de la version 12.10, sont montée avec un clic depuis le gestionnaire de fichiers Thunar, ce qui n'était pas le cas avant ... Et comme je ne trouvais pas les modifs de disk-manager bien stable... J'ai fini, par désinstaller le paquet, via synaptic , puis modifier le fichier "fstab" (le fichier  " fstab-disk-manager-save " ne servant plus à rien, je l'ai viré) ...
Et la machine démarre sans message d'erreur avec le point de montage modifié dans le fichier "fstab" ...

Avant de supprimer le paquet disk-manager, voila ce que tu peux tester ...
Modifier le fichier "fstab" en mode root , ouvrir disk-manager , décocher toutes les coches à  gauche des partitions ,qui voudront bien se laisser décocher ...
Rebooter la machine, si elle démarre sans le message d'erreur, c'est que la modif est valide, tu peux virer disk-manager et   " fstab-disk-manager-save "      si tu en a envie ...Où le garder tel que ...

Voila pour t'éclairer ...

Bon courage ...

@+.  Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#19 Le 13/01/2013, à 17:58

pvm

Re : Probleme de fstab [RESOLU]

je n'ai pas pu decocher les partitions dans disk manager vu qu'il etait buggé donc je l'ai viré avec  fstab-disk-manager-save et aussi les fichiers de config mais ça n'a rien donné au reboot. je ne comprend pas vu que quand je tape sur "s" au démarrage toute les partirtions montent correctement et meme la partition sdb1 Mesdocuments s'ouvre automatiquement alors que je ne lui ai jamais demandé.
Pour ce qui est de modifier le fichier "fstab" je ne suis pas assez pointu sur le sujet, (une erreur de caractere peut tout fausser).
pour l'instant je suis coincé.
Merci.
Cdt.


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#20 Le 13/01/2013, à 18:45

Babdu89

Re : Probleme de fstab [RESOLU]

je ne comprend pas vu que quand je tape sur "s" au démarrage toute les partirtions montent correctement et meme la partition sdb1 Mesdocuments s'ouvre automatiquement alors que je ne lui ai jamais demandé.

Lorsque tu utilise l'option (S) , même si le système voit une grosse erreur, çà te permet d'ignorer l'erreur et de poursuivre le chargement de l'OS ...

Alors, dans le "fstab" que les indications soient bonnes où pas ,depuis la version 12.10 , les partions sont montées automatiquement, dans /media/<nom user > Même si tu ne le demandes pas...
Je le dis plus haut lorsque j'ai testé disk-manager sur la 12.10 , les partitions étaient montées automatiquement, bien que les points de montage soit erronés dans le fstab ...


Pour ce qui est de modifier le fichier "fstab" je ne suis pas assez pointu sur le sujet, (une erreur de caractere peut tout fausser).
pour l'instant je suis coincé.

Bon... Ouvrir Thunar (gestionnaire de fichiers sous Xubuntu)  en mode root graphique, pour avoir les droit nécessaire ...

gksudo thunar

Dans un premier temps ,naviguer jusqu'à  /media ...  dans /media , tu devrais voir une dossier avec ton nom user ... C'est là,dans ce dossier avec pour nom, ton user, que sont montées les partitions depuis la 12.10 ...Avant , jusqu'a la 12.04 ,elles étaient montées dans /media ...

Ensuite...
Naviguer jusqu' au fichier "/etc/fstab " ...
Un clic droit sur ce fichier "fstab" ...  faire un copier/coller , sur place, tu vas avoir une sauvegarde du fichier à modifier ...   (copie) fstab ...
Et tu peux modifier le fichier "fstab", comme indiqué ,plus haut , sans risque ,puisque tu peux revenir à la copie de sauvegarde  ...

Remarque ,toujours faire une copie de sauvegarde d'un fichier système que l'on modifie, çà permet de revenir en arrière en cas de souci...

Puis tu peux tester la manip en deux fois, pour t'assurer que c'est bien cette ligne de la partition /dev/sdb1 qui ne va pas ...

Tu commentes la ligne où est indiquée l'UUID de cette partition en mettant un dièse en début de ligne ... Une ligne commentée n'est pas prise en compte par le système ...

Donc la Ligne :

UUID=64DAE3105EF3F674	/media/MesDocuments	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0

devient;

#UUID=64DAE3105EF3F674	/media/MesDocuments	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0

Tu enregistres la modif, et tu reboot la machine ...
Si tu n'as plus de message d'erreur, c'est que cette ligne contient bien l'erreur ...
Si tu as toujours le message d'erreur, il faudra que l'on  cherche ailleurs ..

Si il n'y a plus d'erreur , tu reviens en mode root graphique avec Thunar, au fichier  /etc/fstab ...
Et tu modifier les lignes ;

#Entry for /dev/sdb1 :
#UUID=64DAE3105EF3F674	/media/MesDocuments	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0

en ;

#Entry for /dev/sdb1 :
UUID=64DAE3105EF3F674	/media/pvm/MesDocuments	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0

Ne pas oublier d'enlever le  #  en début de deuxième ligne et d'ajouter   /media/pvm/MesDocuments

Tu enregistres la modif... Tu fermes ,et tu testes si le reboot se fait sans erreur ...

Bon courage ...

@ Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#21 Le 13/01/2013, à 19:13

pvm

Re : Probleme de fstab [RESOLU]

l'erreur est toujours là


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#22 Le 13/01/2013, à 19:18

Babdu89

Re : Probleme de fstab [RESOLU]

Ah!!!...
Stp, veux tu bien poster le contenu du fichier fstab modifié ... Merci ...

@+.   Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#23 Le 13/01/2013, à 19:35

pvm

Re : Probleme de fstab [RESOLU]

Auparavent "Mesdocuments" etaient bien montés dans "/media" parce que en le faisant monter dans "/media/pvm/ tous les liens et raccourcis vers mes documents ne fonctionnent plus.


# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc	/proc	proc	nodev,noexec,nosuid	0	0
#Entry for /dev/sda1 :
UUID=dc1d3a9f-7021-41c2-bd0c-debd90af5be2	/	ext4	errors=remount-ro	0	1
#Entry for /dev/sdb1 :
UUID=64DAE3105EF3F674	/media/pvm/MesDocuments	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0
#Entry for /dev/sda5 :
UUID=177c095c-a7eb-43bc-95a6-2a6584d1489b	none	swap	sw	0	0
/dev/fd0	/media/floppy0	auto	rw,user,noauto,exec,utf8	0	0

Dernière modification par pvm (Le 13/01/2013, à 19:36)


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#24 Le 13/01/2013, à 19:50

Babdu89

Re : Probleme de fstab [RESOLU]

Auparavent "Mesdocuments" etaient bien montés dans "/media" parce que en le faisant monter dans "/media/pvm/ tous les liens et raccourcis vers mes documents ne fonctionnent plus.

Normal, çà il faudra refaire tous les liens et signets avec les nouveaux points de montage ...
Puisque depuis la 12.10 le point de montage des partitions à changé dans /media ...

Tu as vérifié, dans /media tu as bien un dossier /media/pvm   , avec tes partitions montées dedans ...
Pour ce faire...
Dans Thunar, tu cliques dans le volet de gauche ,sur toutes les partitions, elles vont se monter et s'ouvrir... Puis tu vas voir dans /media/pvm vérifier qu'elles sont bien là ...

@+.   Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#25 Le 13/01/2013, à 19:51

Babdu89

Re : Probleme de fstab [RESOLU]

J'ai le message suivant :
"une erreur est survenue lors du montage de /etc/fstab:.
Appuyez sur s pour passer le montage ou M pour la recuperation manuelle."

Le message d'erreur est toujours le même, où il a changé de nature?...


@+.  Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

Haut de page ↑