Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#26 Le 13/01/2013, à 19:56

Babdu89

Re : Probleme de fstab [RESOLU]

Ah!!... ,au fait !! ...
As tu bien fais toutes les mises à jour système depuis que tu as installé le méta paquet Xfce, et que tu es passé en 12.10 ?? ....

@+.   Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#27 Le 13/01/2013, à 21:59

pvm

Re : Probleme de fstab [RESOLU]

le message d'erreur est toujours le même!.
Toutes les mises à jour ont été faite.
sad
cdt.
pvm

Dernière modification par pvm (Le 13/01/2013, à 22:01)


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#28 Le 14/01/2013, à 00:51

Babdu89

Re : Probleme de fstab [RESOLU]

Alors,j'ai un Xubuntu 12.10 installé ...  voici le contenu du fichier fstab de mon Xubuntu 12.10 ,
J'ai regardé par curiosité, pour comparer avec le tien ...

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sd*13 during installation
UUID=d3ff57e0-e54b-4837-b431-99a9173fa1be /               ext4    errors=remount-ro 0       1
# /home was on /dev/sd*14 during installation
UUID=4df1c928-3c7e-4e4e-bfe2-cf4e56a8d88d /home           ext4    defaults        0       2
# swap was on /dev/sd*6 during installation
UUID=6c7ae98d-a2b0-4ca1-bec0-38863dcb1d0a none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Contrairement au tien, je n'ai pas la ligne ;

proc	/proc	proc	nodev,noexec,nosuid	0	0

stp, fais un test en la commentant, tu ajoutes un dièse ( # ) , en début de ligne ...

#proc	/proc	proc	nodev,noexec,nosuid	0	0

Puis tu redémarres sur ton Os , pour voir si le message d'erreur est toujours là ...

ÉDIT... Pour info , j'ai un Ubuntu 12.10 installé, pas de ligne ==> proc    /proc    proc    nodev,noexec,nosuid    0    0 dans le fstab ...
J'ai un Ubuntu 13.04 en test ,aussi, pas de ligne ==> proc    /proc    proc    nodev,noexec,nosuid    0    0  , dans le fstab ...

Et depuis la 12.10 les partitions sont montées dans ces Os dans  /media/<nom user>

La ligne ==> proc    /proc    proc    nodev,noexec,nosuid    0    0  ,   c'est peut-être çà le souci ...

Je vais tester en ajoutant cette ligne dans une copie du fstab de mon Xubuntu 12.10 ...  Voir ce que çà fait ...

RE-ÉDIT ...
Non çà ne change rien au boot chez moi, çà démarre sans message d'erreur...
J'ai remis le fstab comme il était avant ...

Là je commence à sècher ...

@+.   Babdu89   .

Dernière modification par Babdu89 (Le 14/01/2013, à 01:26)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#29 Le 14/01/2013, à 10:57

pvm

Re : Probleme de fstab [RESOLU]

Rien de changé, le fait de rajouter un # devant la ligne ==> proc    /proc    proc    nodev,noexec,nosuid    0    0  , ne change rien.
Cdt.
pvm.


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#30 Le 14/01/2013, à 11:39

alfe08

Re : Probleme de fstab [RESOLU]

Bonjour,

J'ai Ubuntu 12.10 avec un fstab que j'ai simplifié :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/sda2    /               ext4    errors=remount-ro 0       1
/dev/sda5    /home           ext4    defaults        0       2
/dev/sda4    none            swap    sw              0       0
/dev/sda6    /mnt/Doc    ext3    defaults        0       2
/dev/sda7    /mnt/Jeux    ntfs    defaults,umask=007,gid=46 0       0
/dev/sdb1    /mnt/Media    ntfs    defaults,umask=007,gid=46 0       0
/dev/sdb2    /mnt/Archives    ntfs    defaults,umask=007,gid=46 0       0

Si j'avais ta configuration, je ferais ceci :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

/dev/sda1    /    ext4    errors=remount-ro    0    1
/dev/sdb1    /media/MesDocuments    ntfs    defaults,umask=007,gid=46 0       0
/dev/sda5    none        swap    sw    0    0
/dev/fd0    /media/floppy0    auto    rw,user,noauto,exec,utf8    0    0


Ubuntu 13.10 sur PC composé - CM "MSI Z87-G45 Gaming" & CG "MSI GeForce GTX 770 Lightning"
Kubuntu 13.04 sur EeePc 1001PXD

Hors ligne

#31 Le 14/01/2013, à 11:45

The Uploader

Re : Probleme de fstab [RESOLU]

Il vaut mieux utiliser les UUID fournis par bklid.
UUID=XXXXXXXXXXXXXXXX...


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#32 Le 14/01/2013, à 11:53

pvm

Re : Probleme de fstab [RESOLU]

Ça maaaaaarche nickel!!!!!!

grand merçi.
pvm


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#33 Le 14/01/2013, à 12:17

alfe08

Re : Probleme de fstab [RESOLU]

Je n'ai jamais eu de problème avec l'ancienne méthode, c'est pas le cas avec les UUID ; ils peuvent changer, ça m'est arrivé hmm


Ubuntu 13.10 sur PC composé - CM "MSI Z87-G45 Gaming" & CG "MSI GeForce GTX 770 Lightning"
Kubuntu 13.04 sur EeePc 1001PXD

Hors ligne

#34 Le 14/01/2013, à 12:57

The Uploader

Re : Probleme de fstab [RESOLU]

Ils changent uniquement si on le demande expressément (en tant que root) ou si on détruit et recréé la partition.

Sinon, ils n'auraient aucun intérêt.

Dernière modification par The Uploader (Le 14/01/2013, à 12:57)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#35 Le 14/01/2013, à 14:26

Babdu89

Re : Probleme de fstab [RESOLU]

Bonjour...

Entièrement de l'avis de  The Uploader ...

Stp, en faisant une sauvegarde de ton fstab modifié, essaye ceci, pour voir ...

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc	/proc	proc	nodev,noexec,nosuid	0	0
#Entry for /dev/sda1 :
/dev/sda1  
UUID=dc1d3a9f-7021-41c2-bd0c-debd90af5be2	/	ext4	errors=remount-ro	0	1
#Entry for /dev/sdb1 :
/dev/sdb1  
UUID=64DAE3105EF3F674	/media/MesDocuments	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0
#Entry for /dev/sda5 :
/dev/sda5  
UUID=177c095c-a7eb-43bc-95a6-2a6584d1489b	none	swap	sw	0	0
/dev/fd0	/media/floppy0	auto	rw,user,noauto,exec,utf8	0	0

Si çà marche ,au moins les UUID des partitions sont toujours là ...
(Chez moi çà marche je viens de tester sur Xubuntu 12.10 et Ubuntu 13.04 ) ...


Il faut garder les UUID des partitions, car Grub et d'autres programmes fonctionnent avec...
Je ne suis pas sûr qu'a la prochaine réinstallation maj de Grub, çà tienne comme çà , sans les UUID des partitions ...

Par-contre, je ne suis pas assez "costaud" en commandes,et connaissance du système... Mais je pense qu'il faudrait trouvé ce qui fait que les UUID des partitions ne soient plus prises en compte dans le fstab ...

Tu dis aussi que Gparted ne fonctionne plus, si il y a bien un programme qui fonctionne avec les UUID des partitions , c'est bien lui ...
Idemne pour Disk-manager, dont tu disais q'u'il ne fonctionnait plus lui aussi ...Il utilise aussi les UUID des partitions ...

Dans la doc ,il est dit ...

Si vous êtes l'heureux possesseur d'un DD externe et d'une clé USB, il peut arriver que ces périphériques soient identifiés aléatoirement au montage tantôt comme /dev/sda1 tantôt comme /dev/sdb1. Ceci peut occasionner quelques problèmes, par exemple dans le cas ou un script (sauvegarde, vérification etc..) doit s'exécuter sur l'un mais pas sur l'autre.

Vous pouvez forcer le système à les monter sur un point de montage précis en les différenciant tout simplement par leur UUID.

J'ai une de mes machine qui fonctionne comme çà ...
Je peux te garantir que si je n'avait pas les UUID des partitions, je ferais un massacre, car sur cette machine il y a 4 hdd internes +mes 4 hdd externes, tous avec des Os installés dessus...

J'utilise souvent  Boot-Repair ,pour réinstaller Grub ... Heureusement lui prend en compte les UUID ...

@+.   Babdu89  .

Dernière modification par Babdu89 (Le 14/01/2013, à 15:05)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#36 Le 14/01/2013, à 15:20

pvm

Re : Probleme de fstab [RESOLU]

bonjour.
Je viens de tester et ça marche.
Je vais conserver çà.
Par contre j'ai toujours mon volume "Mesdocuments" qui s'ouvre automatiquement au demarrage, chose qui n'existait pas avant le plantage de mon "fstab"
Si quelqu'un à une idée pour arreter ça?
merçi.
pvm


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#37 Le 14/01/2013, à 15:30

The Uploader

Re : Probleme de fstab [RESOLU]

Choses à essayer :
1.Regarder dans gestionnaire de paramètres => Session et démarrage => Démarrage automatique s'il n'y aurait pas une entrée lançant Thunar avec comme argument le chemin vers "Mesdocuments" (peu de chances)
2.Vider le cache de sessions :

rm -I ~/.cache/sessions/*

3.Regarder dans gestionnaire de paramètres => disques amovibles et médias si une des options d'ouverture de Thunar quand un média est inséré est cochée (mais je ne pense pas que ça soit cela)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#38 Le 14/01/2013, à 15:38

Babdu89

Re : Probleme de fstab [RESOLU]

Arrrfffff  !!!....

Essaye ceci ,pour voir dans ton fstab ...

Mettre un dièse devant les lignes ...

/dev/sdb1  
UUID=64DAE3105EF3F674	/media/MesDocuments	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0

Pour que çà devienne ;

#/dev/sdb1  
#UUID=64DAE3105EF3F674	/media/MesDocuments	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0

Reboot de  la machine, et dis nous si çà monte la partition automatiquement encore  ?? ...
Si elle n'est plus montée automatiquement, est-ce que tu peux la monter en cliquant dessus dans le volet gauche de Thunar ??...

Pour info ...
Chez moi, avec les 12.10 et la 13.04 installés, lorsque je lance Gparted (installé par mes soins dans mes Os) , j'ai droit à une ouverture intempestive de fenêtres  Thunar , des partitions de la config ...

Avec Xubuntu 12.10 ,lorsque je branche un hdd externe, même chose ... Mais avec Ubuntu 12.10 et 13.04 ,çà ne le fait pas ...
Je suppose que c'est un souci avec Thunar ...

Sur Xubuntu 12.10 ,j'ai aussi installé  Nautilus ...

Mais bon, c'est un autre sujet ...

@+.  Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#39 Le 14/01/2013, à 15:40

pvm

Re : Probleme de fstab [RESOLU]

vider le cache me donne çà :

root@pvm-System-Product-Name:/home/pvm# rm -I ~/.cache/sessions/*
rm: impossible de supprimer «/root/.cache/sessions/*»: Aucun fichier ou dossier de ce type
root@pvm-System-Product-Name:/home/pvm# 

" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#40 Le 14/01/2013, à 15:48

The Uploader

Re : Probleme de fstab [RESOLU]

Il ne faut pas le faire en tant que root !


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#41 Le 14/01/2013, à 15:50

Babdu89

Re : Probleme de fstab [RESOLU]

Comment ce fait-il que tu soies en  root ,permanent dans tes manips terminal , on dirait ?? ...

root@pvm-System-Product-Name:/home/pvm#

Tu fais prendre des risques à ton système comme çà ...

Chez moi, pour en  arriver à cette situation, il faut que je tape dans un terminal (fenêtre du haut)

gksudo thunar

Lorque Thunar est ouvert, un clic droit dans le volet de droite, et "Ouvrir une terminal ici "

1358171154.png


Tu as testé ce que je propose post#38 ??...

@+.   Babdu89   .

Dernière modification par Babdu89 (Le 14/01/2013, à 15:52)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#42 Le 14/01/2013, à 16:07

alfe08

Re : Probleme de fstab [RESOLU]

Babdu89 a écrit :

Il faut garder les UUID des partitions, car Grub et d'autres programmes fonctionnent avec...
Je ne suis pas sûr qu'a la prochaine réinstallation maj de Grub, çà tienne comme çà , sans les UUID des partitions ...

Je ne suis pas d'accord sur la deuxième ligne ;
je n’utilise plus les UUID depuis plus de deux ans et je n'ai jamais eu aucun problème avec Grub, ni après avoir fait quelques modif sur ma table partition aussi bien avec testdisk que gparted.
Et j'ai testé pas mal de distributions en double ou triple boots wink

Mais chacun fait ce qui lui convient cool

Dernière modification par alfe08 (Le 14/01/2013, à 16:10)


Ubuntu 13.10 sur PC composé - CM "MSI Z87-G45 Gaming" & CG "MSI GeForce GTX 770 Lightning"
Kubuntu 13.04 sur EeePc 1001PXD

Hors ligne

#43 Le 14/01/2013, à 16:20

Babdu89

Re : Probleme de fstab [RESOLU]

Bonjour...
@ alfe08  ...
Stp, veux tu bien répondre à cette demande ??..   Merci ...

http://forum.ubuntu-fr.org/viewtopic.php?id=614071

Çà se fait très facilement , depuis une session Linux installé, en installant/utilisant Boot-Repair,avec cette commande

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update; sudo apt-get install -y boot-repair && boot-repair

En cliquant sur le bouton " Créer un rapport bot info...

Çà devrait intéresser YannUbuntu et moi même ,un rapport boot info fait avec une machine qui n'utilise pas les UUID des partitions ...

Merci ...

@+.  Babdu89   .

Dernière modification par Babdu89 (Le 14/01/2013, à 16:21)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#44 Le 14/01/2013, à 16:24

pvm

Re : Probleme de fstab [RESOLU]

j'ai testé (post#38) ça ne marche pas , pire ça m'a replanté comme au debut.
pour vider le cache j'ai cette reponse :

pvm@pvm-System-Product-Name:~/Bureau$ rm -I ~/.cache/sessions/*
rm: impossible de supprimer «/home/pvm/.cache/sessions/thumbs-pvm-System-Product-Name:0»: est un dossier
pvm@pvm-System-Product-Name:~/Bureau$ 

" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#45 Le 14/01/2013, à 16:29

Babdu89

Re : Probleme de fstab [RESOLU]

j'ai testé (post#38) ça ne marche pas , pire ça m'a replanté comme au debut.

Merci OK, au moins on aura essayé ...

Pour le vidage du cache ,voir post#40, ce que dit The Uploader, et post#41, ce que je dis ...

@+.   Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#46 Le 14/01/2013, à 16:49

Babdu89

Re : Probleme de fstab [RESOLU]

Ah !!... Au fait , pour aider à identifier le problème ...

C'est toujours avec la partition /sdb1 qu'il y a des soucis, on dirait  ...

Alors, un peu de détails sur cette partition ... Elle est sur quel disque? interne, usb &&&?? ...

Si il s'agît d'un hdd usb , stp teste ceci ...

Débrancher le hdd où est cette partition /sdb1 ...

Mofifier le fstab comme ceci ...

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc	/proc	proc	nodev,noexec,nosuid	0	0
#Entry for /dev/sda1 :
UUID=dc1d3a9f-7021-41c2-bd0c-debd90af5be2	/	ext4	errors=remount-ro	0	1
#Entry for /dev/sda5 :
UUID=177c095c-a7eb-43bc-95a6-2a6584d1489b	none	swap	sw	0	0
/dev/fd0	/media/floppy0	auto	rw,user,noauto,exec,utf8	0	0

Rebooter la machine, sans le disque où est cette partition ...

Si çà redémarre sans message d'erreur ... On connaît le fautif ... Et les UUID n'ont rien à voir la dedans ...

Après si c'est çà le souci, il faudra se pencher sur le cas de cette partition /sdb1 ...

@+.   Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#47 Le 14/01/2013, à 17:59

alfe08

Re : Probleme de fstab [RESOLU]

Babdu89 a écrit :

Bonjour...
@ alfe08  ...
Stp, veux tu bien répondre à cette demande ??..   Merci ...

http://forum.ubuntu-fr.org/viewtopic.php?id=614071

@+.  Babdu89   .

C'est fait cool


Ubuntu 13.10 sur PC composé - CM "MSI Z87-G45 Gaming" & CG "MSI GeForce GTX 770 Lightning"
Kubuntu 13.04 sur EeePc 1001PXD

Hors ligne

#48 Le 14/01/2013, à 18:04

pvm

Re : Probleme de fstab [RESOLU]

Boot-repair ma donné çà:

http://paste.ubuntu.com/1531068/


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#49 Le 14/01/2013, à 18:44

pvm

Re : Probleme de fstab [RESOLU]

sdb1 est interne serial ata


" Avant notre venue, rien de manquait au monde ; après notre départ, rien ne lui manquera. ""(Omar Khayyâm)"

Hors ligne

#50 Le 14/01/2013, à 18:54

Babdu89

Re : Probleme de fstab [RESOLU]

@ alfe08 ...

Merci ...


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

Haut de page ↑