Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#26 Le 13/01/2013, à 16:39

xabilon

Re : Probleme de mise a jour

http://doc.ubuntu-fr.org/probleme_apt#erreur_gpg
donc :

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5

Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

En ligne

#27 Le 13/01/2013, à 21:14

BABIS

Re : Probleme de mise a jour

Re

Alors les clés c'est bon, la mise a niveau 12.04 se lance mais elle me telecharge toujours ce fameu paquet linux image et ne veu pas l'installer ce qui fait que la mise a niveau est impossible
J'ai retiré ce paquet, relancé la mise a niveau, et la, elle ne veu pas s'installer car il lui manque ce paquet
C'est con l'informatique quand meme

J'ai eu ca aussi mais je pense que ca n'a rien a voir :

Certaines entrées de votre fichier sources.list, concernant des tierces parties, ont été désactivées. Vous pouvez les réactiver après la mise à niveau avec l'outil « Sources de logiciels » ou avec Synaptic.


En fait c'est juste cet histoire de paquet image qui merde

Dernière modification par BABIS (Le 13/01/2013, à 21:15)

Hors ligne

#28 Le 13/01/2013, à 22:45

xabilon

Re : Probleme de mise a jour

BABIS a écrit :

C'est con l'informatique quand meme

Ah, ça fait toujours bizarre de le découvrir big_smile

Peux-tu donner le message d'erreur complet lors de la mise à niveau ?
Si tu veux la faire en ligne de commande, c'est :

sudo apt-get dist-upgrade

Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

En ligne

#29 Le 14/01/2013, à 03:24

BABIS

Re : Probleme de mise a jour

Des erreurs ont été rencontrées pendant l'exécution :
linux-image-2.6.31-612-imx51
linux-image-imx51
linux-imx51


En fait c'est toujours la meme, la mise a niveau dure au moins 3 heures pour m'anoncer cela a la fin
En plus apres la mise  a niveau mon navigateur web chromium est en anglais, sur firefox je n'ai plus acces aux options etc..
Je pense que je vais laisser tomber, refaire une restauration et rester avec cette version 10.04

J'ai relancer une vérification mise a jour et elle me propose encore ce paquet, c'est dingue !!!

Dernière modification par BABIS (Le 14/01/2013, à 03:42)

Hors ligne

#30 Le 14/01/2013, à 08:25

tiramiseb

Re : Probleme de mise a jour

Le problème semble simple, on a déjà commencé à y regarder, il suffirait d'avancer pour le résoudre plutôt que reculer et réinstaller ou de recommencer une vérification qui, de toute façon, donnera toujours le même résultat smile

Peux-tu réessayer la commande

uname - a

?


Une autre possibilité qui pourrait être envisagée c'est d'installer directement la 12.04, mais ne connaissant pas trop les architectures ARM je ne peux pas assurer que ça marchera.

Dernière modification par tiramiseb (Le 14/01/2013, à 08:26)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#31 Le 14/01/2013, à 13:10

BABIS

Re : Probleme de mise a jour

slash@slash-laptop:~$ uname - a
uname: opérande supplémentaire «-»
Saisissez « uname --help » pour plus d'informations.
slash@slash-laptop:~$ uname --help
Utilisation : uname [OPTION]...
Affiche certaines informations système. Sans OPTION, identique à -s.

  -a, --all                affiche toutes les informations, dans l'ordre
                           suivant, mais sans -p et -i s'il sont inconnus :
  -s, --kernel-name        affiche le nom du kernel
  -n, --nodename           affiche le nom du noeud réseau (hostname)
  -r, --kernel-release     affiche la version du noyau
  -v, --kernel-version     affiche la version du kernel
  -m, --machine            affiche le nom de matériel de la machine
  -p, --processor          affiche le type de processeur ou « unknown » (inconnu)
  -i, --hardware-platform  affiche la plate-forme matérielle ou « unknown » (inconnu)
  -o, --operating-system   affiche le système d'exploitation
      --help     affiche l'aide et quitte
      --version  affiche des informations de version et quitte

Signalez les anomalies de « uname » à <bug-coreutils@gnu.org>
Page d'accueil de « GNU coreutils » : <http://www.gnu.org/software/coreutils/>
Aide générale sur les logiciels GNU : <http://www.gnu.org/gethelp/>
Traduction de « uname » à <http://translationproject.org/team/fr.html>
slash@slash-laptop:~$

Ne serait ce pas du a la configuration de mon gestionnaire de mise a jour sachant que j'ai coché des choses dans logiciel ubuntu ?

Hors ligne

#32 Le 14/01/2013, à 13:15

xabilon

Re : Probleme de mise a jour

tiramiseb : tu as mis un espace de trop entre - et a. La bonne commande est :

uname -a

Sinon, t'es pas tout seul, donc il peut s'agir d'un bug d'installation de ce paquet


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

En ligne

#33 Le 14/01/2013, à 13:25

tiramiseb

Re : Probleme de mise a jour

Désolé, c'est mon téléphone qui a mis cette espace et j'ai mal relu sad
La commande est en effet uname -a.

En fait, vu que tu as fait une restauration du système il va falloir qu'on refasse certaines vérifications pour savoir dans quel état est ton ordinateur maintenant.

Il nous faudrait le résultat COMPLET des commandes suivantes :

uname -a
ls /boot
cat /etc/apt/sources.list
ls /etc/apt/sources.list.d/
cat /etc/apt/sources.list.d/*
sudo apt-get update
sudo apt-get dist-upgrade

(j'indique "complet" en majuscules et en gras car les quatre lignes que tu as citées en #29 sont loin de représenter le retour complet de la commande).

PS : lorsque tu copie-colles des retours de terminaux, il faut les mettre entre les balises "[ code ]", que tu obtiendras en cliquant sur l"icône "< >" en haut du champ où tu tapes ta réponse.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#34 Le 14/01/2013, à 13:29

xabilon

Re : Probleme de mise a jour

Le sudo apt-get dist-upgrade va le faire repartir pour 3h de mise à niveau, non ? À moins que les 3h soient juste le téléchargement des paquets.
Sinon, un bug d'installation est bel et bien confirmé pour ce paquet : https://bugs.launchpad.net/ubuntu/+sour … bug/908528

Dernière modification par xabilon (Le 14/01/2013, à 13:31)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

En ligne

#35 Le 14/01/2013, à 13:36

tiramiseb

Re : Probleme de mise a jour

xabilon a écrit :

Le sudo apt-get dist-upgrade va le faire repartir pour 3h de mise à niveau, non ? À moins que les 3h soient juste le téléchargement des paquets.

p'tet ben qu'oui, p'tet ben qu'non. Je pense qu'il s'agit en effet surtout du téléchargement.
Quoi qu'il en soit, pour bien comprendre on a besoin du message d'erreur complet

xabilon a écrit :

Sinon, un bug d'installation est bel et bien confirmé pour ce paquet : https://bugs.launchpad.net/ubuntu/+sour … bug/908528

Je pense qu'il faut donc suivre ce rapport de bug, en espérant qu'une solution sorte rapidement.
En parallèle on peut voir, avec les retours des commandes que j'ai citées ci-dessus, s'il y a un moyen de contourner.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#36 Le 14/01/2013, à 14:36

BABIS

Re : Probleme de mise a jour

tiramiseb a écrit :

(j'indique "complet" en majuscules et en gras car les quatre lignes que tu as citées en #29 sont loin de représenter le retour complet de la commande).

Que veux tu dire en majuscules et en gras ?
J'ai essayer a la fin de la derniére mise a niveau de choper l'erreur mais le terminal ne me donne pas toute les pages a moins de la choper en cours de route mais je ne sait pas comment faire
En attendant je vais te donner les premiéres commandes

Hors ligne

#37 Le 14/01/2013, à 14:41

tiramiseb

Re : Probleme de mise a jour

Que veux tu dire en majuscules et en gras ?

J'ai écrit le mot "complet" en majuscule et en gras dans mon message #33 pour montrer à quel point ce mot est important...

le terminal ne me donne pas toute les pages

Par défaut je crois qu'il retient 500 lignes, ça devrait être suffisant, tu dois pouvoir remonter avec la barre de défilement...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#38 Le 14/01/2013, à 14:51

BABIS

Re : Probleme de mise a jour

slash@slash-laptop:~$ uname -a
Linux slash-laptop 2.6.35.4-ecafe-v4C #36 PREEMPT Mon Oct 24 17:18:51 CEST 2011 armv7l GNU/Linux
slash@slash-laptop:~$ ls /boot
abi-2.6.31-607-imx51	 initrd.img		      initrd.img.old		   vmlinuz
abi-2.6.31-612-imx51	 initrd.img-2.6.31-607-imx51  System.map-2.6.31-607-imx51  vmlinuz-2.6.31-607-imx51
config-2.6.31-607-imx51  initrd.img-2.6.31-612-imx51  System.map-2.6.31-612-imx51  vmlinuz-2.6.31-612-imx51
config-2.6.31-612-imx51  initrd.img-2.6.35.4-ecafe    uImage-2.6.35.4-ecafe-v4C    vmlinuz.old
slash@slash-laptop:~$ cat /etc/apt/sources.list
deb http://package.ecafe.hercules.com/ lucid main restricted
deb-src http://package.ecafe.hercules.com/ lucid main restricted

deb http://ports.ubuntu.com/ lucid main restricted universe multiverse
deb http://ports.ubuntu.com/ lucid-updates main restricted universe multiverse
deb http://ports.ubuntu.com/ lucid-security main restricted universe multiverse
slash@slash-laptop:~$ ls /etc/apt/sources.list.d/
slash@slash-laptop:~$ cat /etc/apt/sources.list.d/*
cat: /etc/apt/sources.list.d/*: Aucun fichier ou dossier de ce type
slash@slash-laptop:~$ 

Désolé pour les balises, je ne savais pas je le ferais désormé

J'attend ta réponse pour lancer la mise a niveau, si je fait tout sélectionner ca va faire beaucoup de texte pour avoir le rapport d'erreur

Dernière modification par BABIS (Le 14/01/2013, à 14:56)

Hors ligne

#39 Le 14/01/2013, à 15:00

BABIS

Re : Probleme de mise a jour

En faite j'ai fait défiler les 500 derniére lignes la derniére fois et apparement l'erreur se trouve plus haut

Hors ligne

#40 Le 14/01/2013, à 15:11

tiramiseb

Re : Probleme de mise a jour

Bon, la logique du truc est simple :
tu tournes actuellement sur un noyau 2.6.35.
Donc même si tu arrivais à installer ce noyau 2.6.31 problématique, il ne serait pas utilisé. Alors il est possible simplement de lui dire de ne pas l'installer, comme xabilon te l'avait fait faire en #18 :

sudo apt-get remove linux-image-2.6.31-612-imx51

On se retrouveras alors exactement à l'étape où tu as abandonné en réinstallant dans la nuit d'avant-hier à hier.

Alors tu taperas :

sudo apt-get update
sudo apt-get upgrade

Dernière modification par tiramiseb (Le 14/01/2013, à 15:11)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#41 Le 14/01/2013, à 15:28

BABIS

Re : Probleme de mise a jour

Tu veux que je retape cette commande et que je relance la mise a niveau mais je l'ai déja fait et au résultat cela m'a indiqué qu'il manquait ce fameu paquet

Hors ligne

#42 Le 14/01/2013, à 15:35

tiramiseb

Re : Probleme de mise a jour

Je souhaite que tu exécutes ces trois commandes et que tu m'en donnes le retour exact.

Car ce que je crois comprendre de ce que tu dis n'a aucun sens par rapport aux comportements qu'on pourrait rencontrer : si tu as désinstallé le paquet, le système ne devrait plus t'en parler. Il n'est a priori pas indispensable à quoi que ce soit.

Alors j'aimerais lire, au caractère près, l'erreur que tu rencontres, afin de comprendre ce que l'ordinateur veut te dire.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#43 Le 14/01/2013, à 15:50

xabilon

Re : Probleme de mise a jour

Il est possible qu'une mise à jour d'un paquet de 10.04 vers 12.04 demande ce noyau particulier.
Il faut s'assurer :
- qu'aucun paquet ayant directement ou indirectement le noyau imx51 n'est indispensable
- qu'ils ont tous été désinstallés


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

En ligne

#44 Le 14/01/2013, à 15:53

tiramiseb

Re : Probleme de mise a jour

xabilon : sauf que là on n'est pas encore à la mise à jour vers la version 12.04, vu que le sources.list contient toujours les entrées de lucid...

(ou alors j'ai raté quelque chose...)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#45 Le 14/01/2013, à 15:55

xabilon

Re : Probleme de mise a jour

non, c'est moi qui l'ai raté smile


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

En ligne

#46 Le 14/01/2013, à 16:35

BABIS

Re : Probleme de mise a jour

Juste une question, je passe par le terminal pour lancer la mise a niveau ou par le gestionnaire de mise a jour car si l'erreur se trouve trop haut dans le terminal je pourrais pas la choper juste la voir et essayer de la noter

Hors ligne

#47 Le 14/01/2013, à 16:39

tiramiseb

Re : Probleme de mise a jour

La mise à jour fait dérouler tout un ensemble de processus pour tous les paquets à mettre à jour.
Si tu as une erreur qui est "trop haut dans le terminal", alors une possibilité sera de relancer la mise à jour : les autres paquets auront déjà été mis à jour et la sortie devrait être beaucoup plus réduite, ne concernant que ceux qui n'ont pas déjà été mis à jour, donc normalement ceux qui posent problème.

Et si ça ne suffit pas, il est possible de rendre le terminal "illimité" (dans les préférences du profil, onglet défilement, case à cocher illimité).


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#48 Le 14/01/2013, à 17:39

BABIS

Re : Probleme de mise a jour

Ok bin c'est parti je lance !!!

Hors ligne

#49 Le 14/01/2013, à 18:33

BABIS

Re : Probleme de mise a jour

slash@slash-laptop:~$ sudo apt-get update
[sudo] password for slash: 
Atteint http://package.ecafe.hercules.com lucid Release.gpg
Ign http://package.ecafe.hercules.com/ lucid/main Translation-fr
Ign http://package.ecafe.hercules.com/ lucid/restricted Translation-fr
Atteint http://ports.ubuntu.com lucid Release.gpg                      
Atteint http://ports.ubuntu.com/ lucid/main Translation-fr             
Atteint http://ports.ubuntu.com/ lucid/restricted Translation-fr       
Atteint http://package.ecafe.hercules.com lucid Release                
Atteint http://ports.ubuntu.com/ lucid/universe Translation-fr         
Atteint http://ports.ubuntu.com/ lucid/multiverse Translation-fr
Réception de : 1 http://ports.ubuntu.com lucid-updates Release.gpg [198B]
Atteint http://ports.ubuntu.com/ lucid-updates/main Translation-fr
Atteint http://ports.ubuntu.com/ lucid-updates/restricted Translation-fr
Atteint http://ports.ubuntu.com/ lucid-updates/universe Translation-fr
Atteint http://ports.ubuntu.com/ lucid-updates/multiverse Translation-fr
Réception de : 2 http://ports.ubuntu.com lucid-security Release.gpg [198B]
Ign http://ports.ubuntu.com/ lucid-security/main Translation-fr
Ign http://ports.ubuntu.com/ lucid-security/restricted Translation-fr
Ign http://ports.ubuntu.com/ lucid-security/universe Translation-fr
Ign http://ports.ubuntu.com/ lucid-security/multiverse Translation-fr
Atteint http://ports.ubuntu.com lucid Release
Réception de : 3 http://ports.ubuntu.com lucid-updates Release [58,3kB]
Ign http://package.ecafe.hercules.com lucid/main Packages                              
Ign http://package.ecafe.hercules.com lucid/restricted Packages                        
Ign http://package.ecafe.hercules.com lucid/main Sources           
Ign http://package.ecafe.hercules.com lucid/restricted Sources     
Réception de : 4 http://ports.ubuntu.com lucid-security Release [57,3kB]
Ign http://package.ecafe.hercules.com lucid/main Packages                             
Ign http://package.ecafe.hercules.com lucid/restricted Packages                            
Ign http://package.ecafe.hercules.com lucid/main Sources     
Atteint http://ports.ubuntu.com lucid/main Packages                                            
Atteint http://ports.ubuntu.com lucid/restricted Packages                                      
Atteint http://ports.ubuntu.com lucid/universe Packages                                        
Atteint http://ports.ubuntu.com lucid/multiverse Packages                                      
Ign http://package.ecafe.hercules.com lucid/restricted Sources                                 
Réception de : 5 http://ports.ubuntu.com lucid-updates/main Packages [573kB]                   
Atteint http://package.ecafe.hercules.com lucid/main Packages                                  
Atteint http://package.ecafe.hercules.com lucid/restricted Packages
Atteint http://package.ecafe.hercules.com lucid/main Sources      
Atteint http://package.ecafe.hercules.com lucid/restricted Sources
Réception de : 6 http://ports.ubuntu.com lucid-updates/restricted Packages [14B]
Réception de : 7 http://ports.ubuntu.com lucid-updates/universe Packages [254kB]
Réception de : 8 http://ports.ubuntu.com lucid-updates/multiverse Packages [9 440B]
Réception de : 9 http://ports.ubuntu.com lucid-security/main Packages [387kB]
Réception de : 10 http://ports.ubuntu.com lucid-security/restricted Packages [14B]
Réception de : 11 http://ports.ubuntu.com lucid-security/universe Packages [120kB]
Réception de : 12 http://ports.ubuntu.com lucid-security/multiverse Packages [4 334B]
1 463ko réceptionnés en 8s (166ko/s)                                                                                        
Lecture des listes de paquets... Fait
slash@slash-laptop:~$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
slash@slash-laptop:~$ 

Voila j'ai fait la premiére commande qui ma suprimé le paquet et ca ce sont les 2 autres commandes
Je pense qu'apres tu va me faire faire lancer la mise  a niveau, j'attend tes ordres smile

Hors ligne

#50 Le 14/01/2013, à 18:41

tiramiseb

Re : Probleme de mise a jour

Eh bien lance la mise à niveau, soit avec l'interface graphique soit dans le terminal avec la commande suivante :

do-release-upgrade

Soit ça marche bien auquel cas tant mieux.
Soit ça merde assez vite auquel cas tu auras peut-être encore un message d'erreur précis dans le terminal et tu pourras nous le donner
Soit ça tourne longtemps et ça pose problème sur certains paquets et réexécuter la commande sudo apt-get dist-upgrade nous aidera à retrouver le(s) message(s) d'erreur.


En fait, une mise à niveau correspond grosso modo "simplement" à :
- changer les sources des paquets pour pointer vers precise au lieu de lucid
- faire un apt-get dist-upgrade


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne