Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 15/01/2013, à 12:11

free.rage

[résolu] Home ne monte plus !

Bonjour,

Je ne peux plus démarrer de session graphique depuis mon compte avec un Home chiffré. Après avoir validé mon mot de passe de login, un écran noir apparaît très peu de temps (1/2 sec) puis je suis renvoyé vers l'écran de connexion.

Je pensais que c'était lié à Unity mais à partir du moment où je monte mon Home moi-même depuis un autre compte non chiffré, je peux démarrer ma session. Il semble que le système ne monte pas le Home chiffré.

L'une de mes dernières actions avant d'avoir ce plantage a été d'installer samba. Peut-être cela a t il un rapport ?

Merci par avance pour votre aide,
free.rage

Dernière modification par free.rage (Le 16/01/2013, à 23:30)

Hors ligne

#2 Le 15/01/2013, à 17:41

amj

Re : [résolu] Home ne monte plus !

bonjour
je ne sait pas exactement à quoi c'est dû mais c'est probablement en lien avec fstab (c'est le fichier où il est indiqué quelle partitions sont montées automatiquement et comment )

http://doc.ubuntu-fr.org/mount_fstab

pourrais tu poster le résultat des commandes suivantes

sudo fdisk -l
cat /etc/fstab

Dernière modification par amj (Le 15/01/2013, à 17:44)


Vive le logiciel libre !! Articles aléatoires sur Wikipédia sur les logiciels libre, sur linux.

Hors ligne

#3 Le 15/01/2013, à 18:36

free.rage

Re : [résolu] Home ne monte plus !

Bonsoir,

Merci de ton aide, voici le résultat des commandes :

[b]sudo fdisk -l [/b]

Attention : identifiant de table de partitions GPT (GUID) détecté sur « /dev/sda » ! L'utilitaire sfdisk ne prend pas GPT en charge. Utilisez GNU Parted.


Disk /dev/sda: 252.0 GB, 252000000000 bytes
255 têtes, 63 secteurs/piste, 30637 cylindres, total 492187500 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x2790deaf

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1               1   492187499   246093749+  ee  GPT

Disk /dev/mapper/cryptswap1: 10.0 GB, 10000269312 bytes
255 têtes, 63 secteurs/piste, 1215 cylindres, total 19531776 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0xbe60a626

Le disque /dev/mapper/cryptswap1 ne contient pas une table de partitions valable
 [b]cat /etc/fstab[/b]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda3 during installation
UUID=b58d6bf8-bc7b-4c42-8601-f74e95167153 /               ext4        discard,noatime,nodiratime,errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=86D4-BD05  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sda2 during installation
#UUID=eb915754-df71-489e-a57a-0fb2efd4a558 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

La dernière ligne vient des recommandations du site help.Ubuntu.comsur la configuration la plus adaptée à ce modèle de portable (je suis en 12.04 sur un UX31A-R4003P).

Merci encore et par avance,
free.rage.

Hors ligne

#4 Le 16/01/2013, à 17:53

vajpaille

Re : [résolu] Home ne monte plus !

Salut,

Peux-tu tenter quelque chose comme :

Exécute :

cat /etc/crypttab

Si ça te renvoi quelque chose  crée un fichier (test.sh) colle la boucle suivante et fais un "chmod +x test.sh" de ton fichier, ensuite exécute le "./test.sh"

#/bin/bash
for i in $(cat /etc/crypttab | awk '{print $1}')
 do
   sudo cryptsetup status $i
done

Je n'y crois pas trop.
Je ne sais pas si ça fonctionne mais en utilisant un liveCD :

sudo ecryptfs-recover-private

Sinon les commandes ecryptfs-* doivent pouvoir te venir en aide.

Bon courage.


GNU/Linux : Ubuntu, Debian, Red Hat
BSD : OpenBSD, GhostBSD, PC-BSD

Hors ligne

#5 Le 16/01/2013, à 20:16

free.rage

Re : [résolu] Home ne monte plus !

Bonsoir,

Voici le résultat de la commande

cat /etc/crypttab a écrit :

cryptswap1 /dev/sda2 /dev/urandom swap,cipher=aes-cbc-essiv:sha256

Attention je l'ai utilisée sur le disque monté car comme je l'ai indiqué je peux accéder à ma session si je monte le disque à partir d'un compte (non chiffré) sur la même machine (avec mount -t ecryptfs).

J'hésite un peu à passer l'autre commande car il s'agit d'un PC pro et je ne voudrais pas casser quoi que ce soit. Peux-tu me dire ce qu'elle devra faire ?

En fait j'ai l'impression que c'est "juste" le fait qu'au démarrage de la session, le système ne sait pas monter le home chiffré.

Merci de votre aide,
free.rage

Hors ligne

#6 Le 16/01/2013, à 23:30

free.rage

Re : [résolu] Home ne monte plus !

Bsr,

Mon problème est résolu, j'avais simplement modifié mon mot de passe utilisateur en utilisant la commande sudo passwd $user alors que ce n'est pas autorisé par ecryptfs.

J'ai donc remodifié mon mot de passe de session et tout semble rentré dans l'ordre.

Merci pour votre aide,
free.rage.

Hors ligne

#7 Le 17/01/2013, à 11:44

vajpaille

Re : [résolu] Home ne monte plus !

Bonjour,

Effectivement après chaque changement de mot de passe il y a une commande à passer avant de rebooter.
J'ai rencontré se problème il y a quelques années.
Et dans ce cas précis je crois que la commande c'est quelque chose dans le genre :

ecryptfs-rewrap-pass /home/"user"

Bonne journée.


GNU/Linux : Ubuntu, Debian, Red Hat
BSD : OpenBSD, GhostBSD, PC-BSD

Hors ligne

Haut de page ↑