Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 17/01/2013, à 17:17

jermil

[RESOLU] .gtk-bookmarks récalcitrant

Hep ! A l'aide ! smile

j'ai édité .gtk-bookmarks pour y rajouter un bookmark pointant vers un partage réseau smb, jusque là tout va bien, quand je fais la manip ce la fonctionne et mon "lecteur réseau" apparait bien dans le panneau lattéral. Or, dès que je reboot, le bookmark n'apparait plus dans thunar.... je peux bien sur ré accéder au reseau, puis au partage concerné et le "glisser" dans le panneau latéral, mais je veux pas à avoir expliquer aux personnes utilisant ces machines la manip refaire à chaque fois.


Donc grossomodo voilà ce que j'ajoute dans .gtk-bookmarks : smb://serveur/multimedia/ multimedia

après un reboot, la ligne n'a pas bougée, mais le bookmark "multimedia" n'est plus là....

Help ? j'ai fouiné et j'avoue baisser un peu les bras devant les recherches sur le forum... dans la précédente versions de Xubuntu je me contentais de monter le partage dans les applications ua démarrage et c'était réglé, masi je n'ai pas pu réutiliser cette méhtode ! sad

Dernière modification par jermil (Le 18/01/2013, à 10:31)


SciTE ForEVeR

Hors ligne

#2 Le 17/01/2013, à 17:46

The Uploader

Re : [RESOLU] .gtk-bookmarks récalcitrant

Salut

L'icône "Réseau" dans la barre latérale de Thunar est-il surmonté d'une croix (la première fois que tu ouvres Thunar) ?

Dernière modification par The Uploader (Le 17/01/2013, à 17:47)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

Hors ligne

#3 Le 17/01/2013, à 17:49

jermil

Re : [RESOLU] .gtk-bookmarks récalcitrant

Non, je viens de tester après 2 reboots, pas de croix sur l'icone réseau du panneau lattéral à la premiere ouverture d'une fenetre thunar.


Ta question m'oriente vers ce que je suspecte.... je me dis que thunar initialise ses bookmarks alors que la connexion sur mon réseau local n'est pas encore établie... Si ça peut ete ça... aucune idée de comment y remédier


SciTE ForEVeR

Hors ligne

#4 Le 17/01/2013, à 18:46

The Uploader

Re : [RESOLU] .gtk-bookmarks récalcitrant

Alors je viens d'essayer chez moi (j'utilise Xfce 4.10, Thunar 1.6.2, exo 0.10.2, et l'automount réseau de gvfs est activé) : le bookmark smb est bien affiché tout le temps, même après un reboot.

Je crois que tu as trois solutions :

  • Utiliser gigolo (même s'il est "obsolète" et n'a pas évolué depuis Xfce 4.8 qui a intégré le réseau à Thunar, il devrait toujours fonctionner). Nom du paquet : gigolo
    Gigolo servait de gestionnaire de bookmarks réseaux pour Thunar. Il devra être utilisé à chaque fois que l'utilisateur veut ouvrir Thunar sur une adresse réseau, comme au temps de Xfce 4.6...

  • Utiliser une action personnalisée :
    1.Menu Éditer => Configurer les actions personnalisées...
    2.Cliquer sur 'Ajouter...'
    3.Nom : ce que tu veux. Commande : thunar smb://serveur/multimedia
    4.Dans les conditions d'apparitions, cocher tout

    Tu pourras toujours ensuite y accéder dans le menu contextuel de Thunar.

  • (pas sûr et c'est vraiment pas la meilleure option) : installer le PPA de Xfce 4.10 où il semble que ce bug ait été résolu (mais je suis pas vraiment sûr que ce soit Xfce 4.10 ou Xfce 4.12, je ne trouve pas de rapport de bug correspondant. Je pencherais pour Xfce 4.10 cependant)

    - Si tu as la 12.10 :
    Alors cela a peut-être été résolu dans Xfce 4.12. Le PPA est par là : https://launchpad.net/~xubuntu-dev/+archive/xfce-4.12 . Il permet d'avoir (entre autres) Thunar 1.6.x

    - Si tu as la 12.04 :

    Alors le problème a peut-être été résolu dans Xfce 4.10. Le PPA est par là : https://launchpad.net/~xubuntu-dev/+archive/xfce-4.10

    Après avoir installé le PPA de Xfce 4.10 sur la 12.04, mis à jours tes paquets, et redémarré, tu auras certainement un tableau de bord avec un aspect différent d'avant. Pour retrouver son aspect originel, tu auras besoin de rajouter un séparateur étendu et transparent juste après le greffon "Boutons des fenêtres" dans le tableau de bord.

    Si Xfce 4.10 ne résout pas le problème, tu peux rajouter le PPA de Xfce 4.12. De toutes façons, pour la 12.04 le PPA de Xfce 4.12 ne peut être installé sans avoir installé le PPA de Xfce 4.10


    A part ça, le PPA pour Xfce 4.10 offre des logiciels stables. Mais évidemment le PPA de Xfce 4.12 est considéré comme beaucoup plus expérimental vu que Xfce 4.12 est très loin d'être fini.

Dernière modification par The Uploader (Le 17/01/2013, à 18:57)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

Hors ligne

#5 Le 18/01/2013, à 09:25

jermil

Re : [RESOLU] .gtk-bookmarks récalcitrant

Ok merci des réponses, je mets en pratique et j'up le post après résultats....


SciTE ForEVeR

Hors ligne

#6 Le 18/01/2013, à 09:37

jermil

Re : [RESOLU] .gtk-bookmarks récalcitrant

The Uploader a écrit :
  • Utiliser gigolo (même s'il est "obsolète" et n'a pas évolué depuis Xfce 4.8 qui a intégré le réseau à Thunar, il devrait toujours fonctionner). Nom du paquet : gigolo
    Gigolo servait de gestionnaire de bookmarks réseaux pour Thunar. Il devra être utilisé à chaque fois que l'utilisateur veut ouvrir Thunar sur une adresse réseau, comme au temps de Xfce 4.6...

Gigolo était déjà installé, que faire après ?

The Uploader a écrit :
  • Utiliser une action personnalisée :
    1.Menu Éditer => Configurer les actions personnalisées...
    2.Cliquer sur 'Ajouter...'
    3.Nom : ce que tu veux. Commande : thunar smb://serveur/multimedia
    4.Dans les conditions d'apparitions, cocher tout

    Tu pourras toujours ensuite y accéder dans le menu contextuel de Thunar.

Fait... Mais ça fait rien du tout, rien de plus dans le panneau lattéral.



Vu que tu ne recommande pas la dernière option, j'ai pas tenté.....



---==----
C'est quand relou cette affaire, j'avais aucun souci avec la 10.04... (et arf/lol) je viens de voir que l'upgrade du système faite hier m'a upgradé en 11.10 !! Bordel j'étais sur une LTS avant...... Bref c'est un autre souci ça et je sais pas pourquoi depuis quand l'upgrade d'une LTS se fait vers une verison de transition ???


SciTE ForEVeR

Hors ligne

#7 Le 18/01/2013, à 10:31

jermil

Re : [RESOLU] .gtk-bookmarks récalcitrant

Alors autant pour moi : je sais pas laquelle des méthodes a marché.... après plusieurs reboot, si j'accède une premiere fois manuellement àmon partage istant, il s'ajoute bel et bien dans les bookmarks thunar....

Du coup faut que je trouve mais je fouiner la doc, comment faire en sorte qu'au démarrage l'emplacement s'ouvre automatiquement....

merci du coup, meme si j'avoue que je sais pas ce qui a fonctionné.... je préciserai sur les autres postes quelle la méthode qui a marché....

Je change le sujet du post..


SciTE ForEVeR

Hors ligne

#8 Le 18/01/2013, à 11:46

The Uploader

Re : [RESOLU] .gtk-bookmarks récalcitrant

jermil a écrit :

Gigolo était déjà installé, que faire après ?

doc ubuntu a écrit :

Pour ajouter une ressource, cliquez sur le bouton « Se connecter » (en forme de prise) ou sur le bouton « Éditer les signets » (bloc-note). Sélectionnez le type de service (FTP, SSH, Obex, etc.) et remplissez les informations nécessaires (nom du serveur, authentification, etc.). Une icône supplémentaire apparait dans la fenêtre principale indiquant le statut de la ressource.

Pour toi le type de service sera "Partage Windows" ou "SMB" (je me souviens plus trop comment Gigolo le nomme)
Tu peux aussi cocher l'auto-connexion. Mais je ne fais que reprendre la doc' (partie 'utilisation') : http://doc.ubuntu-fr.org/gigolo#utilisation

Le port et le nom d'utilisateur sont facultatifs.

jermil a écrit :

Fait... Mais ça fait rien du tout, rien de plus dans le panneau lattéral.

Les actions personnalisées s'affichent uniquement dans le menu contextuel. Celui qui s'affiche quand tu fais un clic droit dans Thunar.

jermil a écrit :

Du coup faut que je trouve mais je fouiner la doc, comment faire en sorte qu'au démarrage l'emplacement s'ouvre automatiquement....

L'option de connexion automatique de Gigolo d'après la doc' te reconnecte à la ressource dès l'ouverture de la session Xfce.

Sinon, tu peux rajouter une entrée lançant "thunar smb://serveur/multimeda" (sans les ") dans le gestionnaire de paramètres => Session et Démarrage => Démarrage automatique.

Si tu choisis cette deuxième manière, attention à ne pas sauvegarder la session (décocher "Enregistrer la session pour les connexions futures" lorsque tu éteins/redémarre la machine ou que tu te déconnectes de Xfce. Heureusement cette case à cocher n'est pas à décocher à chaque fois. Juste une fois.), car le gestionnaire de session risque ensuite de lancer thunar plusieurs fois à force de restaurer les sessions précédentes où Thunar était ouvert (auquel cas il faudra virer tous les fichiers du dossier ~/.cache/sessions/).

J'espère que c'est un peu plus clair. ^^

Dernière modification par The Uploader (Le 18/01/2013, à 12:02)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

Hors ligne

Haut de page ↑