Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 16/01/2013, à 19:41

tali893

[Résolu] pb install ubuntu en dual boot avec windows 7 en mode UEFI

Bonjour à tous,

Ma machine est un AlienWare Aurora R4 acheté récemment. Celui-ci a été livré avec windows7 pré-installé en mode UEFI. Je me sert de windows pour pouvoir utiliser des logiciels de 3D. Toutefois, étant développeur et sachant que windows c'est le mal ! J'ai donc voulu installer ubuntu. J'ai donc suivi le tutoriel de ce site qui explique très bien la marche à suivre pour procéder une installation d'ubuntu UEFI en dualboot avec windows.

J'ai pour ce faire, créer une usb-live d'ubuntu 12.04 64bits.
L'installation se déroule correctement, mais au moment de redémarrer, je n'est pas de grub et j'arrive directement sur ma partition ubuntu. Suite à cela, j'ai rebooté sur ma usb-live puis installer et utilisé grub-repaire. Je redémarre ensuite et là j'ai mon grub.

Tout content je teste ma partition ubunu OK !
Je test ma partition windows OK !
Et là je repars sur ma partition ubuntu et surprise... plus de grub..

Je me suis alors rendu compte pour avoir effectué plusieurs tests que le grub reste présent tant que je ne suis pas allé sur ma partition windows. Une fois que je suis allé sur ma partition windows, le grub saute et démarre automatiquement sur windows.
J'ai tenté avec ubuntu 12.10 64 bits. Et ça me donne le même résultat. C'est pourquoi j'en appel à la communauté pour m'aider smile . J'ai vraiment besoin d'ubuntu en dualboot car je n'apprécie pas les VM en graphique.
Alors, si quelqu'un me trouve la solution ça serai vraiment sympas. Merci d'avance pour toutes vos réponses et l'aide apporté.

Dernière modification par tali893 (Le 19/01/2013, à 20:52)

Hors ligne

#2 Le 17/01/2013, à 09:46

malbo

Re : [Résolu] pb install ubuntu en dual boot avec windows 7 en mode UEFI

Boot-Repair fonctionne comme expliqué ici par son concepteur lui-même : http://ubuntuforums.org/showpost.php?p= … tcount=637
Tu constateras que c'est peu éloigné de la piraterie comme procédé : il y a substitution de fichier .efi
Moi, je pense que ton Win7 est équipé d'un dispositif de protection qui détecte qu'on a bricolé de fichier .efi et qui réécrit le fichier .efi d'origine qu'il doit avoir sauvegardé. De ce fait, le démarrage se fait directement sous Windows 7.
Je pense que tu devrais éviter d'utiliser Boot-repair ou bien désactiver le module de protection du démarrage dans Win7 (si c'est possible)

Dernière modification par malbo (Le 17/01/2013, à 09:47)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#3 Le 17/01/2013, à 11:30

tali893

Re : [Résolu] pb install ubuntu en dual boot avec windows 7 en mode UEFI

Merci de ta réponse, je pense que c'est effectivement le cas.
J'ai regardé les différentes partitions de mon disque dure et j'ai pu voir que mon alienware avec un bios de 10 Go ce qui me parait excessif. Il se pourrait donc bel et bien qu'il détecte que le boot n'est pas l'efi windows et le remette en place. Mais que faire pour pallié au problème ? j'ai regardé dans mon bios, suite à l'installation d'ubuntu, sa boot sur ubuntu efi, mais si je démarre sous windows, le boot windows efi viens alors remplacer celui d'ubuntu et impossible de le sélectionner dans le bios, car il ne fait pas partis des options de boot possible.

La question est donc la suivante : comment faire en sorte que le boot d'ubuntu ne soit jamais remplacé par celui de windows afin de pouvoir démarrer sur mon grub et ainsi finaliser mon dualboot ?

Dernière modification par tali893 (Le 17/01/2013, à 11:31)

Hors ligne

#4 Le 17/01/2013, à 13:11

malbo

Re : [Résolu] pb install ubuntu en dual boot avec windows 7 en mode UEFI

Pourrais-tu répondre à cette demande parce que j'ai peur de répondre à côté du problème : http://doc.ubuntu-fr.org/tutoriel/boot-info


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#5 Le 17/01/2013, à 14:50

tali893

Re : [Résolu] pb install ubuntu en dual boot avec windows 7 en mode UEFI

Pas de problème, je fait ça en rentrant du travail. Merci pour le lien.

Hors ligne

#6 Le 17/01/2013, à 22:22

tali893

Re : [Résolu] pb install ubuntu en dual boot avec windows 7 en mode UEFI

Voici le lien requis : http://paste.ubuntu.com/1542596/
Je reste à disposition pour plus d'informations

Hors ligne

#7 Le 18/01/2013, à 06:42

malbo

Re : [Résolu] pb install ubuntu en dual boot avec windows 7 en mode UEFI

Tu disposes d'une partition EFI qui est vide actuellement : c'est la partition sdb1. Je te suggère d'utiliser Boot-Repair pour installer Grub en spécifiant bien la partition séparée sdb1 (et pas sda1). Le but étant de tenter de se sortir de là en pouvant définir une priorité de boot au niveau du choix du disque dur. Après cette réparation avec Boot-Repair, je te prie de noter l'URL pour pouvoir la poster ici. Il conviendra alors de placer en priorité de Boot dans ton Bios le disque dur sdb (modèle WD10EZEX-75Z) pour que sdb1 soit utilisée. 

Tu peux voir dans ton Boot-Info ceci tout à la fin :

=================== Default settings
Recommended-Repair
This setting would reinstall the grub-efi of sdb2, using the following options:        sda1/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s   fix-windows-boot

Ce qui veut dire que la "Réparation recommandée" de Boot-Repair ne te convient pas puisqu'elle installerait encore grub-efi dans sda1 : il faut que tu fasses une réparation avancée en spécifiant sdb1 au lieu de sda1


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#8 Le 19/01/2013, à 16:50

tali893

Re : [Résolu] pb install ubuntu en dual boot avec windows 7 en mode UEFI

J'ai effectué les opérations que tu m'as conseillées et ça marche à merveille ! j'ai mon dual boot ubuntu windows sur mon pc.
Voici le lien fournis par boot-repair : http://paste.ubuntu.com/1549120/

Donc pour l'installation en dual boot de windows et ubuntu en mode EFI et plus particulièrement les possesseurs d'alienware aurora R4 avec un bios de version A07, voici les étapes que j'ai suivies :

Matériel requis, une clé USB.

1-   Télécharger ubuntu 12.04 64 bits via ce lien : http://www.ubuntu-fr.org/telechargement
2-   Télécharger linux live usb creator sur cette page  : http://www.linuxliveusb.com/fr/download
3-   Créer votre usb live via live usb creator.
4-   Connecter votre clé puis redémarrer.
5-   Accéder a votre bios (touche F12 pour les pocesseurs d'alienware. Et démarrer sur votre clé usb en mode efi
6-   Procéder à l'installation
7-   Une fois fait, redémarer une nouvelle fois sur votre clé usb en mode efi et selectionner try ubuntu
8-   Ctrl T pour afficher le terminal puis installer boot repaire comme expliquer ici : http://doc.ubuntu-fr.org/boot-repair
9-   Lancer le puis allez dans options avancées, choisissez le disque dure ou vous avez installé ubunut
10- Une fois fait, votre pc redémarre, retourner dans votre bios allez dans les préférences de boot et mettez les dans cet ordre : ubuntu EFI puis Windows loader EFI

Et voilà vous avez un dual-boot tout propre windows et ubuntu.

Voilà un grand merci à Malbo en tout cas pour m'avoir expliqué la marche à suivre.

Note :
Je recommande la version LTS (12.04) de ubuntu car la version 12.10 n'est pour le moment pas très stable surtout pour compiz sur ma machine et unity saute donc, a vous de voir pour la version de ubuntu que vous vulez installer.

Hors ligne

#9 Le 19/01/2013, à 20:32

malbo

Re : [Résolu] pb install ubuntu en dual boot avec windows 7 en mode UEFI

Bravo pour ce bon résultat.
Je te prie de modifier le titre de ton post #1 pour qu'il devienne :

[Résolu] pb install ubuntu en dual boot avec windows 7 en mode UEFI

conformément aux indications du post 5.2 de ce fil : http://doc.ubuntu-fr.org/tutoriel/howto … _en_resolu


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#10 Le 19/01/2013, à 20:53

tali893

Re : [Résolu] pb install ubuntu en dual boot avec windows 7 en mode UEFI

c'est fait.

Hors ligne

Haut de page ↑