Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 20/01/2013, à 04:08

Hada de la Luna

[+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Bonjour à tous wink

j'ai donc un netbook ASUS (1) avec Ubuntu 12.04 LTS en 32 bits (2) sur lequel j'ai dû installer xubuntu (3) et j'ai un problème étrange avec Xfce (xubuntu).

En effet, mon appareil photo (4) ne se monte pas lorsque je le branche alors que je suis avec Xfce, alors que lorsque je me connecte avec Unity, il est monté automatiquement !

Quel est le réglage à faire de Xfce pour que mes appareils se montent lorsque je les connecte ? Parce que cela me parait très peu pratique de devoir changer de session pour décharger mon appareil photo...

Notes :

  1. EeePC X101CH-BLK007U : http://www.ldlc.com/fiche/PB00134286.html

  2. détails du pourquoi du comment, là : http://forum.ubuntu-fr.org/viewtopic.php?id=1166111

  3. pour avoir un bureau fonctionnel et souple... car sinon à cause de l'installation 32 bits j'avais Unity 2D qui a très peu de fonctions et de réglages disponibles

  4. un Nikon Coolpix S2600 : http://www.fnac.com/Nikon-CoolPix-S2600 … =&Mn=&to=0

Dernière modification par Hada de la Luna (Le 21/01/2013, à 17:38)


Hada de la Luna :o)

Hors ligne

#2 Le 20/01/2013, à 04:13

Maisondouf

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

est que il y a un périphérique nouveau qui apparaît dans le répertoire /dev  de Xubuntu?

ls -d /dev/sd*

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 20/01/2013, à 04:57

Hada de la Luna

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

avant de brancher l'appareil photo :

$ ls -d /dev/sd*
/dev/sda  /dev/sda1  /dev/sda2  /dev/sda3

une fois l'appareil photo branché...

$ ls -d /dev/sd*
/dev/sda  /dev/sda1  /dev/sda2  /dev/sda3

Hada de la Luna :o)

Hors ligne

#4 Le 20/01/2013, à 05:58

Maisondouf

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

et sur les ports USB

lsusb

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#5 Le 20/01/2013, à 06:02

Hada de la Luna

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 04f2:b26f Chicony Electronics Co., Ltd 
Bus 002 Device 002: ID 15d9:0a4d Trust International B.V. 

Hada de la Luna :o)

Hors ligne

#6 Le 20/01/2013, à 06:05

Maisondouf

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Ben là, il n'y est pas...


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#7 Le 20/01/2013, à 09:42

ljere

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

il faut créer le fichier thunar-volman avec ces quelques lignes

sudo echo -e '#!/bin/sh \nsleep 1 \nexec /usr/bin/thunar-volman $@ >/tmp/thunar-volman.log 2>&1' > /usr/local/bin/thunar-volman

on le rend exécutable

sudo chmod +x /usr/local/bin/thunar-volman

il ne reste plus qu'à redémarrer la session


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba satellite_c670d-11l sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

Hors ligne

#8 Le 20/01/2013, à 22:01

Hada de la Luna

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

$ sudo echo -e '#!/bin/sh \nsleep 1 \nexec /usr/bin/thunar-volman $@ >/tmp/thunar-volman.log 2>&1' > /usr/local/bin/thunar-volman
bash: /usr/local/bin/thunar-volman: Permission non accordée
$ 

il ne m'a même pas demandé mon mot de passe et cela plusieurs fois... parce que au début j'ai cru à une fausse manœuvre de ma part... hmm

je précise que j'ai vérifié ensuite que sudo fonctionne parfaitement pour moi par ailleurs... wink

Édit : en lisant la ligne j'ai trouvé le nom "thunar-volman" étonnant et inconnu, j'ai donc demandé à google qui il est et j'ai ensuite eu un doute sur l'installation de thunar-volman et ai donc tenté de le lancer dans un terminal ce qui donne cela :

$ thunar-volman
thunar-volman: Spécifier le chemin sysfs des nouveaux périphériques avec l'iption --device-added.

Dernière modification par Hada de la Luna (Le 20/01/2013, à 22:17)


Hada de la Luna :o)

Hors ligne

#9 Le 20/01/2013, à 23:50

Maisondouf

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

La honte, c'était marqué dans la doc : http://doc.ubuntu-fr.org/thunar

Pour la commande de ljere, il faut la faire en 2 temps sinon la 2ème redirection te jette une erreur

sudo -s
echo -e '#!/bin/sh \nsleep 1 \nexec /usr/bin/thunar-volman $@ >/tmp/thunar-volman.log 2>&1' > /usr/local/bin/thunar-volman
exit

Dernière modification par Maisondouf (Le 20/01/2013, à 23:53)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#10 Le 21/01/2013, à 01:06

Hada de la Luna

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Merci ! big_smile

je ne sais pas ce qu'est une redirection
j'ai copié collé

sudo -s

puis :

echo -e '#!/bin/sh \nsleep 1 \nexec /usr/bin/thunar-volman $@ >/tmp/thunar-volman.log 2>&1' > /usr/local/bin/thunar-volman

puis :

sudo chmod +x /usr/local/bin/thunar-volman

et tout est toujours pareil... l'appareil photo n'est pas monté... et c'est uniquement sur Xfce que c'est comme ça : aussi bien sur Unity que sur lubuntu on le voir directement... roll


Hada de la Luna :o)

Hors ligne

#11 Le 21/01/2013, à 01:11

Maisondouf

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Tu as fermé et re-ouvert thunar ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#12 Le 21/01/2013, à 01:22

Hada de la Luna

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

c'est à dire ?
si c'est un redémarrage du PC, c'est fait
si c'est éteindre le PC puis rallumer, c'est fait aussi...
et c'est toujours pareil... pas d'appareil photo de monté avec Xfce sad


Hada de la Luna :o)

Hors ligne

#13 Le 21/01/2013, à 02:54

Maisondouf

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

est ce que 'thunar-volman' est bien là ?

which thunar-volman

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#14 Le 21/01/2013, à 02:59

Maisondouf

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Si oui dans les préférences de thunar, dans l'onglet "avancée", il y a une case à cocher "activer le gestionnaire de volume" qu'il faut cocher.
Juste en dessous il y a une sorte de lien "Configurez", cliques dessus et normalement 'thunar-volman' va s'ouvrir.
Tu pourras paramétrer tout.
PS: j'ai installé un Xubuntu sur un vieux PC pour tester....


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#15 Le 21/01/2013, à 03:45

Hada de la Luna

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Merci ! big_smile

oui il est installé et il est configuré :

Stockage>
x monter les disques amovibles à la connexion
x monter les disques mobiles à l'insertion
x parcourir les disques mobiles à l'insertion
  auto-exécution d'applications pour les nouveaux disques et médias
  auto ouverture des fichiers pour les nouveaux disques et médias

Caméras>
(rien de coché car si oui ça demande une commande pour importer les fichiers automatiquement)

et quand on branche l'appareil, j'ai un message système "appareil photographique détecté", un bip par l'appareil photo et toujours rien (mais c'était déjà le cas avant)

Dernière modification par Hada de la Luna (Le 21/01/2013, à 03:48)


Hada de la Luna :o)

Hors ligne

#16 Le 21/01/2013, à 05:28

Maisondouf

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

il était temps que tu le dises : et quand on branche l'appareil, j'ai un message système "appareil photographique détecté"
Depuis le début, tu dis que rien ne se passe ....


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#17 Le 21/01/2013, à 12:21

Hada de la Luna

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Sauf que depuis le début j'avais un bip de l'appareil photo (le même que sur une prise USB branchée uniquement à une prise électrique) et pas le message "appareil photographique détecté"... Là aujourd'hui j'ai de nouveau testé et ça fait le bip + "appareil photographique détecté" mais ça ne le monte toujours pas... sad


Hada de la Luna :o)

Hors ligne

#18 Le 21/01/2013, à 13:44

The Uploader

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Salut

C'est effectivement un symptôme que j'ai aussi chez moi (et évoqué plusieurs fois par d'autres personnes sur le forum). Xfce détecte l'appareil mais ne le monte pas.

La seule solution que j'ai trouvé est de lancer shotwell après que l'appareil ait été détecté par Xfce.

Le gestionnaire de fichiers intégré à shotwell montre appareil photo et permet de consulter ce qu'il contient et d'importer les photos. smile

Le problème est que si on veut gérer ses photos avec autre chose, ben on ne peut pas... (du moins pas avant de les avoir importé).


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
exclusive /dev/dsp access (ALSA), SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#19 Le 21/01/2013, à 15:15

Hada de la Luna

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Bonjour et merci ! big_smile

Effectivement en mettant shotwell dans thunar-volman (onglet Caméras) comme commande à exécuter alors on peut importer les photos, mais c'est moins souple que avec un navigateur "normal" puisqu'on importe dans Shotwell et que Shotwell enregistre dans le dossier "images" et nulle part ailleurs tout en refusant d'effacer les images qu'on a déjà importées une fois de l'appareil (oui, j'ai fait plusieurs essais sad)...

Mais si c'est la seule solution qui fonctionne avec Xfce... C'est déjà cela ! wink


Hada de la Luna :o)

Hors ligne

#20 Le 21/01/2013, à 15:43

The Uploader

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Sinon dans KDE, le gestionnaire de fichiers Dolphin fonctionne très bien avec les appareils photos.

Tu peux utiliser dolphin dans Xfce, il suffit de l'installer et de le lancer (on peut même l'utiliser en tant que gestionnaire de fichiers par défaut : voir dans gestionnaire de paramètres => applications favorites => utilitaires).

Tu peux aussi essayer nautilus (le gestionnaire de fichiers de Gnome), si tu as la 12.04 ou plus récent.


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
exclusive /dev/dsp access (ALSA), SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

#21 Le 21/01/2013, à 16:34

Hada de la Luna

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Merci ! big_smile

dolphin ne fonctionne pas du tout pour l'appareil photo dans Xfce : je vais rester avec shotwell car passer mon temps à installer / essayer / désinstaller ce n'est pas exactement ni bon pour ma productivité, ni pour mon système, ni même pour mon netbook...

Dernière modification par Hada de la Luna (Le 21/01/2013, à 16:34)


Hada de la Luna :o)

Hors ligne

#22 Le 21/01/2013, à 18:09

Maisondouf

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Hada de la Luna a écrit :

Sauf que depuis le début j'avais un bip de l'appareil photo (le même que sur une prise USB branchée uniquement à une prise électrique) et pas le message "appareil photographique détecté"... Là aujourd'hui j'ai de nouveau testé et ça fait le bip + "appareil photographique détecté" mais ça ne le monte toujours pas... sad

Tu peux essayer la commande 'mount'...
Si tu as le bip, c'est que ton appareil est détecté en tant que device et il doit apparaître dans /dev sous la forme d'un nouveau /dev/sdXXX.
Tu te crée un répertoire chez toi par exemple 'Nikon' et tu fais:

sudo mount /dev/sdXX ~/Nikon

Tu devrais avoir le contenu de la SD de ton appareil dedans.

EDIT: et si tu ne veux pas d'embêter à savoir à chaque fois sur quel device est l'appareil, tu notes l'UUID de la SD :

sudo blkid

et tu la montes comme ça:

sudo mount UUID=<UUID_relevée> ~/Nikon

Dernière modification par Maisondouf (Le 21/01/2013, à 18:11)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#23 Le 21/01/2013, à 18:47

The Uploader

Re : [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Il est peut-être possible d'éviter sudo, en utilisant gvfs-mount. Voici l'aide de cette commande :

> gvfs-mount --help
Utilisation :
  gvfs-mount [OPTION...] [EMPLACEMENT...]

Monter les emplacements.

Options de l'aide :
  -h, --help                         Affiche les options de l'aide

Options de l'application :
  -m, --mountable                    Monter en tant que « montable »
  -d, --device=PÉRIPHÉRIQUE          Monter un volume avec le fichier périphérique
  -u, --unmount                      Démonter
  -e, --eject                        Éjecter
  -s, --unmount-scheme=PROTOCOLE     Démonter tous les points de montage du protocole indiqué
  -l, --list                         Lister
  -o, --monitor                      Surveiller des évènements
  -i, --detail                       Afficher des informations supplémentaires

Et ainsi de mettre :

gvfs-mount <UUID-périphérique> ~/UnDossierQuelconque

dans la configuration de thunar-volman (Gestionnaire de paramètres => disques amovibles et médias => Caméras => Commande: )

Il faudra que j'essaie avec "mon" appareil photo....

edit : bon ben il est bien listé par lsusb mais pas par blkid, ni dans /dev/disk/by-id/
J'en reste à "shotwell" comme solution. hmm

Dernière modification par The Uploader (Le 21/01/2013, à 18:57)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
exclusive /dev/dsp access (ALSA), SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

En ligne

  • Accueil
  • » Forum
  • » XFCE
  • » [+ou- résolu]12.04 LTS: Nikon monté si Unity pas monté si Xfce

Haut de page ↑