Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 20/01/2013, à 01:34

Julyen

Problème Diablo III (tout va bien sauf le lancement)

Bonsoir,

j'ai un petit soucis, j'utilise PlayOnLinux bien sûr, j'ai installer Diablo III une première fois ça avait marché et tout niquel (j'avais mis à jour les pilotes etc. je suis avec nvidia) puis j'ai du faire un reboot de l'ordinateur (compliqué) j'ai tout refais, tout réinstallé, le pilote nvidia etc.

J'installe PlayOnLinux, je refais la même chose pour Diablo III, tout se télécharge et s'installe correctement, puis quand je lance le jeu en faisant :

" jouer "

Rien ne se passe, comme si c'était invisible (j'entends le son mais rien de plus, pas d'image ou de cadre wine)

Voilà j'espère que vous pourrez m'aidez,

Cordialement,

Julien.

Hors ligne

#2 Le 20/01/2013, à 04:16

Julyen

Re : Problème Diablo III (tout va bien sauf le lancement)

Quelques messages d'erreur lors du démarrage de PlayOnLinux :

PlayOnLinux n'est pas en mesure de trouver les bibliothèques OpenGL 32bits.

Vos jeux risquent de ne pas fonctionner comme prévu
PlayOnLinux cannot find 7z (from P7ZIP full)

You should install it to use PlayOnLinux

Et voici le message de déboggage quand je fais " jouer " :

Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.

et ce n'est qu'un bout du message d'erreur, il se répète infinemment,

j'espère que vous pourrez m'aidez...

Dernière modification par Julyen (Le 20/01/2013, à 04:22)

Hors ligne

#3 Le 20/01/2013, à 17:47

Julyen

Re : Problème Diablo III (tout va bien sauf le lancement)

up...

Hors ligne

#4 Le 21/01/2013, à 13:50

Horigo

Re : Problème Diablo III (tout va bien sauf le lancement)

Tu as installé les pilotes de ta carte graphique ?

Hors ligne

#5 Le 21/01/2013, à 19:58

Julyen

Re : Problème Diablo III (tout va bien sauf le lancement)

oui tout smile

image :

542445Capturedu20130121185811.png

Dernière modification par Julyen (Le 21/01/2013, à 20:01)

Hors ligne

#6 Le 22/01/2013, à 14:47

Horigo

Re : Problème Diablo III (tout va bien sauf le lancement)

Pourquoi y'en a plusieurs de cochés ?
Enfin je sais pas moi j'ai une radéon et j'en ai qu'un de coché.
ça m'a l'air d'être un beau bordel nvidia sous linux

Dernière modification par Horigo (Le 22/01/2013, à 14:47)

Hors ligne

#7 Le 22/01/2013, à 21:04

Julyen

Re : Problème Diablo III (tout va bien sauf le lancement)

Un pilote pour le nvidia, les experimental sont pour l'accélération 3D et le reste pour mises à jour ou panneau de config.. ce n'est pas un bordel, je suis là pour qu'on m'aide pas pour qu'on me dise que c'est un bordel, alors qu'on s'est même pas ce que c'est. smile

Donc si tu ne peux pas m'aider, ben tant pis, mais dis rien alors.

Hors ligne

#8 Le 29/01/2013, à 18:30

morfla

Re : Problème Diablo III (tout va bien sauf le lancement)

Même problème de mon coté, install de D3 Ok , mise a jour OK, quand je clique sur jouer.. bah le launcher disparait et rien sad

Hors ligne

#9 Le 29/01/2013, à 22:17

Haleth

Re : Problème Diablo III (tout va bien sauf le lancement)

Un pilote pour le nvidia, les experimental sont pour l'accélération 3D et le reste pour mises à jour ou panneau de config.. ce n'est pas un bordel, je suis là pour qu'on m'aide pas pour qu'on me dise que c'est un bordel, alors qu'on s'est même pas ce que c'est.

Donc si tu ne peux pas m'aider, ben tant pis, mais dis rien alors.

Y'en a qu'un qui est utile. Je sais pas lequel il prend, mais un seul est utilisé. lsmod pour savoir lequel, j'imagine.

J'utilise ca comme script pour le lancer:

15% [alex:~]cat /usr/local/bin/d3 
#!/bin/bash
export WINEDLLPATH=/mnt/add/D3/1.5.5/lib/wine
export WINEPREFIX=/mnt/add/D3/DiabloIII
cd '/mnt/add/D3/DiabloIII/drive_c/Program Files/Diablo III'
/mnt/add/D3/1.5.5/bin/wine 'Diablo III Launcher.exe'

C'est quoi vos versions de wine ?
J'imagine que vous avez l'accélération 3D active..:

13% [alex:~]glxinfo | grep -i rendering
direct rendering: Yes
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering,

Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

  • Accueil
  • » Forum
  • » Jeux
  • » Problème Diablo III (tout va bien sauf le lancement)

Haut de page ↑