Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 06/11/2005, à 18:37

yuoyuo

double carte son

Bonjour,

voilà , j'ai deux cartes son sur mon PC
- card0 : chipset Nforce2 , carte son intégrée
- card1 : CMIxxx , carte son PCI

Pour les applications comme vlc ou xmms, j'arrive à choisir la carte son que je souhaite utiliser via les menus "préférence".
En l'occurence ces applications utilisent la card1
et c'est bien....

Mais, je voudrais aussi que d'autres applications choississent la card1 comme le jeux Enemy territory !
mais par défaut, ce petit cochon utilise toujours la card0

bref, j'espère avoir ete clair et que vous pourrez m'aider !

#2 Le 07/11/2005, à 03:11

sylware

Re : double carte son

Si tu es sous breezy, va danssystème - préférences - sélecteur de système multimédia. Tu devrais pouvoir sélectionner la carte son par défaut.
Si tu es sous Hoary:
http://wiki.ubuntu-fr.org/installation/son?s=cartes
Va à la section "plusieurs cartes son".

Hors ligne

#3 Le 07/11/2005, à 14:15

Sparx

Re : double carte son

Pour info,
Si tu ne veux jamais utiliser la carte son intégrée et n'utiliser que la PCI, désactive la CS intégrée dans le bios c'est encore le mieux.


Le temps passe mais les oeufs durent...

Hors ligne

#4 Le 09/11/2005, à 11:31

loyo

Re : double carte son

bon, voila
je me suis inscrit (en fait c parce que jai d'autres questions)

@Sparx : je ne veux pas desactiver la carton son intégré dans le bios, car mon micro (sous teamspeak) fonctionne sacrément mieux avec sous windows et sous linux.

@sylware : le sélecteur de multimédia me permet de choisir le "sink par défaut" et la "source par défaut". bref, j'ai bien essayé de changer les options mais ca ne change rien ! Tous passe par la card0 (sauf les applis auxquelles j'ai demandé explicitement d'utiliser la card1)

Bref, je vais essayer de reformuler ma demande :

Est-il possible de créer un script de lancement pour une application lui demandant d'utiliser telle ou telle carte son. Ca pourrait donner un truc du genre :

{utilise la carte son numéro 1 -- card1 --)
puis 
/usr/local/games/enemy-territory/et

(j'espere que c plus clair comme ça tongue)

Hors ligne

#5 Le 10/11/2005, à 01:25

sylware

Re : double carte son

Tu veux donc garder les 2 cartes, et dire à enemy-territory d'utiliser telle ou telle carte audio. Je n'ai pas enemy-territory, mais il faut regarder si cela est une option de enemy-territory. Peut être en ligne de commande? Essaye
/usr/local/games/enemy-territory/et --help
ou
/usr/local/games/enemy-territory/et -h
Des trucs comme ça. Sinon il serait utile de savoir quel(s) système(s) sonore(s) utililsent et.

Hors ligne

#6 Le 10/11/2005, à 09:41

sksbir

Re : double carte son

houla, le wiki a drolement changé depuis que j'avais moi-meme un pb de sélection de la bonne carte son!

Par contre, je trouve les solutions proposées bien compliquées...

A l'époque, j'avais résolu mon soucis ( décris en détail ici) en rajoutant une seule ligne dans /etc/modules.conf, et j'ai refais la manip quand j'ai réinstallé breezy.

Dernière modification par sksbir (Le 10/11/2005, à 10:04)

Hors ligne

#7 Le 10/11/2005, à 10:02

loyo

Re : double carte son

@skbir : ton lien pointe sur le meme sujet du forum tongue

Hors ligne

#8 Le 10/11/2005, à 10:05

sksbir

Re : double carte son

loyo a écrit :

@skbir : ton lien pointe sur le meme sujet du forum tongue

oups roll.... c'est corrigé... smile

Pour en revenir à ton cas particulier, j'imagine que tu as le meme soucis que moi : la carte son par défaut est celle qui fait sortir le son sur la TV...

je te suggere donc de mettre par défaut via /etc/modules la carte son de tes haut-parleur de bureau, et d'utiliser les options de VLC & autre lecteur multimédia pour faire quand même sortir le son sur la TV...

Dernière modification par sksbir (Le 10/11/2005, à 10:08)

Hors ligne

#9 Le 10/11/2005, à 11:18

loyo

Re : double carte son

je viens de parcourir ton lien !
bon c un chti peu compliqué pour moi, mais je me mets a etudier la chose tongue
merci !
jte tiens au jus, si ca marche !

update :

en fait, mon problème est plus vicieux, il me semble

la carte son par défaut (card0) -- associé au casque -- me sert pour utiliser Teamspeak et tous les autres "sons" (gaim, irc, sons system...)
la 2ème (card1) -- associé aux haut parleurs -- , je l'utilise pour xmms et vlc (via les préférences). Effectivement comme ca, le son de ma carte par défaut (via le casque, ne viens par parasiter ma musique ou les divx que je mate.

Le truc, c que les jeux (enemy territory, warsow...) utilisent la carte son par défaut (casque - card0) et ca, je n'aime pas trop !
c'est pourkoi je voudrais bien, leur faire utiliser la card 1...

cf wiki :

Vous avez la chance d’avoir plusieurs cartes sons (idéal pour mixer comme un dj avec mixxx par exemple), mais problème : la carte principale n’est pas celle que vous vouler utiliser. Le problème se pose aussi avec les cartes TV, qui souvent s’identifient comme carte son principale, la vrai carte son passant en 2eme position, donc plus aucun son n’en sort.

Dans le wiki, mon problème n'est pas que je ne veu pas l'utiliser , bien au contraire, je veux utiliser les 2 ! mais à mon gré !
Pour résumer :
Par défaut, je veux que le système utiliser card0
mais, pour certaines applications, je veux qu'il utilise la card1 !

Dernière modification par loyo (Le 10/11/2005, à 11:31)

Hors ligne

#10 Le 10/11/2005, à 12:01

sksbir

Re : double carte son

ha oui, là, c'est plus compliqué.

Le probleme de base, c'est de pouvoir configurer tes jeux sur la carte son secondaire.

Ce que je propose avec la modification de /etc/modules, c'est une solution de contournement : c'est faire en sorte que ta carte son par défaut soit associée aux haut-parleurs.
Avec cette modif dans /etc/modules, ta carte associée au casque s'appellera card1, et celle des HP s'appellera card0

Apres il faudra dire aux softs Teamspeak, gaim,irc,etc... d'utiliser la carte card1 ,ce qui n'est pas gagné non plus , d'ou ma remarque du début... smile


Revenons donc au probleme de base : t'as essayé de trouver les options en ligne de commande de  tes jeux ?
Au fait, tu sais si c'est ESD ou Alsa qui est utilisé ?

Dernière modification par sksbir (Le 10/11/2005, à 12:04)

Hors ligne

Haut de page ↑